Subject: Re: [Hipsec] Status of HIP-DEX/BEX implementations

From: Gonzalo Camarillo <[email-masked]>
Date: Tue, 22 Sep 2020 10:05:38 +0000

Hi Eric,

your email below arrived during my summer vacation. I am catching up on stuff now. 

Please, note that the 3 links provided below point to a paper from 2013, to a repo where the last commit is from 2011, and to a repo where the last commit was performed 10 years ago. Are you sure you want that type of completely out-of-date information in the writeup?

Cheers,

Gonzalo

> -----Original Message-----
> From: Eric Vyncke (evyncke) <[email-masked]>
> Sent: Tuesday, August 4, 2020 16:18
> To: Miika Komu <[email-masked]>; [email-masked]
> Cc: Gonzalo Camarillo <[email-masked]>
> Subject: Re: Status of HIP-DEX/BEX implementations
> 
> Thank you Miika for these pieces of information.
> 
> Gonzalo, as you are the document shepherd for DEX, would you mind
> updating the write-up with this list of implementations?
> 
> For information, I have just request the IESG secretary to approve the HIP-
> NAT document as all DISCUSS & COMMENT points were addressed. Now, we
> need to get DEX through
> 
> -éric
> 
> -----Original Message-----
> From: Miika Komu <[email-masked]>
> Date: Tuesday, 4 August 2020 at 14:50
> To: Eric Vyncke <[email-masked]>, "[email-masked]" <[email-masked]>
> Cc: Gonzalo Camarillo <[email-masked]>
> Subject: Re: Status of HIP-DEX/BEX implementations
> 
>     Hi Eric,
> 
>     ti, 2020-07-14 kello 11:45 +0000, Eric Vyncke (evyncke) kirjoitti:
>     > [Bcc previous and current authors in HIP related documents]
>     >
>     > In the framework of the IESG evaluation of HIP-DEX, it would be
>     > useful to know whether there are implementations of HIP-DEX.
> 
>     sorry for not sending this earlier due to my vacations. I am aware of
>     three implementations (no idea about interoperability):
> 
>     1. Contiki-based implementation
>     https://www.researchgate.net/publication/259475424_Slimfit_-
> _A_HIP_DEX_compression_layer_for_the_IP-based_Internet_of_Things
> 
>     2. Java: https://protect2.fireeye.com/v1/url?k=9d0fb0d6-c3af5042-
> 9d0ff04d-86d2114eab2f-a5a60a52da996ac0&q=1&e=533f7f17-d75e-4aff-
> a064-
> c679cfd0273b&u=https%3A%2F%2Fcode.google.com%2Farchive%2Fp%2Fhip-
> dex%2F
> 
>     3. Java: https://protect2.fireeye.com/v1/url?k=f5c05a7d-ab60bae9-
> f5c01ae6-86d2114eab2f-d4d4be7ca0b8dbde&q=1&e=533f7f17-d75e-4aff-
> a064-c679cfd0273b&u=https%3A%2F%2Fgithub.com%2Fjuhovh%2Fhip-
> dex%2Ftree%2Fmaster%2FSpotHIP
> 
>     > In the same vein, getting a list of HIPv2 BEX (Base Exchange) would
>     > also be useful.
> 
>     AFAIK, HIPv2 has been implemented and interoperated successfully by the
>     following implementations:
> 
>     1. OpenHIP
>     2. HIP for Linux
> 
>     (Maybe also by the HIP4Inter.net implementation but I am not sure about
>     this)

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Wed, 23 Sep 2020 14:20:28 +0000

Gonzalo

This is indeed a good catch about DEX, the protocol has probably changed a lot since then. So, perhaps mentioning the 2 repos (not the paper) in the write-up BUT WITH the last commit year; this is also a useful piece of information when evaluating a protocol (not saying a positive piece though ☹ ...).

As you are the doc shephers, it is really up to you to decide of course

Regards

-éric

-----Original Message-----
From: Gonzalo Camarillo <[email-masked]>
Date: Tuesday, 22 September 2020 at 12:05
To: Eric Vyncke <[email-masked]>, Miika Komu <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: Status of HIP-DEX/BEX implementations

    Hi Eric,

    Cheers,

    Gonzalo

---

From: Andrei Gurtov <[email-masked]>
Date: Tue, 22 Sep 2020 12:38:34 +0200

Hi,

FYI, current OpenHIP development for v2 and DRIP happens actively here

https://bitbucket.org/openhip/workspace/projects/OP

br Andrei

-- 
Andrei Gurtov, PhD, ACM Distinguished Scientist
Professor, LiU, Sweden
Vice-chair, IEEE Sweden
https://www.ida.liu.se/~andgu38/

On 9/22/2020 12:05 PM, Gonzalo Camarillo wrote:
> _______________________________________________
> Hipsec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hipsec