Subject: [Hipsec] Lars Eggert's Discuss on draft-ietf-hip-dex-24: (with DISCUSS and COMMENT)

From: Lars Eggert via Datatracker <[email-masked]>
Date: Wed, 24 Mar 2021 13:29:09 -0700

Lars Eggert has entered the following ballot position for
draft-ietf-hip-dex-24: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-hip-dex/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

I realize I'm missing a lot of history and context here. So apologies
if this was discussed in the past. But this document seems to be completely
outside of the current HIP charter. Why has the WG worked on this, and why
should this be published? I'll note that the only IETF document referencing
draft-ietf-hip-dex is draft-ietf-hip-rfc4423, and the reference is an appendix
that basically summarizes -dex and is not normative. So not publishing this
document will not block any other work.

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

-------------------------------------------------------------------------------
All comments below are very minor change suggestions that you may choose to
incorporate in some way (or ignore), as you see fit. There is no need to let me
know what you did with these suggestions.

Section 5.2.6, paragraph 4, nit:
-    the Responder in I2 which echos it back to the Initiator in R2.
+    the Responder in I2 which echoes it back to the Initiator in R2.
+                                  +

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Thu, 25 Mar 2021 06:33:16 +0000

Lars,

Thank you for your review.

The hip-dex document was already in IESG evaluation (and had even a ballot, which was deferred) when I became the responsible AD, so, I have no more historical context than you (and to be honest, I did not check the charter).

In a separate email thread, I will check with chairs, previous ADs, and authors. Unsure whether I will get a reply before our telechat.

The cluster C386 is blocked by this document and my fall-back plan is to remove completely the appendix of draft-ietf-hip-rfc4423-bis to remove the dependency.

Let's discuss later today

-éric

-----Original Message-----
From: Hipsec <[email-masked]> on behalf of Lars Eggert via Datatracker <[email-masked]>
Reply-To: Lars Eggert <[email-masked]>
Date: Wednesday, 24 March 2021 at 21:29
To: The IESG <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: [Hipsec] Lars Eggert's Discuss on draft-ietf-hip-dex-24: (with DISCUSS and COMMENT)

    _______________________________________________
    Hipsec mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/hipsec

---

From: Gonzalo Camarillo <[email-masked]>
Date: Thu, 25 Mar 2021 10:13:23 +0000

Hi Lars,

here you have the background to the decision of working on HIP-DEX. In February 2016, I discussed the addition of HIP-DEX to the charter of the WG with the responsible AD at the time (Terry). I proposed to re-charter the group as follows:
https://mailarchive.ietf.org/arch/msg/hipsec/izV5ZM8X9pmKfLNa016z0PBniv8/

However, Terry told me there was no need to re-charter the WG. Instead, in the email below he asked me to simply add the corresponding milestone. 

-------- 8< --------
Subject: Re: [Hipsec] Charter proposal
Date: Tue, 16 Feb 2016 02:35:14 +0000
From: Terry Manderson <[email-masked]>
To: Gonzalo Camarillo <[email-masked]>
CC: [email-masked] <[email-masked]>

Hi Gonzalo,

I don't think you need to actually rev the charter.

Just update the milestones and add:

o Develop a standards track specification of a light-weight HIP exchange

o Close WG

Is there a reason why you would like to rev the charter?

T.
-------- >8 --------

This is the email where I discuss the specific milestone related to HIP-DEX on the list:
https://mailarchive.ietf.org/arch/msg/hipsec/D3VJFodc0C7fr5ic_7NH5xRIhn4/

Accordingly, I added the milestones about HIP-DEX at the end of March. However, apparently Terry never got to approving them. In the email thread below, you can see my last ping to him, in October that year.

-------- 8< --------
Subject: Re: Review Required - Milestones changed for hip WG
Date: Fri, 21 Oct 2016 10:23:26 +0300
From: Gonzalo Camarillo <[email-masked]>
To: [email-masked]

Hi Terry,

it seems you never approved the two additional milestones below. The
charter page says at the bottom: "2 new milestones currently in Area
Director review."

https://datatracker.ietf.org/wg/hip/charter/

If you could approve them, that would be great.

Thanks,

Gonzalo

On 31/03/2016 5:34 PM, Gonzalo Camarillo wrote:
> Hi Terry,
> 
> per our email exchange some weeks ago, I have updated the exiting HIP
> milestones so that they show current due dates, changed the last
> milestone so that it reads "Close WG" in January 2017, and added these
> two milestones for the HIP DEX document.
> 
> Cheers,
> 
> Gonzalo
> 
> On 31/03/2016 5:32 PM, IETF Secretariat wrote:
>> Added milestone "WGLC HIP DEX" for review, due September 2016.
>>
>> Added milestone "Submit HIP DEX to the IESG" for review, due October
>> 2016.
>>
>> URL: https://datatracker.ietf.org/wg/hip/charter/
>>
>
-------- >8 --------

Cheers,

Gonzalo

> From: Eric Vyncke (evyncke) <[email-masked]>
> Sent: Thursday, March 25, 2021 07:33
> To: Lars Eggert <[email-masked]>; The IESG <[email-masked]>
> Cc: [email-masked]; [email-masked]; Gonzalo Camarillo
> <[email-masked]>; [email-masked]
> Subject: Re: [Hipsec] Lars Eggert's Discuss on draft-ietf-hip-dex-24: (with
> DISCUSS and COMMENT)
> 
> Lars,
> 
> The hip-dex document was already in IESG evaluation (and had even a ballot,
> which was deferred) when I became the responsible AD, so, I have no more
> historical context than you (and to be honest, I did not check the charter).
> 
> In a separate email thread, I will check with chairs, previous ADs, and
> authors. Unsure whether I will get a reply before our telechat.
> 
> The cluster C386 is blocked by this document and my fall-back plan is to
> remove completely the appendix of draft-ietf-hip-rfc4423-bis to remove the
> dependency.
> 
> Cc: "[email-masked]" <[email-masked]>, "hip-
> [email-masked]" <[email-masked]>, "[email-masked]"
> <[email-masked]>, "[email-masked]" <[email-masked]>

---

From: Lars Eggert <[email-masked]>
Date: Thu, 25 Mar 2021 13:00:19 +0200

Hi Gonzalo,

> However, Terry told me there was no need to re-charter the WG. Instead, in the email below he asked me to simply add the corresponding milestone.
...
> Accordingly, I added the milestones about HIP-DEX at the end of March. However, apparently Terry never got to approving them. In the email thread below, you can see my last ping to him, in October…

thanks for the context! It's very unfortunate that the addition of this work item to the charter scope was never fully completed.

I'll clear my DISCUSS based on the contents of the emails you forwarded.

Thanks,
Lars