Subject: [Hls-interest] Questions about section 8.11 (Low-Latency Playlist)

From: "Weil, Nicolas" <[email-masked]>
Date: Fri, 1 May 2020 18:53:09 +0000

Hi,

Section 8.11 shows only an example of discrete part addressing scheme, while the preliminary LL-HLS specification was also including an example of byterange addressing scheme. Will such an example be added in an upcoming RFC version, or should we assume that Apple players finally won't support byterange addressing for parts?

The example shows 2 seconds EXT-X-PARTS with only the first part being INDEPENDENT, whereas the reference stream https://ll-hls-test.apple.com/cmaf/master.m3u8 shows 1 second parts, all INDEPENDENT. Will there be an update of the HLS Authoring Specification for Apple Devices page with a specific recommendation for the EXT-PARTS settings, or should we assume that the reference stream settings is the actual recommendation and that the example in the RFC is only a theoretical example?

Thanks,
Nicolas

----------------
Nicolas Weil | Senior Product Manager - Media Services
AWS Elemental

---

From: Roger Pantos <[email-masked]>
Date: Fri, 01 May 2020 12:13:55 -0700

> On May 1, 2020, at 11:53 AM, Weil, Nicolas <[email-masked]> wrote:
> 
> Hi,
>  
> Section 8.11 shows only an example of discrete part addressing scheme, while the preliminary LL-HLS specification was also including an example of byterange addressing scheme. Will such an example be added in an upcoming RFC version,

Probably not. We’re pretty stingy with examples in the spec; it’s plenty long enough already.

Note that all the examples currently in the preliminary article will remain in it as it transitions to being an informative supplement to the spec.

> or should we assume that Apple players finally won’t support byterange addressing for parts?

You have to read the spec to determine what is supported; the examples are not guaranteed to be complete. Take a look at https://tools.ietf.org/html/draft-pantos-hls-rfc8216bis-07#section-4.4.4.9 and specifically the BYTERANGE attribute.

See also the discussion about byte range hinting in https://tools.ietf.org/html/draft-pantos-hls-rfc8216bis-07#section-6.3.8 where it talking about hints and subranges. 

Partial segment specification by byte range is the basis for the interoperability point between LL-HLS and LL-DASH.

>  
> The example shows 2 seconds EXT-X-PARTS with only the first part being INDEPENDENT, whereas the reference stream https://ll-hls-test.apple.com/cmaf/master.m3u8 <https://ll-hls-test.apple.com/cmaf/master.m3u8> shows 1 second parts, all INDEPENDENT. Will there be an update of the HLS Authoring Specification for Apple Devices page with a specific recommendation for the EXT-PARTS settings, or should we assume that the reference stream settings is the actual recommendation and that the example in the RFC is only a theoretical example?

Yes, there will be an update to the Authoring Spec with specific recommendations for low-latency. Stay tuned.

Roger.

>  
> Thanks,
> Nicolas  
>  
> ----------------
> Nicolas Weil | Senior Product Manager – Media Services
> AWS Elemental
>  
> -- 
> Hls-interest mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/hls-interest <https://www.ietf.org/mailman/listinfo/hls-interest>