Subject: [Hls-interest] AV sync issues with AES 128 encrypted non-multiplexed HLS streams in macOS 10.15.4

From: Boy van Dijk <[email-masked]>
Date: Wed, 20 May 2020 16:41:22 +0200

Hi,

Some of our customer have notified us about AV sync issues when streaming AES 128 encrypted HLS streams in macOS 10.15.4 / Safari 13.1.

After some investigation, it is clear that these issues only happen with non-multiplexed content. 

The issues become worse the longer you play the stream. After about 10 minutes it's very easily noticeable.

As we have seen this issue with content packaged with different products, and because it's only reproducible in the latest public release of macOS, it seems this is a bug on Apple's side.

This is a demo stream that exhibits the issue, generated by just-in-time packager Unified Origin (the sync issues can be noticed from about 5 minutes into the content): 

https://demo.unified-streaming.com/video/tears-of-steel/tears-of-steel-aes.ism/.m3u8?hls_no_multiplex

In case I need to report this bug elsewhere, or if additional info is needed, please let me know.

Thanks.

Boy (Unified Streaming)

---

From: Roger Pantos <[email-masked]>
Date: Wed, 20 May 2020 08:51:45 -0700

> On May 20, 2020, at 7:41 AM, Boy van Dijk <[email-masked]> wrote:
> 
> Hi,
> 

For issues that are specific to Apple clients please file a bug and include a sysdiagnose here: http://feedbackassistant.apple.com <http://feedbackassistant.apple.com/>

Roger Pantos
Apple Inc.

> 
> Thanks.
> 
> Boy (Unified Streaming)
> -- 
> Hls-interest mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hls-interest