Subject: [Hls-interest] Reloading the Media Playlist File

From: Ofer Shem Tov <[email-masked]>
Date: Sat, 13 Jun 2020 13:27:54 +0300

Target duration was used to decide when to reload a live media playlist
file. Is that changed?

https://tools.ietf.org/html/draft-pantos-hls-rfc8216bis-07

"When a client loads a Playlist file for the first time or reloads a

   Playlist file and finds that it has changed since the last time it
   was loaded, the client MUST wait for at least the duration of the
   last segment in the Playlist before attempting to reload the Playlist
   file again, measured from the last time the client began loading the
   Playlist file."

Is this the current spec? If so are they Apple players or other
players that behave like that?

Thanks

Ofer

-- 
<http://www.verizonmedia.com>

Ofer Shem Tov

Distinguished Software Dev Engineer
Media Platform

M +972548842664
2A Jabotinsky St.
Amot Atrium 36th Floor
Ramat Gan

<http://www.facebook.com/verizonmedia>   <http://twitter.com/verizonmedia>
<https://www.linkedin.com/company/verizon-media/>
<http://www.instagram.com/verizonmedia>

---

From: Roger Pantos <[email-masked]>
Date: Tue, 16 Jun 2020 12:57:55 -0700

Hello Ofer, 

> On Jun 13, 2020, at 3:27 AM, Ofer Shem Tov <ost=[email-masked]> wrote:
> 
> Target duration was used to decide when to reload a live media playlist file. Is that changed?
> 
> https://tools.ietf.org/html/draft-pantos-hls-rfc8216bis-07 <https://tools.ietf.org/html/draft-pantos-hls-rfc8216bis-07>
> 
> Is this the current spec? If so are they Apple players or other players that behave like that?

This was changed in the first version of the 2nd edition HLS spec, in 2017. It was changed to allow faster discovery in the presence of short segments. 

Note that it is stated as a minimum, so clients that wait a full target duration regardless are still compliant. 

The Apple native clients, at least, have changed to take advantage of the 2017 provision.

regards,

Roger Pantos
Apple Inc.

> 
> Thanks
> 
> Ofer
> 
> -- 
>  <http://www.verizonmedia.com/>
> Ofer Shem Tov
> 
>  <http://www.facebook.com/verizonmedia>   <http://twitter.com/verizonmedia>   <https://www.linkedin.com/company/verizon-media/>   <http://www.instagram.com/verizonmedia>
> 
> -- 
> Hls-interest mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hls-interest

---

From: Ofer Shem Tov <[email-masked]>
Date: Tue, 16 Jun 2020 23:16:04 +0300

Thanks for the answer. Will the Apple client do that always or only for an
HLS playlist of some version? Also what iOS version included the change in
behaviour?

Ofer

On Tue, Jun 16, 2020 at 10:58 PM Roger Pantos <rpantos=
[email-masked]> wrote:

> Hello Ofer,
>
> On Jun 13, 2020, at 3:27 AM, Ofer Shem Tov <
> ost=[email-masked]> wrote:
>
> This was changed in the first version of the 2nd edition HLS spec, in
> 2017. It was changed to allow faster discovery in the presence of short
> segments.
>

Ofer Shem Tov

M +972548842664
2A Jabotinsky St.
Amot Atrium 36th Floor
Ramat Gan

---

From: Roger Pantos <[email-masked]>
Date: Tue, 16 Jun 2020 13:18:37 -0700

> On Jun 16, 2020, at 1:16 PM, Ofer Shem Tov <ost=[email-masked]> wrote:
> 
> Thanks for the answer. Will the Apple client do that always or only for an HLS playlist of some version?

In the Apple client the behavior is not gated by playlist version.

> Also what iOS version included the change in behaviour?

Let's see, 2017, so iOS 11 and onward.

Roger.

> 
> Ofer
> 
> On Tue, Jun 16, 2020 at 10:58 PM Roger Pantos <rpantos=[email-masked] <mailto:[email-masked]>> wrote:
> Hello Ofer, 
> 
>> On Jun 13, 2020, at 3:27 AM, Ofer Shem Tov <ost=[email-masked] <mailto:ost=[email-masked]>> wrote:
>> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/hls-interest <https://www.ietf.org/mailman/listinfo/hls-interest>
> 
> 
> 
> --