Subject: [Hls-interest] Inclusive Language

From: John Bartos <[email-masked]>
Date: Thu, 23 Jul 2020 14:34:33 -0400

Hi All,

I'd like to start a discussion about inclusive language in the HLS spec. At
Twitch we are committed to using inclusive engineering terms. We believe
that inclusive language creates an environment where everyone feels welcome
and supported.

As we've spread this awareness across the tech we use, I've noticed that
the HLS spec uses the word "master" in a way which implies master/slave. I
see this as contrary to our goals of inclusivity. It seems that we have
already acknowledged this by changing "slave" to "child", but that is only
a half measure.

I'd like to see us do better. I expressed the above to the #video-dev
community where I received broad support and some new ideas. Among them are:

   - Main
   - Index

And for child:

   - Media
   - Rendition

Let me know what you all think. Thanks to everyone who has offered input
and support so far. I'm looking forward to a productive discussion.

- John

---

From: Joey Parrish <[email-masked]>
Date: Thu, 23 Jul 2020 11:47:00 -0700

I would support this change in naming.

On Thu, Jul 23, 2020 at 11:41 AM John Bartos <bartsjb=
[email-masked]> wrote:

> Hi All,
>
> I'd like to start a discussion about inclusive language in the HLS spec.
> At Twitch we are committed to using inclusive engineering terms. We believe
> --
> Hls-interest mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hls-interest
>

---

From: John Luther <[email-masked]>
Date: Thu, 23 Jul 2020 15:27:16 -0400

JW Player supports the renaming, preferring Index and Media.

JL

---

From: "Law, Will" <[email-masked]>
Date: Thu, 23 Jul 2020 20:15:45 +0000

‘index’ is an overloaded term and the current ‘master’ playlist doesn’t actually provide an index (i.e an ordinal entry) in to anything. It simply lists the media playlists that are available and in so doing describes the content of what is available. Given that “rendition” also has a creepy second (and common) meaning, I’d go with the terms “content playlist” and “media playlist”.

-Will

From: John Luther <jluther=[email-masked]>
Date: Thursday, July 23, 2020 at 12:27 PM
To: Joey Parrish <joeyparrish=[email-masked]>
Cc: John Bartos <bartsjb=[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Hls-interest] Inclusive Language

JL

On Thu, Jul 23, 2020 at 2:47 PM Joey Parrish <joeyparrish=[email-masked]<mailto:[email-masked]>> wrote:
I would support this change in naming.

On Thu, Jul 23, 2020 at 11:41 AM John Bartos <bartsjb=[email-masked]<mailto:[email-masked]>> wrote:
Hi All,

I'd like to start a discussion about inclusive language in the HLS spec. At Twitch we are committed to using inclusive engineering terms. We believe that inclusive language creates an environment where everyone feels welcome and supported.

As we've spread this awareness across the tech we use, I've noticed that the HLS spec uses the word "master" in a way which implies master/slave. I see this as contrary to our goals of inclusivity. It seems that we have already acknowledged this by changing "slave" to "child", but that is only a half measure.

I'd like to see us do better. I expressed the above to the #video-dev community where I received broad support and some new ideas. Among them are:

  *   Main
  *   Index
And for child:

  *   Media
  *   Rendition

Let me know what you all think. Thanks to everyone who has offered input and support so far. I'm looking forward to a productive discussion.

- John
--
Hls-interest mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/hls-interest<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_hls-2Dinterest&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=KkevKJerDHRF9WRs8nW8Ew&m=AEyY4odM4YLon2oHNVf1rfM5-NKxC6qGBqFVkzQxIZw&s=dBeRfhvlDUr90hBBpzgFVKjIR9ujvZHB1HkG-rE2G2Y&e=>
--
Hls-interest mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/hls-interest<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_hls-2Dinterest&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=KkevKJerDHRF9WRs8nW8Ew&m=AEyY4odM4YLon2oHNVf1rfM5-NKxC6qGBqFVkzQxIZw&s=dBeRfhvlDUr90hBBpzgFVKjIR9ujvZHB1HkG-rE2G2Y&e=>

---

From: "Pope, Cooper" <[email-masked]>
Date: Thu, 23 Jul 2020 20:18:20 +0000

WarnerMedia fully supports a change.

Personally, I think the new terminology would be more natural if the word "playlist" is only used to describe the media playlist. Therefore, it would be "playlist index" or "index"; and, "media playlist(s)" or "playlist(s)". Just something to consider.

Thanks,
Cooper

From: Hls-interest <[email-masked]> on behalf of John Luther <jluther=[email-masked]>
Date: Thursday, July 23, 2020 at 3:27 PM
To: Joey Parrish <joeyparrish=[email-masked]>
Cc: John Bartos <bartsjb=[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Hls-interest] Inclusive Language

JL

  *   Main
  *   Index
And for child:

  *   Media
  *   Rendition

- John
--
Hls-interest mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/hls-interest<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_hls-2Dinterest&d=DwMFaQ&c=tq9bLrSQ8zIr87VusnUS9yAL0Jw_xnDiPuZjNR4EDIQ&r=NEGndsAnayHBFRDVn1TWIM_1saXPAJyHcpQ0-0Rz5t0&m=NZ-Jm7_jFHc6QK61kHGJTvn_H5StfB9pTW-C_4kTatI&s=4bdEUC9kwwJ5xBUEgU1Zq2Yw6GioPSLJMjW93FyORgA&e=>
--
Hls-interest mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/hls-interest<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_hls-2Dinterest&d=DwMFaQ&c=tq9bLrSQ8zIr87VusnUS9yAL0Jw_xnDiPuZjNR4EDIQ&r=NEGndsAnayHBFRDVn1TWIM_1saXPAJyHcpQ0-0Rz5t0&m=NZ-Jm7_jFHc6QK61kHGJTvn_H5StfB9pTW-C_4kTatI&s=4bdEUC9kwwJ5xBUEgU1Zq2Yw6GioPSLJMjW93FyORgA&e=>

---

From: John Luther <[email-masked]>
Date: Thu, 23 Jul 2020 16:22:37 -0400

Index has some precedent as the "starting point" of a content
tree (index.html, etc.), but I'd be fine with Content Playlist.

JL

On Thu, Jul 23, 2020 at 4:15 PM Law, Will <wilaw=[email-masked]>
wrote:

> ‘index’ is an overloaded term and the current ‘master’ playlist doesn’t
> actually provide an index (i.e an ordinal entry) in to anything. It simply
> lists the media playlists that are available and in so doing describes the
> content of what is available. Given that “rendition” also has a creepy
> second (and common) meaning, I’d go with the terms “content playlist” and
> “media playlist”.
>
>
>
> -Will
>
>
>
>
>
>
>
>
>
> *From: *John Luther <jluther=[email-masked]>
> *Date: *Thursday, July 23, 2020 at 12:27 PM
> *To: *Joey Parrish <joeyparrish=[email-masked]>
> *Cc: *John Bartos <bartsjb=[email-masked]>, "
> [email-masked]" <[email-masked]>
> *Subject: *Re: [Hls-interest] Inclusive Language
>
>
>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_hls-2Dinterest&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=KkevKJerDHRF9WRs8nW8Ew&m=AEyY4odM4YLon2oHNVf1rfM5-NKxC6qGBqFVkzQxIZw&s=dBeRfhvlDUr90hBBpzgFVKjIR9ujvZHB1HkG-rE2G2Y&e=>
>
> --
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_hls-2Dinterest&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=KkevKJerDHRF9WRs8nW8Ew&m=AEyY4odM4YLon2oHNVf1rfM5-NKxC6qGBqFVkzQxIZw&s=dBeRfhvlDUr90hBBpzgFVKjIR9ujvZHB1HkG-rE2G2Y&e=>
>
>

---

From: Jason Forbes <[email-masked]>
Date: Thu, 23 Jul 2020 20:51:06 +0000

I’ve always referred to them as root and variant manifests. JLF

--
Jason Forbes
Technical Consultant
m: +1-720-863-4560
<mailto:[email-masked]>     <https://www.linkedin.com/in/jasonlforbes/>      <https://velocix.com/>      <https://twitter.com/velocix>
<https://velocix.com/>

From: Hls-interest <[email-masked]> On Behalf Of John Luther
Sent: Thursday, July 23, 2020 14:23
To: Law, Will <wilaw=[email-masked]>
Cc: Joey Parrish <[email-masked]>; John Bartos <[email-masked]>; [email-masked]
Subject: Re: [Hls-interest] Inclusive Language

EXTERNAL: Do not click links or open attachments if you do not recognize the sender.
Index has some precedent as the "starting point" of a content tree (index.html, etc.), but I'd be fine with Content Playlist.

JL

On Thu, Jul 23, 2020 at 4:15 PM Law, Will <wilaw=[email-masked]<mailto:[email-masked]>> wrote:
‘index’ is an overloaded term and the current ‘master’ playlist doesn’t actually provide an index (i.e an ordinal entry) in to anything. It simply lists the media playlists that are available and in so doing describes the content of what is available. Given that “rendition” also has a creepy second (and common) meaning, I’d go with the terms “content playlist” and “media playlist”.

-Will

From: John Luther <jluther=[email-masked]<mailto:[email-masked]>>
Date: Thursday, July 23, 2020 at 12:27 PM
To: Joey Parrish <joeyparrish=[email-masked]<mailto:[email-masked]>>
Cc: John Bartos <bartsjb=[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Hls-interest] Inclusive Language

JL

  *   Main
  *   Index
And for child:

  *   Media
  *   Rendition

- John

Velocix Solutions Limited is a limited company registered in England and Wales with registered number 11560407. Registered office address: Unit A1, Methuen Park, Chippenham, Wiltshire, SN14 0GT.

---

From: Phil Cluff <[email-masked]>
Date: Fri, 24 Jul 2020 12:02:42 +0100

+1 from the team here at Mux.

Personally I'm a fan of "variant" and "media" because the name explains
what the playlist contains - a list of variants, and a list of media
segments, but I do appreciate that it would be a confusing change.

Thanks

On Thu, Jul 23, 2020 at 9:51 PM Jason Forbes <[email-masked]>
wrote:

> <[email-masked]>    <https://www.linkedin.com/in/jasonlforbes/>
>      <https://velocix.com/>     <https://twitter.com/velocix>
>
> <https://velocix.com/>
>
>
>
> *From:* Hls-interest <[email-masked]> * On Behalf Of *John
> Luther
> *Sent:* Thursday, July 23, 2020 14:23
> *To:* Law, Will <wilaw=[email-masked]>
> *Cc:* Joey Parrish <[email-masked]>; John Bartos <
> [email-masked]>; [email-masked]
> *Subject:* Re: [Hls-interest] Inclusive Language
>
>
>
> *EXTERNAL: Do not click links or open attachments if you do not recognize
> the sender.*
>
> On Thu, Jul 23, 2020 at 4:15 PM Law, Will <wilaw=
> [email-masked]> wrote:
>
> Velocix Solutions Limited is a limited company registered in England and
> Wales with registered number 11560407. Registered office address: Unit A1,
> Methuen Park, Chippenham, Wiltshire, SN14 0GT.
> --

-- 
Phil Cluff | Streaming Architect | +44 7983 406 937 | [email-masked]

---

From: "May, Bill" <[email-masked]>
Date: Fri, 24 Jul 2020 13:29:29 +0000

Hi, all,

As one of the authors of the specification, I can tell you that no master/slave relationship was ever intended.

I do not believe that we have used the term “child” or “slave” anywhere in the HLS specifications or any of the drafts.  Or even considered those terms in any of our drafts.  If they exist, can you please point them so that they can be changed.

We introduced “Rendition” in draft-07 (9/2011) and this has a particular meaning.

In draft-11 (2013), we introduced the terms “Master Playlist” and starting consistently using “Media Playlist”.  We intended “Master Playlist”  to be used with “master” as an adjective rather than a noun or a verb, with its “chief or principal” definition (https://www.dictionary.com/browse/master?s=t , adjective, 2nd meaning, which gives the example “master list").

Also note that everywhere in the specifications, we have always use “Master Playlist” as 1 unit and capitalized, and likewise always use “Media Playlist” as 1 unit and capitalized.  Consistency of naming is one thing that has made the HLS specification very friendly to read.

The “Master Playlist” does not imply a master/slave relationship; it is contains a list of independent playlists and configurations that can be used together.  Each “Media Playlist” is an independent entity.

As to changing the name, we’ve discussed it internally at DSS, and we do not feel that a change is required.

We will not object if a change is made, however, and recommend the term “Presentation Playlist” as being more descriptive than any terms given so far.

Thank you for the conversation.

Bill May
Engineering Fellow
Disney Streaming Service

On Jul 23, 2020, at 1:18 PM, Pope, Cooper <Cooper.Pope=[email-masked]<mailto:Cooper.Pope=[email-masked]>> wrote:

Thanks,
Cooper

From: Hls-interest <[email-masked]<mailto:[email-masked]>> on behalf of John Luther <jluther=[email-masked]<mailto:jluther=[email-masked]>>
Date: Thursday, July 23, 2020 at 3:27 PM
To: Joey Parrish <joeyparrish=[email-masked]<mailto:joeyparrish=[email-masked]>>
Cc: John Bartos <bartsjb=[email-masked]<mailto:bartsjb=[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Hls-interest] Inclusive Language

JL

  *   Main
  *   Index

And for child:

  *   Media
  *   Rendition

- John
--
Hls-interest mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/hls-interest<https://nam12.safelinks.protection.outlook.com/?url=https%3A%2F%2Furldefense.proofpoint.com%2Fv2%2Furl%3Fu%3Dhttps-3A__www.ietf.org_mailman_listinfo_hls-2Dinterest%26d%3DDwMFaQ%26c%3Dtq9bLrSQ8zIr87VusnUS9yAL0Jw_xnDiPuZjNR4EDIQ%26r%3DNEGndsAnayHBFRDVn1TWIM_1saXPAJyHcpQ0-0Rz5t0%26m%3DNZ-Jm7_jFHc6QK61kHGJTvn_H5StfB9pTW-C_4kTatI%26s%3D4bdEUC9kwwJ5xBUEgU1Zq2Yw6GioPSLJMjW93FyORgA%26e%3D&data=02%7C01%7Cbill.may%40disneystreaming.com%7Cb62b9afe33724c475b8b08d82f4591cd%7C65f03ca86d0a493e9e4ac85ac9526a03%7C1%7C0%7C637311323142210609&sdata=93nAaV8XE%2B8ds1R%2FWElEYUqj%2F7ltwxGfuY8O3OsmKP0%3D&reserved=0>
--
Hls-interest mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/hls-interest<https://nam12.safelinks.protection.outlook.com/?url=https%3A%2F%2Furldefense.proofpoint.com%2Fv2%2Furl%3Fu%3Dhttps-3A__www.ietf.org_mailman_listinfo_hls-2Dinterest%26d%3DDwMFaQ%26c%3Dtq9bLrSQ8zIr87VusnUS9yAL0Jw_xnDiPuZjNR4EDIQ%26r%3DNEGndsAnayHBFRDVn1TWIM_1saXPAJyHcpQ0-0Rz5t0%26m%3DNZ-Jm7_jFHc6QK61kHGJTvn_H5StfB9pTW-C_4kTatI%26s%3D4bdEUC9kwwJ5xBUEgU1Zq2Yw6GioPSLJMjW93FyORgA%26e%3D&data=02%7C01%7Cbill.may%40disneystreaming.com%7Cb62b9afe33724c475b8b08d82f4591cd%7C65f03ca86d0a493e9e4ac85ac9526a03%7C1%7C0%7C637311323142210609&sdata=93nAaV8XE%2B8ds1R%2FWElEYUqj%2F7ltwxGfuY8O3OsmKP0%3D&reserved=0>
--
Hls-interest mailing list
[email-masked]<mailto:[email-masked]>
https://nam12.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fhls-interest&amp;data=02%7C01%7Cbill.may%40disneystreaming.com%7Cb62b9afe33724c475b8b08d82f4591cd%7C65f03ca86d0a493e9e4ac85ac9526a03%7C1%7C0%7C637311323142230597&amp;sdata=DJwRyMlyL9lIxzPNXDmyGOv1efLRa37UeYMCgC7Ky%2Fk%3D&amp;reserved=0

---

From: Jeremy Martin <[email-masked]>
Date: Fri, 24 Jul 2020 10:07:28 -0400

Bill speaks to a distinction that I wasn't quite sure how to articulate,
but to his point, I would mention that as an implementer I've never
understood "Master" in "Master Playlist" to imply a master/slave
relationship, either. There's no sense in which the Master Playlist
exhibits control, asymmetric or otherwise, over the Media Playlists that it
references.

Given the intent and the spirit in which these changes are proposed, I
don't hold any specific objections, but I do question if the original
contention, that "the HLS spec uses the word 'master' in a way which
implies master/slave" is, in fact, accurate?

Regards,

Jeremy Martin
Chief Technology Officer
Stream.Live

On Fri, Jul 24, 2020 at 9:29 AM May, Bill <Bill.May=
[email-masked]> wrote:

> Hi, all,
>
> As one of the authors of the specification, I can tell you that no
> master/slave relationship was ever intended.
>
> I do not believe that we have used the term “child” or “slave” anywhere in
> the HLS specifications or any of the drafts.  Or even considered those
> terms in any of our drafts.  If they exist, can you please point them so
> that they can be changed.
>
> In draft-11 (2013), we introduced the terms “Master Playlist” and starting
> consistently using “Media Playlist”.  We intended “Master Playlist”  to be
> used with “master” as an adjective rather than a noun or a verb, with its
> “chief or principal” definition (
> https://www.dictionary.com/browse/master?s=t , adjective, 2nd meaning,
> which gives the example “master list").
>
> Also note that everywhere in the specifications, we have always use
> “Master Playlist” as 1 unit and capitalized, and likewise always use “Media
> Playlist” as 1 unit and capitalized.  Consistency of naming is one thing
> that has made the HLS specification very friendly to read.
>
> The “Master Playlist” does not imply a master/slave relationship; it is
> contains a list of independent playlists and configurations that can be
> used together.  Each “Media Playlist” is an independent entity.
>
> We will not object if a change is made, however, and recommend the term
> “Presentation Playlist” as being more descriptive than any terms given so
> far.
>
> On Jul 23, 2020, at 1:18 PM, Pope, Cooper <
> Cooper.Pope=[email-masked]> wrote:
>
> Personally, I think the new terminology would be more natural if the word
> "playlist" is only used to describe the media playlist. Therefore, it would
> be "playlist index" or "index"; and, "media playlist(s)" or "playlist(s)".
> Just something to consider.
>
> Thanks,
> Cooper
>
>
>
> *From: *Hls-interest <[email-masked]> on behalf of John
> Luther <jluther=[email-masked]>
> *Date: *Thursday, July 23, 2020 at 3:27 PM
> <https://nam12.safelinks.protection.outlook.com/?url=https%3A%2F%2Furldefense.proofpoint.com%2Fv2%2Furl%3Fu%3Dhttps-3A__www.ietf.org_mailman_listinfo_hls-2Dinterest%26d%3DDwMFaQ%26c%3Dtq9bLrSQ8zIr87VusnUS9yAL0Jw_xnDiPuZjNR4EDIQ%26r%3DNEGndsAnayHBFRDVn1TWIM_1saXPAJyHcpQ0-0Rz5t0%26m%3DNZ-Jm7_jFHc6QK61kHGJTvn_H5StfB9pTW-C_4kTatI%26s%3D4bdEUC9kwwJ5xBUEgU1Zq2Yw6GioPSLJMjW93FyORgA%26e%3D&data=02%7C01%7Cbill.may%40disneystreaming.com%7Cb62b9afe33724c475b8b08d82f4591cd%7C65f03ca86d0a493e9e4ac85ac9526a03%7C1%7C0%7C637311323142210609&sdata=93nAaV8XE%2B8ds1R%2FWElEYUqj%2F7ltwxGfuY8O3OsmKP0%3D&reserved=0>
>
> --
> <https://nam12.safelinks.protection.outlook.com/?url=https%3A%2F%2Furldefense.proofpoint.com%2Fv2%2Furl%3Fu%3Dhttps-3A__www.ietf.org_mailman_listinfo_hls-2Dinterest%26d%3DDwMFaQ%26c%3Dtq9bLrSQ8zIr87VusnUS9yAL0Jw_xnDiPuZjNR4EDIQ%26r%3DNEGndsAnayHBFRDVn1TWIM_1saXPAJyHcpQ0-0Rz5t0%26m%3DNZ-Jm7_jFHc6QK61kHGJTvn_H5StfB9pTW-C_4kTatI%26s%3D4bdEUC9kwwJ5xBUEgU1Zq2Yw6GioPSLJMjW93FyORgA%26e%3D&data=02%7C01%7Cbill.may%40disneystreaming.com%7Cb62b9afe33724c475b8b08d82f4591cd%7C65f03ca86d0a493e9e4ac85ac9526a03%7C1%7C0%7C637311323142210609&sdata=93nAaV8XE%2B8ds1R%2FWElEYUqj%2F7ltwxGfuY8O3OsmKP0%3D&reserved=0>
>
> --

---

From: Gary Katsevman <[email-masked]>
Date: Fri, 24 Jul 2020 11:09:17 -0400

Brightcove is also in support of the name change.

We have a slight preference to main and media playlists.

---

From: John Bartos <[email-masked]>
Date: Fri, 24 Jul 2020 15:07:28 -0400

Thanks everyone for the support so far. Regarding intention, I don't
believe that it matters at this moment. The fact that the terms *can* be
interpreted in that way is the issue, and it's clear that that
interpretation does happen. We don't get to determine how people interpret
it. Furthermore, people reading the spec don't have the context Bill
provided here which digs into its origin.

I don't want to get caught up on semantics, but I see it like this: the two
files are presented hierarchically and one is called "master". I don't
think it's a stretch if someone interprets the other as "slave".

To be clear I'm not blaming or attacking the authors. What I am saying is
that we can improve ourselves.

As for the terms, I like "playlist" over "rendition". So we have:

   - Main playlist
   - Variant playlist
   - Content playlist
   - Root playlist
   - Index playlist (I do agree with JL, and I think we can acknowledge the
   prevalence of "index.m3u8")

And for the segments:

   - Media playlist
   - Variant playlist (again, but in a different context. It is a variant
   instead of it contains variants, which is a bit confusing imo).

I have been using Main/Media at work for a while now and have not run into
any confusion yet. So I prefer those.

For next steps, I think we should narrow down the above and then I'll send
out a poll. Of course until Apple/Roger weighs in this is all voluntary and
up to each organization to implement. But as Bill said, consistency is good.

- John

On Fri, Jul 24, 2020 at 11:09 AM Gary Katsevman <[email-masked]>
wrote:

>>> <[email-masked]>
>>> <https://www.linkedin.com/in/jasonlforbes/>     <https://velocix.com/>
>>>      <https://twitter.com/velocix>
>>>
>>> <https://velocix.com/>
>>>
>>>
>>>
>>> *EXTERNAL: Do not click links or open attachments if you do not
>>> recognize the sender.*
>>>

---

From: John Bartos <[email-masked]>
Date: Fri, 24 Jul 2020 15:14:02 -0400

Forgot Bill's suggestion: "Presentation Playlist" for main. It also has the
benefit of aligning with DASH

On Fri, Jul 24, 2020 at 3:07 PM John Bartos <[email-masked]> wrote:

> I don't want to get caught up on semantics, but I see it like this: the
> two files are presented hierarchically and one is called "master". I don't
>    - Index playlist (I do agree with JL, and I think we can acknowledge
>    the prevalence of "index.m3u8")
>
> And for the segments:
>
>    - Media playlist
>>>> I'd like to start a discussion about inclusive language in the HLS
>>>> spec. At Twitch we are committed to using inclusive engineering terms. We
>>>> believe that inclusive language creates an environment where everyone feels
>>>> welcome and supported.
>>>>
>>>>
>>>>
>>>> As we've spread this awareness across the tech we use, I've noticed
>>>> that the HLS spec uses the word "master" in a way which implies
>>>> master/slave. I see this as contrary to our goals of inclusivity. It seems
>>>> that we have already acknowledged this by changing "slave" to "child", but
>>>> that is only a half measure.
>>>>
>>>>
>>>>
>>>> Let me know what you all think. Thanks to everyone who has offered
>>>> input and support so far. I'm looking forward to a productive discussion.
>>>>
>>>>
>>>>
>>>> - John
>>>>
>>>> --
>>>> Velocix Solutions Limited is a limited company registered in England
>>>> and Wales with registered number 11560407. Registered office address: Unit
>>>> A1, Methuen Park, Chippenham, Wiltshire, SN14 0GT.
>>>> --

---

From: "May, Bill" <[email-masked]>
Date: Fri, 24 Jul 2020 21:12:27 +0000

On Jul 24, 2020, at 12:07 PM, John Bartos <bartsjb=[email-masked]<mailto:bartsjb=[email-masked]>> wrote:

Thanks everyone for the support so far. Regarding intention, I don't believe that it matters at this moment. The fact that the terms can be interpreted in that way is the issue, and it's clear that that interpretation does happen. We don't get to determine how people interpret it. Furthermore, people reading the spec don't have the context Bill provided here which digs into its origin.

I don't want to get caught up on semantics, but I see it like this: the two files are presented hierarchically and one is called "master". I don't think it's a stretch if someone interprets the other as "slave”.

I’m not going to debate here, but you’re exactly caught up on semantics.

The whole argument is that you’re interpreting a phrase in a way that wasn’t intended when the definition in the specification explicitly states a different interpretation.

To be clear I'm not blaming or attacking the authors. What I am saying is that we can improve ourselves.

  *   Main playlist
  *   Variant playlist
  *   Content playlist
  *   Root playlist
  *   Index playlist (I do agree with JL, and I think we can acknowledge the prevalence of "index.m3u8")

And for the segments:

  *   Media playlist
  *   Variant playlist (again, but in a different context. It is a variant instead of it contains variants, which is a bit confusing imo).

I have been using Main/Media at work for a while now and have not run into any confusion yet. So I prefer those.

For next steps, I think we should narrow down the above and then I'll send out a poll. Of course until Apple/Roger weighs in this is all voluntary and up to each organization to implement. But as Bill said, consistency is good.

I believe that the term "Master Playlist” is the only term up for consideration to be changed.

 “Media Playlist”, “Variant Playlist” and “Rendition” have exact meanings in the specification and are used consistently and correctly.   I’m not aware of any objections to these terms .  Is there?

If not, they should not be up for any type of change.

In addition, I don’t believe any poll we have would be binding and may actually be counterproductive.

Roger is exacting in his terminology and if Apple decides that it should be changed, I trust him to come up with an exact term that will correctly describe the relationship.

Unless someone believes that there is something else offensive in the terminology in the specification, I believe that this conversation raised the point and should wait for Roger’s official verdict.

Thanks,
Bill

---

From: Roger Pantos <[email-masked]>
Date: Fri, 31 Jul 2020 10:09:43 -0700

> On Jul 24, 2020, at 2:12 PM, May, Bill <Bill.May=[email-masked]> wrote:
> 
> 
> 
>> On Jul 24, 2020, at 12:07 PM, John Bartos <bartsjb=[email-masked] <mailto:bartsjb=[email-masked]>> wrote:
>> 
>> Main playlist
>> Variant playlist
>> Content playlist
>> Root playlist
>> Index playlist (I do agree with JL, and I think we can acknowledge the prevalence of "index.m3u8")
>> And for the segments:
>> Media playlist
>> Variant playlist (again, but in a different context. It is a variant instead of it contains variants, which is a bit confusing imo).
>> 

Hi folks. I’m catching up after a few days of vacation and saw this thread. I don't have an answer for you yet but I want to acknowledge the discussion

I agree that the name "Master Playlist” is an issue that we should consider seriously. That said, I also want to make clear that changing it is by no means free. While it’s easy enough to search-and-replace in the current Internet-Draft, we have also have an RFC and over 10 years of documents and videos produced by Apple and others that use the current name. Some of that can change; some cannot. A new name will add friction to learning and will trigger a long tail of “what’s this, oh, do you mean that?” type of conversations.

So while we might change the name, it’s not a casual decision. And, this isn’t the only such discussion going on within Apple right now. Technologies other than HLS are facing the same or similar questions. Since I recognize that my own biases may prevent me from judging the true weight of this problem, I think that it’s important that I seek broader input than I usually do. 

So, that’s what I’m doing now. Thanks for your patience in the meantime.

Roger Pantos,
Apple Inc.

> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/hls-interest <https://www.ietf.org/mailman/listinfo/hls-interest>