Subject: [Hls-interest] Is there a standard protocol for uploading segments (and the playlist) to a web server?

From: Ross Finlayson <[email-masked]>
Date: Sat, 11 Jul 2020 10:15:52 +1200

I have an (open source) application[*] that acts as a proxy for a RTSP stream (e.g., from a network camera), converting it in real time to HLS segments, plus a (continuously-updated) “.m3u8” playlist.  This HLS stream can then be viewed - by browsers - via a separate web server.

An issue that many users face is that their RTSP stream (network camera) is on a private network, behind a firewall.  Whereas the web server needs to run on the public Internet (so that users anywhere can view the stream).  Therefore, it would be ideal if the HLS segments - and the playlist - could somehow be uploaded from the private network to the web server (on the public Internet), in real time.

Is there a standard protocol (e.g., using HTTP) for doing this?  Or are people generally ‘rolling their own’ solutions (or relying on something completely different, like network file sharing) to achieve this?

Ross Finlayson
Live Networks, Inc.
http://www.live555.com/

[*] http://www.live555.com/hlsProxy/

---

From: "Ali C. Begen" <[email-masked]>
Date: Sat, 11 Jul 2020 12:14:24 +0300

Ross, have a look at what we specified at DASH-IF:
https://dashif-documents.azurewebsites.net/Ingest/master/DASH-IF-Ingest.html

On Sat, Jul 11, 2020 at 1:16 AM Ross Finlayson <[email-masked]>
wrote:

> I have an (open source) application[*] that acts as a proxy for a RTSP
> stream (e.g., from a network camera), converting it in real time to HLS
> segments, plus a (continuously-updated) “.m3u8” playlist.  This HLS stream
> can then be viewed - by browsers - via a separate web server.
>
> An issue that many users face is that their RTSP stream (network camera)
> is on a private network, behind a firewall.  Whereas the web server needs
> to run on the public Internet (so that users anywhere can view the
> stream).  Therefore, it would be ideal if the HLS segments - and the
> playlist - could somehow be uploaded from the private network to the web
> server (on the public Internet), in real time.
>
> Is there a standard protocol (e.g., using HTTP) for doing this?  Or are
> people generally ‘rolling their own’ solutions (or relying on something
> completely different, like network file sharing) to achieve this?
>
>
> Ross Finlayson
> Live Networks, Inc.
> http://www.live555.com/
>
> --
> Hls-interest mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hls-interest
>

---

From: Roger Pantos <[email-masked]>
Date: Mon, 13 Jul 2020 09:31:42 -0700

> On Jul 10, 2020, at 3:15 PM, Ross Finlayson <[email-masked]> wrote:
> 

I've seen a variety of exotic transit protocols used for HLS, optimized for various things. (UDP multicast distribution across a managed backbone, anyone?) But if you want something simple, easy and well-supported, HTTP PUT can do the job. You can combine it with WebDAV DELETE if you want your application to drive expiry of old segments. That's what our reference tools do if you specify an http URL as the output directory.

You can configure a web server to provide private entry + public egress in a variety of ways. 

Roger Pantos
Apple Inc.