Subject: [Hls-interest] rendition report clarification

From: Scott Kellicker <[email-masked]>
Date: Fri, 26 Mar 2021 11:47:25 -0400

At least to me the spec is not clear about rendition-reports between audio
streams and video streams.  Looking at LLHLS streams produced by several
companies, I see different behavior.

To take an example.  If I have one audio group rendition and 3 video
renditions which point back to the audio group.  For example:

curl http://IP/playlist.m3u8
#EXTM3U
#EXT-X-VERSION:6
#EXT-X-MEDIA:TYPE=AUDIO,GROUP-ID="Audio",URI="audio1.m3u8"
#EXT-X-STREAM-INF:BANDWIDTH=3600000,CODECS="avc1.4d4c28,mp4a.40.2",RESOLUTION=1920x1080,AUDIO="Audio"
video1.m3u8
#EXT-X-STREAM-INF:BANDWIDTH=1400000,CODECS="avc1.4d4c1e,mp4a.40.2",RESOLUTION=540x360,AUDIO="Audio"
video2.m3u8
#EXT-X-STREAM-INF:BANDWIDTH=750000,CODECS="avc1.4d4c15,mp4a.40.2",RESOLUTION=320x240,AUDIO="Audio"
video3.m3u8

Q. When I return the m3u8 for one of the video renditions, should the
REND-REPORT contain the audio m3u8?

$ curl http://IP/video1.m3u8 |grep REND. ; should have all the audio RRs
when requesting video m3u8
#EXT-X-RENDITION-REPORT:URI="audio1=.m3u8",LAST-MSN=131,LAST-PART=1
#EXT-X-RENDITION-REPORT:URI="video2.m3u8",LAST-MSN=131,LAST-PART=1
#EXT-X-RENDITION-REPORT:URI="video3.m3u8",LAST-MSN=131,LAST-PART=1

Q. Conversely, when I return the rendition report for the audio rendition,
should it contain the 3 video rend report entries?

curl http://IP/audio1.m3u8 |grep REND.  ; should have all the video RRs
when requesting audio m3u8
#EXT-X-RENDITION-REPORT:URI="video1.m3u8",LAST-MSN=122,LAST-PART=1
#EXT-X-RENDITION-REPORT:URI="video2.m3u8",LAST-MSN=122,LAST-PART=1
#EXT-X-RENDITION-REPORT:URI="video3.m3u8",LAST-MSN=122,LAST-PART=1

mediastreamvalidator would seem to answer "yes" to both questions.
However, in my experience MSV is often wrong and can conflict with the
spec.  (And what ultimately matters is the spec AND what players expect)

Scott Kellicker
Blank Canvas Video LLC

---

From: Eryk Vershen <[email-masked]>
Date: Mon, 29 Mar 2021 08:52:50 -0700

> From: Scott Kellicker <[email-masked] <mailto:[email-masked]>>
> Date: March 26, 2021 at 8:48:44 AM PDT
> To: [email-masked] <mailto:[email-masked]>
> Subject: [Hls-interest] rendition report clarification
> 
> 
> At least to me the spec is not clear about rendition-reports between audio streams and video streams.  Looking at LLHLS streams produced by several companies, I see different behavior.
> 
> To take an example.  If I have one audio group rendition and 3 video renditions which point back to the audio group.  For example:
> 
> curl http://IP/playlist.m3u8 <http://ip/playlist.m3u8>
> #EXTM3U
> #EXT-X-VERSION:6
> Q. When I return the m3u8 for one of the video renditions, should the REND-REPORT contain the audio m3u8?
> 
> $ curl http://IP/video1.m3u8 <http://ip/video1.m3u8> |grep REND. ; should have all the audio RRs when requesting video m3u8

Yes.

See Appendix B.1 in draft-pantos-hls-rfc8216bis-07 (or later) -

   "Each Media Playlist contains one EXT-X-RENDITION-REPORT tag for each
    Media Playlist (Rendition) in the Master Playlist, except for the Media Playlist
    to which the EXT-X-RENDITION-REPORT tag is being added, and Playlists
    that contain the EXT-X-I-FRAMES-ONLY tag."

> Q. Conversely, when I return the rendition report for the audio rendition, should it contain the 3 video rend report entries?
> 
> curl http://IP/audio1.m3u8 <http://ip/audio1.m3u8> |grep REND.  ; should have all the video RRs when requesting audio m3u8

Yes, for the same reason.

> mediastreamvalidator would seem to answer "yes" to both questions.  However, in my experience MSV is often wrong and can conflict with the spec.  (And what ultimately matters is the spec AND what players expect)

Please take the time to submit bugs against the mediastreamvalidator.

regards,
Eryk Vershen
Apple Inc

> 
> Scott Kellicker
> Blank Canvas Video LLC
> 
> 
> -- 
> Hls-interest mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/hls-interest <https://www.ietf.org/mailman/listinfo/hls-interest>