Subject: [Hls-interest] Availability Duration of Partial Segments

From: Vijay Jayaraman <[email-masked]>
Date: Thu, 15 Apr 2021 15:21:56 +0000

Hi All,

I have a question related to LLHLS ( 6.2.2. Live Playlists - https://tools.ietf.org/html/draft-pantos-hls-rfc8216bis-07#section-6.2.2 )

The spec states the following about part *tags* in the playlist.

EXT-X-PART tags SHOULD be removed from the Playlist after they are

   greater than three Target Durations from the end of the Playlist.

The spec states the following about the availability duration of media *segments*.
The Availability Duration of a Media Segment is the duration of the
   segment plus the duration of the longest-duration Playlist
   distributed by the server containing that segment.  If the server
   removes a Media Segment URI from a Playlist that contains an EXT-
   X-ENDLIST tag, clients MUST be able to download the corresponding
   Media Segment until the time of removal plus the segment's
   Availability Duration.

I couldn’t find specific information on the Availability Duration of *Partial Segments*.

  1.  When not using BYTERANGE for partial segments, what is the Availability duration of the partial segments?
  2.  When using BYTERANGE for partial segments, does the Availability Duration of Media Segments apply to Partial Segments as well?

Thanks,
-Vijay

Vijay Jayaraman
Staff Software Engineer
Wowza Media Systems | The solution you start with, the partner you scale with.
[[email-masked]]<http://www.wowza.com/>[[email-masked]]<https://www.facebook.com/Wowza>[[email-masked]]<https://twitter.com/wowzamedia>[[email-masked]]<https://www.linkedin.com/company/wowza-media-systems>[[email-masked]]<https://www.youtube.com/user/wowzamedia>

This message may contain confidential or proprietary information of Wowza. If you are not the intended recipient of this message, please delete and do not share or use this message.

---

From: Roger Pantos <[email-masked]>
Date: Fri, 16 Apr 2021 09:31:19 -0700

Hello Vijay, You’re right that we should clarify this in the spec. In the meantime:

> On Apr 15, 2021, at 8:21 AM, Vijay Jayaraman <Vijay.Jayaraman=[email-masked]> wrote:
> 
> Hi All,
>  
> I have a question related to LLHLS ( 6.2.2. Live Playlists - https://tools.ietf.org/html/draft-pantos-hls-rfc8216bis-07#section-6.2.2 <https://tools.ietf.org/html/draft-pantos-hls-rfc8216bis-07#section-6.2.2> )
>  
> When not using BYTERANGE for partial segments, what is the Availability duration of the partial segments?

I would follow the lead of the caching advice in Appendix B.1:

      Successful responses to blocking Media segment requests should be
      cached for six Target Durations. 

and keep Partial Segments available for at least 6 target durations on the origin.

> When using BYTERANGE for partial segments, does the Availability Duration of Media Segments apply to Partial Segments as well?

Well, in most cases keeping a Media Segment available means that byte range requests against that segment are available too. But if your origin is peculiar in that it can make whole-resource requests available for longer than range requests against those resources, I would keep the range requests available for at least six target durations as well.

regards,

Roger Pantos
Apple Inc.

>  <http://www.wowza.com/> <https://www.facebook.com/Wowza> <https://twitter.com/wowzamedia> <https://www.linkedin.com/company/wowza-media-systems> <https://www.youtube.com/user/wowzamedia>
>  
> -- 
> Hls-interest mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/hls-interest <https://www.ietf.org/mailman/listinfo/hls-interest>

---

From: Vijay Jayaraman <[email-masked]>
Date: Wed, 21 Apr 2021 18:07:58 +0000

Hi Roger,

Thanks for the clarification; that makes a lot of sense. I agree with your statement about clarifying this in the spec.

Thanks,
-Vijay

From: Roger Pantos <rpantos=[email-masked]>
Date: Friday, April 16, 2021 at 10:31 AM
To: Vijay Jayaraman <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [Hls-interest] Availability Duration of Partial Segments

CAUTION: This email originated from outside of the organization. Do not click links or open attachments unless you recognize the sender and know the content is safe.

On Apr 15, 2021, at 8:21 AM, Vijay Jayaraman <Vijay.Jayaraman=[email-masked]<mailto:Vijay.Jayaraman=[email-masked]>> wrote:

Hi All,

I have a question related to LLHLS ( 6.2.2. Live Playlists - https://tools.ietf.org/html/draft-pantos-hls-rfc8216bis-07#section-6.2.2<https://linkprotect.cudasvc.com/url?a=https%3a%2f%2ftools.ietf.org%2fhtml%2fdraft-pantos-hls-rfc8216bis-07%23section-6.2.2&c=E,1,siLVbnzIX2WOiEYwxHAe63tKRGGNkEwopq3Mr8NL2TFXTA145Mh71glb4D04c3rEX13vdR3AA9kr9y6AuoFWAx9Wdfr0nyx_NLfSfOf6ntadHJ0CYFemR0e4IQ,,&typo=1> )

  1.  When using BYTERANGE for partial segments, does the Availability Duration of Media Segments apply to Partial Segments as well?

regards,

Roger Pantos
Apple Inc.

Thanks,
-Vijay

Vijay Jayaraman
Staff Software Engineer
Wowza Media Systems | The solution you start with, the partner you scale with.
<https://linkprotect.cudasvc.com/url?a=http%3a%2f%2fwww.wowza.com%2f&c=E,1,Q30fkaeUQ418HRiywbZ5GcKir6nix7HGePQZlhuntpDKov5tQ46W0uR_vPg9Er6sX6hOazfI6_tJX_0_cPnupbTxaQMBe6O0VIaCeCT3CxOpejI0X_0,&typo=1><https://www.facebook.com/Wowza><https://twitter.com/wowzamedia><https://www.linkedin.com/company/wowza-media-systems><https://www.youtube.com/user/wowzamedia>

--
Hls-interest mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/hls-interest<https://linkprotect.cudasvc.com/url?a=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2fhls-interest&c=E,1,BN2PA5XiVohq8dxyL0EBhNVs1TAGf8yItj8iP9EHu1_PL-PWxXxFVrm65he0EZSpUGWaPn1JU5nEIjiXipRT3lgcfCfEi6ZzceRxFYhw&typo=1>