Subject: [Hls-interest] WWDC 2021 HLS sessions

From: Roger Pantos <[email-masked]>
Date: Mon, 07 Jun 2021 13:58:11 -0700

A quick reminder: WWDC started today, and we have four sessions this year focused on HLS. Tomorrow we have a couple of app-focused sessions about our native AVPlayer API:

Explore HLS variants in AVFoundation: Discover how you can use AVFoundation APIs to highlight different variants of your content within your app. We'll show you how you can inspect HLS content using these APIs for different video characteristics, including attributes like SDR/HDR, FPS, and the like. And we'll explore the AVAssetVarient, which represents streaming and offline content.

Transition media gaplessly with HLS: Discover how you can create streaming media content that seamlessly transitions between episodes, songs, scenes, and individual resources. With gapless HLS playback, you can stitch together multiple pieces of content on the fly to create customized workouts, design interactive content, tell compelling stories, and more. We'll show you how you can provide faithful continuity for streaming music, event recordings, and pre-recorded video and provide a captivating viewing experience within your app.

On Wednesday we have sessions about two new HLS features, Interstitials and Content Steering:

Explore dynamic pre-rolls and mid-rolls in HLS: Learn how you can create seamless transitions between advertisements and your HLS streams. We'll show you how to incorporate HLS tags and AVFoundation APIs to create media experiences that move easily between your primary content and mid-rolls, and provide best practices for playing these streams in your app.

Improve global streaming availability with HLS Content Steering: Discover how you can use HLS playlist tags and the Steering Manifest format with your content to help dynamically update CDN redundancy policies tuned for each viewer. Learn how to load balance, set failover, and more.

https://developer.apple.com/wwdc21/sessions/

regards,

Roger Pantos
Apple Inc.

---

From: kdk <[email-masked]>
Date: Mon, 07 Jun 2021 14:37:04 -0700

To add to Roger’s list of WWDC’21 Sessions, we would like to point your attention to a related session 
Evaluate videos with the Advanced Video Quality Tool
This is an introduction to a tool that allows you to evaluate the visual quality of your video material using perceptual-based ML approach. It is a natural complement to the HLS tools that we have delivered throughout the years that evaluate the stream quality of your content.
This session will take place on Wednesday and it will be followed up by a Lab session on Friday morning (Pacific time).

Krasimir

> On Jun 7, 2021, at 1:58 PM, Roger Pantos via HLS-Announce <[email-masked]> wrote:
> 
> https://developer.apple.com/wwdc21/sessions/ <https://developer.apple.com/wwdc21/sessions/>
> 
> regards,
> 
> Roger Pantos
> Apple Inc.
> _______________________________________________
> Do not post admin requests to the list. They will be ignored.
> HLS-Announce mailing list      ([email-masked])
> Help/Unsubscribe/Update your Subscription:
> https://lists.apple.com/mailman//listinfo/hls-announce

---

From: Roger Pantos <[email-masked]>
Date: Tue, 08 Jun 2021 08:24:27 -0700

> On Jun 7, 2021, at 1:58 PM, Roger Pantos <rpantos=[email-masked]> wrote:
> 

> Explore dynamic pre-rolls and mid-rolls in HLS: Learn how you can create seamless transitions between advertisements and your HLS streams. We'll show you how to incorporate HLS tags and AVFoundatio…

https://developer.apple.com/streaming/GettingStartedWithHLSInterstitials.pdf <https://developer.apple.com/streaming/GettingStartedWithHLSInterstitials.pdf>

> Improve global streaming availability with HLS Content Steering: Discover how you can use HLS playlist tags and the Steering Manifest format with your content to help dynamically update CDN redunda…

https://developer.apple.com/streaming/HLSContentSteeringSpecification.pdf <https://developer.apple.com/streaming/HLSContentSteeringSpecification.pdf>

Roger.

> -- 
> Hls-interest mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hls-interest