Subject: [Hls-interest] coming to Apple HLS clients later this year: M-JPEG support

From: Roger Pantos <[email-masked]>
Date: Wed, 23 Feb 2022 09:03:37 -0800

Hi folks. This is just a quick heads-up to let you know that in an OS release later this year, the Apple HLS clients will be updated to support Motion-JPEG fMP4 segments (i.e. JPEG images inside fMP4 containers). This will allow you to provide I-frame playlists (for both VOD and live content) that contain JPEG I-frames, rather than AVC or HEVC as previously supported.

We're doing this to support interoperability with lower-end devices from other manufacturers that cannot spawn a second video decoder instance, but can decode JPEG in software.

M-JPEG is specified in ISO/IEC 23008-12 "High efficiency coding and media delivery in heterogeneous environments —Part 12: Image File Format."  The 4cc codec type is 'mjpg' with no parameters (http://mp4ra.org/#/codecs), So an example EXT-X-I-FRAME-STREAM-INF would be:

#EXT-X-I-FRAME-STREAM-INF:BANDWIDTH=331000,CODECS="mjpg",URI="iframe_index.m3u8"

We also plan to update our mediafilesegmenter tool to enable it to produce M-JPEG fMP4 segments from JPEG source.

regards,

Roger Pantos
Apple Inc.

---

From: Alex Giladi <[email-masked]>
Date: Wed, 23 Feb 2022 11:01:56 -0700

Hi Roger,
What do we do for HDR? Any plans for HEIF?
Best,
Alex.

On Wed, Feb 23, 2022 at 10:04 AM Roger Pantos <rpantos=
[email-masked]> wrote:

> Hi folks. This is just a quick heads-up to let you know that in an OS
> release later this year, the Apple HLS clients will be updated to support
> Motion-JPEG fMP4 segments (i.e. JPEG images inside fMP4 containers). This
> will allow you to provide I-frame playlists (for both VOD and live content)
> that contain JPEG I-frames, rather than AVC or HEVC as previously supported.
>
> We're doing this to support interoperability with lower-end devices from
> other manufacturers that cannot spawn a second video decoder instance, but
> can decode JPEG in software.
>
> M-JPEG is specified in ISO/IEC 23008-12 "High efficiency coding and media
> delivery in heterogeneous environments —Part 12: Image File Format."  The
> 4cc codec type is 'mjpg' with no parameters (http://mp4ra.org/#/codecs),
> So an example EXT-X-I-FRAME-STREAM-INF would be:
>
>
> --
> Hls-interest mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hls-interest
>

---

From: Roger Pantos <[email-masked]>
Date: Wed, 23 Feb 2022 10:06:09 -0800

Hi Alex. A platform with a software decoder for individual HEVC images can in principle consume I-frame playlists containing HDR10 / Dolby Vision / HLG segments.

Roger. 

> On Feb 23, 2022, at 10:01 AM, Alex Giladi <[email-masked]> wrote:
> 
> Hi Roger,
> On Wed, Feb 23, 2022 at 10:04 AM Roger Pantos <rpantos=[email-masked] <mailto:[email-masked]>> wrote:
> M-JPEG is specified in ISO/IEC 23008-12 "High efficiency coding and media delivery in heterogeneous environments —Part 12: Image File Format."  The 4cc codec type is 'mjpg' with no parameters (http://mp4ra.org/#/codecs <http://mp4ra.org/#/codecs>), So an example EXT-X-I-FRAME-STREAM-INF would be:
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/hls-interest <https://www.ietf.org/mailman/listinfo/hls-interest>

---

From: Alex Giladi <[email-masked]>
Date: Wed, 23 Feb 2022 11:17:05 -0700

Thanks!

On Wed, Feb 23, 2022, 11:06 AM Roger Pantos <[email-masked]> wrote:

> Hi Alex. A platform with a software decoder for individual HEVC images can
> in principle consume I-frame playlists containing HDR10 / Dolby Vision /
> HLG segments.
>
>
> Roger.
>
>> We also plan to update our mediafilesegmenter tool to enable it to
>> produce M-JPEG fMP4 segments from JPEG source.
>>
>>
>> regards,
>>
>> Roger Pantos
>> Apple Inc.
>> --