Subject: [HOKEY] change in terminology in early authentication problem statement draft?

From: "Glen Zorn" <[email-masked]>
Date: Wed, 13 May 2009 16:05:01 +0700

One thing that was established during the lengthy debate over this draft was
that the CA & SA may not be actually functioning as EAP authenticators
during the early authentication process, so I've been thinking that a change
in terminology would be appropriate (at the very least to avoid overloading
the term "authenticator" even further).  I propose that "candidate
authenticator" be changed to "candidate attachment point" (CAP) and "serving
authenticator" to "serving attachment point" (SAP).  Any or comments, or
other suggestions?

~gwz

At one time in the US, in the mid-nineteenth century, working for wage labor
was considered not very different from chattel slavery...anyone who thinks
it's legitimate to be a wage laborer is internalizing oppression in a way
which would have seemed intolerable to people in the mills 150 years ago.
  -- Noam Chomsky, "Propaganda & the Public Mind"

---

From: Tina TSOU <[email-masked]>
Date: Thu, 14 May 2009 20:23:10 +0800

Fully support.

B. R.
Tina
http://tinatsou.weebly.com/contact.html

On May 13, 2009, at 5:05 PM, Glen Zorn wrote:

> _______________________________________________
> HOKEY mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hokey

---

From: Subir Das <[email-masked]>
Date: Thu, 14 May 2009 08:32:51 -0400

IMO, 'Attachment Point'  is not the correct terminology for this 
purpose. "Attachment Point"
in many cases is used as layer-2 point of attachment which may not be 
the authenticator per se.

-Subir

---

From: Tina TSOU <[email-masked]>
Date: Thu, 14 May 2009 21:19:23 +0800

Then how about Pre-"candidate authenticator" (PCA) and Pre-"serving  
authenticator" (PSA)?

B. R.
Tina

On May 14, 2009, at 8:32 PM, Subir Das wrote:

> in many cases is used as layer-2 point of attachment which may not  
> be the authenticator per se.
>
> -Subir
>
> Glen Zorn wrote:

---

From: Katrin Höper <[email-masked]>
Date: Thu, 14 May 2009 09:01:16 -0500

If we change the terminology, we should avoid "authenticator" all-together.

It's difficult to avoid any conflict with already established terminology
but how about Point-of-Attachment (PoA), i.e. candidate PoA and serving PoA?

Regards,
Katrin Hoeper

On Thu, May 14, 2009 at 8:19 AM, Tina TSOU <[email-masked]> wrote:

> IMO, 'Attachment Point'  is not the correct terminology for this purpose.
>> "Attachment Point"
>> in many cases is used as layer-2 point of attachment which may not be the
>> authenticator per se.
>>
>> -Subir
>>
>> Glen Zorn wrote:
>>

---

From: Tina TSOU <[email-masked]>
Date: Thu, 14 May 2009 22:15:06 +0800

Sounds good, but It didn't solve Subir's concern.

B. R.
Tina

On May 14, 2009, at 10:01 PM, Katrin Höper wrote:

> It's difficult to avoid any conflict with already established  
> terminology but how about Point-of-Attachment (PoA), i.e. candidate  
> PoA and serving PoA?
>
> Regards,
> Katrin Hoeper
>

---

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 14 May 2009 07:43:21 -0700 (PDT)

PoA is used in 802.21 as point of attachment to Layer 2 devices like base stations.

That may not preclude Hokey to use PoA for its purposes, though.

Regards,

Behcet

________________________________
From: Subir Das <[email-masked]>
To: Glen Zorn <[email-masked]>
Cc: [email-masked]
Sent: Thursday, May 14, 2009 7:32:51 AM
Subject: Re: [HOKEY] change in terminology in early authentication problem statement draft?

-Subir

---

From: Subir Das <[email-masked]>
Date: Thu, 14 May 2009 10:52:06 -0400

May be it would be better if we see what would be the definition of POA 
in this case.
Although  I do not know what would be the problem with the authenticator 
term.

-Subir

Katrin Höper wrote:
> On Thu, May 14, 2009 at 8:19 AM, Tina TSOU <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Then how about Pre-"candidate authenticator" (PCA) and
>     Pre-"serving authenticator" (PSA)?
>
>
>     B. R.
>     Tina
>         IMO, 'Attachment Point'  is not the correct terminology for
>         this purpose. "Attachment Point"
>         in many cases is used as layer-2 point of attachment which may
>         not be the authenticator per se.
>
>         -Subir
>
>         Glen Zorn wrote:
>
>             [email-masked] <mailto:[email-masked]>
>         [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>

---

From: "Glen Zorn" <[email-masked]>
Date: Fri, 15 May 2009 09:15:44 +0700

> the authenticator per se.

Precisely the point.

---

From: "Glen Zorn" <[email-masked]>
Date: Fri, 15 May 2009 09:21:19 +0700

> Then how about Pre-"candidate authenticator" (PCA) and Pre-"serving

Apparently my initial message was unclear: the point of the change in
terminology is the reflection of the fact that the at least one of the
entities involved are _not_ acting as an EAP authenticator WRT the peer at
the time the early authentication process is taking place.

...

---

From: "Glen Zorn" <[email-masked]>
Date: Fri, 15 May 2009 09:39:26 +0700

Behcet Sarikaya [mailto:[email-masked]] writes:

PoA is used in 802.21 as point of attachment to Layer 2 devices like base
stations.

At this late date, I suspect that it will be difficult to find any
reasonable term that hasn't already been used by somebody for something ;-).
The important part is that the term we choose accurately reflects the
functionality we're talking about, which may or may not include that of an
EAP authenticator.  So, aside from having the (IMHO desirable) quality that
it does not designate an EAP-specific entity, what is wrong with "attachment
point"?  How about the always-popular "network access server (NAS)" or the
derivative "access server (AS)"?   These would produce "serving NAS (SNAS)"
and "candidate NAS (CNAS)" or SAS & CAS, respectively.

Regards,

Behcet

  _____  

From: Subir Das <[email-masked]>
To: Glen Zorn <[email-masked]>
Cc: [email-masked]
Sent: Thursday, May 14, 2009 7:32:51 AM
Subject: Re: [HOKEY] change in terminology in early authentication problem
statement draft?

-Subir

Glen Zorn wrote:
> which would have seemed intolerable to people in the mills 150 years ago..
> https://www.ietf..org/mailman/listinfo/hokey
<https://www.ietf.org/mailman/listinfo/hokey>

---

From: Qin Wu <[email-masked]>
Date: Fri, 15 May 2009 14:19:28 +0800

I support to use " Network Access Server"  if we consider to replace authenticator. 
  ----- Original Message ----- 
  From: Glen Zorn 
  To: 'Behcet Sarikaya' ; 'Subir Das' 
  Cc: [email-masked] 
  Sent: Friday, May 15, 2009 10:39 AM
  Subject: Re: [HOKEY] change in terminology in early authentication problemstatement draft?

  At this late date, I suspect that it will be difficult to find any reasonable term that hasn't already been used by somebody for something ;-).  The important part is that the term we choose accurately reflects the functionality we're talking about, which may or may not include that of an EAP authenticator.  So, aside from having the (IMHO desirable) quality that it does not designate an EAP-specific entity, what is wrong with "attachment point"?  How about the always-popular "network access server (NAS)" or the derivative "access server (AS)"?   These would produce "serving NAS (SNAS)" and "candidate NAS (CNAS)" or SAS & CAS, respectively.

  Regards,

  Behcet

------------------------------------------------------------------------------

  -Subir

------------------------------------------------------------------------------