Subject: Re: [HOKEY] IEEE 802.21 integration w/hokey

From: Hasnaa Moustafa <[email-masked]>
Date: Thu, 4 Jun 2009 15:00:51 +0200

Hi,

I think that there some some discussions on this issue before.
 IMO, it is an interesting issue to be discussed and that could allow
Inter-technology authentication in an optimized manner (which is an
important trend in NGN and so far there is not a standard solution for
this).
I remember that Behcet Sarikaya has highlighted the Inter-technology issue
during last meeting but there was no time to present his proposed pists.

Kind regards,
Hassnaa
 •
On Mon, Jun 1, 2009 at 7:58 AM, Glen Zorn <[email-masked]> wrote:

> Several WG members have expressed interest in this topic; however, it's not
> clear to me what (if anything) 802.21 has to do with keying (a problem that
> is exacerbated by the lack of public access to the relevant documents).  We
> might be able to clear up the access problem with a liaison to IEEE, but I
> am wondering what the rationale for integration might be.  Can anyone
> provide such a rationale?
>
> ~ gwz
>
> Half a loaf is better than no loafing at all.
>  --T-Bone Slim
>
>
>
> _______________________________________________
> HOKEY mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hokey
>

---

From: Qin Wu <[email-masked]>
Date: Fri, 05 Jun 2009 09:56:02 +0800

Hi,
IEEE 802.21 provides an optimization of handover between heterogeneous networks  And hokey focuses on Accommodating inter-technology heterogeneous handover. So it is a good idea to integrate 802.21 into hokey WG. 
As regarding the public access to some document, I think IETF mipshop WG has been standarizing some works on 802.21. e.g.,
http://tools.ietf.org/html/draft-ietf-mipshop-mstp-solution-12
draft-ietf-mipshop-mstp-solution-12 focuses on a mobility services framework desgin for the IEEE 802.21 Media Independent Handover (MIH) protocol and describes transport layer mechanisms for the reliable delivery of MIH messages.
http://tools.ietf.org/html/draft-ietf-mipshop-mos-dns-discovery-06

draft-ietf-mipshop-mos-dns-discovery-06 provides DNS procedures for discovering servers which provide IEEE 802.21 defined Mobility Services.
http://tools.ietf.org/html/draft-ietf-mipshop-mos-dhcp-options-14

draft-ietf-mipshop-mos-dhcp-options-14 provides DHCP procedures for discovering servers which provide IEEE 802.21 defined Mobility Services.
I wonder whether these relevant works mentioned above in IETF mipshop can be taken as some anchor point to IEEE 802.21?

Regards!
-Qin

---

From: Qin Wu <[email-masked]>
Date: Fri, 05 Jun 2009 10:03:46 +0800

Hi, Hassnaa:
Can you provide some NGN relevant works as regarding inter-technology authentication? As I know, NGN emphasizes on architectural work. So I would like to know whether NGN has designed some architecture work on inter-technology authentication? What is it like?

Regards!
-Qin
  ----- Original Message ----- 
  From: Hasnaa Moustafa 
  To: Glen Zorn 
  Cc: [email-masked] 
  Sent: Thursday, June 04, 2009 9:00 PM
  Subject: Re: [HOKEY] IEEE 802.21 integration w/hokey

  Hi,

  I think that there some some discussions on this issue before.
   IMO, it is an interesting issue to be discussed and that could allow Inter-technology authentication in an optimized manner (which is an important trend in NGN and so far there is not a standard solution for this).
  I remember that Behcet Sarikaya has highlighted the Inter-technology issue during last meeting but there was no time to present his proposed pists.

  Kind regards,
  Hassnaa
  • 

    ~ gwz

------------------------------------------------------------------------------

---

From: "Glen Zorn" <[email-masked]>
Date: Fri, 5 Jun 2009 10:36:03 +0700

Qin Wu [mailto:[email-masked]] writes:

> Hi,
> IEEE 802.21 provides an optimization of handover between heterogeneous
> networks  And hokey focuses on Accommodating inter-technology
> heterogeneous handover. 

Actually, hokey focuses on optimizing one particular aspect of handover
(heterogeneous or not): keying (and associated authentication).  

> So it is a good idea to integrate 802.21 into
> hokey WG.

Why?  How does 802.21 help optimize handover keying?

> As regarding the public access to some document, I think IETF mipshop
> WG has been standarizing some works on 802.21. e.g.,
> draft-ietf-mipshop-mstp-solution-12 focuses on a mobility services
> framework desgin for the IEEE 802.21 Media Independent Handover (MIH)
> protocol and describes transport layer mechanisms for the reliable
> delivery of MIH messages.
> draft-ietf-mipshop-mos-dns-discovery-06 provides DNS procedures for
> discovering servers which provide IEEE 802.21 defined Mobility
> Services.
> draft-ietf-mipshop-mos-dhcp-options-14 provides DHCP procedures for
> discovering servers which provide IEEE 802.21 defined Mobility
> Services.
> I wonder whether these relevant works mentioned above in IETF mipshop
> can be taken as some anchor point to IEEE 802.21?

Presumably the authors of the documents you mention (and hopefully, the
mipshop WG -- otherwise how can it evaluate the drafts?) have access to the
IEEE documents, but I don't see how that really helps us in hokey.  However,
since mipshop seems to have the task of integrating .21 w/IETF protocols
pretty well in hand, why should we get involved?

...

---

From: Qin Wu <[email-masked]>
Date: Fri, 05 Jun 2009 12:15:48 +0800

----- Original Message ----- 
From: "Glen Zorn" <[email-masked]>
To: "'Qin Wu'" <[email-masked]>
Cc: <[email-masked]>
Sent: Friday, June 05, 2009 11:36 AM
Subject: RE: [HOKEY] IEEE 802.21 integration w/hokey

> Why?  How does 802.21 help optimize handover keying?

[Qin] If we can integrate 802.21 functionality into the handover architecture,i.e., integrate MIH funcationlity into the peer, the NAS,
the IEEE 802.21 sigaling exchange can be used to accelerate the handover preparation procedure, e.g., enable authenticator discovery
faster, During the authentication execution, the IEEE 802.21 signaling can be used as transport protocol to carry other authentication signaling.
In this way, the signaling exchange overhead can be saved.
Also Event service provided by the MIH Functinality can be used to indicate NAS to trigger handover authentication as early as possbile.
This is what I understand how to optimize handover keying with 802.21.

> pretty well in hand, why should we get involved?

[Qin]: I think mipshop WG more focus on handover optimization, not handover authentication optimization.
The main work on 802.21 in mipshop WG is to design transport protocol to carry MIH services, e.g., Event service, command service and information service.
I am afraid  all these works are not relevant to the handover authentication issues. So maybe we need to check the other relevant work in the IEEE, e.g., 
802.21 security topic.

---

From: Jong-Hyouk Lee <[email-masked]>
Date: Fri, 5 Jun 2009 13:47:38 +0900

Hi, all.

I totally agree with Qin in his opinion.

As we know, HOKEY is mainly focused on optimizing authentication procedures
in handover. MIPSHOP is however mainly related to enhancing handover
performance. Most of guys in MIPSHOP is not expert at security issues
including key derivation and authentication.

IEEE 802.21 (Media Independent Handover Services) provides useful
information for optimizing handover performance as well as authentication
performance. As references, see the following paper that has been cited in
draft-ietf-hokey-preauth-ps-07.

Media-Independent Pre-Authentication Supporting Secure Interdomain Handover
Optimization published in IEEE Wireless Communications, 2008.

Hope to see HOKEY involves IEEE 802.11's network assistance information for
optimizing authentication performance.

Cheers.

-- 
Internet Management Technology Lab, Sungkyunkwan University.
Jong-Hyouk Lee.

#email: jonghyouk (at) gmail (dot) com
#webpage: http://hurryon.googlepages.com/