Subject: [HOKEY] New draft for Diameter ERP: poll for adoption

From: Sebastien Decugis <[email-masked]>
Date: Mon, 08 Jun 2009 12:57:04 +0900

Hi all DIME and HOKEY members,

I have gone forward on the Diameter ERP topic and created a new draft
[1] with the same content (re-organized, hopefully for clarity) as I
presented during last DIME meeting in IETF#74. The main change with
current draft-ietf-dime-erp-00 is the use of a new separate Diameter
application for messages exchanged between the NAS and the ER server.

I would like to poll the people interested in this topic about the
adoption of this new document for Diameter ERP (in which case it would
become draft-ietf-dime-erp-01). I don't know if this can be done before
the next IETF meeting, or at least during the meeting in Stockholm?

Thank you for reading, and eventually providing your comments.
Sebastien.

[1]
http://www.ietf.org/internet-drafts/draft-sdecugis-dime-diameter-erp-01.txt

-- 
Sebastien Decugis
Research fellow
Network Architecture Group
NICT (nict.go.jp)

---

From: "Glen Zorn" <[email-masked]>
Date: Mon, 8 Jun 2009 11:48:44 +0700

> become draft-ietf-dime-erp-01). 

Isn't this the job of the WG Chairs?

> I don't know if this can be done before

I am strongly opposed to the adoption of this draft as a WG item, if for no
other reason than that it is clearly derived from other work (as is admitted
in section 1.1), the authors of which are not recognized.  Add Wu,
Bournelle, Morand & Dondeti to the author list (provided that they agree, of
course).  BTW, "disappearing" co-authors is one good way to ensure that no
one agrees to collaborate with you in the future...

> _______________________________________________
> DiME mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dime

---

From: Sebastien Decugis <[email-masked]>
Date: Mon, 08 Jun 2009 14:13:38 +0900

Hello,

Thank you for quick answer.

> Isn't this the job of the WG Chairs?
Ok, I did not know. My intent is just to provide this new idea for
workgroup consideration, within the scope of the Diameter ERP topic that
is already a workgroup item.

> one agrees to collaborate with you in the future...
The authors of the previous draft are listed in contributors section. As
you mention, I don't know if they agree with the content of this new
draft, hence they are not listed as authors for this submission. Anyway,
in case the document is accepted (for its ideas, not its form...) the
authors list would be restored of course. I am not doing this to steal
the work of other people, just trying to push a new different idea to
move the document forward. And I already tried to involve in this new
direction the other co-authors of the previous draft, but got no answer,
hence my separate submission.

Sorry for the apparently tactless process, I hope my intent is now
clarified.

Best regards,
Sebastien.

---

From: "Glen Zorn" <[email-masked]>
Date: Mon, 8 Jun 2009 13:20:01 +0700

Sebastien Decugis [mailto://[email-masked]] writes:

...

> hence my separate submission.

I see.  Maybe they will respond now!

> Sorry for the apparently tactless process, I hope my intent is now

Re-reading my response above, it appears that I was the one w/o tact!  I
didn't mean to suggest any nefarious intent on your part, please accept my
apology.

...

---

From: Qin Wu <[email-masked]>
Date: Mon, 08 Jun 2009 15:42:13 +0800

> Bournelle, Morand & Dondeti to the author list (provided that they agree, of

[Qin]: I accept being included in the author list.

---

From: Julien Bournelle <[email-masked]>
Date: Mon, 8 Jun 2009 10:38:42 +0200

Hi sebastien, all,

 See below,

> hence my separate submission.

I thought the consensus was to wait for HOKEY WG inputs, in particular on
architectural aspects before moving forward with what we already did !

 I have to admit that I'm a little surpised...

 Regards,

 Julien

---

From: Sebastien Decugis <[email-masked]>
Date: Mon, 08 Jun 2009 18:06:37 +0900

Hi Julien,

> I thought the consensus was to wait for HOKEY WG inputs, in particular
> on architectural aspects before moving forward with what we already did !
As a matter of fact, this new draft is just a rewritting of a design
document I wrote before the previous IETF (and presented at that
meeting), before this decision to wait for a (hypothetical)
clarification document was taken.

>  I have to admit that I'm a little surpised...
Let me clarify this in private mail (it's easier to do in my native
language, and also not of much interest to other people on the lists...)

Best regards,
Sebastien.

---

From: Julien Bournelle <[email-masked]>
Date: Tue, 9 Jun 2009 09:01:30 +0200

Hello,

 See inline,

> the next IETF meeting, or at least during the meeting in Stockholm?

AFAIK, this is not how things are working at IETF. The WG has already a WG
document called draft-ietf-dime-erp-00.txt which is supposed to reflect the
current WG consensus. We can't arrive with a new individual submission and
just bypass the current WG I-D. At least, I never saw that.

Having said that, we have an issue with the current WG document concerning
use of a new Application-ID or reuse of the Diameter EAP. My understanding
was that we were a little blocked because of an architectural issue
concerning the HOKEY server in regards to AAA/EAP server and because of a
routing issue. So I'd like to know what has changed from this point.

 Note that I'm not against your proposal per se. We just have to get a
consensus.

 Best regards,

 Julien

---

From: Sebastien Decugis <[email-masked]>
Date: Tue, 09 Jun 2009 17:27:54 +0900

Hi,

(BTW, I propose the follow-ups directed to the DIME mailing-list only,
to avoid the cross-posting. If people from HOKEY ML are interested and
not subscribed to DIME ML, let me know...)

> AFAIK, this is not how things are working at IETF. The WG has already
> a WG document called draft-ietf-dime-erp-00.txt which is supposed to
> reflect the current WG consensus. We can't arrive with a new
> individual submission and just bypass the current WG I-D. At least, I
> never saw that.
Well, once again, sorry for the quiproquo here... I was not
ill-intended, just interested in pushing a new different direction for
the design of Diameter ERP, and submit the new idea to the WG(s) for
consideration (and eventually integration, not by-passing). Enough with
the politics on the WG lists (but I can continue in private if people
want to argue), and let's focus on technical matters...

> Having said that, we have an issue with the current WG document
> concerning use of a new Application-ID or reuse of the Diameter EAP.
> My understanding was that we were a little blocked because of an
> architectural issue concerning the HOKEY server in regards to AAA/EAP
> server and because of a routing issue. So I'd like to know what has
> changed from this point.
For the routing issue: this new proposal aims to solve it.
For the architectural issue: I think it was a misunderstanding from the
beginning, or at least I did not understand the issue, so if someone can
clarify (what the issue was), it would be helpful.

>  Note that I'm not against your proposal per se. We just have to get a
Of course!

Best regards,
Sebastien.

---

From: "Tschofenig, Hannes (NSN - FI/Espoo)" <[email-masked]>
Date: Tue, 9 Jun 2009 11:46:17 +0300

Hi all, 
 
there seems to be a misunderstanding here. 
 
We have a working group document with agreed authors. 
The only question therefore is what the group wants to go into the
existing document - the content. No new document will be added to the
DIME milestones.
 
What Sebastien should be asking the group is whether the content in
draft-sdecugis-dime-diameter-erp-01.txt should be included in the next
version of draft-ietf-dime-erp. 
 
I personally think that draft-ietf-dime-erp-01 could have included the
updated text already since we discussed it on the list. Anyway, ... 

In any case, it is good to ask the group whether this significant change
should be made. 

My answer: I believe that this is the right direction, as I indicated
previously on the list. 

Ciao
Hannes

________________________________

	From: [email-masked] [mailto:[email-masked]] On
Behalf Of ext Julien Bournelle
	Sent: 09 June, 2009 10:02
	To: Sebastien Decugis
	Cc: [email-masked]; [email-masked]
	Subject: Re: [Dime] New draft for Diameter ERP: poll for
adoption

	Hello,
	
	 See inline,

	On Mon, Jun 8, 2009 at 5:57 AM, Sebastien Decugis
<[email-masked]> wrote:

		I have gone forward on the Diameter ERP topic and
created a new draft
		[1] with the same content (re-organized, hopefully for
clarity) as I
		presented during last DIME meeting in IETF#74. The main
change with
		current draft-ietf-dime-erp-00 is the use of a new
separate Diameter
		application for messages exchanged between the NAS and
the ER server.
		
		I would like to poll the people interested in this topic
about the
		adoption of this new document for Diameter ERP (in which
case it would
		become draft-ietf-dime-erp-01). I don't know if this can
be done before
		the next IETF meeting, or at least during the meeting in
Stockholm?

	AFAIK, this is not how things are working at IETF. The WG has
already a WG document called draft-ietf-dime-erp-00.txt which is
supposed to reflect the current WG consensus. We can't arrive with a new
individual submission and just bypass the current WG I-D. At least, I
never saw that.
	
	Having said that, we have an issue with the current WG document
concerning use of a new Application-ID or reuse of the Diameter EAP. My
understanding was that we were a little blocked because of an
architectural issue concerning the HOKEY server in regards to AAA/EAP
server and because of a routing issue. So I'd like to know what has
changed from this point.
	
	 Note that I'm not against your proposal per se. We just have to
get a consensus.
	
	 Best regards,
	
	 Julien

		
		Thank you for reading, and eventually providing your
comments.
		Sebastien.
		
		[1]
	
http://www.ietf.org/internet-drafts/draft-sdecugis-dime-diameter-erp-01.
txt

---

From: Tina TSOU <[email-masked]>
Date: Wed, 10 Jun 2009 12:23:17 +0800

Hi Hannes,
Thank you for your clarification. It is much clearer.
This change should be made, since ERP is one of the most important  
applications for Diameter.

B. R.
Tina
IPTIME - Unified QoS ARchitecture (UQAr) [ju'ka:] /pronounced like  
"you"+"car"/
[email-masked]
http://uqar.weebly.com
http://tinatsou.weebly.com/contact.html

On Jun 9, 2009, at 4:46 PM, Tschofenig, Hannes (NSN - FI/Espoo) wrote:

> My
> HOKEY mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hokey

---

From: "Tschofenig, Hannes (NSN - FI/Espoo)" <[email-masked]>
Date: Thu, 11 Jun 2009 11:22:52 +0300

Hi Tina, 
 
thanks for the support regarding the Diameter ERP work. 
I hope the excitement for it will also result in some running code that
would help us to make the design decisions in a better fashion. 

When I was talking to Sebastien recently we were wondering whether there
is HOKEY ERP code available somewhere since this is a pre-requisite for
the implementation of the Diameter ERP stuff. 

Ciao
Hannes

	From: ext Tina TSOU [mailto:[email-masked]] 
	Sent: 10 June, 2009 07:23
	To: Tschofenig, Hannes (NSN - FI/Espoo)
	Cc: ext Julien Bournelle; Sebastien Decugis; [email-masked];
[email-masked]
	Subject: Re: [HOKEY] [Dime] New draft for Diameter ERP: poll for
adoption

	Hi Hannes,
	Thank you for your clarification. It is much clearer.
	This change should be made, since ERP is one of the most
important applications for Diameter.

eak-word; -webkit-nbsp-mode: space; -webkit-line-break:
after-white-space; "> 
					B. R.
	Tina
	IPTIME - Unified QoS ARchitecture (UQAr) [ju'ka:] /pronounced
like "you"+"car"/
	[email-masked]
	http://uqar.weebly.com

	

	On Jun 9, 2009, at 4:46 PM, Tschofenig, Hannes (NSN - FI/Espoo)
wrote:

		Hi all, 

		We have a working group document with agreed authors. 
		The only question therefore is what the group wants to
go into the
		existing document - the content. No new document will be
added to the
		DIME milestones.
		
		What Sebastien should be asking the group is whether the
content in
		draft-sdecugis-dime-diameter-erp-01.txt should be
included in the next
		version of draft-ietf-dime-erp. 
		
		I personally think that draft-ietf-dime-erp-01 could
have included the
		updated text already since we discussed it on the list.
Anyway, ... 
		
		In any case, it is good to ask the group whether this
significant change
		s answer: I believe that this is the right direction, as
I indicated
		previously on the list. 
		
		Ciao
		Hannes

		
		
		From: [email-masked]
[mailto:[email-masked]] On
		Behalf Of ext Julien Bournelle
		Sent: 09 June, 2009 10:02
		To: Sebastien Decugis
		Cc: [email-masked]; [email-masked]
		Subject: Re: [Dime] New draft for Diameter ERP: poll for
		adoption

		Hello,
		
		See inline,

		
		I have gone forward on the >created a new draft

		
		AFAIK, this is not how things are working at IETF. The
WG has
		already a WG document called draf ich is
		supposed to reflect the current WG consensus. We can't
arrive with a new
		individual submission and just bypass the current WG
I-D. At least, I
		never saw that.
		
		Having said that, we have an issue with the current WG
document
		concerning use of a new Application-ID or reuse of the
Diameter EAP. My
		understanding was that we were a little blocked because
of an
		architectural issue concerning the HOKEY server in
regards to AAA/EAP
		server and because of a routing issue. So I'd like to
know what has
		changed from this point.
		
		Note that I'm not against your proposal per se. We just
have to
		get a consensus.

		Julien

		
		
		[1]

		

		______________________
		HOKEY mailing list
		[email-masked]

---

From: "Glen Zorn" <[email-masked]>
Date: Thu, 11 Jun 2009 22:21:35 +0700

Tschofenig, Hannes (NSN - FI/Espoo) [mailto://[email-masked]]

> version of draft-ietf-dime-erp.

Yes.

> updated text already since we discussed it on the list. Anyway, ...

Yes.

> My answer: I believe that this is the right direction, as I indicated

A quick review and comparison with the WG draft suggests to me that the new
doc is an improvement.

---

From: Qin Wu <[email-masked]>
Date: Wed, 17 Jun 2009 17:43:10 +0800

> version of draft-ietf-dime-erp. 

[Qin]: I support incorporating Sebastien's changes into next version of draft-ietf-dime-erp.