Subject: [HOKEY] Re-chartering & new work items

From: "Glen Zorn" <[email-masked]>
Date: Sat, 20 Jun 2009 14:52:04 +0700

Now that all of the original work items in our charter are (almost)
complete, it seems appropriate to start talking about interest in
re-chartering the WG and potential work items for the new charter.  All
suggestions are welcome!

~gwz

Play assigns meaning to human activity--work erases it.
  -- P.L. Wilson

---

From: Qin Wu <[email-masked]>
Date: Mon, 22 Jun 2009 15:53:49 +0800

Hi all,

As regarding WG rechartering, I have some concerns, I think recharter should be a bit more relaxed and more extensive than before . e.g., As discussed in the maillist before, the work on integration 802.21 with hokey architecture, at least the folks are interested in doing the work. Another example is some solutions for optimized fast authentication are EAP method specific and left out from the current scope of hokey WG, However these solutions can be widely used in the real deployment, e.g., 3GPP. So I wonder whether hokey need to consider some EAP method specific optimizated mechanism in the future work. Therefore We should add at least 3 or 5 more items to this list. I've identified some of the potential work items below.

Regards
Qin
--------------------------------------------------------------------
1.Early authentication solution
Since we nearly complete the work on the problem statement for Early authentication, I think 
Early authentication solution work can be identified and started.

2.Hokey architectural and implemenation guide
As regarding how to deploy hokey architecture in the real practice, I think there are lots of amibiguities and
possible various choices. So I think we need one more document to provide some guideline to clarify on how to apply 
hokey achitecture in the practice.

3.IEEE 802.21 integration w/hokey

4.Interaction between NAS/Authenticator
Some folks raise this issue in the mailist which can be realized as potentical work item.

5. EAP method specific optimized fast authentication 
----- Original Message ----- 
From: "Glen Zorn" <[email-masked]>
To: <[email-masked]>
Sent: Saturday, June 20, 2009 3:52 PM
Subject: [HOKEY] Re-chartering & new work items

> _______________________________________________
> HOKEY mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hokey

---

From: "Hoeper Katrin-QWKN37" <[email-masked]>
Date: Wed, 24 Jun 2009 14:01:49 -0400

Hi,

I think a document explaining HOKEYs architecture should be the most
important work item in case of re-chartering the WG. This is a document
other groups, e.g. DIME, are waiting for and it will be very useful
(actually absolute necessary!) for all people who actually want to
implement some of the proposed protocols. For example, many important
architectural questions necessary to implement the re-authentication
protocol have not been addressed in any WG document. I think the
NAS/authenticator discussion that Qin mentioned would be an important
part of such a document and not a separate work item.

If there is interest, early authentication solutions would certainly
make sense for the reason given by Qin.

IMO a liaison with IEEE 802.21 makes sense (see my previous posts on
this topic), but I am not sure whether liaisons are work items???

In response to Qin's suggestions, I don't think that any method-specific
solutions should be work items.

Just my two cents,
Katrin

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> Qin Wu
> Sent: Monday, June 22, 2009 2:54 AM
> To: Glen Zorn; [email-masked]
> Subject: Re: [HOKEY] Re-chartering & new work items
> 
> Hi all,
> 
> As regarding WG rechartering, I have some concerns, I think recharter
> should be a bit more relaxed and more extensive than before . e.g., As
> discussed in the maillist before, the work on integration 802.21 with
> hokey architecture, at least the folks are interested in doing the
work.
> Another example is some solutions for optimized fast authentication
are
> EAP method specific and left out from the current scope of hokey WG,
> However these solutions can be widely used in the real deployment,
e.g.,
> 3GPP. So I wonder whether hokey need to consider some EAP method
specific
> optimizated mechanism in the future work. Therefore We should add at
least
> 3 or 5 more items to this list. I've identified some of the potential
work
> items below.
> possible various choices. So I think we need one more document to
provide
> some guideline to clarify on how to apply

---

From: Qin Wu <[email-masked]>
Date: Sat, 27 Jun 2009 09:48:01 +0800

Hi, Katrin:
Thank for your comments. 

NAS/authenticatior can be the part of hokey architecture,  the distribution of NAS including local ER can greatly
affect the architecture deployment and implementation. Therefore I am okay to integrate NAS/authentcation issues into
 Hokey architecture design as one work item.

As regarding a liaison with IEEE 802.21, I don't think it is a  work item. However it is necessary and helpful to
to check out whether there are some relevant works in IEEE 802.21 and what 802.21 folks look at integration with hokey
before we consider to start to develop some real work item. However I am not sure whether 802.21 folks will interest in this topic. I would like
to suggest one of us or anybody else who are interested in this topic can get into 802.21 maillist and follow up what's going on  there.

With respect to the method-specific solution, I agree the current hokey work most focus on method independent solution, however when you take a look 
at 3GPP standards, EAP AKA' is widely used and well implemented. And it is not ERP but EAP AKA' Fast Re-authentiction which is adopted there.
I wonder whether this method specific solution can be viewed as one part of Re-authentication. Also I am interested to know whether there are some other 
optimized method specific solutions that can be identified and used. Just my 2 cents. Maybe there are other opinions.

Regards!
-Qin
----- Original Message ----- 
From: "Hoeper Katrin-QWKN37" <[email-masked]>
To: "Qin Wu" <[email-masked]>; "Glen Zorn" <[email-masked]>; <[email-masked]>
Sent: Thursday, June 25, 2009 2:01 AM
Subject: RE: [HOKEY] Re-chartering & new work items

Hi,

Just my two cents,
Katrin

Of
work.
are
e.g.,
specific
least
work
provide