Subject: [HOKEY] FW: I-D Action:draft-ietf-hokey-ldn-discovery-04.txt

From: "Glen Zorn" <[email-masked]>
Date: Thu, 16 Sep 2010 15:17:00 +0700

I believe that this version takes care of all the issues raised by the dhc
WG review.

Hope this helps.

 ~gwz

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: Thursday, September 16, 2010 3:00 PM
To: [email-masked]
Cc: [email-masked]
Subject: [HOKEY] I-D Action:draft-ietf-hokey-ldn-discovery-04.txt

A New Internet-Draft is available from the on-line Internet-Drafts
directories.
This draft is a work item of the Handover Keying Working Group of the IETF.

	Title           : The Local Domain Name DHCPv6 Option
	Author(s)       : G. Zorn, et al.
	Filename        : draft-ietf-hokey-ldn-discovery-04.txt
	Pages           : 6
	Date            : 2010-09-16

In order to derive a Domain-Specific Root Key (DSRK) from the Extended
Master Session Key (EMSK) generated as a side-effect of an Extensible
Authentication Protocol (EAP) method, the EAP peer must discover the name of
the domain to which it is attached.

This document specifies a Dynamic Host Configuration Protocol Version
6 (DHCPv6) option designed to allow a DHCPv6 server to inform clients of the
name of the local domain..

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-hokey-ldn-discovery-04.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Ted Lemon <[email-masked]>
Date: Thu, 16 Sep 2010 02:30:14 -0700

It looks good. I'd like to see the section on server behavior eliminated though, since that behavior is definitively specified in RFC3315, and I don't think you intend to update 3315. :)

---

From: Qin Wu <[email-masked]>
Date: Thu, 16 Sep 2010 18:09:37 +0800

Hi, Ted:
----- Original Message ----- 
From: "Ted Lemon" <[email-masked]>
To: "Glen Zorn" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Thursday, September 16, 2010 5:30 PM
Subject: Re: [dhcwg] [HOKEY] I-D Action:draft-ietf-hokey-ldn-discovery-04.txt

> It looks good. I'd like to see the section on server behavior eliminated though, since that behavior is definitively specified in RFC3315, and I don't think you intend to update 3315. :)

[Qin]: Sounds reasonable, I think the server's behavior should follow RFC3315. Also when the server receive DHCPv6 Relay-Supplied options, the server also need to follow
I.D-ietf-dhc-dhcpv6-relay-supplied-options.
So How about rephrase like:
"
   If the option code for the LDN option is included in an Option
   Request option and ther server knows the local domain name, 
   the server SHOULD process it  in accordance with [RFC3315]. 
   If a DHCPv6 Relay-Supplied options is received from a relay
   agent with a non-empty local-domain-name field included in LDN
   option, the server SHOULD process it in accordance with [I.D-ietf-dhc-dhcpv6-relay-supplied-options].
"
?
Furthermore, shall we need to take care of one specific case when the server knows the local domain name and also receives the local domain name from the relay agent.
In such case, do we needs server to have extra behavior to handle this?
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg

---

From: "Glen Zorn" <[email-masked]>
Date: Thu, 16 Sep 2010 17:22:39 +0700

Ted Lemon [mailto://[email-masked]]

> It looks good. I'd like to see the section on server behavior eliminated
> though, since that behavior is definitively specified in RFC3315, and I
> don't think you intend to update 3315. :)

Okee-dokee.

---

From: "Glen Zorn" <[email-masked]>
Date: Thu, 16 Sep 2010 17:30:29 +0700

Qin Wu [mailto://[email-masked]] writes:

> > It looks good. I'd like to see the section on server behavior
> eliminated though, since that behavior is definitively specified in
> RFC3315, and I don't think you intend to update 3315. :)
> 
> [Qin]: Sounds reasonable, I think the server's behavior should follow
> RFC3315. Also when the server receive DHCPv6 Relay-Supplied options, the
> server also need to follow

I don't think that that is really necessary.

> Furthermore, shall we need to take care of one specific case when the
> server knows the local domain name and also receives the local domain
> name from the relay agent.

It's already covered in draft-ietf-dhc-dhcpv6-relay-supplied-options, I
believe.

---

From: Qin Wu <[email-masked]>
Date: Thu, 16 Sep 2010 18:44:47 +0800

Hi,
----- Original Message ----- 
From: "Glen Zorn" <[email-masked]>
To: "'Qin Wu'" <[email-masked]>; "'Ted Lemon'" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Thursday, September 16, 2010 6:30 PM
Subject: RE: [dhcwg] [HOKEY] I-D Action:draft-ietf-hokey-ldn-discovery-04.txt

> I don't think that that is really necessary.

[Qin]: Okay, but it seems incompelete if we didn't specify anything for server behavior
even we don't have new behavior for the server.

> It's already covered in draft-ietf-dhc-dhcpv6-relay-supplied-options, I

[Qin]: Yes, you are right. This case has been addressed.