Subject: Re: [HOKEY] [dhcwg] Fw: draft-ietf-hokey-ldn-discovery WGLC ends

From: Ted Lemon <[email-masked]>
Date: Thu, 2 Sep 2010 13:01:37 -0400

On Aug 24, 2010, at 6:22 AM, Glen Zorn wrote:
> Looks fine to me, but the question is one of timing: as you know, we are past WGLC on this doc, so I’m wondering how close your draft is to publication as an RFC (my guess is that it’s a ways out).  The problem is that any reference to your draft would need to be normative, which would essentially stop all progress on this draft.

I don't want to delay your draft, and at the same time I don't want to have new non-option DHCP protocol specification in an option draft.   I think the right thing to do would be to add you (or one of the other authors of this draft) as an author on the relay-supplied-options draft and let you be the driving force behind it.   That way you don't have to feel like you have to depend on me to make forward progress, but we get both drafts instead of just one.   I think the rso draft is pretty close to done--the only delay on it is that I originally wrote it to benefit a different protocol spec, and the author of that spec hasn't communicated with me since the Anaheim IETF, so I had it on the back burner.

---

From: Qin Wu <[email-masked]>
Date: Mon, 13 Sep 2010 14:57:21 +0800

Hi,:
Sorry for late reply.
It think draft-ietf-hokey-ldn-discovery intend to address two different cases:
case 1: DHCP server have the information, DHCP Client request information directly from DHCP server 
case 2: DHCP server didn't have the information, but DHCP relay have. DHCP Relay provides information to the client through DHCP server.
Therefore it seems reasonable to have one common option to address both cases in the inter-authenticator handover scenario.

Regards!
-Qin
  ----- Original Message ----- 
  From: Ted Lemon 
  To: Glen Zorn 
  Cc: [email-masked] ; [email-masked] 
  Sent: Friday, September 03, 2010 1:01 AM
  Subject: Re: [HOKEY] [dhcwg] Fw: draft-ietf-hokey-ldn-discovery WGLC ends

------------------------------------------------------------------------------

  _______________________________________________
  HOKEY mailing list
  [email-masked]
  https://www.ietf.org/mailman/listinfo/hokey

---

From: Ted Lemon <[email-masked]>
Date: Mon, 13 Sep 2010 09:53:11 -0400

> Therefore it seems reasonable to have one common option to address both cases in the inter-authenticator handover scenario.

I can't tell from this response whether you are agreeing to use the mechanism described in the relay-supplied options draft or not.   Could you clarify?

---

From: Qin Wu <[email-masked]>
Date: Tue, 14 Sep 2010 23:50:10 +0800

Hi,
----- Original Message ----- 
From: "Ted Lemon" <[email-masked]>
To: "Qin Wu" <[email-masked]>
Cc: "Glen Zorn" <[email-masked]>; <[email-masked]>; <[email-masked]>
Sent: Monday, September 13, 2010 9:53 PM
Subject: Re: [HOKEY] [dhcwg] Fw: draft-ietf-hokey-ldn-discovery WGLC ends

[Qin]: For the case 1, we don't need relay-supplied options since client can request informtaion directly from server using LDN option defined in 
          draft-ietf-hokey-ldn-discovery.
          For the case 2, we have two options:
          (a) Relay include information in the  LDN option defined in draft-ietf-hokey-ldn-discovery and forward to the server
          (b)  Relay Encapsulate LDN option into relay-supplied options and forward relay-supplied options to the server.
         I think both options works in the case 2. but comparing with their difference, relay-supplied options is more generic and reusable.
         
BTW: If you look at the history of draft-ietf-hokey-ldn-discovery, one revelant draft to draft-ietf-hokey-ldn-discovery(i.e., http://tools.ietf.org/html/draft-   wang-dhc-ldn-option-00) was discussed  in DHC WG early at IETF 74 and has the similar idea to relay-supplied options.