Subject: [HOKEY] [hokey] #10: keepalives

From: "hokey issue tracker" <[email-masked]>
Date: Sun, 11 Sep 2011 11:17:55 -0000

#10: keepalives

 Tina: in 3.1.1, when local/home server is remote, if you minimize too
 much, may need keepalives
 Simon: matter of policy; ERP server could just be allowed to extend the
 lifetime of the key until reachability of home AAA server is restored
 Tina: something about this needs to be said

-- 
-----------------------------+----------------------------------------------
 Reporter:  gwz@…            |       Owner:  draft-ietf-hokey-arch-design@…             
     Type:  defect           |      Status:  new                                        
 Priority:  minor            |   Milestone:                                             
Component:  arch-design      |     Version:                                             
 Severity:  In WG Last Call  |    Keywords:                                             
-----------------------------+----------------------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/hokey/trac/ticket/10>
hokey <http://tools.ietf.org/wg/hokey/>

---

From: Glen Zorn <[email-masked]>
Date: Sun, 11 Sep 2011 18:23:07 +0700

>  much, may need keepalives

I don't know what the keepalives would be for, or how they could help
minimize communication with the home server.

>  Tina: something about this needs to be said

Text, please!

---

From: Qin Wu <[email-masked]>
Date: Wed, 28 Sep 2011 12:03:55 +0800

----- Original Message ----- 
From: "hokey issue tracker" <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Cc: <[email-masked]>
Sent: Sunday, September 11, 2011 7:17 PM
Subject: [hokey] #10: keepalives

> Tina: something about this needs to be said

According to RFC5296, The rRK is expired when the parent key EMSK expires and MUST be
 removed from use at that time.
However if EMSK expires, new EAP method exchange is required to generate new EMSK.
The peer can use the rRK lifetime to know when to trigger an EAP method exchange.
Therefore I don't think any addtional text for keeping alive is required. Hope it clarifies.