Subject: Re: [HOKEY] REMINDER: WGLC on draft-ietf-hokey-erp-aak-04

From: Tina TSOU <[email-masked]>
Date: Thu, 29 Sep 2011 02:27:52 +0000

Hi Glen et al,
Comments are in line...

Best Regards,
Tina TSOU
http://tinatsou.weebly.com/contact.html

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Glen Zorn
Sent: Tuesday, August 23, 2011 1:12 AM
To: Zhen Cao
Cc: [email-masked]
Subject: Re: [HOKEY] REMINDER: WGLC on draft-ietf-hokey-erp-aak-04

On 8/23/2011 12:33 PM, Zhen Cao wrote:

...

>> 4) The realm in the keyName-NAI field is used to locate the peer's ERP/AAK
>> server
>> [Richard] what would happen if the SAP does not know the ERP/AAK server
>> indicated by the keyName-NAI

Routing of EAP messages (encapsulated, in this case, in Diameter) is
always a function of the AAA infrastructure., I think.

> 
> Inter-realm handover is not in scope.

Really?  I would think that that would be the only really useful purpose
of ERP-AAK...
[TT: RFC5296 supports ERP with the home ER server. In that case, one can say RFC5296 supports Inter-realm handover.]

...
_______________________________________________
HOKEY mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/hokey

---

From: Qin Wu <[email-masked]>
Date: Thu, 29 Sep 2011 11:17:44 +0800

Hi, Tena and all:
----- Original Message ----- 
From: "Tina TSOU" <[email-masked]>
To: "Glen Zorn" <[email-masked]>; "Zhen Cao" <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, September 29, 2011 10:27 AM
Subject: Re: [HOKEY] REMINDER: WGLC on draft-ietf-hokey-erp-aak-04

> [TT: RFC5296 supports ERP with the home ER server. In that case, one can say RFC5296 supports Inter-realm handover.]

[Qin]: RFC5296 does support ERP with home ER server. This is referred to as Explicit ERP Bootstrapping in RFC5296.
However comparing between Implicit ERP Bootstrapping with Explicit ERP Bootstrapping, there is not so much benefit to 
use Explicit Bootstrapping. Becos Explicit Bootstrapping needs another additonal round exchange beween home ER server
and Home EAP sever. In my understanding,Explict Boostrapping is only used when there is no local ER server and rRK 
does not exprire yet.

However if rRK expire, you need to trigger EAP-method exchange to generate a new EMSK to derive a new rRK.
Becos of this, we proposed to abandon using Explicit bootstapping in RFC5296bis. but that haven't formed consesus yet.

Currently, ERP-AAK still put referenc to old version ERP (RFC5296), therefore I agree what Glen said.
But as I mentioned in this thread, we need to revise NAI-Identitifer to support inter-realm handover.

---

From: Zhen Cao <[email-masked]>
Date: Thu, 29 Sep 2011 12:00:08 +0800

There is some mis-understanding. I am sorry for the ambiguity.

By "inter-realm", it means "inter roaming domain", RFC5296 supports it
and it is also in scope.

I thought it meant "inter-AAA", and RFC5296 does not support that.

Thanks for helping me understand this.

-- 
Best regards,
Zhen