Subject: [homegate] Draft BoF Agenda - Your Feedback Needed

From: Jason Livingood <[email-masked]>
Date: Wed, 21 Oct 2009 16:33:58 -0400

Below is the draft agenda that we¹ve been carrying forward in working
documents for the BoF for a few months now.  As a result, it is probably a
bit out of date and our view of what we want to do has evolved somewhat.  It
is now time to take a hard look at this agenda, make sure it is in line with
the charter/objectives/priorities, and get ready for IETF 76.

Deadline for a final agenda is: Wednesday, 28 October (one week away)

Proposed Agenda:  (120 minutes)
1  Agenda, Goals, and Administrivia / Chairs
10 minutes
2  HomeGate Problem Exploration
70 minutes         
            - Discussion of Problem Statement
            - Issues with DNSSEC, DNS Proxies
            - IPv6 support issues
            - Congestion-related support issues
            - Security issues
            - Zero-Config issues
3  Open Discussion / All
30 minutes
4  Questions and Next Steps / Chairs (per RFC5434)
10 minutes

Does this look right?  What should we change, remove, or add?  We need help
on Section 2 of the agenda.

Feedback desired...

Jason

---

From: Jason Livingood <[email-masked]>
Date: Mon, 26 Oct 2009 11:18:07 -0400

We only have a couple more days to lock down our agenda  feedback is still
desired.

Ray Bellis --> Can you take on the section regarding DNSSEC and DNS Proxies?

John Brzozowski --> Can you take on the section regarding IPv6?

Q: Do we have a volunteer to speak to congestion-related support?

Q: Do we have volunteer to speak to any security-related issues?

Q: Do we have a volunteer to speak to any IPv4-related issues not already
covered?

Thanks
Jason

On 10/21/09 4:33 PM, "Jason Livingood" <[email-masked]>
wrote:

> documents for the BoF for a few months now.  As a result, it is probably a bit
> out of date and our view of what we want to do has evolved somewhat.  It is
> now time to take a hard look at this agenda, make sure it is in line with the
> charter/objectives/priorities, and get ready for IETF 76.
> 
> Does this look right?  What should we change, remove, or add?  We need help on
> Section 2 of the agenda.
> 
> Feedback desired...
> 
> Jason
>

---

From: Iñigo Artundo <[email-masked]>
Date: Mon, 26 Oct 2009 16:45:34 +0100

Hi,

I agree on the comments by Paul Hoffman on the minimum requirements for 
the home gateway, as manufacturers will try to strip down to a minimum 
the set of required (read MUST) features on the box to reduce costs.

Relating DNSSEC, it might be useful to have a look at the documents in 
dnssec.net to see up-to-date field deployments and problems with its 
implementation in broadband routers, specifically:

DNSSEC - Compatibility Test of Consumer Broadband Routers 
<http://iis.se/docs/Routertester_en.pdf>
Joakim Åhlund, Patrik Wallström, Feb 2008

DNSSEC Impact on Broadband Routers and Firewalls 
<http://download.nominet.org.uk/dnssec-cpe/DNSSEC-CPE-Report.pdf>
Ray Bellis, Nominet UK, Lisa Phifer, Core Competence, Sep 2008

Iñigo

Jason Livingood escribió:
> We only have a couple more days to lock down our agenda – feedback is 
> still desired.
>
> *Ray Bellis *--> Can you take on the section regarding DNSSEC and DNS 
> Proxies?
>
> *John Brzozowski -*-> Can you take on the section regarding IPv6?
>
> Q: Do we have a volunteer to speak to any IPv4-related issues not 
> already covered?
>
> Thanks
> Jason
>
>
> On 10/21/09 4:33 PM, "Jason Livingood" 
> <[email-masked]> wrote:
>
>     Below is the draft agenda that we’ve been carrying forward in
>     working documents for the BoF for a few months now. As a result,
>     it is probably a bit out of date and our view of what we want to
>     do has evolved somewhat. It is now time to take a hard look at
>     this agenda, make sure it is in line with the
>     *
>     Proposed Agenda*: (120 minutes)
>     1 – Agenda, Goals, and Administrivia / Chairs 10 minutes
>     2 – HomeGate Problem Exploration 70 minutes
>     /- Discussion of Problem Statement
>     /3 – Open Discussion / All 30 minutes
>     4 – Questions and Next Steps / Chairs (per RFC5434) 10 minutes
>
>     Does this look right? What should we change, remove, or add? _We
>     need help on Section 2 of the agenda.
>     _
>     Feedback desired...
>
>     Jason
>
> ------------------------------------------------------------------------
>
> _______________________________________________
> homegate mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/homegate
>

---

From: [email-masked]
Date: Mon, 26 Oct 2009 15:57:19 +0000

> We only have a couple more days to lock down our agenda – feedback 
> is still desired.
> 

Yes, I can take on DNS proxies and DNSSEC (albeit only in so far as 
proxies affect the transport of DNSSEC).
 
Ray

---

From: [email-masked]
Date: Mon, 26 Oct 2009 15:59:28 +0000

> Ray Bellis, Nominet UK, Lisa Phifer, Core Competence, Sep 2008

Inigo,

You will find that the findings of those reports have already been done in 
IETF language, namely BCP 152 (RFC 5625).

kind regards,

Ray

-- 
Ray Bellis, MA(Oxon) MIET
Senior Researcher in Advanced Projects, Nominet
e: [email-masked], t: +44 1865 332211

---

From: Iñigo Artundo <[email-masked]>
Date: Mon, 26 Oct 2009 17:14:44 +0100

True, as of August 2009, thanks for the update!
Then obviously RFC5625 should also be among the RFCs to be included for 
review and adaptation in Homegate.

Iñigo

[email-masked] escribió:
> You will find that the findings of those reports have already been 
> done in IETF language, namely BCP 152 (RFC 5625).
>
> kind regards,
>
> Ray
>
> --

---

From: [email-masked]
Date: Mon, 26 Oct 2009 16:22:04 +0000

> review and adaptation in Homegate.

It shouldn't need review or adaption - it's the current state of the art 
and was (I believe) one of the documents from which the seed of the idea 
for this BOF came.

Ray

---

From: John Jason Brzozowski <[email-masked]>
Date: Tue, 27 Oct 2009 08:20:10 -0400

Sure thing, thanks.

> John Brzozowski --> Can you take on the section regarding IPv6?

=========================================
John Jason Brzozowski
Comcast Cable
e) mailto:[email-masked]
o) 609-377-6594
m) 484-962-0060
=========================================

---

From: Jason Livingood <[email-masked]>
Date: Wed, 28 Oct 2009 17:17:16 -0400

Our draft agenda has been uploaded to:
http://www.ietf.org/proceedings/09nov/agenda/homegate.txt

We could still use someone to speak about congestion issues with home
gateway devices.  Do I have any volunteers?

Also, security-related issues  need a volunteer as well.

Thanks
Jason