Subject: [homegate] Another (silly?) suggestion for WG name

From: David R Oran <[email-masked]>
Date: Mon, 26 Jul 2010 09:47:04 +0200

"Home Internet Services and Home Easy Routing Systems"

His&Hers

---

From: Vittal Krishnamurthy <[email-masked]>
Date: Mon, 26 Jul 2010 00:54:07 -0700

My contrib: :)

"Easy Home internet services "

Cheers,
-Vittal

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of David R Oran
Sent: Monday, July 26, 2010 12:47 AM
To: [email-masked]
Subject: [homegate] Another (silly?) suggestion for WG name

His&Hers

---

From: Ole Troan <[email-masked]>
Date: Mon, 26 Jul 2010 10:15:53 +0200

> "Home Internet Services and Home Easy Routing Systems"

if cuteness isn't a prerequisite, then "Home Networking WG" -> homenet.

cheers,
Ole

---

From: Toni Stoev <[email-masked]>
Date: Mon, 26 Jul 2010 11:26:57 +0300

Please refer me to the definition of this (prospective) group.

Regards
Toni

On Monday 26 July 2010 at 11:15:53 Ole Troan sent:
> _______________________________________________
> homegate mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/homegate
>

---

From: Paul Hoffman <[email-masked]>
Date: Mon, 26 Jul 2010 14:36:50 +0200

If we're going to change the name of the future WG, *please* consider removing "home" from the name. This is about (at a minimum) SOHO, and we really mean "gateways rarely-managed by the user".

--Paul Hoffman, Director
--VPN Consortium

---

From: Ray Bellis <[email-masked]>
Date: Mon, 26 Jul 2010 12:42:59 +0000

On 26 Jul 2010, at 14:36, Paul Hoffman wrote:

> If we're going to change the name of the future WG, *please* consider removing "home" from the name.

noted.

> This is about (at a minimum) SOHO, and we really mean "gateways rarely-managed by the user".

By "rarely managed by the user" do you mean:

1. because they're managed by the ISP, or
2. because most users never touch them once they're installed and working?

Ray

---

From: David R Oran <[email-masked]>
Date: Mon, 26 Jul 2010 05:47:00 -0700

While I'm somewhat sympathetic with Paul's comment, there's a slippery slope here.
For all I can tell many Enterprise class routers are "rarely managed by the user", at least to the point of working reasonably :-)

I think the justification for "home" is mostly the sales and engineering model for the devices, the channel, and that it's supposed to work OOTB.

There are many SOHO routers that don't follow that business model - for example the 8xx series from Cisco, which are pretty complex IOS-based boxes.

To me, for the mental model that best captures the problem set we experience and want to solve, "home" seems pretty evocative.

So, if we do get rid of "home", I'm not sure what to replace it with - Paul's "not managed by the user" could mean lots of things, including "managed by the service provider", or "managed by he company the user works for", etc.

DaveO.

---

From: Joe Touch <[email-masked]>
Date: Mon, 26 Jul 2010 07:59:40 -0700

I'd also suggest sticking to a-z, maybe including '-'.

the "&" might interact badly with some things (e.g., tools pages) - I 
don't recall seeing one in a short-name of a WG or RG before

Joe

---

From: Dave CROCKER <[email-masked]>
Date: Mon, 26 Jul 2010 17:16:37 +0200

On 7/26/2010 2:47 PM, David R Oran wrote:
> To me, for the mental model that best captures the problem set we experience
> and want to solve, "home" seems pretty evocative.
>
> So, if we do get rid of "home", I'm not sure what to replace it with - Paul's
> "not managed by the user" could mean lots of things, including "managed by
> the service provider", or "managed by he company the user works for", etc.

Your note explained some points that explain why 'remote office' has examples 
that don't fit within this.  But you didn't really say what the characteristics 
are that define this set.  Perhaps that's because I should have seen them 
already stated, but I'll ask you to humor me with a very short bullet list of 
the core characteristics that define this set.

It might well be that 'home' calls that set up more readily, but it might help 
to have that concise list in view to decide.

d/
-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net

---

From: Ray Bellis <[email-masked]>
Date: Mon, 26 Jul 2010 16:33:24 +0000

[I forgot to cc: the list]

On 26 Jul 2010, at 10:26, Toni Stoev wrote:

The proposed charter may be found at:

http://trac.tools.ietf.org/area/tsv/trac/wiki/HOMEGATE

kind regards,

Ray

---

From: Jason Livingood <[email-masked]>
Date: Mon, 26 Jul 2010 12:37:13 -0400

So based on feedback maybe -
homenet
smallnet
hohonet (home + home office networks)

I'm sure folks can come up to the mic at the BoF to offer other suggestions.
:-)

Jason

---

From: "Woundy, Richard" <[email-masked]>
Date: Mon, 26 Jul 2010 12:40:51 -0400

>2. because most users never touch them once they're installed and
working?

(some more alternatives just for fun)

3. because I'm borrowing my neighbor's gateway and I don't have admin
rights (yet).

4. because it's managed by my teenager (who is the real tech expert).

5. because it's managed by a Russian botnet via the latest home gateway
exploit.

6. because it's managed by Google via their new Street View van-based
gateway management service.

-- Rich

PS Thanks to Rich Ferrise for one of above.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Ray Bellis
Sent: Monday, July 26, 2010 2:43 PM
To: Paul Hoffman
Cc: <[email-masked]>
Subject: Re: [homegate] Another (silly?) suggestion for WG name

noted.

1. because they're managed by the ISP, or
2. because most users never touch them once they're installed and
working?

Ray

---

From: Mark Baugher <[email-masked]>
Date: Mon, 26 Jul 2010 10:45:19 -0700

What's wrong with homegate?  I think that the focus should be on  
residential networks and on the gateway device(s) on those networks.   
The gateway has SP and home network interfaces, so home networking  
protocols and services would be within scope.

Mark

---

From: grenville armitage <[email-masked]>
Date: Tue, 27 Jul 2010 07:45:13 +1000

Perhaps:

HORN - Home Office and Residential Networks

cheers,
gja

---

From: Jason Livingood <[email-masked]>
Date: Tue, 27 Jul 2010 03:46:01 -0400

Mark --

Duncan Bees, from the Home Gateway Initiative (HGI) has raised the
reasonable concern that HomeGate is too similar to his SDO and it could
therefore cause confusion.

J

---

From: "James M. Polk" <[email-masked]>
Date: Tue, 27 Jul 2010 03:18:46 -0500

>I'm sure folks can come up to the mic at the BoF to offer other suggestions.

how about

Home and soho netwOrking Made Easy (HOME)

James

---

From: Fred Baker <[email-masked]>
Date: Tue, 27 Jul 2010 10:42:06 +0200

SOHO Management Services (SMS)

---

From: Dave CROCKER <[email-masked]>
Date: Tue, 27 Jul 2010 10:53:21 +0200

> SOHO Management Services (SMS)

Will this require limiting products to 40mbps or the working group to 40 meetings?:

d/

-- 

   Dave Crocker

---

From: Fred Baker <[email-masked]>
Date: Tue, 27 Jul 2010 11:01:26 +0200

> Will this require limiting products to 40mbps or the working group to 40 meetings?:

It may require application layer exchanges to be encapsulated in 140 byte messages...

---

From: Dave CROCKER <[email-masked]>
Date: Tue, 27 Jul 2010 13:20:31 +0200

> It may require application layer exchanges to be encapsulated in 140 byte messages...

oh.  right.  Thanks.

As usual, I was off by 1.

d/
-- 

   Dave Crocker

---

From: Mark Baugher <[email-masked]>
Date: Tue, 27 Jul 2010 08:02:37 -0700

How about "resgate" then?

Mark

---

From: Mark Townsley <[email-masked]>
Date: Tue, 27 Jul 2010 17:05:31 +0200

> residential networks and on the gateway device(s) on those networks. 

I think that if we are going to tackle the home network, we should
include the network itself, not just the outermost edge device. In
particular, v6 routing in the home, DNS, etc. If we don't consider what
happens when we have more than one router in the home, we might end up
with the wrong design.

I think that even if we tried to limit the scope to just the gateway
device, we'll end up making a lot of assumptions on what the "LAN side"
of the gateway looks like. I'd rather define/describe it formally.

We could still prioritize the "gate" place in the network in terms of
deliverables.

- Mark

---

From: Ralph Droms <[email-masked]>
Date: Tue, 27 Jul 2010 17:29:26 +0200

I agree with Mark - we really should be considering more than just the gateway. And that scope should be reflected in the name, perhaps homenet or sohonet.

- Ralph

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Tue, 27 Jul 2010 17:45:49 +0200

I don't like too much the gate part of homegate which appears as too much of control/blocking. Else, like Mark it is clear.

Or HomeEdge? Or HOMe Edge Router (HOMER)

-éric

> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Mark Townsley (townsley)
> Sent: mardi 27 juillet 2010 17:06
> To: [email-masked]

---

From: Mark Baugher <[email-masked]>
Date: Tue, 27 Jul 2010 08:49:06 -0700

Mark
  Both the examples that you cite, v6 routing in the home and DNS
are topics of interest to the residential gateway.  I did not
limit the problem to a single gateway or router in the home,
or exclude consideration of alternative home topologies than
the single LAN that is most common today.

  I don't know what you mean by being forced to make assumptions
about the LAN side since the gateway, router, and other network
devices all participate in home-network services and protocols.

  We certainly want to include multiple gateways in the scope
of the group and I would say multiple routers as well, since
home routers typically can configured to perform the gateway
function or not.

  Before I come around and agree with you, I'd like to better
understand what you have in mind when you say you want to
define and describe "it" formally.  What does "it" mean?

  We'll do much better if the WG is founded on well-bounded
and well-understood goals.  Yours sound pretty amorphous to me.

Mark

On Jul 27, 2010, at 8:05 AM, Mark Townsley wrote:

>>>>> So, if we do get rid of "home", I'm not sure what to replace it  
>>>>> with
>>>>> - Paul's
>>>> Your note explained some points that explain why 'remote office'  
>>>> has
>>>> examples
>>>> are that define this set.  Perhaps that's because I should have  
>>>> seen
>>>> them
>>>> already stated, but I'll ask you to humor me with a very short  
>>>> bullet
>>>> list of

---

From: Simeon Lisec <[email-masked]>
Date: Tue, 27 Jul 2010 17:50:37 +0200

Hi all,

Some additional comment from my side on this topic
- name must represent the scope and be a kind of sexy, on the otherside its just a name and do not loose to much time on naming.
- if you want that the document is usefull for ISP and other SP, than you "must" focus on both areas, on local and on wide and be very clear how to route between them.
- the charter should somehow mention also remotely managed or unmanaged devices

Br
simeon

On 7/27/10 5:29 PM, "Ralph Droms" <[email-masked]> wrote:

- Ralph

Simeon Lisec

Sektor za omrežje in infrastrukturo /  Network and infrastructure department
tel:   +386-1-234-1634; gsm: +386-41-382-791
Cigaletova 15, SI-1000 Ljubljana, Slovenia

---

From: Mark Baugher <[email-masked]>
Date: Tue, 27 Jul 2010 08:52:20 -0700

Ralph, are we interested in home networks that don't have gateways?  I  
don't think we are, and the gateway is crucial to supporting the  
homenet or sohonet.  What protocols or services are you interested in  
that would be out of scope if we limited the scope to the gateway? We  
all know that successful WG's have a manageable scope, so I favor  
restricting it.

Mark

On Jul 27, 2010, at 8:29 AM, Ralph Droms wrote:

> I agree with Mark - we really should be considering more than just  
> the gateway. And that scope should be reflected in the name, perhaps  
> homenet or sohonet.
>
> - Ralph
>
>>>>> It might well be that 'home' calls that set up more readily, but  
>>>>> it
>>>>> might help

---

From: Lars Eggert <[email-masked]>
Date: Tue, 27 Jul 2010 17:59:37 +0200

> Or HomeEdge? Or HOMe Edge Router (HOMER)

The acronym nicely describes a subset of the owners/"operators" of these devices :-)

Lars

---

From: Ralph Droms <[email-masked]>
Date: Tue, 27 Jul 2010 18:01:24 +0200

I want to make sure we consider protocols, functions and services that are required for a network that includes multiple routers.

- Ralph

On Jul 27, 2010, at 5:52 PM 7/27/10, Mark Baugher wrote:

> Ralph, are we interested in home networks that don't have gateways?  I don't think we are, and the gateway is crucial to supporting the homenet or sohonet.  What protocols or services are you interested in that would be out of scope if we limited the scope to the gateway? We all know that successful WG's have a manageable scope, so I favor restricting it.
> 
> Mark
>

---

From: Marc Blanchet <[email-masked]>
Date: Tue, 27 Jul 2010 18:03:28 +0200

I'd vote for HOMER! Marc.

-- 
=========
IPv6 book: Migrating to IPv6, Wiley. http://www.ipv6book.ca
Stun/Turn server for VoIP NAT-FW traversal: http://numb.viagenie.ca
DTN news service: http://reeves.viagenie.ca
NAT64-DNS64 Opensource: http://ecdysis.viagenie.ca

---

From: "STARK, BARBARA H (ATTLABS)" <[email-masked]>
Date: Tue, 27 Jul 2010 12:03:24 -0400

I agree with Ralph and Mark. Recommendations for desirable behavior of
consumer-oriented host devices in the LAN to work with the rest of the
LAN, and with the "home gateway", should be in scope. It's very
difficult to design a home gateway when host device behavior is
unpredictable.

It's going to be hard to come up with a good in-home-LAN DNS solution if
we can't consider the behavior of hosts as being fair game.
Barbara

> Behalf Of Mark Baugher
> Sent: Tuesday, July 27, 2010 11:52 AM
> To: Ralph Droms
> Cc: [email-masked]
> >>>>>> To me, for the mental model that best captures the problem set
> we
> >>>>>> experience

---

From: Mark Baugher <[email-masked]>
Date: Tue, 27 Jul 2010 09:03:26 -0700

I do too.

Mark

On Jul 27, 2010, at 9:01 AM, Ralph Droms wrote:

> I want to make sure we consider protocols, functions and services  
> that are required for a network that includes multiple routers.
>
> - Ralph
>
>> Ralph, are we interested in home networks that don't have  
>> gateways?  I don't think we are, and the gateway is crucial to  
>> supporting the homenet or sohonet.  What protocols or services are  
>> you interested in that would be out of scope if we limited the  
>> scope to the gateway? We all know that successful WG's have a  
>> manageable scope, so I favor restricting it.
>>
>> Mark
>>
>>> the gateway. And that scope should be reflected in the name,  
>>> perhaps homenet or sohonet.
>>>
>>> - Ralph
>>>
>>>>>>>> To me, for the mental model that best captures the problem  
>>>>>>>> set we
>>>>>>>> experience
>>>>>>>> So, if we do get rid of "home", I'm not sure what to replace  
>>>>>>>> it with
>>>>>>>> - Paul's
>>>>>>> Your note explained some points that explain why 'remote  
>>>>>>> office' has
>>>>>>> examples
>>>>>>> are that define this set.  Perhaps that's because I should  
>>>>>>> have seen
>>>>>>> them
>>>>>>> It might well be that 'home' calls that set up more readily,  
>>>>>>> but it
>>>>>>> might help

---

From: Marc Blanchet <[email-masked]>
Date: Tue, 27 Jul 2010 18:08:33 +0200

but the acronym of the wg cannot be overload by all topics of the 
charter. Moreover, sometimes as the wg goes, the acronym is much less 
related to the work... MIF is a good example where pretty early in the 
Problem statement was discussed, we were generalizing to multiple 
provisioning domains...

so wg acronym should not contain the whole charter...

Marc.

Le 10-07-27 18:03, Mark Baugher a écrit :
>> I want to make sure we consider protocols, functions and services that
>> are required for a network that includes multiple routers.
>>
>> - Ralph
>>

---

From: "James M. Polk" <[email-masked]>
Date: Tue, 27 Jul 2010 11:10:19 -0500

At 10:45 AM 7/27/2010, Eric Vyncke (evyncke) wrote:
>I don't like too much the gate part of homegate 
>which appears as too much of control/blocking. Else, like Mark it is clear.
>

+1

> > From: [email-masked] 
> [mailto:[email-masked]] On Behalf

---

From: Mark Townsley <[email-masked]>
Date: Tue, 27 Jul 2010 18:12:45 +0200

On 7/27/10 5:52 PM, Mark Baugher wrote:
> Ralph, are we interested in home networks that don't have gateways? 

Are we interested in gateways with no home network?

- Mark

 I
> don't think we are, and the gateway is crucial to supporting the homenet
> or sohonet.  What protocols or services are you interested in that would
> be out of scope if we limited the scope to the gateway? We all know that
> successful WG's have a manageable scope, so I favor restricting it.
> 
> Mark
> 
>> I agree with Mark - we really should be considering more than just the
>> gateway. And that scope should be reflected in the name, perhaps
>> homenet or sohonet.
>>
>> - Ralph
>>

---

From: Mark Baugher <[email-masked]>
Date: Tue, 27 Jul 2010 09:29:10 -0700

> Are we interested in gateways with no home network?

Yes, there are many cases where the residence has a single computer
that is directly attached to the gateway/router with no "NAS", computer
to computer sharing, digital media adapters, broadband sharing, etc.
I would not exclude this configuration since we're interested in the
SP side of the gateway and that applies here.

Mark

>>> the

---

From: David R Oran <[email-masked]>
Date: Tue, 27 Jul 2010 19:07:04 +0200

> Are we interested in gateways with no home network?
What would such a device do?
You mean a single IP host attached to a service provider uplink as would be a PC with a USB-atached DSL modem?

---

From: David R Oran <[email-masked]>
Date: Tue, 27 Jul 2010 19:08:03 +0200

>> Ralph, are we interested in home networks that don't have gateways? 
No, since then there is no access to the internet or any of its services.

---

From: Mark Baugher <[email-masked]>
Date: Tue, 27 Jul 2010 10:21:10 -0700

On Jul 27, 2010, at 10:07 AM, David R Oran wrote:

> You mean a single IP host attached to a service provider uplink as  
> would be a PC with a USB-atached DSL modem?

Or even directly attached via Ethernet.  I suppose you could argue  
that a single PC on a LAN is a home network.  In this case, I'd say we  
always have a home network but not necessarily a very interesting one.

Mark

>>>>>>>>> the service provider", or "managed by he company the user  
>>>>>>>>> works
>>>>>>>>> for", etc.
>>>>>>>>
>>>>>>>>
>>>>>>>> already stated, but I'll ask you to humor me with a very  
>>>>>>>> short bullet
>>>>>>>> list of

---

From: Vittal Krishnamurthy <[email-masked]>
Date: Tue, 27 Jul 2010 10:38:41 -0700

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Mark Townsley
Sent: Tuesday, July 27, 2010 9:13 AM
To: Mark Baugher
Cc: [email-masked]
Subject: Re: [homegate] Another (silly?) suggestion for WG name

Are we interested in gateways with no home network?
[VK]  We should be considering both gateways and home network.  The device will be handling a host of protocols in voice video(video server, DVR etc), apart from pure data.
How about HOme edge Router Network(HORNET)?

- Mark

 I

---

From: David R Oran <[email-masked]>
Date: Wed, 28 Jul 2010 08:41:39 +0200

On Jul 27, 2010, at 7:21 PM, Mark Baugher wrote:

> Or even directly attached via Ethernet.  I suppose you could argue that a single PC on a LAN is a home network.  In this case, I'd say we always have a home network but not necessarily a very interesting one.
> 
Agreed. If we can't handle the degenerate cases cleanly then we probably have a bad design.

---

From: Mark Townsley <[email-masked]>
Date: Wed, 28 Jul 2010 11:46:49 +0200

On 7/27/10 6:10 PM, James M. Polk wrote:
>> I don't like too much the gate part of homegate which appears as too
>> much of control/blocking. Else, like Mark it is clear.
>>

Except its not just the edge.

Still like homenet.

- Mark

---

From: "Stephen [kiwin] PALM" <[email-masked]>
Date: Wed, 28 Jul 2010 06:38:50 -0700

> Still like homenet.

This group is NOT doing home networking... ie, the MAC/PHY.
Many other groups do that.

>>>>> What's wrong with homegate?

Too close t HomeGatewayIntiative

>>>> happens when we have more than one router in the home, we might end up

Like solving the multiple DHCP server problem?
But is that in scope?

regards, kiwin

---

From: Mark Townsley <[email-masked]>
Date: Wed, 28 Jul 2010 17:00:27 +0200

> Many other groups do that.

"net" could imply "Network Layer"

- Mark

---

From: Mark Baugher <[email-masked]>
Date: Wed, 28 Jul 2010 08:26:34 -0700

> Like solving the multiple DHCP server problem?

This problem is not mentioned in the charter AFAICT.  Maybe it will  
eventually be recognized as necessarily in-scope for the WG.  I think  
that the most important issues in deploying dual-stack gateway/routers  
on home networks might potentially be in scope.  This seems to be  
consistent with the charter, in general terms.

Mark