Subject: Re: [homegate] wanted: your old NAT home router

From: Lars Eggert <[email-masked]>
Date: Fri, 9 Jul 2010 10:15:16 +0300

Hi,

a quick status update. We now have received over 100 donated home gateways, plus a DSLAM. The students are on their summer break, after which we'll start running a significantly expanded set of tests over this much larger population of devices.

Many of yo have donated boxes and suggested more experiments and better ways of performing our current tests - thank you!

In case you are attending IETF-78 in Maastricht and would like to donate a home gateway, simply bring it. (Or contact me now for shipping details; no cost to you.)

We're especially interested in devices from outside the EU and North America, or any other model we may not have yet (see http://fit.nokia.com/lars/tmp/2010-hgw-study-devices.txt). And we're still lacking a CMTS for testing cable modems...

See you in Maastricht,
Lars

On 2010-6-2, at 18:36, Lars Eggert wrote:
> Hi,
> 
> FYI, a first report with test results for 34 devices is available at http://fit.nokia.com/lars/tmp/2010-hgw-study.pdf. Slides that summarize the results are at http://fit.nokia.com/lars/tmp/2010-hgw-study-slides.pdf.
> 
> We have received another 30-odd devices as donations, which we'll add to the testbed and include in a follow-up study.
> 
> If you have an unused, spare home gateway to donate to this effort, please contact us at [email-masked]. We're also interested in obtaining a DSLAM and a CMTS.
> 
> Thanks,
> Lars
> 
> On 2010-4-29, at 12:34, Lars Eggert wrote:
>> Hi,
>> 
>> for a measurement study done together with Markku Kojo's team at the University of Helsinki, we're looking to collect as many different NAT home routers as possible. If you have an old clunker lying around somewhere, please contact me off-list. I'll cover shipping via DHL. Feel free to forward this email as you see fit.
>> 
>> The boxes will find a permanent home at the University of Helsinki. Study results will be published openly. The intent is that this collection become a resource for the community to be shared for future studies. 
>> 
>> Caveat: The boxes should NAT between Ethernet interfaces - we don't have DSL or cable access equipment in the lab setup at the moment.
>> 
>> Thanks,
>> Lars
>

---

From: Jean-Francois Mule <[email-masked]>
Date: Fri, 9 Jul 2010 03:34:33 -0600

Hi Lars,

On Jul9 2010, at 09:15, Lars Eggert wrote:
...snip...

> We're especially interested in devices from outside the EU and North America, or any other model we may not have yet (see http://fit.nokia.com/lars/tmp/2010-hgw-study-devices.txt). And we're still…

I will send a note out to a few folks to donate devices from North America (will bring you one at IETF).

As far as CMTSes are concerned for cable modem tests, there is something we could potentially assist with at CableLabs.
If it is of interest, we could work together to arrange your students to come to our lab for a week at a time when we are not running any formal certification or interop testing.  We could also try and see if we could get students from Boulder CU to assist in the study to cut costs.
We could likely make it happen if we can get some cable modem vendor to support this (at a minimum, they would need to be ok with us facilitating the testing on some of the CM home gateway models we have in the labs) and more importantly, if we have cable operator sponsors for this.
I think this could be done.

Let me know if this would be something worth exploring.
Jean-Francois.
---
Jean-François Mulé
CableLabs
tel:+1-303-661-3708
mailto:[email-masked]

On Jul9 2010, at 09:15, Lars Eggert wrote:

> <smime.p7s>_______________________________________________
> homegate mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/homegate

---

From: Yuchung Cheng <[email-masked]>
Date: Tue, 20 Jul 2010 11:00:24 -0700

Hi Lars,

This is very interesting study! it provides many useful information for the
TCP research at Google.

The queuing and processing delays on slide 12 (or figure 9 in the paper) are
mostly <50ms, but the following paper
"Characterizing residential broadband networks"  published in IMC 2007
measures much higher queuing length ranging from 100ms to a few secs (
http://portal.acm.org/citation.cfm?id=1298306.1298313 figure 13).

Any idea about the differences?

Thanks,

Yuchung

On Fri, Jul 9, 2010 at 12:15 AM, Lars Eggert <[email-masked]> wrote:

> Hi,
>
> a quick status update. We now have received over 100 donated home gateways,
> plus a DSLAM. The students are on their summer break, after which we'll
> start running a significantly expanded set of tests over this much larger
> population of devices.
>
> Many of yo have donated boxes and suggested more experiments and better
> ways of performing our current tests - thank you!
>
> In case you are attending IETF-78 in Maastricht and would like to donate a
> home gateway, simply bring it. (Or contact me now for shipping details; no
> cost to you.)
>
> We're especially interested in devices from outside the EU and North
> America, or any other model we may not have yet (see
> http://fit.nokia.com/lars/tmp/2010-hgw-study-devices.txt). And we're still
> lacking a CMTS for testing cable modems...
>
> See you in Maastricht,
> Lars
>
> > FYI, a first report with test results for 34 devices is available at
> http://fit.nokia.com/lars/tmp/2010-hgw-study.pdf. Slides that summarize
> the results are at http://fit.nokia.com/lars/tmp/2010-hgw-study-slides.pdf
> .
> >
> > We have received another 30-odd devices as donations, which we'll add to
> the testbed and include in a follow-up study.
> >
> > If you have an unused, spare home gateway to donate to this effort,
> please contact us at [email-masked]. We're also interested in
> obtaining a DSLAM and a CMTS.
> >
> > Thanks,
> > Lars
> >
> >> for a measurement study done together with Markku Kojo's team at the
> University of Helsinki, we're looking to collect as many different NAT home
> routers as possible. If you have an old clunker lying around somewhere,
> please contact me off-list. I'll cover shipping via DHL. Feel free to
> forward this email as you see fit.
> >>
> >> The boxes will find a permanent home at the University of Helsinki.
> Study results will be published openly. The intent is that this collection
> become a resource for the community to be shared for future studies.
> >>
> >> Caveat: The boxes should NAT between Ethernet interfaces - we don't have
> DSL or cable access equipment in the lab setup at the moment.
> >>
> >> Thanks,
> >> Lars
> >
>
>
> _______________________________________________
> 78attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/78attendees
>
>

---

From: Vittal Krishnamurthy <[email-masked]>
Date: Tue, 20 Jul 2010 11:16:02 -0700

Hi Lars/All,
 I am addressing this point from lars
      "And we're still lacking a CMTS for testing cable modems..."
  If there is cisco employee from San Jose who is reading this, you can try the PLM/marketing team in Bldng 6, Floor 4 for a CMTS.  Worth a try atleast.
You can try asking for a 7200 VXR (if I remember right) or an UBR10k (unused) with 1 linecard.  I have worked on the Cisco CMTS before and so I can help with the configuration etc., if the test beds are in San Francisco Bay area.
            Also another neat trick is that the older cisco cable modems can be loaded with "script kiddies", which essentially simulates hundreds modems by incrementally changing the mac and start training.

Cheers,
-Vittal

From: [email-masked] [mailto:[email-masked]] On Behalf Of Yuchung Cheng
Sent: Tuesday, July 20, 2010 11:00 AM
To: [email-masked]
Cc: [email-masked] list; [email-masked]; IETF BEHAVE WG; [email-masked]; [email-masked] Discussion
Subject: Re: [homegate] [78attendees] wanted: your old NAT home router

Hi Lars,

This is very interesting study! it provides many useful information for the TCP research at Google.

The queuing and processing delays on slide 12 (or figure 9 in the paper) are mostly <50ms, but the following paper
"Characterizing residential broadband networks"  published in IMC 2007 measures much higher queuing length ranging from 100ms to a few secs (http://portal.acm.org/citation.cfm?id=1298306.1298313 figure 13).

Thanks,

Yuchung

On Fri, Jul 9, 2010 at 12:15 AM, Lars Eggert <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

See you in Maastricht,
Lars

On 2010-6-2, at 18:36, Lars Eggert wrote:
> If you have an unused, spare home gateway to donate to this effort, please contact us at [email-masked]<mailto:[email-masked]>. We're also interested in obtaining a DSLAM and a CMTS.
>
> Thanks,
> Lars
>

_______________________________________________
78attendees mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/78attendees

---

From: Lars Eggert <[email-masked]>
Date: Wed, 21 Jul 2010 10:01:20 +0300

Hi,

thanks for the pointer. Dave Oran has secured a Cisco CMTS for us in the meantime - thanks Dave!

Lars

On 2010-7-20, at 21:16, Vittal Krishnamurthy wrote:

>      “And we're still lacking a CMTS for testing cable modems...”
>            Also another neat trick is that the older cisco cable modems can be loaded with “script kiddies”, which essentially simulates hundreds modems by incrementally changing the mac and start training.
> 
> 
> Cheers,
> -Vittal
> 
> <ATT00001..txt>

---

From: Lars Eggert <[email-masked]>
Date: Wed, 21 Jul 2010 10:18:36 +0300

Hi,

Lars

---

From: Lars Eggert <[email-masked]>
Date: Thu, 22 Jul 2010 08:50:26 +0300

Hi,

> This is very interesting study! it provides many useful information for the TCP research at Google.

thanks! Let's chat at the IETF if there are any tests we can do that would make the results even more relevant for you guys?

> Any idea about the differences?

We haven't looked into the details much. One factor may be that the delay numbers we measured where taken at the same time we did the bulk throughput measurements, and they only used a single connection up and/or down. And IIRC we measured the delay experience by that connection and not the delay experienced by other connections through the box at the time. It may also be that our population is home gateways is newer (= better?) than the one measured by the IMC paper. We'll attempt to look into this more deeply during the next phase of the study.

Lars

---

From: "Woundy, Richard" <[email-masked]>
Date: Thu, 22 Jul 2010 20:10:36 -0400

(Trimmed the recipients somewhat)

Here is my pet theory and explanation about why there was a difference
in the queuing delays in Lars' study and in the IMC 2007 paper.

The first part of my theory is that most home gateways and broadband
modems are built with queue lengths sized according to the vendor's
anticipated maximum transmit speed of the network interface. The second
part of my theory is that most home gateways and broadband modems do not
adjust their queue lengths based on the *actual* transmit speed of that
network interface.

Here is an example of the effect of that theory. Suppose a broadband
modem has been designed with enough buffering to be able to saturate a
broadband uplink of 10 Mbps with TCP traffic. But suppose that the modem
is only able to transmit at most 1 Mbps on the uplink. My theory would
imply that the modem uses 10x as much buffering as it needs, which might
easily translate to a 1000+ msec queuing delay on the uplink under
congestion.

Why is the broadband modem not able to transmit at its maximum speed?
For a DOCSIS modem, the modem vendor's maximum uplink transmission speed
may have assumed that the modem has the entire DOCSIS uplink capacity at
its disposal, which isn't true since DOCSIS is a shared network medium
(most of the time). For an xDSL modem, the actual maximum uplink
transmission speed may be limited by the length of the local copper
loop. And of course, the broadband access speed may be limited according
to the service tier purchased from the ISP and provisioned for the
broadband modem.

Here's an interesting exercise. I wonder what would happen if the home
gateway testbed was changed from using 100 Mbps Ethernet links to only
10 Mbps Ethernet links? Especially for testing the faster home gateways?

-- Rich

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Lars Eggert
Sent: Thursday, July 22, 2010 1:50 AM
To: Yuchung Cheng
Cc: [email-masked]; IETF BEHAVE WG; [email-masked] Discussion;
[email-masked]; [email-masked] list;
[email-masked]
Subject: Re: [homegate] [78attendees] wanted: your old NAT home router

Hi,

> This is very interesting study! it provides many useful information
for the TCP research at Google.

thanks! Let's chat at the IETF if there are any tests we can do that
would make the results even more relevant for you guys?

> The queuing and processing delays on slide 12 (or figure 9 in the
paper) are mostly <50ms, but the following paper
> "Characterizing residential broadband networks"  published in IMC 2007
measures much higher queuing length ranging from 100ms to a few secs
(http://portal.acm.org/citation.cfm?id=1298306.1298313 figure 13).
> Any idea about the differences?

We haven't looked into the details much. One factor may be that the
delay numbers we measured where taken at the same time we did the bulk
throughput measurements, and they only used a single connection up
and/or down. And IIRC we measured the delay experience by that
connection and not the delay experienced by other connections through
the box at the time. It may also be that our population is home gateways
is newer (= better?) than the one measured by the IMC paper. We'll
attempt to look into this more deeply during the next phase of the
study.

Lars

> 
> Thanks,
> 
> Yuchung
> 
> On Fri, Jul 9, 2010 at 12:15 AM, Lars Eggert
<[email-masked]<mailto:[email-masked]>> wrote:
> Hi,
> 
> a quick status update. We now have received over 100 donated home
gateways, plus a DSLAM. The students are on their summer break, after
which we'll start running a significantly expanded set of tests over
this much larger population of devices.
> 
> Many of yo have donated boxes and suggested more experiments and
better ways of performing our current tests - thank you!
> 
> In case you are attending IETF-78 in Maastricht and would like to
donate a home gateway, simply bring it. (Or contact me now for shipping
details; no cost to you.)
America, or any other model we may not have yet (see
http://fit.nokia.com/lars/tmp/2010-hgw-study-devices.txt). And we're
still lacking a CMTS for testing cable modems...
http://fit.nokia.com/lars/tmp/2010-hgw-study.pdf. Slides that summarize
the results are at
http://fit.nokia.com/lars/tmp/2010-hgw-study-slides.pdf.
>> 
>> We have received another 30-odd devices as donations, which we'll add
to the testbed and include in a follow-up study.
>> If you have an unused, spare home gateway to donate to this effort,
please contact us at
[email-masked]<mailto:[email-masked]>. We're also
interested in obtaining a DSLAM and a CMTS.
>>> for a measurement study done together with Markku Kojo's team at the
University of Helsinki, we're looking to collect as many different NAT
home routers as possible. If you have an old clunker lying around
somewhere, please contact me off-list. I'll cover shipping via DHL. Feel
free to forward this email as you see fit.
>>> The boxes will find a permanent home at the University of Helsinki.
Study results will be published openly. The intent is that this
collection become a resource for the community to be shared for future
studies.
>>> 
>>> Caveat: The boxes should NAT between Ethernet interfaces - we don't
have DSL or cable access equipment in the lab setup at the moment.

---

From: "Mario Paalvast (mpaalvas)" <[email-masked]>
Date: Fri, 23 Jul 2010 15:36:20 +0200

Just wondering about the other low layer delay / latency factor related
to Forward Error Control (FEC) in xDSL networks being Interleave versus
FastPath as configurable on the ATU-C (DSLAM) side. I did not see this
taken into account.

Thanks, 
Mario Paalvast
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Woundy, Richard
Sent: vrijdag 23 juli 2010 2:11
To: Lars Eggert; Yuchung Cheng
Cc: [email-masked]; [email-masked];
[email-masked]
Subject: Re: [homegate] [78attendees] wanted: your old NAT home router

-- Rich

-----Original Message-----

Hi,

Lars

please contact us at

---

From: "Woundy, Richard" <[email-masked]>
Date: Fri, 23 Jul 2010 10:15:36 -0400

I've heard from others that xDSL Interleave versus FastPath may have an
impact as well... but I'm a cable guy so I'm not an expert. :)

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Mario Paalvast (mpaalvas)
Sent: Friday, July 23, 2010 9:36 AM
To: Woundy, Richard; Lars Eggert; Yuchung Cheng
Cc: [email-masked]; [email-masked];
[email-masked]
Subject: Re: [homegate] [78attendees] wanted: your old NAT home router

Thanks, 
Mario Paalvast
-----Original Message-----

-- Rich

-----Original Message-----

Hi,

Lars

please contact us at

---

From: Ray Bellis <[email-masked]>
Date: Fri, 23 Jul 2010 14:34:02 +0000

> impact as well... but I'm a cable guy so I'm not an expert. :)

When I worked in the ISP rather than DNS side of the industry, gamers would prefer FastPath vs interleaved for the improved latency.  The trade-off was potentially worse reliability.

Ray

---

From: "STARK, BARBARA H (ATTLABS)" <[email-masked]>
Date: Fri, 23 Jul 2010 14:18:17 -0400

Given the time when these studies were done, the speeds that were
tested, the companies included in the tests, and the fact that they seem
to have gone after "mass market" IP address ranges, I would hazard a
guess that there was no interleaving on those lines.
Barbara

> Sent: Friday, July 23, 2010 10:16 AM
> To: Mario Paalvast (mpaalvas); Lars Eggert; Yuchung Cheng