Subject: Re: [homegate] Homegate charter

From: David R Oran <[email-masked]>
Date: Wed, 1 Sep 2010 08:54:06 -0400

On Aug 31, 2010, at 7:38 PM, Mark Baugher wrote:

> 
> On Aug 31, 2010, at 3:07 PM, Mark Townsley wrote:
> 
>> 
>> I'm confused. On one hand you cite UPnP expecting home routing to exist,
>> along with a use-case or two backing it up. On the other you say "home
>> routing" may never become of practical importance.
>> 
>> Surely I'm missing something.
> 
> No, not necessarily.  Home networks are mostly bridged not routed today.  So why are we worried about routing?  I think you and I can agree that the present situation might change in the future.  Or it might not.  The only real evidence I have that we may need routed home networks is that one new LAN type, 802.15.4, cannot be bridged; some networks like sensor networks probably should not be bridged.  And we also expect the number of home network devices to increase exponentially in the future.  Will these factors change the status quo of having only one bridged LAN in the home?  I think it's possible but not necessarily likely.  I don't see the 'killer app' for home routing.  Multi-homing and other gateway services seem to be of more practical importance to me. But I have no crystal ball.
> 
The fact of the matter is that none of the devices run 802.1D bridging protocols so they are pooched if the user creates a loop anyway. Ironically, they mostly ARE capable of running RIP, at least for v4, so we are arguably closer to a practical solution with IP routing than bridging.

Therefore it seems inescapable that non-trivial home network topologies will need some kind of routing protocols. I think depending on 802.1D bridging would be the wrong way to go.

DaveO.

>> 
>>> 
>>> I'm not sure what we problems we are trying to solve or what we hope
>>> to accomplish in this group.
>> 
>> IMHO, Ole made a decent list.
>> 
> 
> I think it's a decent place to start if we are going to rethink the charter again. 
> 
> Mark
> 
> _______________________________________________
> homegate mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/homegate

---

From: "Stephen [kiwin] PALM" <[email-masked]>
Date: Wed, 1 Sep 2010 07:06:44 -0700

On 9/1/2010 5:54 AM, David R Oran wrote:
 > The fact of the matter is that none of the devices run 802.1D bridging protocols

Really?
Which ones are you referring to?
As an example, my home network has 5+ bridges/switches and works well.

> Therefore it seems inescapable that non-trivial home network topologies will need some kind of routing protocols. I think depending on 802.1D bridging would be the wrong way to go.

Unfortunately, many of the applications that consumers run on their home networks are not tolerant
of routing... so unlikely to be accepted by consumers.

regards, kiwin

-- 
Stephen [kiwin] Palm   Ph.D.                          E:  [email-masked]
Senior Technical Director                             T: +1-949-926-PALM
Broadcom Broadband Communications Group               F: +1-949-926-7256
Irvine, California                               W: http://www.kiwin.com
Secondary email accounts:  [email-masked]  [email-masked]
[email-masked]  [email-masked]  [email-masked]  [email-masked]

---

From: Mark Baugher <[email-masked]>
Date: Wed, 1 Sep 2010 09:26:59 -0700

> Therefore it seems inescapable that non-trivial home network topologies will need some kind of routing protocols. I think depending on 802.1D bridging would be the wrong way to go.

HCI and compatibility issues determine to a great extent what we can and cannot introduce on the home network.  The question for me is not so much whether we need home network routing.  There is no pressing need AFAICT.  I wonder whether (or how soon) will we need non-trivial home network topologies, what applications will force this evolution, how well routing services can be be configured and run in an unmanaged environment, and what existing applications will break and how.

Mark

---

From: Ralph Droms <[email-masked]>
Date: Wed, 1 Sep 2010 22:03:53 -0400

Mark - there is a pressing need to define how home routing should work, because - exactly as you pointed out - IEEE802.15.4 cannot be bridged.  ZigBee Alliance is defining a ZigBee-IP architecture and specification, which anticipates the use of multiple routes in the premises.  The IETF needs to specify an addressing architecture, and standards for PD and routing in the premises network, or ZA will have to do it.

- Ralph

---

From: "Stephen [kiwin] PALM" <[email-masked]>
Date: Thu, 2 Sep 2010 06:59:13 -0700

Let the brain dead technologies solve their own problems.
ZigBee did not even contemplate supporting IP until recently...
they should also figure out how to support bridging.
It is unreasonable for ZigBee to expect the rest of the civilized IP world change for them...
especially when there are other existing technologies that are better.

regards, kiwin

On 9/1/2010 7:03 PM, Ralph Droms wrote:
> On Sep 1, 2010, at 12:26 PM, Mark Baugher<[email-masked]>  wrote:
>
>>

---

From: David R Oran <[email-masked]>
Date: Thu, 2 Sep 2010 10:05:07 -0400

> especially when there are other existing technologies that are better.
That's funny - I would see this exactly the opposite way. Rather than deal with all the problems and limitation of bridging, with all sorts of incorrect transparency assumptions, addressing mismatches, multicast inefficiencies, etc. etc., I consider it a giant step FORWARD that Zigbee saw the light and did IPv6 and will depend on IP routing to talk to the rest of the world.

---

From: "Stephen [kiwin] PALM" <[email-masked]>
Date: Thu, 2 Sep 2010 07:25:19 -0700

Unfortunately legacy exists and new technologies that do not embrace legacy
usually aren't successful.
IPv6 is a classic example... it has languished since the cost and complexity of cutover
has been too high.

regards, kiwin

---

From: Mark Baugher <[email-masked]>
Date: Thu, 2 Sep 2010 07:37:39 -0700

I agree that it would be better for the IETF to address this problem than the Zigbee Alliance.

Mark

---

From: "Stephen [kiwin] PALM" <[email-masked]>
Date: Thu, 2 Sep 2010 07:50:30 -0700

So are we back to the proposal that this group is mainly trying to find a way to make IPv6 
deployable in the real world?

---

From: David R Oran <[email-masked]>
Date: Thu, 2 Sep 2010 10:55:07 -0400

On Sep 2, 2010, at 10:50 AM, Stephen [kiwin] PALM wrote:

> So are we back to the proposal that this group is mainly trying to find a way to make IPv6 deployable in the real world?
> 
I would say that's primarily the responsibility of v6ops. 

Homegate can (and should) refine that work as needed for the particular environment of home networks, where the OOTB experience, auto-configuration, differing defaults, simpler topologies, smaller networks, need for easy automated naming, etc. are first order considerations.