Subject: [homegate] Update on BOF / WG formation

From: Ray Bellis <[email-masked]>
Date: Mon, 20 Sep 2010 16:38:19 +0000

Hopefully you will all have seen that we've been given a BOF slot at IETF79 based on the current charter text.  However this slot is _provisional_ and is in serious jeopardy.

At IESG and IAB review serious concerns were raised about the wide scope of the proposed group, and it's potential to overlap with other WGs.  Specifically, the message we received on Friday from  the IESG and IAB is that Homenet should _only_ produce BCPs for implementation of _existing_ IETF protocols, at least for now.  Architecture and Framework documents or any protocol development have been specifically ruled out of scope.

Mark and I have been exchanging e-mails over the weekend with the ADs to understand the proposed restrictions under which they require us to operate, and to see how the charter might have to change, but time is short.  Our view is that this discussion needs to move to the list.

David Harrington is about to send to the list a copy of the e-mail we received last Friday, explaining the IESG and IAB view in more detail.

We've been given until 30th September to produce a charter which is acceptable to the IESG and IAB.  If we cannot reach consensus on that then the BOF session will almost certainly be cancelled.

Ray and Mark

---

From: Mark Townsley <[email-masked]>
Date: Fri, 24 Sep 2010 12:53:17 +0200

Good day everyone.

As I have seen very little response to David, I presume everyone is
busy, confused, or is suffering from a case of "Too Long; Didn't Read."

This is a summary of what the IESG and IAB is saying, as I understand it:

Homenet might be allowed to exist, but only if it agrees now to not
develop any home networking architecture documents, not perform any
protocol gap analysis, not extend any protocols, nor recommend the
extension of any protocols.

There is a provision that the above can still happen in the IETF,
but only outside of Homenet, just as anyone could do today via
individual drafts, presentation to other WGs, etc. I don't know how to
parse this other than the potential Homenet group being the one place
where we would actively avoid doing a large chunk of Home Networking work.

In short, what is left are feature BCPs directed at vendors.

My personal view is that this is directing the group towards maximum
overlap with the existing forums and standards bodies in this area
(including IETF's on v6ops*), and not the direction Ray and I wanted to
try and lead the group based on the feedback we were hearing from you.

I think the question on the table now is whether it is worthwhile to
charter homenet for just this type of work or not. I tend to think the
answer to that is no, but I want to hear from the list first.

- Mark

* "BCP Work" for IPv6 home networking is covered within the newly
proposed v6ops charter:

ftp://ftpeng.cisco.com/fred/v6ops/v6ops-new-charter-00.txt

"4. Publish Informational or BCP RFCs that identify and analyze
solutions for deploying IPv6 within common network environments,
such as ISP Networks, Enterprise Networks, Unmanaged Networks
(Home/Small Office), and Cellular Networks."

---

From: Ray Bellis <[email-masked]>
Date: Fri, 24 Sep 2010 11:30:30 +0000

> answer to that is no, but I want to hear from the list first.

For the avoidance of doubt, that is my position too.

Ray

---

From: "Stephen [kiwin] PALM" <[email-masked]>
Date: Fri, 24 Sep 2010 07:42:26 -0700

I also had questioned some of the aims of the proposed group when other groups
were doing most, if not all, of the same things (albeit wearing different hats)

On 9/24/2010 4:30 AM, Ray Bellis wrote:
> _______________________________________________
> homegate mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/homegate
>

-- 
Stephen [kiwin] Palm   Ph.D.                          E:  [email-masked]
Senior Technical Director                             T: +1-949-926-PALM
Broadcom Broadband Communications Group               F: +1-949-926-7256
Irvine, California                               W: http://www.kiwin.com
Secondary email accounts:  [email-masked]  [email-masked]
[email-masked]  [email-masked]  [email-masked]  [email-masked]

---

From: Joe Touch <[email-masked]>
Date: Fri, 24 Sep 2010 08:07:12 -0700

FWIW, I view the first steps here along the lines of PILC, i.e., 
document best practices using existing protocols.

If that process hints that there are potential gaps, then I would expect 
we would/could be rechartered to determine the gaps, and indicate where 
and how they would be best addressed.

If there are gaps and no other WG is more appropriate to do the work, or 
if it needs to be coordinated, then we could try to recharter for that task.

I do agree with the current approach, though - not to jump in assuming 
this is a new architectural component, or that it requires new 
protocols, until we understand what's really missing first.

Joe

---

From: Jaime Fink <[email-masked]>
Date: Fri, 24 Sep 2010 08:46:57 -0700

I concur, I have a hard time understanding given this scope how it could differentiate versus existing work by other WGs, as well as other existing standards bodies focused on this area.  It feels like it would end up with a lot of very scope limited patchwork efforts that will be difficult for vendors to follow.

I certainly would continue to urge participation in the IPv6 BCP work, as well as for those interested continuing to support Broadband Forum and HGI efforts which are a bit more comprehensive.

Jaime Fink
Chief Technology Officer | +1.415.692.1776
2Wire | 1704 Automation Parkway, San Jose, CA 95131 USA

2Wire, Inc. Company Confidential.  The information contained in this message may be privileged and/or confidential.  If the reader of this message is not the intended recipient, or an employee or agent responsible for delivering this message to the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited.  If you have received this communication in error, please notify us immediately by replying to the message and deleting it from your computer.

On Sep 24, 2010, at 7:42 AM, Stephen [kiwin] PALM wrote:

Ray

_______________________________________________
homegate mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/homegate

--
Stephen [kiwin] Palm   Ph.D.                          E:  [email-masked]<mailto:[email-masked]>
Senior Technical Director                             T: +1-949-926-PALM
Broadcom Broadband Communications Group               F: +1-949-926-7256
Irvine, California                               W: http://www.kiwin.com
Secondary email accounts:  [email-masked]<mailto:[email-masked]>  [email-masked]<mailto:[email-masked]>
[email-masked]<mailto:[email-masked]>  [email-masked]<mailto:[email-masked]>  [email-masked]<mailto:[email-masked]>  [email-masked]<mailto:[email-masked]>

_______________________________________________
homegate mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/homegate

---

From: Mark Townsley <[email-masked]>
Date: Sat, 25 Sep 2010 15:03:03 +0200

> protocols, until we understand what's really missing first.

What "current approach" do you agree with?

For example, the message from David included specifically that no
"protocol gap analysis" would be permitted within the WG, so I am
assuming you don't mean the approach laid out in that email.

- Mark

---

From: Mark Baugher <[email-masked]>
Date: Sat, 25 Sep 2010 11:09:42 -0700

I like Joe Touch's general approach.

I don't see where the IETF has any experience in producing standards for home and other small, private networks - except for mDNS, which has taken an absurdly long amount of time and is surely going to be out of date by the time it is an RFC.  Another challenge is that usability issues are a major concern in home and SOHO networks - also not a forte of the IETF to date AFAICT.  

I support doing work on home-network routing and related charter items in the IETF, but it seems prudent to start small and less ambitious for some of the reasons mentioned above. PILC might be an example to follow.

I do get your point that it is not possible to do BCPs without having done requirements that take into account home network applications, services, protocols, topologies, owners and users.    

Mark

---

From: Fred Baker <[email-masked]>
Date: Sat, 25 Sep 2010 13:41:19 -0700

On Sep 24, 2010, at 3:53 AM, Mark Townsley wrote:
>  [snip]

FYI, that paragraph is unchanged from the previous charter.

---

From: "Kirksey, Heather R (Heather)" <[email-masked]>
Date: Mon, 27 Sep 2010 04:37:25 -0500

Mark et al,

Apologies as I was in the "busy" category travelling in Asia last week.

I also was rather disappointed at the caveats to the BoF/chartering exercise.  Rather than reducing the possibility of overlap with efforts such as BBF TR-124 (as well as HGI residential profiles), it seems that this new direction is more likely to encourage such overlap.  Additionally, some of the work that I know the operators are looking to see from the IETF (such as v6 guidance in complex topologies) seems off the table now.  

I do respect the concerns being raised around the Homenet scope being rather large. I would much rather have seen that resulting in a prioritization exercise and whittling of the topics to be addressed in the proposal from Mark and Ray than a re-orientation towards device requirements, however. 

Mark, I agree with your assessment that chartering a group for just this type of work is unlikely to be worthwhile.

Thanks,
Heather

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Mark Townsley
Sent: Friday, September 24, 2010 5:53 AM
To: [email-masked]
Subject: Re: [homegate] Update on BOF / WG formation

Good day everyone.

- Mark

---

From: Andrew Sullivan <[email-masked]>
Date: Mon, 27 Sep 2010 08:32:52 -0400

On Fri, Sep 24, 2010 at 12:53:17PM +0200, Mark Townsley wrote:
> individual drafts, presentation to other WGs, etc.

I think that was the key part to me.  I'm not actually sure I see the
value in a WG with such a constrained charter.

At the same time, I take David's (and others', presumed) point that
it's a good thing when WGs have narrow, well-defined scope and clear
deliverables.

This makes me think that the gap analysis we think is needed ought to
be undertaken now, without a WG or BoF or anything, by individuals who
are interested.  If that happens, and we end up with a document in
hand outlining what we think the problems are, that would provide the
basis for the specific and well-circumscribed remedy proposals that I
think David and the other IESG members are looking for.  Similarly, if
that _doesn't_ happen, it amounts to evidence either that the problem
is not well enough understood, or the interest is not sufficient, for
a WG to be successful.

Thoughts?

A

-- 
Andrew Sullivan
[email-masked]
Shinkuro, Inc.

---

From: Ole Troan <[email-masked]>
Date: Mon, 27 Sep 2010 15:15:48 +0200

> is not well enough understood, or the interest is not sufficient, for

I think that's a good idea.
 - let's see individual drafts, preferably with -homenet- in the filename
 - continue to use this mailing list for discussion
 - cancel the homenet BOF slot in Beijing.
 - reconsider the need for a wg at a later juncture.

cheers,
Ole

---

From: Ray Bellis <[email-masked]>
Date: Mon, 27 Sep 2010 14:53:12 +0000

> - reconsider the need for a wg at a later juncture.

Considering the feedback received, this would seem to be the best option from here.

Unless we hear strong arguments to the contrary soon, Mark and I intend to ask the IESG to remove the group’s provisional slot from the IETF79 schedule.

This will happen this evening, as today is the final scheduling cutoff.

Ray and Mark

---

From: "David Harrington" <[email-masked]>
Date: Tue, 28 Sep 2010 16:11:04 -0400

Hi,

I think Ole's proposal is a good one. 
Having drafts should help to identify just what work you want to do in
homenet.

dbh

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Ray Bellis
> Sent: Monday, September 27, 2010 10:53 AM
> To: [email-masked]
> Unless we hear strong arguments to the contrary soon, Mark 
> and I intend to ask the IESG to remove the group's 
> provisional slot from the IETF79 schedule.
>