Subject: [homenet] Homenet Architecture & Interim Meeting

From: Mark Townsley <[email-masked]>
Date: Fri, 16 Sep 2011 10:58:28 +0200

Dear Homenet,

I'm pleased to announce that Tim Chown has agreed to act as lead editor for the Homenet Architecture document. Tim is working with co-authors Jari Arkko, Jason Weil, and Ole Troan on this upcoming iteration. draft-arkko-townsley-homenet-arch will not be updated (and I will not be co-authoring the Architecture document going forward).  

Ray and I expect Tim's first version to be published very soon, and if the WG has no objection we'd like to see that identified as draft-ietf-homnet...00 by the end of the month so as to have a solid base to work with before the homenet interim meeting on October 6 and 7. Fred Baker and our Routing Area Advisor Acee Lindem are working on outlining the "routing in the home" discussion as well. Overall Architecture and Routing are two of our nearest-term deliverables for the working group, and both will be a focal point for progress during the homenet interim. 

As for the Interim meeting, please sign up here as soon as you can so that we can be sure we have enough food, drink, and space for everyone. Lunch on Thursday and Friday, a reception on Wed, and Dinner on Thursday are included for all registered attendees (thanks comcast!). 

http://www.ietf.org/registration/homenet/ietfreg.py

Thanks, and see some of you soon!

- Mark

---

From: "Howard, Lee" <[email-masked]>
Date: Mon, 19 Sep 2011 16:03:13 -0400

> Ray and I expect Tim's first version to be published very soon, and if the
> WG has no objection we'd like to see that identified as draft-ietf-homnet...00
> by the end of the month so as to have a solid base to work with before the
> homenet interim meeting on October 6 and 7.

Sorry, I'm unclear on what you're asking us not to object to.  I don't object to
naming a document whatever you want.  Or are you saying that sometime
soon, a draft will be published, and if there are no comments fast enough, it
will be adopted as a WG item?  I don't think it works that way.

Lee

This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: Don Sturek <[email-masked]>
Date: Mon, 19 Sep 2011 13:14:29 -0700

+1

I was going to respond with a similar note but Lee beat me to it.

I have never heard of a WG adopting a non-existant draft soon to be
published.....

Don

On 9/19/11 1:03 PM, "Howard, Lee" <[email-masked]> wrote:

>This E-mail and any of its attachments may contain Time Warner Cable
>proprietary information, which is privileged, confidential, or subject to
>copyright belonging to Time Warner Cable. This E-mail is intended solely
>for the use of the individual or entity to which it is addressed. If you
>are not the intended recipient of this E-mail, you are hereby notified
>that any dissemination, distribution, copying, or action taken in
>relation to the contents of and attachments to this E-mail is strictly
>prohibited and may be unlawful. If you have received this E-mail in
>error, please notify the sender immediately and permanently delete the
>original and any copy of this E-mail and any printout.
>_______________________________________________
>homenet mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/homenet

---

From: Mark Townsley <[email-masked]>
Date: Mon, 19 Sep 2011 23:01:28 +0200

> will be adopted as a WG item?  I don't think it works that way.

Procedurally, the WG can do what it wants to here, there is no official method for declaring a document a WG document. Different WGs operate in very different manners in this regard.

What I am suggesting here is that a draft should be published any moment now (Tim?), and that I want people to read it and let us know if it is an OK start for a work in progress for the WG to actively try to finish. If there are no other competing architecture documents to evaluate, I'd like to see it move towards being a WG document rather quickly (we're supposed to be finished by December). This by no means says the document is finished or even has consensus of the WG in its current state, just that it is the document the WG will try and turn into a final product. All this means is that it becomes the "working group's document" rather than "Tim, Jari, Jason and Ole's document". 

Sometimes, it's a "big deal" when a document moves to WG status. Often that's because the WG has a set of entrenched proposals or groups fighting against one another. I prefer to avoid the drama if we can, that's all.

- Mark

---

From: Tim Chown <[email-masked]>
Date: Wed, 21 Sep 2011 13:40:15 +0100

> What I am suggesting here is that a draft should be published any moment now (Tim?), and that I want people to read it and let us know if it is an OK start for a work in progress for the WG to acti…

Sounds fine.

Now that the update is out, I would just say that so long as the WG knows this is "the homenet architecture draft", it's status is not that important, except that the charter target was WG adoption by the end of this month, and we shouldn't treat those targets too lightly.

From the perspective of the interim meeting, I believe the agenda of that meeting includes slots for each of the five requirements (routing, naming, security, etc) so we should be agreeing as much as we can at the very least on the general principles we will follow for those slots, if not the architecture in full. 

Tim

---

From: Jari Arkko <[email-masked]>
Date: Wed, 21 Sep 2011 18:01:48 +0300

I guess Mark is asking for the working group to adopt the architecture document. The document has been posted by Tim today, I believe. Obviously people have to take a look before they can decide.

In any case, the file name or formal adoption is not as important as talking about the contents.

I'm one of the authors of the new document and would like to provide some background on what we put into the document. First off, the document is a further development of the one that Mark and I wrote earlier in the summer. When he and started out to write that document, our ambition was to "just specify what the architecture is" :-) But as usual, when we worked more on it and with all the discussions in Quebec and on the list, we realized how hard the subject is.

The intent of the new document is to talk about specific topics within the architecture (such as subnet size) and present the various factors that affect the topic, rather than provide a ready-made recommendation (such as using largest possible subnets). We thought that this would be useful input in preparation for our meeting, and perhaps in the meeting we can make some progress in actually selecting the direction. For now, the most important feedback on the document would be if we have covered the important topics and correctly explained the factors affecting them. I'm sure we have missed plenty, so please send contributions!

Jari

---

From: Mark Townsley <[email-masked]>
Date: Wed, 21 Sep 2011 17:17:38 +0200

On Sep 21, 2011, at 5:01 PM, Jari Arkko wrote:

> I guess Mark is asking for the working group to adopt the architecture document.

No, not yet, but I hope very soon.

> The document has been posted by Tim today, I believe. Obviously people have to take a look before they can decide.
> 

Absolutely.

> The intent of the new document is to talk about specific topics within the architecture (such as subnet size) and present the various factors that affect the topic, rather than provide a ready-made…

Don't be shy now!

- Mark

---

From: Roger Jørgensen <[email-masked]>
Date: Wed, 21 Sep 2011 23:45:53 +0200

On Wed, Sep 21, 2011 at 2:40 PM, Tim Chown <[email-masked]> wrote:
<snip>

> From the perspective of the interim meeting, I believe the agenda of that meeting includes slots for each of the five requirements (routing, naming, security, etc) so we should be agreeing as much…

The biggest problem I've run into when talking about future homenet
similar scenarios are the why part. Why will the future be so
different from today?

Minor issue and not sure if it's in the scope, however, the first
question I get from almost all that are new to IPv6 are why do we need
more than one /64, why will/should there be more than one LAN at home?
Some of them are fairly technical to.

And (maybe) another scenario, can we assume all home networks
will/should (not) communicate with each other?
The fridge with the TV or the computer, power/lights with the TV. I
can image having quite a few network setups at home and all of them
sharing the same Internet access but no communication between each
other. All computer isolated on a few LAN, one DMZ, one guest network
and then a few more dedicated to different devices that are
interconnected...

How should the be isolated from each other and how should that be
addressed? Several firewall instances on different "interfaces" on the
router? Guess scenario 3 are the closest to what I'm thinking of...

... other than that, good start to get the ball rolling :)

-- 

Roger Jorgensen           |
[email-masked]          | - IPv6 is The Key!
http://www.jorgensen.no   | [email-masked]

---

From: Daniel Park <[email-masked]>
Date: Thu, 22 Sep 2011 08:48:10 +0900

Quick question at this stage, several years back, v6ops formed several
internal-groups to develop IPv6 transition scenario, and the unmanaged
network (it meant home network) was published as RFC 3904. Are there any
relationship between this draft and that RFC efforts or reference points ?

I will be also trying to come up with more specific comments soon.

Daniel
-- 
 Soohong Daniel Park
Samsung Electronics, DMC R&D
http://www.soohongp.com, twitter:@natpt

On Wed, Sep 21, 2011 at 9:40 PM, Tim Chown <[email-masked]> wrote:

> > Procedurally, the WG can do what it wants to here, there is no official
> method for declaring a document a WG document. Different WGs operate in very
> different manners in this regard.
> >
> > What I am suggesting here is that a draft should be published any moment
> now (Tim?), and that I want people to read it and let us know if it is an OK
> start for a work in progress for the WG to actively try to finish. If there
> are no other competing architecture documents to evaluate, I'd like to see
> it move towards being a WG document rather quickly (we're supposed to be
> finished by December). This by no means says the document is finished or
> even has consensus of the WG in its current state, just that it is the
> document the WG will try and turn into a final product. All this means is
> that it becomes the "working group's document" rather than "Tim, Jari, Jason
> and Ole's document".
>
>
> Sounds fine.
>
> Now that the update is out, I would just say that so long as the WG knows
> this is "the homenet architecture draft", it's status is not that important,
> except that the charter target was WG adoption by the end of this month, and
> we shouldn't treat those targets too lightly.
>
> From the perspective of the interim meeting, I believe the agenda of that
> meeting includes slots for each of the five requirements (routing, naming,
> security, etc) so we should be agreeing as much as we can at the very least
> on the general principles we will follow for those slots, if not the
> architecture in full.
>
> Tim

---

From: Michael Richardson <[email-masked]>
Date: Wed, 21 Sep 2011 20:19:10 -0400

>>>>> "Roger" == Roger Jørgensen <[email-masked]> writes:
    Roger> Minor issue and not sure if it's in the scope, however, the
    Roger> first question I get from almost all that are new to IPv6 are
    Roger> why do we need more than one /64, why will/should there be
    Roger> more than one LAN at home?  Some of them are fairly technical
    Roger> to.

There already is more than one layer-2 at home. It's just that they are
connected together (poorly, and unidirectionally) by NAPT.  Sometimes
the NAPT is intentional, but most of the time it is not.

    Roger> And (maybe) another scenario, can we assume all home networks
    Roger> will/should (not) communicate with each other?  The fridge
    Roger> with the TV or the computer, power/lights with the TV. I can

If we start with an architecture that assumes it is possible for all
networks to communicate, then it is *far easier* to then write policies
to prevent unwanted interactions, once we have a way to name the end
points in question.

-- 
]       He who is tired of Weird Al is tired of life!           |  firewalls  [
]   Michael Richardson, Sandelman Software Works, Ottawa, ON    |net architect[
] [email-masked] http://www.sandelman.ottawa.on.ca/ |device driver[
   Kyoto Plus: watch the video <http://www.youtube.com/watch?v=kzx1ycLXQSE>
	               then sign the petition.

---

From: Roger Jørgensen <[email-masked]>
Date: Thu, 22 Sep 2011 07:43:22 +0200

<snip>
> to prevent unwanted interactions, once we have a way to name the end

Make perfect sense in my head yes :-)

-- 

Roger Jorgensen           |

---

From: Roger Jørgensen <[email-masked]>
Date: Thu, 22 Sep 2011 07:46:19 +0200

correcting myself after pressing enter a bit too fast...

> Make perfect sense in my head yes :-)

 Make sense to do it in that order yes:)

-- 

Roger Jorgensen           |

---

From: Mark Townsley <[email-masked]>
Date: Thu, 22 Sep 2011 08:39:00 +0200

On Sep 22, 2011, at 1:48 AM, Daniel Park wrote:

> Quick question at this stage, several years back, v6ops formed several internal-groups to develop IPv6 transition scenario, and the unmanaged network (it meant home network) was published as RFC 3904. Are there any relationship between this draft and that RFC efforts or reference points ?

There is some good background in RFC 3904, but it is admittedly incomplete (see 4.1.3, 4.3.4...), goes a bit beyond our scope in some areas, and not far enough in others.

Breaking that down, RFC 3904 covers 4 cases described in the intro:

      A) a gateway which does not provide IPv6 at all;
      B) a dual-stack gateway connected to a dual-stack ISP;
      C) a dual-stack gateway connected to an IPv4-only ISP; and
      D) a gateway connected to an IPv6-only ISP.

In homenet, we are focused on case B and D. Specifically, that means we are not going out of our way to ensure that the home network works well with Teredo, 6to4, and other transition mechanisms detailed in the RFC 3904. Also, within B, we are charted to make IPv6 work without breaking IPv4 in the process, but I think we can avoid defining ways of making sure IPv6 only hosts can talk with IPv4 only hosts (that's behave's job anyway). 

While in some cases the document goes in places we are not, in other areas it doesn't go far enough. For example, Section 4 talks about meeting Case B (and by reference later, D) requirements. One method described is extending a subnet to span multiple links via ND Proxy. In contrast to this,  one of the primary goals of the homenet charter is to provide an agreed upon and simple to use method of routing and prefix configuration among multiple subnets. If we are successful (and ISPs avoid delivering service with a single /64 as well!) then we may not need the ND proxy type of function at all.

- Mark

---

From: Henk Uijterwaal <[email-masked]>
Date: Thu, 22 Sep 2011 09:48:09 +0200

> will/should (not) communicate with each other?

I think we should assume that they can and will communicate with
each other, but that there should be ways to block access from one
to another if the user wants to do this (and understand what he
is doing).

> The fridge with the TV or the computer, power/lights with the TV.

I think these are cases were a connection is useful: the fridge sends
data on what is in stock to your PC, you fill out your online grocery
list.  When you switch on the TV, you also dim the lights for better
visibility.  And maybe somebody will finally build my favorite
non-existing gadget: a remote control app for my smartphone, so
that I can control TV, stereo, DVD, lights, phone, and whatever else
with one device, rather than have 6 remote controls next to me.

Henk

-- 
------------------------------------------------------------------------------
Henk Uijterwaal                           Email: henk(at)uijterwaal.nl
                                          http://www.uijterwaal.nl
                                          Phone: +31.6.55861746
------------------------------------------------------------------------------

There appears to have been a collective retreat from reality that day.
                                 (John Glanfield, on an engineering project)