Subject: [homenet] homenet ospfv3 implementation

From: Jari Arkko <[email-masked]>
Date: Mon, 23 Apr 2012 13:39:16 +0300

FYI. I've made some progress with my implementation. I held a presentation on this at RIPE this week:

http://thingsonip.blogspot.com/2012/04/home-networks-by-magic.html

There are a couple of relevant points to raise -- implementation and usage experience always brings up things that one did not think of when writing specifications. Here are some high-level ones:

It is surprising how many connections an autoconfiguration software (running inside OSPFv3 in this case) has to the rest of the system. Sources of prefixes. Users of prefixes. Etc.

There may be a need for system APIs that allow various system components to work together with the autoconfiguration software.

The implementation effort made me think about DNS in a completely different way than what we had been discussing in the WG before. The WG had focused on name resolution Bonjour-style within the entire home vs. a single link. While that is useful, name resolution for the Internet seemed an even more important topic, and getting that autoconfigured is not trivial (unless you assume IPv4 name server use in a dual stack setting). I still don't know what exactly the right approach is, but I think we need to pay more attention to this than we have so far. Or at least I have.

One of aspect of this is to ensure DNS discovery works.

IPv6-only and NAT64-networks require special care. If you have a NAT64 device, behind that device you want to use its DNS64 but elsewhere you do not.

Timing of various events needs thought. If you come up, how long do you wait until you generate ULA space if you don't hear from others or if the others have no global space either?

Jari

---

From: Ray Bellis <[email-masked]>
Date: Mon, 23 Apr 2012 10:48:56 +0000

On 23 Apr 2012, at 11:39, Jari Arkko wrote:

Video of the presentation has also just been put online:

<https://ripe64.ripe.net/archives/video/856/>

Ray