Subject: Re: [homenet] Border Router Discovery Protocol

From: Tim Chown <[email-masked]>
Date: Thu, 11 Oct 2012 12:24:06 +0100

On 26 Sep 2012, at 15:35, RJ Atkinson <[email-masked]> wrote:

> On Tuesday, 25 September 2012, Teco Boot wrote:
>> It might be the right moment to come up with my earlier work 
>> on border router discovery. I have to update to incorporate 
>> the homenet-arch, and remove details for MANET/Autoconf. 
>> 
>> Intro & highlights:
>>  http://tools.ietf.org/id/draft-boot-brdp-framework-00.txt
>> 
>> If there is interest, I'll resubmit for Homenet. 
>> 
>> Teco
> 
> Yes, please.  
> 
> Please don't remove the details for MANET/AutoConf,
> but perhaps put those details into their own section(s). 
> 
> The operational reality is that the IETF needs more tools
> for automatic configuration, zero or minimal configuration,
> site resilience in the face of upstream link changes,
> and also site renumbering.
> 
> A well designed tool for border router discovery ought
> to work well in MANET environments, AutoConf environments,
> ZeroConf environments, HomeNet environments, and probably
> also for renumbering events.  I think BRDP is very close
> to what is needed.  I would not want to lose generality
> of solution merely because it is being discussed in one
> particular IETF WG at the moment.
> 
> Cheers,
> 
> Ran
> 
> PS:  I'd also be quite happy to see BRDP go out as an
>    Experimental status RFC initially, whether through
>    the IETF track, IRTF Routing RG, or the ISE-track.
>    BRDP seems very useful and useful protocols tend
>    to self-deploy into environments where they are useful.

We also have Eric Kline's draft in similar space: draft-kline-default-perimeter-00.

Both can hopefully contribute to the solution for this problem space in homenet.

Tim

---

From: Ole Trøan <[email-masked]>
Date: Thu, 11 Oct 2012 13:50:24 +0200

> Both can hopefully contribute to the solution for this problem space in homenet.

I have read the BRDP framework document, but I failed to understand how BRDP solves the problem of how a border is discovered.
it explains well how to act when a border has been established, but I don't understand how BRDP helps getting to that point. pointers?

cheers,
Ole

---

From: Teco Boot <[email-masked]>
Date: Thu, 11 Oct 2012 19:03:40 +0200

> it explains well how to act when a border has been established, but I don't understand how BRDP helps getting to that point. pointers?

I merge the old BRDP drafts into one, to be submitted soon. Now I have to tweak a bit for Homenet. I do this in slack time, I hope to do some of it before Atlanta.

In a MANET and in general, uplink interfaces (wired, cellular, satcom) are distinguished easily from MANET interfaces. In homenet and ethernet, we could have fixed assigned and color marked interfaces, but this is not our target. So here we need an additional tool. 

After an interface is discovered as an uplink interface, and it has received a prefix (e.g. DHCP-PD), then BRDP propagates this information downstream in the edge network. This could be used for perimeter discovery also. If there is no border router upstream, ask for a prefix with DHCP-PD. If it has assigned such successfully, start acting as BRDP. Other checks would be useful (draft-kline-default-perimeter).

I'll add this in the to be submitted homenet-brdp.

Teco

> 
> cheers,
> Ole
> 
> _______________________________________________
> homenet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/homenet

---

From: Mark Townsley <[email-masked]>
Date: Tue, 16 Oct 2012 10:56:28 +0200

> I merge the old BRDP drafts into one, to be submitted soon. Now I have to tweak a bit for Homenet. I do this in slack time, I hope to do some of it before Atlanta.

If you would like to present this in Atlanta, it would be nice to have a homenet targeted document for people to review. 

> After an interface is discovered as an uplink interface, and it has received a prefix (e.g. DHCP-PD), then

> BRDP propagates this information downstream in the edge network.

In this way, BRDP sounds more like what is being done in draft-arkko-homenet-prefix-assignment.

> This could be used for perimeter discovery also. If there is no border router upstream, ask for a prefix with DHCP-PD. If it has assigned such successfully, start acting as BRDP. Other checks would be useful (draft-kline-default-perimeter).

Right, I don't see anything inconsistent here vs. what draft-kline has been talking about.... Just one more heuristic. 

- Mark

---

From: Teco Boot <[email-masked]>
Date: Tue, 16 Oct 2012 11:34:01 +0200

> If you would like to present this in Atlanta, it would be nice to have a homenet targeted document for people to review.
Yes.
I the few cycles I had, I pushed a single Homenet document. There is more rework needed, any input/help/other support is welcome. 
http://www.ietf.org/internet-drafts/draft-boot-homenet-brdp-00.txt
I'm not sure I can get an -01 out before next deadline.

Teco

---

From: Teco Boot <[email-masked]>
Date: Tue, 16 Oct 2012 16:56:06 +0200

> In this way, BRDP sounds more like what is being done in draft-arkko-homenet-prefix-assignment.
Yes. The BRDP info could be distributed with the routing protocol. I chose for RA because it is IGP agnostic and info is delivered to hosts also. Hosts can benefit from knowledge about the multi-homed network. For MPTCP, this is essential.

I moved BRDP towards centralized prefix management with DHCP-PD, where the CPE = border router = DHCP server that manages the to be assigned /64 prefixes. This would remove the non-volatile requirement from non-CPE routers. And would provide an information base for a (web-based) management tool. 

The boot-homenet-brdp draft includes the mechanism for SA based routing. Can be used with arkko-homenet-prefix-assignment also.

> Right, I don't see anything inconsistent here vs. what draft-kline has been talking about.... Just one more heuristic. 

Added in my draft, with pointer to kline-default-perimeter.

Teco