Subject: [homenet] Interop for OSPF-based homenet solution at IETF 85

From: Mark Townsley <[email-masked]>
Date: Tue, 30 Oct 2012 18:16:11 +0100

Group,

When we created the homenet WG, we identified that open source code was a critical component in the consumer home router marketplace. As such, I thought I'd let the group know that there will be open source coders in our midst next week carrying around some OpenWRT routers and implementations of homenet-targeted drafts. Their work is based on the work Jari has been leading. Jari is one of the coders, the other is Markus Stenberg, whose company is being supported via a Cisco "Technology Fund" project that I was a co-sponsor of within Cisco. Two compilier-wielding Finns.  

The implementations are based on these drafts:

http://tools.ietf.org/html/draft-arkko-homenet-prefix-assignment-02
http://www.ietf.org/id/draft-acee-ospf-ospfv3-autoconfig-03.txt

The IPSO folks have been nice enough to offer them a corner of a table to work on, and I suspect that's where you will be able to find them during the week when they are not doing other things. They have also been generously offered a corner of a table at bits-n-bites in case you miss them during the week and want to look at what they have over food and beer. 

I've been cc'd on some of the emails between Jari and Markus, and believe they will have a presentation ready showing what they hope to have working, not working, etc. by the time we meet next week if not before. My understanding is that Jari and Markus both consider their work "Experimental" at this stage, and the aim is simply to learn as much as possible this week. Assuming they get things up and running, please come by with every kind of IPv6-enabled device you can think of to plug into their network. Try your best to break it, and capture what happened when the breakage occurred. If you're really bored, hack up your own implementation and plug in ;-)

Organization of this has all been very last minute and informal thus far. For future IETFs, the ADs have offered to work with homenet to have our own space rather than having to camp out with others. So - if you have some running code, let us know and we'll make sure we have some place for you to work together. 

See "y'all" in Georgia next week,

- Mark

---

From: Simon Kelley <[email-masked]>
Date: Tue, 30 Oct 2012 21:18:41 +0000

On 30/10/12 17:16, Mark Townsley wrote:
>
> Group,
>
> When we created the homenet WG, we identified that open source code
> was a critical component in the consumer home router marketplace. As
> such, I thought I'd let the group know that there will be open source
> coders in our midst next week ........

This may be an opportune moment to note that I too will be attending 
IETF, thanks to the tireless efforts and sponsorship of Dave Taht. I'm 
the main author and developer of dnsmasq, which is the open-source  DNS 
forwarder and DHCP server component used in many home routers.

Recent releases of dnsmasq have added DHCPv6 support, and future 
releases are slated to add DNSSEC validation. I'm keen to talk to anyone 
who has ideas and requests for further work on dnsmasq which will 
advance the homenet cause, and to anyone who can help provide resources 
to support that work.

Cheers,

Simon.