Subject: Re: [homenet] [v6ops] new draft: draft-shishio-v6ops-dpvt

From: Owen DeLong <[email-masked]>
Date: Wed, 27 Feb 2013 11:57:14 -0800

I'm not on the home net list and I need another list like I need a hole in the head.

However, I think section 3.4.1 is reasonably well written. I think it would be good if
the following were added:

ISPs are strongly encouraged to issue /48s to residential customers whenever requested or hinted by the home gateway.

Also, it appears that section 3.4.1 assumes a custom will change ISPs by disconnecting provider A and then connecting provider B. It does not appear to make a provision for connecting provider B and having a period of transition with dual prefixes. This possibility should be considered and addressed, IMHO.

Owen

On Feb 27, 2013, at 5:56 AM, Tim Chown <[email-masked]> wrote:

> 
> On 26 Feb 2013, at 14:07, "Brzozowski, John" <[email-masked]> wrote:
> 
>> [jjmb] incorrect I have both, just stating that I have both.  Apologies if
>> I was not clear.  I also have a good # of home routers actively using IPv6
>> enabled broadband today, ~3%.
> 
> Congratulations, btw. That must be a large number when converted to real customers :)
> 
> The homenet architecture assumes a CPE rather than a single host. It discusses ISP allocations in section 3.4.1 of http://tools.ietf.org/html/draft-ietf-homenet-arch-07.  As that text is in WGLC, any comments on that section would be welcome (preferably on the homenet list).
> 
> Tim
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: Tim Chown <[email-masked]>
Date: Wed, 27 Feb 2013 20:20:19 +0000

> I'm not on the home net list and I need another list like I need a hole in the head.

I know the feeling :)

> Also, it appears that section 3.4.1 assumes a custom will change ISPs by disconnecting provider A and then connecting provider B. It does not appear to make a provision for connecting provider B an…

Thanks for the comments. I've added that into the WGLC feedback list.

Tim

> homenet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/homenet

---

From: "Brzozowski, John" <[email-masked]>
Date: Fri, 1 Mar 2013 01:45:46 +0000

Tim,

Per your request below here are some comments pertaining to the section
you mention below.

* The section seems to hint at two extremes stable on one end and very
dynamic i.e. at each CER reboot.  I think it is important to note that
there is middle ground here and that providers typically have good reason
for requiring prefix changes, largely related to network capacity
management.  It is not clear to me if this need to be called out in the
text, however, I thought you should know.
* Agreed regarding /64 subnet lengths
* This section does not differentiate between a residential service and a
commercial or SOHO service.  Is this outlined elsewhere in the draft?
Does it need to be?
* Note - some devices today can only utilize a /64 and nothing more these
would not break.
* No NPTv6 please
* ULAs support could be introduced at a later date
* Agreed regarding bridging avoidance
* How is "relatively stable prefix" defined?
* Good text regarding PIA
* Regarding renumbering also note that operators take precautions to
ensure this is seamless as well including lease time lowering in advance
of the renumbering event.  We have been doing this for years.
* Forced renumbering for privacy sounds unfortunate but based on various
emails I have seen lately this seems to be something that must be
supported.
* Agreed that service discovery is essential

I hope these comments are useful, I recognize I was not overly verbose.  I
hope this is a feature not a bug.  Please let know if you wish to discuss
further.

John
-----Original Message-----
From: Tim Chown <[email-masked]>
Date: Wednesday, February 27, 2013 5:56 AM
To: "[email-masked]" <[email-masked]>
Subject: Re: [v6ops] new draft: draft-shishio-v6ops-dpvt

>
>On 26 Feb 2013, at 14:07, "Brzozowski, John"
><[email-masked]> wrote:
>
>
>The homenet architecture assumes a CPE rather than a single host. It
>discusses ISP allocations in section 3.4.1 of
>http://tools.ietf.org/html/draft-ietf-homenet-arch-07.  As that text
> is in WGLC, any comments on that section would be welcome (preferably on
>the homenet list).
>
>
>Tim