Subject: Re: [homenet] Next steps for draft-behringer-homenet-trust-bootstrap?

From: "Michael Behringer (mbehring)" <[email-masked]>
Date: Tue, 5 Mar 2013 17:52:40 +0000

> -----Original Message-----
> From: Mark Townsley [mailto:[email-masked]]
> Sent: 22 February 2013 18:25
> To: Michael Behringer (mbehring)
> Cc: [email-masked]; draft-behringer-homenet-trust-
> [email-masked]
> Subject: Re: [homenet] Next steps for draft-behringer-homenet-trust-
> bootstrap?
> 
> 
> On Feb 13, 2013, at 3:55 PM, Michael Behringer (mbehring) wrote:
> 
> > Homenet WG,
> >
> > In Atlanta we presented draft-behringer-homenet-trust-bootstrap-00,
> which explains (high level) how trust could be bootstrapped in a homenet
> environment.
> >
> > The feedback we got during the meeting was mostly positive; we would
> like to understand the next steps for this draft? We believe this is a useful
> approach, and would like to have the document accepted as a WG doc at
> some point.
> >
> > What is the next step?
> 
> Ray and I are open to more WG discussion on this given the positive
> reception at the last meeting, but I'd rather see more discussion on the list
> beforehand. Where do *you* see this model fitting in?

Mark, thanks for the response, and sorry for my delay; I was co-organising an event last week and didn't have the time to follow up. 

In the limited understanding I have (not following as closely as I should...)  I think trust in the homenet is still an open issue. It is usually referred to as "border discovery", but I think it goes beyond that. 

There needs to be a way to accept/reject a device into a particular homenet. You can do this with pressing buttons at the right time in the right place. You can configure that manually. After that, there needs to be some reasonably secure way for any device in the homenet to know whether another device is part of this homenet or not. 

I think there is a need for a reasonably secure way to
- identify a new device 
- accept it onto the homenet domain or not
- make that device talk to the existing devices, in a reasonably secure way. Or, conversely, make sure that devices don't put trust in devices that shouldn't be in the domain. 

Our draft shows a way to do that in a relatively simple and secure way. I believe this is a fundamental requirement in a homenet; there are other ways to more or less achieve this goal - that needs to be discussed. But we should have the discussion. 

Michael

> 
> - Mark
> 
> > Michael
> > _______________________________________________
> > homenet mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/homenet

---

From: Tim Chown <[email-masked]>
Date: Wed, 13 Mar 2013 20:35:58 +0000

> Our draft shows a way to do that in a relatively simple and secure way. I believe this is a fundamental requirement in a homenet; there are other ways to more or less achieve this goal - that needs…

If you have text to propose for the arch text, please do so.

Tim

---

From: "Michael Behringer (mbehring)" <[email-masked]>
Date: Wed, 13 Mar 2013 23:46:39 +0000

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Tim Chown
> Sent: 13 March 2013 16:36
> To: [email-masked] Group
> > Our draft shows a way to do that in a relatively simple and secure way. I
> believe this is a fundamental requirement in a homenet; there are other
> ways to more or less achieve this goal - that needs to be discussed. But we
> should have the discussion.
> 

OK, I'll write something up. 
Michael