Subject: Re: [homenet] New Version Notification for draft-grundemann-homenet-hipnet-01.txt

From: Tim Chown <[email-masked]>
Date: Wed, 13 Mar 2013 22:09:10 +0000

On 26 Feb 2013, at 15:46, Chris Grundemann <[email-masked]> wrote:

> Hail Homenet,
> 
> FYI - We have updated our "HIPnet" draft. This -01 is a minor update,
> which includes almost exclusively editorial fixes. We have taken note of
> all feedback received thus far, both on and off list, and will work to
> incorporate that feedback in further revisions as it makes sense.

Hi Chris,

It's good to see a 'lightweight' alternative being put forward, with a demo here.

From the arch text point of view I agree it's largely compatible with -07, assuming the text about 'routing protocol' were rewritten to 'routing functionality', since you install routes automatically up/down.

The two points that are partly met are the prefix utilisation efficiency (since it's hierarchical DHCP-PD) and whether arbitrary topologies are supported (given the use of ND in a 'spanning tree' like approach). But it does tick a lot of boxes, and uses existing protocols.  Topics such as realms and borders, and naming/SD are orthogonal to how the prefixes and routing is configured.

The interesting question for the WG is how such an approach could interoperate with (say) a homenet solution using zOSPF. Are the homenet solutions 'all or nothing', or is there something we could do now to improve the chances of future interoperability if hipnet is deployed now?

Tim

---

From: Acee Lindem <[email-masked]>
Date: Fri, 15 Mar 2013 22:14:08 +0000

I think the draft is a bit optimistic with respect to its claim of satisfying homenet requirements. For example, there is a very limited set of multi-homing topologies where the internal routers don't find themselves asking, "Which way is up?". Additionally, without source routing, I don't see how ingress filtering can be avoided. Perhaps multi-homing should be removed. 
Thanks,
Acee 

On Mar 13, 2013, at 6:09 PM, Tim Chown wrote:

> _______________________________________________
> homenet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/homenet