Subject: [homenet] Working Group draft adoptions

From: Ray Bellis <[email-masked]>
Date: Wed, 3 Sep 2014 13:38:16 +0000

This email commences a two week period for comments relating to the adoption of the following drafts by the HOMENET Working Group, as promised during our WG session in Toronto:

  draft-pfister-homenet-prefix-assignment<http://datatracker.ietf.org/doc/draft-pfister-homenet-prefix-assignment/>
  draft-mglt-homenet-front-end-naming-delegation<http://datatracker.ietf.org/doc/draft-mglt-homenet-front-end-naming-delegation/>
  draft-mglt-homenet-naming-architecture-dhc-options<http://datatracker.ietf.org/doc/draft-mglt-homenet-naming-architecture-dhc-options/>

If you have any comments please reply to this message, but please do not mix up comments on the PA draft and the two Naming drafts in a single reply.

thanks,

Ray and Mark

---

From: Thomas Clausen <[email-masked]>
Date: Wed, 3 Sep 2014 15:52:13 +0200

Ray, Mark, all,

On Sep 3, 2014, at 15:38, Ray Bellis <[email-masked]> wrote:

>   draft-pfister-homenet-prefix-assignment

I have read the I-D above, as part of hacking together some prototype code.

The draft has a couple of rough edges for the WG to polish, but otherwise seems sound both in presentation and in content.

Thus, consider this a hum in favor of adoption, based on having actually implemented from the spec.

---

From: Markus Stenberg <[email-masked]>
Date: Wed, 3 Sep 2014 17:12:04 +0300

+1 on the PA draft. 

While it could use some editing, having implemented historic variant of it (hello, draft-arkko-...), I consider it mandatory part of the homenet solution and I have yet to see any real alternatives to it.

Cheers,

-Markus

Sent from my preciouss, aka iPad ;)

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Wed, 3 Sep 2014 16:38:37 +0000

Support the prefix assignment draft. I think it would be instructive to include the TLVs from the prior draft as a conceptual implementation. 
Thanks,
Acee 
On Sep 3, 2014, at 10:12 AM, Markus Stenberg <[email-masked]> wrote:

> _______________________________________________
> homenet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/homenet

---

From: Steven Barth <[email-masked]>
Date: Wed, 03 Sep 2014 18:55:26 +0200

+1 for adopting PA draft.

> Support the prefix assignment draft. I think it would be instructive to include the TLVs from the prior draft as a conceptual implementation.
I think it might make sense to merge the PA-TLVs from the HNCP main 
draft to the PA-draft instead.
https://tools.ietf.org/html/draft-ietf-homenet-hncp-02#page-14 paragraph 
6 minus the border discovery part.

Cheers,

Steven

---

From: Daniel Migault <[email-masked]>
Date: Tue, 9 Sep 2014 12:04:31 +0200

As an author of the naming drafts, I would like these drafts to be adopted
as WG document for the following reasons:
    - the architecture document describes how to outsource DNS zone outside
the home network to any third party by re-using only existing standardized
protocols.
    - the DHCP options ease the configuration of outsourcing DNS
architecture up to zero-config.

Best Regards,
Daniel

On Wed, Sep 3, 2014 at 3:38 PM, Ray Bellis <[email-masked]>
wrote:

>  This email commences a two week period for comments relating to the
> adoption of the following drafts by the HOMENET Working Group, as promised
> during our WG session in Toronto:
>
> <http://datatracker.ietf.org/doc/draft-pfister-homenet-prefix-assignment/>
>   draft-mglt-homenet-front-end-naming-delegation
> <http://datatracker.ietf.org/doc/draft-mglt-homenet-front-end-naming-delegation/>
>   draft-mglt-homenet-naming-architecture-dhc-options
> <http://datatracker.ietf.org/doc/draft-mglt-homenet-naming-architecture-dhc-options/>
>
>  If you have any comments please reply to this message, but please do not
> mix up comments on the PA draft and the two Naming drafts in a single reply.
>
>  thanks,
>
>  Ray and Mark
>
>

-- 
Daniel Migault
Orange Labs -- Security
+33 6 70 72 69 58

---

From: <[email-masked]>
Date: Tue, 9 Sep 2014 12:34:44 +0000

Dear chairs,

I support the adoption of draft-pfister-homenet-prefix-assignment and draft-mglt-homenet-front-end-naming-delegation.

FWIW, below some comments about these two documents:
(1)
PA draft could be enhanced if it considers a mix model (in addition of the completely distributed model) that would let the border router(s) enforce some (centralized) policies (including authenticating and authorizing which nodes are allowed to be grafted in network) and also control which prefixes to be assigned to neighbors. My understanding is that the length of the pool to be delegated to upstream nodes may not be known in advance (because it depends on the radius of that network branch) in the distributed model. Having a mode that allows for a control of the addressing resources would be efficient compared to a completely distributed model that may lead to a waste of resources. The impact of the distributed model on the stability of the network should also be further assessed in the draft.

A side effect of the mix model would be the ability of that border router(s) to discover the topology of the home network (and other information). Discovered information can be used to drive policies that would be required by an administrator or user guidelines (e.g., limit the connectivity of a given node, trigger forwarding decision to avoid the traffic be passed through a given node, etc.).

(2)
dns outsourcing is interesting for managed CPEs in particular. Offloading the CPE is a not only a valid technical argument but, more important, it allows network operators to do some business (similar to offloading a SIP Proxy service to the network side). I do think this document should be merged with the dhc options.

Cheers,
Med

De : homenet [mailto:[email-masked]] De la part de Ray Bellis
Envoyé : mercredi 3 septembre 2014 15:38
À : [email-masked] Group
Objet : [homenet] Working Group draft adoptions

thanks,

Ray and Mark

---

From: Daniel Migault <[email-masked]>
Date: Wed, 10 Sep 2014 10:07:42 +0200

Hi,

Please see my responses in line.

On Tue, Sep 9, 2014 at 6:13 PM, Juliusz Chroboczek <
[email-masked]> wrote:

> Hi Daniel,
> As I mentioned previously, I'd be more comfortable if you could convince
> us that the proposed protocol supports separating the IHAS from the CPE,
> and explain how it works when there are multiple CPEs on a single homenet.
>
>
We have taken your comments into account.  Slide 6 of the presentation [1]
during the Toronto meeting states that we will clarify this in the next
version of the draft. It has also been requested some clarification about
the Public Authoritative Server, that the architecture is compatible with
multiple ISPs, and privacy implications of publishing names on the
internet. They will also be part of the next version.

[1] http://www.ietf.org/proceedings/90/slides/slides-90-homenet-5.pdf

I'd also be grateful if you could provide use cases, since you stated that
> you believe that my use cases are out of scope (my mail of 5 July 2014,
> Message-ID <[email-masked]>).
>
>
Unless I misunderstand the comment, our use case is: outsourcing the
DNS service of your homenet to a dedicated infrastructure.

Working code would make everyone happier, of course.
Of course, we think the protocols are now mature enough to have it, and we
should be able to have one soon.

> In the current situation, I'm opposed to making these two into WG
> documents.
>
> -- Juliusz
>

-- 
Daniel Migault
Orange Labs -- Security
+33 6 70 72 69 58

---

From: Ray Bellis <[email-masked]>
Date: Wed, 10 Sep 2014 14:52:22 +0000

On 10 Sep 2014, at 15:48, Juliusz Chroboczek <[email-masked]> wrote:

> Perhaps it's worth delaying the discussion about promoting these to WG
> status until after you publish the next version, then?

No, we're discussing them now.

Drafts are neither expected nor required to be fully mature before WG adoption.

Ray

---

From: Ray Bellis <[email-masked]>
Date: Thu, 18 Sep 2014 15:32:07 +0000

On 3 Sep 2014, at 14:38, Ray Bellis <[email-masked]<mailto:[email-masked]>> wrote:

On the basis of responses received on and off list, the Chairs' decision is to adopt all three drafts.

Authors - please resubmit new draft-ietf-homenet-*-00 drafts which should be _unchanged_ from those already seen by the Working Group.

Please also note that your responsibility now is to represent the consensus view of the Working Group.  Substantive changes should only be made at the behest and with the blessing of the WG.

thanks,

Ray and Mark

---

From: Michael Richardson <[email-masked]>
Date: Tue, 23 Sep 2014 17:41:12 -0400

Late, but:

I have read draft-pfister-homenet-prefix-assignment.  Adopt it.
I thought I read it before, but maybe not.  It all seems familiar, but what's
with all the IPv4 stuff?  I guess we are doing an IPv4 thing, because we can,
and it's useful to be able to turn off detect that have multiple potential
DHCPv4 servers, and turn them off if we can.

I think that we should remove:
  >If the delegated prefix is too small
  >    given the size of the network, prefixes of arbitrary lengths may
  >    be used.

and stick to 64-bit for all the why-64 reasons.  Let's not talk about any
other options.    This document also seems to interoperate with (CableLabs)
HIP.

I have read previous versions of these documents, and upon looking again, I
see lots of shiny new text, and I like it all.   While there are many people
who are very scared of having home devices in DNS, and many are worried that
they will be forced somehow to do so, I don't think any such comments matter.
This is, like almost all protocols the IETF creates, optional to enable.
Please adopt these documents.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        | network architect  [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Mark Townsley <[email-masked]>
Date: Wed, 24 Sep 2014 13:19:00 +0200

Thanks for the review, late is still welcome.

As for IPv4, as you alluded to, we are chartered to develop solutions that work dual-stack where we can, as long as we are not making harmful concessions to the v6 design due to v4 consideration. 

- Mark

(Thumbtyped)

> On Sep 23, 2014, at 11:41 PM, Michael Richardson <[email-masked]> wrote:
> 
> 
> Late, but:
>