Subject: [homenet] Source Address Dependent Routing - draft-sarikaya-6man-sadr-overview-00

From: Ray Bellis <[email-masked]>
Date: Wed, 10 Sep 2014 12:42:31 +0000

I've just noticed this draft, and thought it worth bringing to the HOMENET WG's attention:

http://tools.ietf.org/html/draft-sarikaya-6man-sadr-overview-00

Ray

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Wed, 10 Sep 2014 15:19:45 +0000

On Sep 10, 2014, at 8:42 AM, Ray Bellis <[email-masked]<mailto:[email-masked]>> wrote:

I’ve heard it said over and over in HOMENET sessions that we weren’t going to put new requirements on the host stacks. Why is this draft interesting?

Thanks,
Acee

Ray

_______________________________________________
homenet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/homenet

---

From: Mikael Abrahamsson <[email-masked]>
Date: Wed, 10 Sep 2014 17:26:43 +0200 (CEST)

On Wed, 10 Sep 2014, Acee Lindem (acee) wrote:

> I’ve heard it said over and over in HOMENET sessions that we weren’t 
> going to put new requirements on the host stacks. Why is this draft 
> interesting?

HOMENET doesn't require new host stack functionality. What part of the 
draft makes you think that it does?

However, if you want to be MIF compliant, then you need new host stack 
functionality. This is however not driven by HOMENET.

-- 
Mikael Abrahamsson    email: [email-masked]

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Wed, 10 Sep 2014 15:46:55 +0000

On Sep 10, 2014, at 11:26 AM, Mikael Abrahamsson <[email-masked]> wrote:

> HOMENET doesn't require new host stack functionality. What part of the draft makes you think that it does?
> 
> However, if you want to be MIF compliant, then you need new host stack functionality. This is however not driven by HOMENET.

My point was the even if this draft is accepted by 6MAN, standardized, and even implemented some day, it doesn’t satisfy the HOMENET  multi-homed routing requirement.

---

From: Mikael Abrahamsson <[email-masked]>
Date: Wed, 10 Sep 2014 17:51:14 +0200 (CEST)

On Wed, 10 Sep 2014, Acee Lindem (acee) wrote:

> My point was the even if this draft is accepted by 6MAN, standardized, 
> and even implemented some day, it doesn’t satisfy the HOMENET 
> multi-homed routing requirement.

I don't get it. Could you please be more elaborate?

---

From: Brian Haberman <[email-masked]>
Date: Wed, 10 Sep 2014 12:43:25 -0400

> I don't get it. Could you please be more elaborate?

The 2nd paragraph of Section 4 says:

   The solution should start with the correct configuration of
   the host.  The host should be configured with the next hop addresses
   and the prefixes supported in these next hops.  This way the host
   having received many prefixes will have the correct knowledge in
   selecting the right source address and next hop when sending packets
   to remote destinations.

That sounds like new functionality on the host.  Not sure if that is
what caught Acee's attention, though.

Regards,
Brian

> [email-masked]

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Wed, 10 Sep 2014 16:53:54 +0000

> what caught Acee's attention, though.

Yes - Additionally, I agree with Mark’s statement on the HOMENET requirement and would like to go on the record as saying that I’m certainly not against correct source address selection by the host stacks ;^) 

Thanks,
Acee

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 11 Sep 2014 13:26:21 +1200

> what caught Acee's attention, though.

Regardless, it isn't specific to homenet or to MIF scenarios, so
the discussion correctly belongs in 6man, IMHO. otoh any implications
for homenet or MIF need to be detected, so I think it's perfectly
appropriate that these two WGs are made aware of the draft.

   Brian

---

From: Mikael Abrahamsson <[email-masked]>
Date: Fri, 12 Sep 2014 08:18:24 +0200 (CEST)

> Yes - Additionally, I agree with Mark’s statement on the HOMENET requirement and would like to go on the record as saying that I’m certainly not against correct source address selection by the host…

My opinion is that homenet shouldn't require new functionality in the host 
stack for it to work, but if we can present suggestions for enhancements 
in the host stack that makes things work better, and also enhance homenet 
to take advantage of enhancements in host stacks to make things work 
better, I'm all for that.

But our baseline is that a 10 year old host stack should work out of the 
box with homenet, and I don't see us changing that.

---

From: Sander Steffann <[email-masked]>
Date: Fri, 12 Sep 2014 09:27:43 +0200

> My opinion is that homenet shouldn't require new functionality in the host stack for it to work, but if we can present suggestions for enhancements in the host stack that makes things work better, and also enhance homenet to take advantage of enhancements in host stacks to make things work better, I'm all for that.
> 
> But our baseline is that a 10 year old host stack should work out of the box with homenet, and I don't see us changing that.

+1 to all of the above
Sander