Subject: Re: [homenet] Working Group draft adoptions

From: <[email-masked]>
Date: Tue, 16 Sep 2014 14:12:05 +0200

Hi,

Regarding

* draft-mglt-homenet-front-end-naming-delegation
* draft-mglt-homenet-naming-architecture-dhc-options

I think this is useful work and support its adoption.

However, I'd like to see these drafts generalized so that mechanisms to provide authorization credentials towards the DNS are not limited to only being provided via DHCP, so that the architecture could also be used within other configuration management approaches as well, e.g. via Netconf/Yang.

Thanks,

Normen Kowalewski

Deutsche Telekom AG
Group Headquarters

P.S. My apologies to the email reviewer(s), since I have needlessly clobbered your review queue with a copy of this content instead of subscribing to this list before sending it.

Re: [homenet] Working Group draft adoptions
[X]
*

From: Ray Bellis <Ray.Bellis at nominet.org.uk<mailto:[email-masked]>>
*       To: "homenet at ietf.org<mailto:[email-masked]> Group" <homenet at ietf.org<mailto:[email-masked]>>
*       Date: Wed, 3 Sep 2014 13:38:16 +0000
*       List-id: <homenet.ietf.org>
[X]
This email commences a two week period for comments relating to the adoption of the following drafts by the HOMENET Working Group, as promised during our WG session in Toronto:

  draft-pfister-homenet-prefix-assignment<http://datatracker.ietf.org/doc/draft-pfister-homenet-prefix-assignment/>
  draft-mglt-homenet-front-end-naming-delegation<http://datatracker.ietf.org/doc/draft-mglt-homenet-front-end-naming-delegation/>
  draft-mglt-homenet-naming-architecture-dhc-options<http://datatracker.ietf.org/doc/draft-mglt-homenet-naming-architecture-dhc-options/>

If you have any comments please reply to this message, but please do not mix up comments on the PA draft and the two Naming drafts in a single reply.

thanks,

Ray and Mark

---

From: Branimir Rajtar <[email-masked]>
Date: Wed, 17 Sep 2014 13:42:08 +0200

+1 for the naming drafts.

Branimir

On Tue, Sep 16, 2014 at 2:12 PM, <[email-masked]> wrote:

> However, I’d like to see these drafts generalized so that mechanisms to
> provide authorization credentials towards the DNS are not limited to only
> being provided via DHCP, so that the architecture could also be used within
> other configuration management approaches as well, e.g. via Netconf/Yang.
>
> Thanks,
>
> Normen Kowalewski
>
> Deutsche Telekom AG
> Group Headquarters
>
> P.S. My apologies to the email reviewer(s), since I have needlessly
> clobbered your review queue with a copy of this content instead of
> subscribing to this list before sending it.
> *Re: [homenet] Working Group draft adoptions*
>
>     - *From*: Ray Bellis <*Ray.Bellis at nominet.org.uk*
>    <[email-masked]>>
>    - *To*: "*homenet at ietf.org* <[email-masked]> Group" <*homenet
>    at ietf.org* <[email-masked]>>
>    - *Date*: Wed, 3 Sep 2014 13:38:16 +0000
>    - *List-id*: <homenet.ietf.org>
>
>   This email commences a two week period for comments relating to the
> adoption of the following drafts by the HOMENET Working Group, as promised
> during our WG session in Toronto:
>
>   *draft-pfister-homenet-prefix-assignment*
> <http://datatracker.ietf.org/doc/draft-pfister-homenet-prefix-assignment/>
>   *draft-mglt-homenet-front-end-naming-delegation*
> <http://datatracker.ietf.org/doc/draft-mglt-homenet-front-end-naming-delegation/>
>   *draft-mglt-homenet-naming-architecture-dhc-options*
> <http://datatracker.ietf.org/doc/draft-mglt-homenet-naming-architecture-dhc-options/>
>
> If you have any comments please reply to this message, but please do not
> mix up comments on the PA draft and the two Naming drafts in a single reply.
>
> thanks,
>
> Ray and Mark
>
>
>
>
>
> _______________________________________________
> homenet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/homenet
>
>

---

From: Mark Townsley <[email-masked]>
Date: Fri, 19 Sep 2014 08:41:04 +0200

On Sep 16, 2014, at 2:12 PM, [email-masked] wrote:

> However, I’d like to see these drafts generalized so that mechanisms to provide authorization credentials towards the DNS are not limited to only being provided via DHCP, so that the architecture could also be used within other configuration management approaches as well, e.g. via Netconf/Yang.

Not the first time we have heard the need to decouple from dhcp, and this is one reason the dhc-options draft is separate. The change notes for version 3 of front-end-naming-delegation indicate that it is the authors intention already to do so as well. In any case, it's one of the first things the WG could ensure happens if there remain any vestiges in the doc that tie configuration to dhc-only. 

Also, we could use some authors for the netconf/yang version as well, please take this as a gentle nudge ;-)

- Mark

> From: Ray Bellis <Ray.Bellis at nominet.org.uk>
> To: "homenet at ietf.org Group" <homenet at ietf.org>
> Date: Wed, 3 Sep 2014 13:38:16 +0000
> List-id: <homenet.ietf.org>
> 
>   draft-pfister-homenet-prefix-assignment
>   draft-mglt-homenet-front-end-naming-delegation
>   draft-mglt-homenet-naming-architecture-dhc-options
>