Subject: [homenet] Homenet Routing Protocol Discussion - 1500 Lehua Suite

From: Mark Townsley <[email-masked]>
Date: Wed, 12 Nov 2014 13:52:42 -1000

We will continue our discussion on Routing Protocols in Homenet tomorrow at
1500 in the Lehua Suite.  1500-1620 HST (Break + Thursday Afternoon Session
II)

http://tools.ietf.org/agenda/91/venue/?room=lehua-suite

We expect this to continue to be an active discussion and debate. I've
asked for a flipchart to be available for drawing diagrams, etc. Remote
participation may be difficult, and for this we apologize. We will ask for
note-takers and a jabber scribe (using [email-masked]) but as this
is ad-hoc it will be on a best effort basis. This is where "conex" was
going to meet before being cancelled, remote participants may be able to
join an audio or video feed there.

Rough agenda:

At 1500, I'd like to ask Dave Thaler to give us his brain dump on what PCP
did to help assist in their selection process. I know that Dave has to
leave by 1520 to participate in LWIG.

1520: Pierre Pfister will present an idea which was discussed among several
members of the group in the hallway at the end of the meeting this morning

1605: Ray and I will direct the group towards a recommendation of next
steps to be reported to the WG list.

1620: The rest of the IETF will be getting cookies and fruit, and we should
be wrapping up.

1640: We lose the room, further discussions left to hallways and bars.

- Mark

---

From: Dave Thaler <[email-masked]>
Date: Fri, 14 Nov 2014 01:59:55 +0000

Dnssd discussion ran long so I couldn’t make it, so will use email.
Here’s the summary…

Slides summarizing are at http://www.ietf.org/proceedings/87/slides/slides-87-pcp-11.pdf
Some things we did:

1)      get agreement on the requirements

2)      get agreement on what possible solutions would meet the requirements (we concluded that there were two, with support roughly split between them and potentially contentiously so)

3)      Appropriately phrase the questions to ask for consensus on (see slide 3)

4)      Do the consensus call on the list.

5)      We chose to use draft-resnick-on-consensus as our handbook for judging consensus.
One wrinkle we ran into was how to handle the few responses that weren’t public (i.e. sent just to the chairs).  As chairs, we shared all such responses with each other and with our AD, and ensured that such responses included no technical issues that weren’t brought up on the mailing list.  If there were, we made sure that such issues were then discussed publically (in this case there were no such technical issues raised in private responses).  There *were* various non-technical business preferences stated, some of which indicated that one or more implementers would only implement one of the two proposals and not bother with the other one.   We had to decide how this affected “consensus”.   What we did is described in the slides, but to save you the suspense it turned out that when judged by technical arguments alone, we declared consensus on the one that the aforementioned implementers were much more likely to implement, so dodged the proverbial bullet on that one… if it was the other way, the protocol would likely be declared a failure in the RFC 5218 sense.

6)      We used technical arguments in favor as the primary metric, as discussed in draft-resnick-on-consensus, but validated the result using several other metrics (all listed in the slides) just to make sure that

A) no one was gaming the system, and

B) as chairs we weren’t missing some important consideration
For example, we counted # respondees not for declaring consensus per se, but to verify that there wasn’t degenerate cases such as are called out in draft-resnick-on-consensus.   And we were happy that we detected nothing of the sort.

7)      We went over our whole analysis with the AD before reporting results to the WG, to make sure we had support for our process and that our conclusions were valid.

8)      Finally, we then reported out to the WG

-Dave

From: Mark Townsley [mailto:[email-masked]]
Sent: Wednesday, November 12, 2014 1:53 PM
To: [email-masked] Group
Cc: Dave Thaler; Ted Lemon; Pierre PFISTER; Acee Lindem (acee)
Subject: Homenet Routing Protocol Discussion - 1500 Lehua Suite

We will continue our discussion on Routing Protocols in Homenet tomorrow at 1500 in the Lehua Suite.  1500-1620 HST (Break + Thursday Afternoon Session II)

We expect this to continue to be an active discussion and debate. I've asked for a flipchart to be available for drawing diagrams, etc. Remote participation may be difficult, and for this we apologize. We will ask for note-takers and a jabber scribe (using [email-masked]<mailto:[email-masked]>) but as this is ad-hoc it will be on a best effort basis. This is where "conex" was going to meet before being cancelled, remote participants may be able to join an audio or video feed there.

Rough agenda:

At 1500, I'd like to ask Dave Thaler to give us his brain dump on what PCP did to help assist in their selection process. I know that Dave has to leave by 1520 to participate in LWIG.

1520: Pierre Pfister will present an idea which was discussed among several members of the group in the hallway at the end of the meeting this morning

1605: Ray and I will direct the group towards a recommendation of next steps to be reported to the WG list.

1620: The rest of the IETF will be getting cookies and fruit, and we should be wrapping up.

- Mark

---

From: Dave Thaler <[email-masked]>
Date: Fri, 14 Nov 2014 02:03:34 +0000

On, and draft-resnick-on-consensus is now RFC 7282.
I highly recommend it.

-Dave

From: Dave Thaler
Sent: Thursday, November 13, 2014 4:00 PM
To: 'Mark Townsley'; [email-masked] Group
Cc: Ted Lemon; Pierre PFISTER; Acee Lindem (acee)
Subject: RE: Homenet Routing Protocol Discussion - 1500 Lehua Suite

-Dave

To: [email-masked]<mailto:[email-masked]> Group

Rough agenda:

- Mark