Subject: Re: [homenet] [Anima] ANIMA scope + homenet interaction + charter v15

From: Sheng Jiang <[email-masked]>
Date: Sat, 1 Nov 2014 11:41:25 +0000

Hi, Ted,

I agree with you that an autonomic network must be able to support incremental grow. So the network topology would not always remain hierarchical. Therefore, hierarchical delegation does not work in an autonomous network. Also, it is difficult to remain routing aggregation based on hierarchical topology in an autonomous network.

But getting back to where we start the discussion, I still think in a large network, the requesting prefix may not always be /64. It is reasonable to have multiple distributed sources for prefix assignment, in a large network. Autonomic network use case also includes to manage the prefix resource among these prefix pools. Some resource may be transferred from one pool to another with negotiation supporting. In such scenario, the requesting device may not know the requesting prefix length, unless it has already negotiated with a certain requested device.

My guess is we should separate the abovementioned scenario from normal /64 prefix assignment. Also Brian's scenario that a devices may require multiple /64 is also common.

Best regards,

Sheng
________________________________________
From: Ted Lemon [[email-masked]]
Sent: 31 October 2014 23:47
To: Sheng Jiang
Cc: Benoit Claise; [email-masked]; Markus Stenberg; [email-masked]
Subject: Re: [homenet] [Anima] ANIMA scope + homenet interaction + charter v15

On Oct 31, 2014, at 10:55 AM, Sheng Jiang <[email-masked]> wrote:
> The current general mechanism are too general to work for the use case of hierarchical prefix delegation. But if we add hierarchical topology and no bypass requests as constraint conditions, we may be able to make hierarchical prefix delegation work.

No, that is not the point I am making.   The point I am making is that hierarchical delegation simply won't work, no matter what mechanism you put in place to do it, because the network has to be able to grow incrementally.   With that as a base assumption, you cannot predict where the network will grow, so you don't know how to construct the hierarchy.   Once the hierarchy is constructed, you would have to renumber on a regular basis to make hierarchical delegation work.   I think it is preferable to simply allow for a complete routing table, and then try as best as possible to make routing hierarchical, without demanding perfection.

---

From: Sheng Jiang <[email-masked]>
Date: Sat, 1 Nov 2014 11:50:15 +0000

A very large carrier is normally organizing its network into multiple ASes. It is naturely aggregated when an AS announced its prefix(es). Complete routing table with in an AS should not be a scaling problem. Because it is not possible for all routers have complete routing table, so the path within an AS may not always be perfect. But reachability would not be in any doubts.

Sheng
________________________________________
From: homenet [[email-masked]] on behalf of Brian E Carpenter [[email-masked]]
Sent: 01 November 2014 8:19
To: Ralph Droms
Cc: Markus Stenberg; Ted Lemon; Benoit Claise; [email-masked]; [email-masked]; Sheng Jiang
Subject: Re: [homenet] [Anima] ANIMA scope + homenet interaction + charter      v15

On 01/11/2014 12:28, Ralph Droms wrote:
>
>
>
>> On Oct 31, 2014, at 4:04 PM, Ted Lemon <[email-masked]> wrote:
>>
>>> On Oct 31, 2014, at 3:25 PM, Brian E Carpenter <[email-masked]> wrote:
>>> Well yes. That's exactly why in autonomic management of prefixes,
>>> we need peer to peer negotiation, as in "I need 3 /64s that I
>>> don't have, do you have any spare ones for me?" Maybe it's
>>> badly explained but that is the whole point of our use case.
>> Sure, you can approach it as a sort of flood fill algorithm that tries to optimize for route aggregation, but copes if that optimization doesn't pan out.
>>
> Do we have use cases in which the number of links is so large that unaggregated routing tables will be a problem?

Not that I'm aware of. In the case of a carrier, the prefix will be aggregated
anyway when it is announced to peer carriers, and possibly aggregated
regionally anyway if it's a very large carrier. Of course, there will be
a scaling limit and that should be a consideration in the design.

    Brian

_______________________________________________
homenet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/homenet

---

From: Ted Lemon <[email-masked]>
Date: Sat, 1 Nov 2014 08:31:20 -0400

On Nov 1, 2014, at 7:41 AM, Sheng Jiang <[email-masked]> wrote:
> But getting back to where we start the discussion, I still think in a large network, the requesting prefix may not always be /64. It is reasonable to have multiple distributed sources for prefix assignment, in a large network. Autonomic network use case also includes to manage the prefix resource among these prefix pools.

It's certainly true that if you have multiple repositories for prefixes to assign, those repositories will need to transfer more than one /64 at a time, and it will be desirable to maintain pools of prefixes on these repositories that are aggregated into larger prefixes.   But prefix _assignment_ will always be a single /64.   I suspect that this is the core of our miscommunication--if you talk about prefix assignment and prefix distribution as if they are the same thing, which is what we started out doing, then it's easy to imagine that we are talking about the same thing when really one of is talking about assignment (me) and the other about distribution (you).  Sorry about that.

---

From: Sheng Jiang <[email-masked]>
Date: Sat, 1 Nov 2014 13:25:35 +0000

Hi, Ted,

Yes, we mixed different concepts. Actually, this was a very good discussion. It gives a very good hints to improve the autonomic prefix management draft. Now, we know prefix management should be at least categoried into prefix assignment and prefix distribution. :) Thanks for your participation in this discussion.

Best regards,

Sheng
________________________________________
From: homenet [[email-masked]] on behalf of Ted Lemon [[email-masked]]
Sent: 01 November 2014 20:31
To: Sheng Jiang
Cc: Benoit Claise; [email-masked]; Markus Stenberg; [email-masked]
Subject: Re: [homenet] [Anima] ANIMA scope + homenet interaction + charter      v15

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 02 Nov 2014 07:57:15 +1300

Right. Also of course we should follow the correct architectural
principle (that any prefix length is valid) but also the agreed
practical position (that the subnet length is normally /64,
as discussed in draft-ietf-6man-why64 that was just approved).

    Brian