Subject: [homenet] Fwd: New Version Notification for draft-jin-homenet-dncp-experience-00.txt

From: "Jin Kaiwen (Mme)" <[email-masked]>
Date: Tue, 7 Jul 2015 11:26:05 +0200 (CEST)

Hello everyone, 

We just submitted a new draft "Experience and Evaluation of the Distributed Node Consensus Protocol". 

It introduces different implementations of dncp and documents the experience of evaluating the performance of dncp using ns3 with the libdncp branch of hnetd implementation. Two metrics(traffic overhead and convergence time) are measured under different topologies. From the simulation results, dncp can converge quite fast but the traffic can differ dramatically depending on different topologies. 

I would be happy to present the results from this draft during IETF in Prague if the chair agrees (the slot is still pending I think). 

We are looking forward to your comments. 

best, 
Kaiwen 
----- Mail original ----- 

On Mon, Jul 6, 2015 at 10:39 PM, < [email-masked] > wrote: 

A new version of I-D, draft-jin-homenet-dncp-experience-00.txt 
has been successfully submitted by Jiazi Yi and posted to the 
IETF repository. 

Name: draft-jin-homenet-dncp-experience 
Revision: 00 
Title: Experience and Evaluation of the Distributed Node Consensus Protocol 
Document date: 2015-07-06 
Group: Individual Submission 
Pages: 16 
URL: https://www.ietf.org/internet-drafts/draft-jin-homenet-dncp-experience-00.txt 
Status: https://datatracker.ietf.org/doc/draft-jin-homenet-dncp-experience/ 
Htmlized: https://tools.ietf.org/html/draft-jin-homenet-dncp-experience-00 

Abstract: 
The Distributed Node Consensus Protocol (DNCP) is a generic state 
synchronization protocol that offers data synchronization and dynamic 
network topology discovery within a network. This document reports 
experience with the DNCP, which includes its implementation status 
and performance evaluation in a simulated environment. 

Please note that it may take a couple of minutes from the time of submission 
until the htmlized version and diff are available at tools.ietf.org . 

The IETF Secretariat

---

From: Juliusz Chroboczek <[email-masked]>
Date: Tue, 07 Jul 2015 11:48:55 +0200

> We just submitted a new draft "Experience and Evaluation of the Distributed Node Consensus
[...]
> Htmlized: https://tools.ietf.org/html/draft-jin-homenet-dncp-experience-00 

Thanks, that's interesting.

TL;DR version: on lossless links with 0.5ms delay, with 80 nodes, DNCP
converges within 15s in a high-diameter topology, within 18s in a worst-
case dense topology, and within 2.6s in a best-case topology.  Which is
pretty cool.

Would you consider simulating lossy links?  I'd be particularly interested
in topologies where the lossy links are redundant, e.g.

       B
      / \
     A...C
      \ /
       D

which is something that's likely to happen in home networks, and where
DNCP is likely to work fine.  If possible, you should assume lower loss
rates for unicast than for multicast.

Thanks again,

-- Juliusz