Subject: [homenet] Shncpd news

From: Juliusz Chroboczek <[email-masked]>
Date: Sat, 11 Jul 2015 17:18:34 +0200

Shncpd has learnt how to do prefix assignment last night.

  https://github.com/jech/shncpd

It remains to teach it to speak RA, DHCPv4 and Babel, and it will be
a minimally compliant Homenet stack all by itself.  (For now, it requires
that you run an external Babel daemon.)

-- Juliusz

---

From: Pierre Pfister <[email-masked]>
Date: Sun, 12 Jul 2015 13:08:05 +0200

Hello Julusz,

Pretty nice, thanks.

Did you look at hnetd source code, or did you do it only from the draft(s) ?

- Pierre

> Le 11 juil. 2015 à 17:18, Juliusz Chroboczek <[email-masked]> a écrit :
> 
> _______________________________________________
> homenet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/homenet

---

From: Juliusz Chroboczek <[email-masked]>
Date: Sun, 12 Jul 2015 13:51:38 +0200

> Pretty nice,

Don't rejoice too soon -- I haven't checked it yet.  (I need a rest, it
was hard work.)

> Did you look at hnetd source code, or did you do it only from the draft(s) ?

From the draft only, although I did have a chat with Markus on IRC.  The
PA draft is better specified than HNCP and DNCP.  On the other hand,
I find that it often lacks rationale.

Pierre, if you want to check my work, the core of the implementation is at

    https://github.com/jech/shncpd/blob/master/prefix.c#L618

-- Juliusz