Subject: [homenet] Prefix adoption and priority

From: Juliusz Chroboczek <[email-masked]>
Date: Tue, 14 Jul 2015 19:19:14 +0200

Pierre,

What happens to the prefix priority when it's being adopted?  The priority
remains unchanged, or should it be reset to the default?

Thanks,

-- Juliusz

---

From: Pierre Pfister <[email-masked]>
Date: Tue, 14 Jul 2015 22:13:32 +0200

Hello Juliusz,

> remains unchanged, or should it be reset to the default?

It is set to the default, or to some other value if the adopting node is configured to do so.
But it is definitely *not* automatically set to the adopted prefix’s previous priority.

That is because the adopting node does not know why a prefix was considered ‘high priority’ or not.

- Pierre

---

From: Juliusz Chroboczek <[email-masked]>
Date: Tue, 14 Jul 2015 22:37:17 +0200

> It is set to the default, or to some other value if the adopting node is
> configured to do so.  But it is definitely *not* automatically set to
> the adopted prefix’s previous priority.

That's clearly the right thing to do.  Where is it specified in the draft?

-- Juliusz

---

From: Pierre Pfister <[email-masked]>
Date: Wed, 15 Jul 2015 08:58:27 +0200

> That's clearly the right thing to do.  Where is it specified in the draft?

End of section 4.1

When the prefix assignment algorithm subroutine requires an
   assignment to be created or adopted, any Advertised Prefix Priority
   value can be used.  Other documents MAY provide restrictions over
   this value depending on the context the algorithm is operating in, or
   leave it as implementation-specific.

And section 4.3

   When the Backoff Timer associated with a given Delegated Prefix and
   Link pair fires while there is a Current Assignment associated with
   the same pair, the Current Assignment MUST be published with some
   associated Advertised Prefix Priority and, if the prefix is not
   applied, the Apply Timer MUST be set to '2 * Flooding Delay'.

Which say that the node has to decide which priority to use, and it can use any based on profile
or configuration. Although using the same priority automatically is a bad idea, it would still converge, so I
don’t think a ‘MUST NOT’ is necessary. I rather just said that the priority is a local decision.

Further details are left to the profile (Most of the ‘priority selection’ is anyway).

For instance, in HNCP-07:
   Default Advertised Prefix Priority:   When a new assignment is
      created or an assignment is adopted - as specified in the prefix
      assignment algorithm routine - the default Advertised Prefix
      Priority to be used is 2.

- Pierre