Subject: [homenet] Protocol Action: 'Home Networking Control Protocol' to Proposed Standard (draft-ietf-homenet-hncp-10.txt)

From: The IESG <[email-masked]>
Date: Tue, 08 Dec 2015 06:09:52 -0800

The IESG has approved the following document:
- 'Home Networking Control Protocol'
  (draft-ietf-homenet-hncp-10.txt) as Proposed Standard

This document is the product of the Home Networking Working Group.

The IESG contact persons are Brian Haberman and Terry Manderson.

A URL of this Internet Draft is:
https://datatracker.ietf.org/doc/draft-ietf-homenet-hncp/

Technical Summary

This document describes the Home Networking Control Protocol (HNCP), an extensible distributed configuration protocol for “unmanaged” (e.g., functions that are not configured manually or by a central management server of some kind) home network devices. The intent is to provide a distributed protocol for flooding of basic configuration state essential to IP network functionality. 

HNCP is described as a profile of and extension to the Distributed Node Consensus Protocol (DNCP).  HNCP enables discovery of network topology and borders, automated configuration of addresses (using the algorithm defined in draft-ietf-homenet-prefix-assignment-08), name resolution, and service discovery. 

Working Group Summary

The earliest roots of HNCP are in draft-acee-ospf-ospfv3-autoconfig-00 (Oct 2011) which was eventually published as Standards Track RFC 7503,  with the expectation that other documents would define HOMENET-specific TLVs to be carried inside OSPFv3.

Strong resistance from the WG (as well as open source router software developers) to this tight coupling between a specific routing protocol and network configuration led to the split of HNCP as a standalone protocol first defined in draft-stenberg-homenet-hncp-00.

Later, DNCP (generic aspects of HNCP concerning synchronization of state among a set of nodes using Trickle[RFC6206]) were split from the main HNCP document to allow for modularity and potential reuse. After this final split, the HNCP document describes the HOMENET-specific TLVs and the DNCP profile used to synchronize them across the home network. 

Document Quality

  Are there existing implementations of the protocol? 

The reference “hnetd” implementation is at https://github.com/sbyx/hnetd/ (project homepage at http://www.homewrt.org/doku.php). 

There is a second (fully independent and interoperable) implementation available at https://github.com/jech/shncpd developed entirely from the specification documents without referal to the reference implementation.

There is a partial third implementation, though not fully independent, available here: https://github.com/fingon/pysyma

  Have a significant number of vendors indicated their plan to 
  implement the specification? 

The reference implementation has been a part of routing feed of OpenWrt since Barrier Breaker (14.07) release in July, 2014.

Google Nest, Comcast Xfinity, D-Link, Freebox, Technicolor, and Cisco have all expressed interest in implementing and/or shipping HNCP. HNCP is referenced in version 1.0 of the Thread Specification (Nest, Samsung, etc.)

“Homenet” running either the early OSPF version and later HNCP (with DNCP) has been demonstrated publicly at 9 IETF BnB events (every BnB since BnB began, plus at least one “pre BnB” event), HNCP split off from OSPF has been demontrated at the last 5 IETF BnB events. In addition to IETF, Homenet Implementations have been presented at:

3 IPv6 World Congress events in Paris
1 CES Event in Las Vegas
1 Cablelabs Meeting in Denver, Co

Are there any reviewers that merit special mention as having done a thorough review,  e.g., one that resulted in important changes or a conclusion that the document had no substantive issues? If there was a MIB Doctor, Media Type or other expert review, what was its course (briefly)? In the case of a Media Type review, on what date was the request posted?

Thomas Clausen provided an exhaustive review on behalf of Routing Area resulting in a number of changes to the document. Review (and coding effort) by Juliusz Chroboczek indicated that a second interoperable implementation was doable, and he provided only some minor clarifications that were incorporated later on. A number of other people have also reviewed the document. 

Personnel

  Who is the Document Shepherd? 

Mark Townsley

  Who is the Responsible Area Director?

Terry Manderson

RFC-Editor Note

It would be helpful if this document was clustered with the publication of draft-ietf-homenet-dncp-12 

IANA Note

Document requests one IANA registry for TLV-types with action “RFC required”,
initial contents and policies are given. Furthermore allocation of two UDP ports and a well-known IPv6 link-local multicast group are requested, the purpose of the allocation is mentioned.

---

From: Juliusz Chroboczek <[email-masked]>
Date: Thu, 10 Dec 2015 08:01:18 +0100

> (draft-ietf-homenet-hncp-10.txt) as Proposed Standard

Yay!

(Congratulations to Markus, Stephen and Pierre, and also to Mark and
everyone else who sweated water and bl

-- Juliusz