Subject: Re: [homenet] How many people have installed the homenet code?

From: Rich Brown <[email-masked]>
Date: Sun, 24 Apr 2016 09:58:17 -0400

Hi folks,

I'm new to this list, but have been using CeroWrt and OpenWrt for several years.

Earlier in this thread there was a mention about hnetd being well integrated into the OpenWrt ecosystem. Before I try installing hnetd, I would like to know:

1) What are the current recommendations for hnetd in OpenWrt? Barrier Breaker? Chaos Calmer? Trunk? Are there settings/bugs/etc. to be aware of?

2) I want to track down documentation about using hnetd in OpenWrt. I already know of:
 
	- Juliusz Chroboczek's "Homenet tutorial": 
		https://www.irif.univ-paris-diderot.fr/~jch/software/homenet/howto.html <https://www.irif.univ-paris-diderot.fr/~jch/software/homenet/howto.html>

	- Tore Anderson's tutorial "Making a Homenet router out of OpenWrt":
		https://blog.toreanderson.no/2015/10/11/making-a-homenet-router-out-of-openwrt.html <https://blog.toreanderson.no/2015/10/11/making-a-homenet-router-out-of-openwrt.html> 

	- The bare-essentials HNCP HOWTO on the OpenWrt wiki: 
		https://wiki.openwrt.org/doc/howto/hncp

I'll update the OpenWrt wiki with the information I collect. Thanks!

Rich Brown
Lyme, NH

---

From: Rich Brown <[email-masked]>
Date: Sun, 24 Apr 2016 11:03:41 -0400

D'oh! I meant to include the HomeWrt tutorial at http://www.homewrt.org/doku.php?id=run-conf <http://www.homewrt.org/doku.php?id=run-conf>

I have updated the OpenWrt Wiki HOWTO at: https://wiki.openwrt.org/doc/howto/hncp <https://wiki.openwrt.org/doc/howto/hncp>

Please send comments/corrections/etc. Thanks.

Rich

> On Apr 24, 2016, at 9:58 AM, Rich Brown <[email-masked]> wrote:
> 
> Hi folks,
> 
> 		https://wiki.openwrt.org/doc/howto/hncp <https://wiki.openwrt.org/doc/howto/hncp>
>

---

From: Tore Anderson <[email-masked]>
Date: Mon, 25 Apr 2016 14:10:17 +0200

* Rich Brown

> I'm new to this list, but have been using CeroWrt and OpenWrt for

Welcome!

> Earlier in this thread there was a mention about hnetd being well
> integrated into the OpenWrt ecosystem. Before I try installing hnetd,
> I would like to know:
> 
> 1) What are the current recommendations for hnetd in OpenWrt? Barrier
> Breaker? Chaos Calmer? Trunk? Are there settings/bugs/etc. to be
> aware of?

Speaking only for myself, I'm using Chaos Calmer but backport newer
Homenet-related packages to ensure that I am up to date with the latest
bugs / bug fixes. I could publish my custom feed to Github in case
you're interested.

As for known bugs and issues, I'd check out the issues reported to
Steven's repositories:

https://github.com/sbyx/hnetd/issues
https://github.com/sbyx/odhcpd/issues
https://github.com/sbyx/ohybridproxy/issues

That said, think what's in CC works well enough for most uses, although
I've had issues with mdnsd causing out-of-memory crashes. That could be
because my old routers are underpowered, but then again I haven't seen
it since upgrading to the latest version available in the devel feed.

Tore

---

From: Rich Brown <[email-masked]>
Date: Tue, 26 Apr 2016 08:09:09 -0400

Thanks for this info. I have two primary interests here.

1) I would like to stop farbling around with configuring subnets in my home. :-)

2) With that knowledge in hand, I'll update the OpenWrt wiki, and include a procedure for getting the developer feed if necessary.

This all sounds pretty straightforward - and that the CC build is a good place to start. Thanks again!

Rich

> On Apr 25, 2016, at 8:10 AM, Tore Anderson <[email-masked]> wrote:
> 
> * Rich Brown
>

---

From: Markus Stenberg <[email-masked]>
Date: Tue, 26 Apr 2016 16:04:51 +0300

> On 26.4.2016, at 15.09, Rich Brown <[email-masked]> wrote:
> 

Just as an advance warning, the CC version has some bugs; trunk build of hnetd is somewhat better in that regard but I have not gotten around to fixing some of the reported issues there either. It _used_ to work in my home, until I gave up on my homerouter-NG project (Linksys WRT1900AC running combination of CC+trunk) and returned to my old home platform w/o hnetd and running BB (and just ohybridproxy).

I hope Turris Omnia box shows up sooner or later so I can try again running hnetd ;-)

Cheers,

-Markus

---

From: Rich Brown <[email-masked]>
Date: Tue, 26 Apr 2016 09:34:22 -0400

Ahhh... This is exactly the kind of advice I was looking for...

> On Apr 26, 2016, at 9:04 AM, Markus Stenberg <[email-masked]> wrote:
> 
> Just as an advance warning, the CC version has some bugs;

Are these bugs important? What problems would someone see? Or would those problems mostly affect people who're skilled in the project? As stated above, my goal is to have a set of clear instructions that "just work".

Plus, I realize I have a third goal:

3) That people have a good experience the first time they try Homenet. (This makes using trunk/DD questionable - maybe the hnetd in trunk works great, but if they install a build of DD on a bad day, it'll contribute to a bad experience, even though it's not hnetd's "fault".)

So my question for the considered wisdom of this group:

Is stock CC "good enough"? Or would CC+development version of hnetd be the best combination? If the latter, I will work toward those instructions. (And I may take Tore up on his offer to push a feed of the newer packages to Github...)

I still need to clear some other projects off my desk, but would hope to start on this in the next week or so.

> trunk build of hnetd is somewhat better in that regard but I have not gotten around to fixing some of the reported issues there either. It _used_ to work in my home, until I gave up on my homerouter-NG project (Linksys WRT1900AC running combination of CC+trunk) and returned to my old home platform w/o hnetd and running BB (and just ohybridproxy).
> 

I agree. We are all pinning great hopes on this equipment.

> -Markus

Thanks, all.

Rich

---

From: Markus Stenberg <[email-masked]>
Date: Tue, 26 Apr 2016 19:51:59 +0300

On 26.4.2016, at 16.34, Rich Brown <[email-masked]> wrote:
> Are these bugs important? What problems would someone see? Or would those problems mostly affect people who're skilled in the project? As stated above, my goal is to have a set of clear instructions that “just work".

There are now 3 different hnetd versions in the wild, actually all slightly incompatible;

- (source-only) hnetd/master/HEAD: follows RFC7787/7788

- hnetd in openwrt-routing/master (DD): follows last draft-ietf-homenet-hncp-10

- hnetd in openwrt-routing/for-15-05 (CC): follows draft-ietf-homenet-hncp-08 

Someday when Steven has time we should probably bump both CC source and binary to hnetd/master/HEAD, following the RFC ports/TLV #s. 
DD I didn’t dare to bump as there seems to be some issue in OpenWrt trunk with the PCP firewall hole-punching (automated system tests with VMs fail as hole fails to appear; TBD why, but it happened to me last week).

Current version in openwrt-routing/master has minor bug or two; CC one has bunch of them, but despite those it probably mostly works. It does pass our automated system testcases, but there is one corner-case-ish crash and some endianness/IPv4 things that are not covered by them and that were fixed ‘later’ pre-current-DD-version.

> 3) That people have a good experience the first time they try Homenet. (This makes using trunk/DD questionable - maybe the hnetd in trunk works great, but if they install a build of DD on a bad day, it’ll contribute to a bad experience, even though it's not hnetd's "fault".)

trunk/DD is definitely questionable with that goal. In general, I have mostly suggested just using CC for now.

> Is stock CC "good enough"? Or would CC+development version of hnetd be the best combination? If the latter, I will work toward those instructions. (And I may take Tore up on his offer to push a feed of the newer packages to Github…)

Probably the correct solution would be to just bump routing 15.05/master to hnetd/master/HEAD, as now the multicast address/port# should stay same and protocol also not change backward incompatibly going forward. While I can do it in the github repository (if I feel lucky enough that it works, see above note about PCP but I think it occurs only in DD which I do not care about that much), I am not sure how to get it to next CC binaries.

I am somewhat leery of pushing _anything_ until I have setup to test it out though, so this might wait until I get that Turris thingy :-)

Until that, I recommend just using CC and living with the bug or three or half dozen it has (git log is amusing reading :p).

Cheers,

-Markus

---

From: Tore Anderson <[email-masked]>
Date: Tue, 26 Apr 2016 21:31:31 +0200

* Rich Brown

> (And I may take Tore up on his offer to push a feed of the newer
> packages to Github...)

I had some time to kill today, so here you go. Let me know if you find
it useful.

https://github.com/toreanderson/openwrt-feed

You're probably better off taking Markus's advice and staying with
stock CC though...use my feed at your own peril.

Tore