Subject: [homenet] HNCP question: multiple delegations for same prefix

From: Juliusz Chroboczek <[email-masked]>
Date: Tue, 19 Apr 2016 17:50:52 +0200

Hi,

Is it legal for multiple HNCP routers to announce the same delegated
(IPv6) prefix?

I assume it is legal, and that nodes should assign a single prefix per
delegated prefix to attached links (the spec says "set of delegated
prefixes", not "multiset"), but I'd like to be sure I'm not overlooking
something.

-- Juliusz

---

From: Pierre Pfister <[email-masked]>
Date: Wed, 20 Apr 2016 09:11:45 +0200

Hello Juliusz,

I think your understanding is correct. 
Nothing in HNCP prevents routers from advertising identical delegated prefixes.
And nothing prevents routers from advertising overlapping delegated prefixes.

But it is stated that the set of delegated prefixes to be used by the prefix assignment algorithm contains: 
     "The set of prefixes encoded in
      Delegated-Prefix TLVs that are not strictly included in prefixes
      encoded in other Delegated-Prefix TLVs."

Which means indeed that in such a situation, only one prefix from the overlapping delegated prefixes will be assigned to each link.

Cheers,

- Pierre

> Le 19 avr. 2016 à 17:50, Juliusz Chroboczek <[email-masked]> a écrit :
> 
> Hi,
> 
> _______________________________________________
> homenet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/homenet