Subject: Re: [homenet] Update on RFC 7788 and .home

From: Ray Bellis <[email-masked]>
Date: Tue, 15 Nov 2016 18:29:07 +0900

On 29/09/2016 23:27, Mark Townsley wrote:

> For the latter, Pierre Pfister (and co-authors) will submit a document
> over the next few weeks, also before the Seoul submission deadline. 
> Whilst this document may take longer to advance, Terry has agreed to
> “cluster” the two documents such that they are published by the RFC
> Editor together.

This document has now been submitted (and adopted as a WG document by
Chair fiat) alongside an update to the "redact" document:

  https://tools.ietf.org/html/draft-ietf-homenet-redact-01
  https://tools.ietf.org/html/draft-ietf-homenet-dot-00

Please review these if possible before tomorrow's session.

Depending on how the discussion goes on these during the meeting it is
our intention to take these documents to WGLC immediately thereafter.

thanks,

Ray and Mark

---

From: Margaret Cullen <[email-masked]>
Date: Wed, 16 Nov 2016 09:53:31 +0900

What is the reasoning for using .homenet as the Homenet Domain, instead of registering and using .home?

Margaret

> On Nov 15, 2016, at 6:29 PM, Ray Bellis <[email-masked]> wrote:
> 
> 
> 
> _______________________________________________
> homenet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/homenet

---

From: Ray Bellis <[email-masked]>
Date: Wed, 16 Nov 2016 10:40:17 +0900

> What is the reasoning for using .homenet as the Homenet Domain, instead of registering and using .home?

<chair hat partly on>

1.  we cannot be sure that using .home is consistent with the
    existing (ab)uses

    [e.g. BT in the UK already have about 5M CPE devices deployed
     that are not "Homenet" devices but do use ".home" as their
     default domain name.  We don't know how those would interact]

2.  ICANN is in receipt of about a dozen applications for ".home",
    and some of those applicants no doubt have deeper pockets than
    the IETF does should they decide to litigate

NB:  Whilst ICANN has previously said that they won't actually delegate
".home" to any of those applicatants because of the amount of existing
(ab)use of that name that's visible at the DNS root servers, they are
under pressure from the applicants collectively to reverse that position.

Ray

---

From: Margaret Cullen <[email-masked]>
Date: Wed, 16 Nov 2016 11:18:50 +0900

Thanks, Ray.  That seems reasonable to me.

I won’t be in the meeting this afternoon (higher priority conflict), but I support the publication of both of these draft ASAP.

Margaret

> On Nov 16, 2016, at 10:40 AM, Ray Bellis <[email-masked]> wrote:
> 
> 
>

---

From: Ralph Droms <[email-masked]>
Date: Tue, 15 Nov 2016 22:48:16 -0500

I’ve read draft-ietf-homenet-dot-00.  If I’ve got it right, the concept and text in draft-ietf-homenet-dot-00 are modeled after the behavior specified in RFC 6303 and the text in RFC 6761that specifies the SUDN registry entries for the SUDNs defined in RFC 6303.  Seems like a good starting point for  draft-ietf-homenet-dot-00.

I think the document can be advanced quickly; here’s some input I hope is helpful...

I suggest that the paragraph in the Introduction that motivates the change from .home to .homenet be augmented or replaced with the reasons Ray listed in his e-mail (included below).

I also have a few clarifications and other fairly minor editorial suggestions…

In section 3, the response to item 3 in the SUDN reservation considerations could be clarified by specifying that any queries in the .homenet zone must be forwarded to a DNS service as configured by explicitly by HNCP or other appropriate local configuration mechanism coordinated with .homenet resolution, as opposed to just “configured”.  A manually configured entry for some external server is “configured”, but not configured in a helpful way.

Given that the existence of draft-ietf-dnsop-terminology-bis, it would be helpful (at least, I would find it helpful) to use the agreed common terminology; for example “recursive resolver” instead of “Caching DNS servers”.

In the answer for question 5, it might help the reader to specify which zones the “authoritative servers” are authoritative for.

“DNS server operator” is likely a term of art in the answer for question, but it’s not clear to me which operators and servers are referred to, here.  Although passive voice should be avoided, it might be appropriate to simply write “DNS servers outside a home network should not be configured to be authoritative for .homenet.

- Ralph

> On Nov 15, 2016, at 8:40 PM, Ray Bellis <[email-masked]> wrote:
> 
> 
>

---

From: Ted Lemon <[email-masked]>
Date: Wed, 16 Nov 2016 13:08:53 +0900

Great comments, Ralph--thanks!

---

From: Ralph Droms <[email-masked]>
Date: Tue, 15 Nov 2016 23:13:43 -0500

> On Nov 15, 2016, at 11:08 PM, Ted Lemon <[email-masked]> wrote:
> 
> Great comments, Ralph—thanks!

You’re welcome.  I noticed a typo in my e-mail - my last comment applies to question 6.

- Ralph