Subject: Re: [homenet] [DNSOP] My assessment of .homenet as described during the WG session yesterday.

From: Terry Manderson <[email-masked]>
Date: Thu, 30 Mar 2017 20:46:39 +0000

Dear WGs (HOMENET and DNSOP)

Based on the reviews from many folk, the discussions in DNSOP and HOMENET, the clarifying questions and responses during the HOMENET session at IETF98, a number of other DNS expert level discussions I have had, and the IAB statement [1] my final assessment on the HOMENET domain is as follows.

A TLD request is not the ideal architectural direction that would encompass the goals of the greater Internet along with the ethos and scope of the IETF.

I shall be returning the document (draft-ietf-homenet-dot) to the WG to consider and find consensus on a domain under .ARPA

The already stated technical assessment is a .ARPA subdomain can satisfy the requirement for a special use domain, in addition to being resolvable in the DNS with the requested characteristics. The WG should consider the situations where the name of the device is escalated to the user, not that I believe the WG should engage in UI/UX design, but to ensure that if it is desired by the WG that the name be suitably obfuscated, HOMENET features should exist to ensure that.

Thanks
Terry

[1] https://www.iab.org/documents/correspondence-reports-documents/2017-2/iab-statement-on-the-registration-of-special-use-names-in-the-arpa-domain/

On 29/03/2017, 3:32 AM, "DNSOP on behalf of Terry Manderson" <[email-masked] on behalf of [email-masked]> wrote:

    Dear HOMENET and DNSOP WG(s),
    
    Wearing the INT AD hat.
    
    Firstly, thank you to the DNSOP WG for the deep review, thoughts, and considered responses to my request for review.
    
    Secondly, my apologies for not sharing my throughs before the HOMENET session. It would have been impractical to do so as this is a very (VERY) fluid situation with IETF leadership also engaged in discussions.
    
    This is simply an iteration of my description of the current situation as delivered yesterday. Do be aware that conversations are continuing and you should NOT take this as a declarative statement. During the HOMENET WG session I specified that for this topic I am comfortable answering _ clarifying _ questions. The same applies here. My answers may or may not change due to the fluid nature of the concern and I hope you appreciate that.
    
    My summary of the situation is this.
    
    1) .homenet _COULD_ be added to the special use domain registry based on RFC6761 
    
    2) The expected future operation of HOMENET resolution for DNSSEC validating stub resolvers requires a break in the DNSSEC chain of trust.
    
    3) To achieve "2", the document _additionally_ asks IANA to insert an insecure delegation into the root zone
    
    4) The ask for "3" is not covered in IETF policy terms, in fact it tries to put an entry into someone else's registry (the root zone), and will require a set of collaborative discussions with the ICANN community and a new process that handles this situation. There are no expectations that this process will be defined in a reasonable time for the uses of HOMENET.

    Options, possibly not an exhaustive list
    
    A) seek a .homenet special use domain with the request for an insecure delegation in the root zone. (This is what the document asks for NOW, and here we are)
    
    B) seek a .homenet special use domain WITHOUT the delegation request AND ask the IETF/IESG/IAB to commence the discussion with the ICANN community to achieve an insecure delegation
    
    c) seek a <SOMETHING>.arpa insecure special use delegation
    
    d) go for "B" and if that doesn't work shift to "C"

    Each of these have different positive and negatives in a raw technical sense, UI design desires, and policy and political frames.
    
    Again, this situation is fluid and as discussions evolve I will provide more information when it is appropriate. In the mean-time I would very much like everyone to take a calming breath and understand that I am taking a very pragmatic view of this concern.
    
    Cheers,
    Terry
    INT AD

---

From: Ted Lemon <[email-masked]>
Date: Thu, 30 Mar 2017 15:54:21 -0500

Thanks, Terry!  I know this wasn't a fun discussion, but it is good to get
a clear answer that sets or expectations, so thanks for that!

---

From: Ted Lemon <[email-masked]>
Date: Thu, 30 Mar 2017 15:58:56 -0500

Leaving dnsop of the cc list, I would like to propose that we cut to the
chase and choose hm.arpa. If some vendor with deep pockets wants to find a
good application, we could talk about that, but I don't expect that, and
even if it were to happen, it wouldn't happen soon since there is no
schedule for the next gtld fiasco.

I think demanding that validating resolvers be specially modified doesn't
scale, so my personal preference is to not go down that road. But I think
that is the only option of we want to keep .homenet.

---

From: james woodyatt <[email-masked]>
Date: Thu, 30 Mar 2017 17:39:40 -0500

On Mar 30, 2017, at 15:58, Ted Lemon <[email-masked]> wrote:
> 
> Leaving dnsop of the cc list, I would like to propose that we cut to the chase and choose hm.arpa. […]

If we’re going to reopen the naming discussion, then I have an opinion. I prefer hab.arpa. My reasoning follows.

p1. The word “hab” has a reasonably obvious pronunciation, even for people who speak languages more closely related to Latin, where a solitary ‘h’ doesn’t have a sound, and even when they drop the ‘h’ English speakers are still going to hear it.

p2. While it’s not as short as “hm.arpa” but it’s only one letter longer, and “hab.arpa" has the additional feature of using a word that has a reasonable connection to the concept for which we are using it. See further reasoning below.

p3. Yes, the word “hab” is jargon. It's an abbreviation of “habitat,” which in its most general sense means “the environment where someone or something lives,” but the abbreviated word “hab" is more commonly used to signify the more specialized concept of “a controlled physical environment suitable for human habitation.” (Here is a good example of that usage, from NASA: <https://www.spacegrant.org/xhab>)

p4. My contention is that this is a more precise term than “home” for the context in which we are working. The Oxford English Dictionary has three different senses in which the word “home” can be used as a noun, and it’s also an adjective, a verb *and* an adverb. In the noun case, Oxford has the word “home” loaded with a lot unnecessary signifiers: “1. the place where one lives permanently, especially as a member of a family or household,” whereas, Oxford’s informal definition of “habitat,” in the one sense where it has any definition at all, is short and to the point: "a person’s usual or preferred surroundings.” Much closer to the mark.

I think this is in keeping with the observation that the protocols we are developing here are more about the environment in which we expect people to be using them and what those people are doing there, and less about a) who is living there, b) how they are related to one another, and c) how often they come and go. The environment in question is the human habitat, i.e “places where people live,” in contrast to places like offices and schools (where people work and study) and industrial environments like data centers (where people are basically an alien hostile threat).

p5. Yes, I admit it: I read science fiction, lots of authors in that genre use the “hab” abbreviation in the sense that NASA is using in the link I mentioned above, and I think it sounds cool. Guilty as charged. Not ashamed.

--james woodyatt <[email-masked]>

---

From: Ted Lemon <[email-masked]>
Date: Thu, 30 Mar 2017 17:54:48 -0500

I'm okay with either hm or hab.   I would very much like for us not to tube on a beauty contest discussion, though.   It would be nice to turn this draft around quickly.

---

From: james woodyatt <[email-masked]>
Date: Thu, 30 Mar 2017 18:01:06 -0500

> I'm okay with either hm or hab.   I would very much like for us not to tube on a beauty contest discussion, though.   It would be nice to turn this draft around quickly.

So, it’s settled then. :)

--james woodyatt <[email-masked] <mailto:[email-masked]>>

---

From: David Schinazi <[email-masked]>
Date: Thu, 30 Mar 2017 18:05:47 -0500

I support science fiction.

However, since this string shouldn't be visible to users, this sounds like the color of the roof of the bike shed.

David

> On Mar 30, 2017, at 18:01, james woodyatt <[email-masked]> wrote:
> 
> 
> On Mar 30, 2017, at 17:54, Ted Lemon <[email-masked] <mailto:[email-masked]>> wrote:
>> 
> _______________________________________________
> homenet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/homenet

---

From: Ted Lemon <[email-masked]>
Date: Thu, 30 Mar 2017 18:11:26 -0500

> However, since this string shouldn't be visible to users, this sounds like the color of the roof of the bike shed.

David, unless something has changed since the last time we had this argument, let's set it aside.   Certainly there are people participating in this discussion who believe that users will see names, even if you don't believe that.   I don't see how we could gain consensus on your position, nor do I see any advantage to trying, since you lose nothing if the name is human-readable.

---

From: David Schinazi <[email-masked]>
Date: Thu, 30 Mar 2017 18:13:08 -0500

Ted,

Apologies, I did not mean to reopen that debate,
I just wanted to say that I was in favor of moving quickly, whatever the chosen name.

David

> On Mar 30, 2017, at 18:11, Ted Lemon <[email-masked]> wrote:
> 
> On Mar 30, 2017, at 6:05 PM, David Schinazi <[email-masked] <mailto:[email-masked]>> wrote:

---

From: George Michaelson <[email-masked]>
Date: Thu, 30 Mar 2017 18:50:41 -0500

Thank you for a quick, informed and above all open decision Terry.

-George

On Thu, Mar 30, 2017 at 3:54 PM, Ted Lemon <[email-masked]> wrote:
> Thanks, Terry!  I know this wasn't a fun discussion, but it is good to get a
> clear answer that sets or expectations, so thanks for that!
>
> DNSOP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop
>

---

From: Michael Richardson <[email-masked]>
Date: Fri, 31 Mar 2017 08:36:32 -0400

Ted Lemon <[email-masked]> wrote:
    > Leaving dnsop of the cc list, I would like to propose that we cut to
    > the chase and choose hm.arpa. If some vendor with deep pockets wants

I'm quite happy with that proposal.

[To me, it pronounces something like: "Her Majesty Arya", but maybe I've been
reading Game of Thrones too much of late :-) ]

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Tim Chown <[email-masked]>
Date: Fri, 31 Mar 2017 14:45:51 +0000

On 31 Mar 2017, at 00:01, james woodyatt <[email-masked]<mailto:[email-masked]>> wrote:

On Mar 30, 2017, at 17:54, Ted Lemon <[email-masked]<mailto:[email-masked]>> wrote:

Something that is fairly unambiguously pronounced, and concise to say, would be nice. By those criteria, hab trumps hm.  Most typical home users should never need to see or say it though.

It would be interesting to hear views from non-English language people, but we should just get this done asap.

Tim