Subject: Re: [homenet] [DNSOP] WG review of draft-ietf-homenet-dot-03

From: Ralph Droms <[email-masked]>
Date: Thu, 23 Mar 2017 14:21:26 -0400

I asked this question on the dnsop WG mailing list; asking again here:

> On Mar 21, 2017, at 9:39 AM, Ralph Droms <[email-masked]> wrote:
> 
> Ted - has the operation of .homenet, as described in draft-ietf-homenet-dot-03, been demonstrated?
> 
> - Ralph
> 

Specifically, has the ability to validate queries to .homenet been demonstrated with a simulated root zone including the entry for .homenet, properly configured recursive resolvers and properly configured clients (having received a list of the local recursive resolvers through DHCP or ND)?

- Ralph

---

From: Michael Richardson <[email-masked]>
Date: Fri, 24 Mar 2017 15:04:47 -0400

Ralph Droms <[email-masked]> wrote:
    >> Ted - has the operation of .homenet, as described in
    >> draft-ietf-homenet-dot-03, been demonstrated?

    > Specifically, has the ability to validate queries to .homenet been
    > demonstrated with a simulated root zone including the entry for
    > .homenet, properly configured recursive resolvers and properly
    > configured clients (having received a list of the local recursive
    > resolvers through DHCP or ND)?

Are you asking this is in the context of a recursive resolver that speaks
homenet (mDNS, etc.), or one that has no knowledge of .homenet.?

I note in the IANA considerations that the root will have an insecure
delegation to a blackhole server.  So I think the simulation above would
need to do that as well.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Ralph Droms <[email-masked]>
Date: Sat, 25 Mar 2017 07:40:27 -0400

> On Mar 24, 2017, at 3:04 PM, Michael Richardson <[email-masked]> wrote:
> 
> 

It would be interesting to test both scenarios - the former scenario will test whether the mechanism in homenet-dot works in practice and the latter will give some indication of how queries in the .homenet zone will be handled (e.g., leakage to root servers) in non-homenet networks.

> delegation to a blackhole server.  So I think the simulation above would

Yes.

- Ralph