Subject: [homenet] homenet rechartering, meetings, and code

From: "STARK, BARBARA H" <[email-masked]>
Date: Fri, 10 May 2019 16:21:52 +0000

Hi homenet,
In Prague, we had discussions about code, meetings, hackathon, and rechartering.
One thing said about code was that if we saw no activity on the list about people discussing code (writing and testing), that the chairs should "beat people up".
Consider yourselves beaten up ...
Where are we on code for the various drafts?

The Montreal Hackathon (https://trac.ietf.org/trac/ietf/meeting/wiki/105hackathon) currently shows:
HOMENET build-out
    Champion(s)
        TO BE DETERMINED, probably Ted. 
    Project(s)
        hook up multiple routers and do back-end and front-end naming tests

Should we be encouraging this on the list (i.e., is anyone intending to show up at the hackathon and work on homenet code)? BTW, I'm happy to bring a couple of OpenWRT routers and play with whatever code others produce.

Do we want a formal homenet session in Montreal?
Would it be good to structure an unstructured get-together in Montreal (that can be used for coding and draft discussion) during the week?

Rechartering: It was suggested in Prague that a rechartering discussion might re-energize homenet. I was just listening to the recording to refresh my memory (https://www.youtube.com/watch?v=y-7G2ItPwco). There was discussion starting around 55:30 into the recording on this topic. Does anyone want to kick off some list-based discussion on rechartering? There was a mention that maybe the charter doesn't cover architecture for IoT controllers subtended from a single router, and maybe the charter should specifically include this. Multiple routers just for the purpose of having multiple (general purpose) routers may not be a common use case? If there's interest in discussing the charter, it might be good to start that on a separate thread, rather than replying to this thread.
Barbara

---

From: Michael Richardson <[email-masked]>
Date: Fri, 10 May 2019 14:23:18 -0400

> hook up multiple routers and do back-end and front-end naming tests

I filled this in (subtle voluntold of Ted) because I had the wiki open, and
Ted had discussed doing exactly this, and I want to participate.

    > Should we be encouraging this on the list (i.e., is anyone intending to
    > show up at the hackathon and work on homenet code)? BTW, I'm happy to
    > bring a couple of OpenWRT routers and play with whatever code others
    > produce.

What we need is to do some discussions online and on-list about what exactly
we want to test.  It's more than just showing up.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-