Subject: [homenet] Montreal homenet activities

From: "STARK, BARBARA H" <[email-masked]>
Date: Tue, 4 Jun 2019 18:26:51 +0000

Hi homenet,
Stephen and I have decided not to have a formal homenet session in Montreal.
We encourage people wanting to work on homenet code to self-organize for the hackathon. I'll be happy to bring some OpenWRT devices to test with (and do some testing), if that would be useful. Let me know ...
If people would like to set a time to have an "unstructured" get-together in Montreal, please let us know. There will be spaces available that can be reserved. We can figure out a time and sign up for such a space. I'm also happy to have a WebEx up and running for anyone who would want to join in remotely to such a get-together.

Homenet is in danger of shutting down if we don't get more active participation.
But with that said, there's been activity on the homenet github site: https://github.com/ietf-homenet-wg/ietf-homenet-hna
Activity is a good thing.
Barbara

---

From: Ted Lemon <[email-masked]>
Date: Tue, 4 Jun 2019 15:02:19 -0400

> If people would like to set a time to have an "unstructured" get-together in Montreal, please let us know. There will be spaces available that can be reserved. We can figure out a time and sign up…

I think these are both great ideas.   It’s been frustrating to me this year working with homenet, because I am actually working full-time on homenet technology, but there doesn’t seem to be the kind of interest in the IETF that would result in standardization.  E.g., some of the work I’ve been doing to get name service going on homenets in the dnssd working group failed last call because nobody responded.   Code is written, documents are up to date, but with no review and no interest, the only alternative is to send this stuff to the ISE.

---

From: Sávyo Vinícius <[email-masked]>
Date: Wed, 5 Jun 2019 12:55:58 -0300

Hello homenet. It's sad to me read this when I'm just starting to follow
the group, and when my research is starting over IoT security in SOHO
networks. Is there some documentation about the current work in progress of
the group? Or some list of objectives for homenet to we start working over
it?

BTW, I hope that we will can keep with the WG and keep doing great jobs
here.

Em ter, 4 de jun de 2019 às 16:04, Ted Lemon <[email-masked]> escreveu:

> We encourage people wanting to work on homenet code to self-organize for
> the hackathon. I'll be happy to bring some OpenWRT devices to test with
> (and do some testing), if that would be useful. Let me know ...
> If people would like to set a time to have an "unstructured" get-together
> in Montreal, please let us know. There will be spaces available that can be
> reserved. We can figure out a time and sign up for such a space. I'm also
> happy to have a WebEx up and running for anyone who would want to join in
> remotely to such a get-together.
>
>
> I think these are both great ideas.   It’s been frustrating to me this
> year working with homenet, because I am actually working full-time on
> homenet technology, but there doesn’t seem to be the kind of interest in
> the IETF that would result in standardization.  E.g., some of the work I’ve
> been doing to get name service going on homenets in the dnssd working group
> failed last call because nobody responded.   Code is written, documents are
> up to date, but with no review and no interest, the only alternative is to
> send this stuff to the ISE.
>
> _______________________________________________
> homenet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/homenet
>

---

From: Ted Lemon <[email-masked]>
Date: Wed, 5 Jun 2019 13:03:02 -0400

On Jun 5, 2019, at 11:55 AM, Sávyo Vinícius <[email-masked]> wrote:
> Hello homenet. It's sad to me read this when I'm just starting to follow the group, and when my research is starting over IoT security in SOHO networks. Is there some documentation about the current work in progress of the group? Or some list of objectives for homenet to we start working over it?

Welcome!   No need to despair—I think that there is a lot of stuff happening right now, just not in the form of presentations to the WG that would justify a meeting.

Are you planning to be in Montreal?

You can see some discussion of stuff that’s on my radar here: https://tools.ietf.org/html/draft-lemon-homenet-review-00 <https://tools.ietf.org/html/draft-lemon-homenet-review-00>

I also gave a presentation on this in Prague, which you can find here:

https://datatracker.ietf.org/meeting/104/session/homenet <https://datatracker.ietf.org/meeting/104/session/homenet>

There was a good discussion about where to go next after my presentation.   IoT security on SOHO was one of the things I mentioned as an important thing to work on.

---

From: Sávyo Vinícius <[email-masked]>
Date: Wed, 5 Jun 2019 23:26:59 -0300

Thanks Ted, I'll calmly check it out, but in a fast reading I found really
interesting things to do. So, I saw something about isolation of Things
communication and a few days ago I readed a paper (
https://dl.acm.org/citation.cfm?id=3323413) that discribes one
implementation of it over OpenWRT (if you dont meet, maybe it's a good idea
take a look).

About Montreal I'm not going, but I'm looking for the ISOC's fellowship
program for try attend to Singapore's meeting.

Em qua, 5 de jun de 2019 às 14:03, Ted Lemon <[email-masked]> escreveu:

> Welcome!   No need to despair—I think that there is a lot of stuff
> happening right now, just not in the form of presentations to the WG that
> would justify a meeting.
>
> You can see some discussion of stuff that’s on my radar here:
> https://tools.ietf.org/html/draft-lemon-homenet-review-00
>
> https://datatracker.ietf.org/meeting/104/session/homenet
>
> There was a good discussion about where to go next after my presentation.
>   IoT security on SOHO was one of the things I mentioned as an important
> thing to work on.
>
>

---

From: Ted Lemon <[email-masked]>
Date: Wed, 5 Jun 2019 22:30:45 -0400

On Jun 5, 2019, at 10:26 PM, Sávyo Vinícius <[email-masked]> wrote:
> Thanks Ted, I'll calmly check it out, but in a fast reading I found really interesting things to do. So, I saw something about isolation of Things communication and a few days ago I readed a paper (https://dl.acm.org/citation.cfm?id=3323413 <https://dl.acm.org/citation.cfm?id=3323413>) that discribes one implementation of it over OpenWRT (if you dont meet, maybe it's a good idea take a look).
> 
> About Montreal I'm not going, but I'm looking for the ISOC's fellowship program for try attend to Singapore's meeting.

Given that there’s no f2f meeting in Montreal, maybe we can make some progress before Singapore.   Thanks for the link!

---

From: Michael Richardson <[email-masked]>
Date: Tue, 11 Jun 2019 13:54:10 -0400

(context: The HOMENET WG will not meet in Montreal at IETF105)

The HOMENET front-end-naming design team will spend some unstructure time
together.   This relates to
https://datatracker.ietf.org/doc/draft-ietf-homenet-front-end-naming-delegation/

The exact time is to be determined as the unstructured schedule has yet to be
determined.  Tentatively, I want to suggest an hour on Tuesday morning.

We would love to spend some time with people who design and/or operate public
anycast DNS systems.  We want to make sure that we match any terminology that
you use, and to learn about practical limitations that we might be unaware
of.  This in particular relates to the questions at:
  https://mailarchive.ietf.org/arch/msg/homenet/VcXftoB30feY9PlsPtvEV65JycM

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-