Subject: [homenet] final planning for not formally meeting

From: "STARK, BARBARA H" <[email-masked]>
Date: Mon, 15 Jul 2019 19:09:51 +0000

Hi homenet,
Now that we're less than a week out...
- What planning should people do who can/will attend the hackathon? I intend to come, and can bring a (LEDE load, currently) wireless router and other items (Raspberry Pi ?). If that would be useful. Does anyone else want to share their plans or ask for something specific?
- I haven't scheduled an unstructured meeting. Should I? Should I do a quick Doodle poll for when? Or would people prefer to wing it when we get there? If we schedule something, I could set up a WebEx for remote people.

Please let me know what support you'd like to move your homenet efforts forward.
Thx,
Barbara

---

From: Michael Richardson <[email-masked]>
Date: Mon, 15 Jul 2019 15:19:33 -0400

STARK, BARBARA H <[email-masked]> wrote:
    > Hi homenet, Now that we're less than a week out...  - What planning
    > should people do who can/will attend the hackathon? I intend to come,
    > and can bring a (LEDE load, currently) wireless router and other items
    > (Raspberry Pi ?).

I will bring 2-3 devices with custom openwrt 18.06 loads.
I will bring 4-5 multi-port devices that can be placed "behind" the routers.
(These are OrangePi0 devices in custom cases).

    > If that would be useful. Does anyone else want to
    > share their plans or ask for something specific?

I think that the MUD people and the Homenet people should occupy a table with
a switch together.  I have been trying to get confirmation from the NOC that
the DHCPv6-PD is ready to go, but so far I haven't gotten any replies.

    > - I haven't scheduled
    > an unstructured meeting. Should I? Should I do a quick Doodle poll for
    > when? Or would people prefer to wing it when we get there? If we
    > schedule something, I could set up a WebEx for remote people.

I had suggested that it should be a *-naming "design team" focus,
I had proposed Tuesday morning. I hadn't booked anything yet either.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Mon, 15 Jul 2019 19:42:39 +0000

> I had suggested that it should be a *-naming "design team" focus, I had
> proposed Tuesday morning. I hadn't booked anything yet either.

I reserved the Coller room for Tuesday morning (08:30 - 10:00). It says it holds up to 16 people. There are bigger rooms available (and additional times, but I figured you meant before the first session since there's an anima meeting Tuesday first session), but I thought this size might be better because I'm not expecting a lot of people? I can also support remote attendance with this size of room, using an iPad. You'll find the reservation listed at:
https://trac.ietf.org/trac/ietf/meeting/wiki/105sidemeetings

Barbara

---

From: Ted Lemon <[email-masked]>
Date: Mon, 15 Jul 2019 15:55:11 -0400

On Jul 15, 2019, at 3:42 PM, STARK, BARBARA H <[email-masked]> wrote:
> https://trac.ietf.org/trac/ietf/meeting/wiki/105sidemeetings <https://trac.ietf.org/trac/ietf/meeting/wiki/105sidemeetings>

This is opposite a “Technology Deep Dive” talk that some folks might want to go to.

I have an OpenWRT repo set up here that I’m using for the hacking I’m doing, and that we could use as a collaborative space if it seems useful: https://github.com/IETF-Hackathon/openwrt <https://github.com/IETF-Hackathon/openwrt>

Right now the packages I’m working on don’t build out of the box, but I’ll fix that in the next day or so.   If anybody is interested in building what I’m building, I can supply some pointers.   I’m doing my development on the GL-iNet AR-750S router, which builds cleanly out of this repo.   In principle the repo is tracking OpenWRT current, but I haven’t merged in a few days.

My plan is to hack on homenet stuff—if there are folks who want to do naming, that would be great, but I wouldn’t mind doing some HNCP integration if there’s anyone who’s interested in that.

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Mon, 15 Jul 2019 21:48:26 +0000

If there are people interested in HNCP integration, I’m happy to reserve space for that (at a time different from the -naming effort), and I’m happy to participate in that as well.
Just pick a date/time.
Wherever there’s interest, I’d like to try to help get like-minded people together.
I’ll see about reflashing my router to the most current OpenWRT. It really needs updating, anyway.
Barbara

From: Ted Lemon <[email-masked]>
Sent: Monday, July 15, 2019 3:55 PM
To: STARK, BARBARA H <[email-masked]>
Cc: Michael Richardson <[email-masked]>; homenet <[email-masked]>
Subject: Re: [homenet] final planning for not formally meeting

On Jul 15, 2019, at 3:42 PM, STARK, BARBARA H <[email-masked]<mailto:[email-masked]>> wrote:
I reserved the Coller room for Tuesday morning (08:30 - 10:00). It says it holds up to 16 people. There are bigger rooms available (and additional times, but I figured you meant before the first session since there's an anima meeting Tuesday first session), but I thought this size might be better because I'm not expecting a lot of people? I can also support remote attendance with this size of room, using an iPad. You'll find the reservation listed at:
https://trac.ietf.org/trac/ietf/meeting/wiki/105sidemeetings<https://urldefense.proofpoint.com/v2/url?u=https-3A__trac.ietf.org_trac_ietf_meeting_wiki_105sidemeetings&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=LoGzhC-8sc8SY8Tq4vrfog&m=6WX9BNWncURSoCVOLeT7gjD4x8P5NJBGe6ERscM8Foc&s=_i0_ukESYyJFPuUfRMuoFfO_jyZ5iZACVpC2CeHI6Lo&e=>

I have an OpenWRT repo set up here that I’m using for the hacking I’m doing, and that we could use as a collaborative space if it seems useful: https://github.com/IETF-Hackathon/openwrt<https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_IETF-2DHackathon_openwrt&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=LoGzhC-8sc8SY8Tq4vrfog&m=6WX9BNWncURSoCVOLeT7gjD4x8P5NJBGe6ERscM8Foc&s=-G81Nu9eU4g4R48aO7c6Jp8DAX3BjRi0zuCHRe6jsHc&e=>

---

From: Ted Lemon <[email-masked]>
Date: Mon, 15 Jul 2019 17:52:10 -0400

I meant that I would like to work on HNCP integration at the Hackathon. I do not want to have a theoretical discussion about it. :)

Sent from my iPhone

> On Jul 15, 2019, at 5:48 PM, STARK, BARBARA H <[email-masked]> wrote:
> 
> I have an OpenWRT repo set up here that I’m using for the hacking I’m doing, and that we could use as a collaborative space if it seems useful: https://github.com/IETF-Hackathon/openwrt
>

---

From: Michael Richardson <[email-masked]>
Date: Fri, 19 Jul 2019 19:14:08 -0400

> This is opposite a “Technology Deep Dive” talk that some folks might

True.
I think that it will be standing room only, and it will show up on Youtube.

    > I have an OpenWRT repo set up here that I’m using for the hacking I’m
    > doing, and that we could use as a collaborative space if it seems
    > useful: https://github.com/IETF-Hackathon/openwrt

okay.... 

    > Right now the packages I’m working on don’t build out of the box, but
    > I’ll fix that in the next day or so. If anybody is interested in
    > building what I’m building, I can supply some pointers. I’m doing my
    > development on the GL-iNet AR-750S router, which builds cleanly out of
    > this repo. In principle the repo is tracking OpenWRT current, but I
    > haven’t merged in a few days.

    > My plan is to hack on homenet stuff—if there are folks who want to do
    > naming, that would be great, but I wouldn’t mind doing some HNCP
    > integration if there’s anyone who’s interested in that.

I would like to suggest that we spend at least 3-4 hours setting up HNCP
among a few people.  Maybe a "tell-two-friends" kind of effort.

If we/you can then make homenet naming work that would be very cool.
I expect that my build experts will be there, otherwise, I'll have to fix
(git update, etc.) by build machine.  It's supposed to be all CI now.

I brought one router...  Damn!  Stupid packing list this afternoon.
I was supposed to bring a few spare 3800s as well!
I have a bunch of small machines that can go behind routers though.
I also brought some extra TTL/USB adapters, and since I'm on the train a
bunch of tools.

-- 
]               Never tell me the odds!                 | ipv6 mesh networks [ 
]   Michael Richardson, Sandelman Software Works        | network architect  [ 
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Michael Richardson <[email-masked]>
Date: Fri, 19 Jul 2019 19:15:51 -0400

STARK, BARBARA H <[email-masked]> wrote:
    > If there are people interested in HNCP integration, I’m happy to
    > reserve space for that (at a time different from the -naming effort),
    > and I’m happy to participate in that as well.

I want to do HNCP integration at the hackathon, if we can.
If it overflows into the Code Lounge, fine.  But, my idea for Tuesday morning
is that it's about bashing documents, not code.

    > really needs updating, anyway.

I'm also happy if we get (at the Hackathon) devices that people bring up to "current"

---

From: Ted Lemon <[email-masked]>
Date: Fri, 19 Jul 2019 19:49:02 -0400

Stuart and I have four AR750S routers between us. The challenge will be figuring out how to get HNCPd to negotiate naming. 

Sent from my iPhone

> On Jul 19, 2019, at 7:15 PM, Michael Richardson <[email-masked]> wrote:
> 
>

---

From: RayH <[email-masked]>
Date: Sat, 20 Jul 2019 11:46:22 +0300

> If anybody is interested in building what I’m building, I can supply some pointers.

Please. A working build chain would save a lot of effort. I'm on vacation now, but I should have some time when I get back.

> Stuart and I have four AR750S routers between us. The challenge will be figuring out how to get HNCPd to negotiate naming.

I think that depends on how the name space, serving, and resolving is going to be structured.

Do you already have ideas?

A fully distributed system would need to inform other name servers of the local zones in use, and break ties. A centralised system would need to crown a queen in a similar way to selecting the root bridge in 802.1d.

Regards,

On 20 Jul 2019 02:49, Ted Lemon <[email-masked]> wrote:

Sent from my iPhone

>> I’ll see about reflashing my router to the most current OpenWRT. It

>> really needs updating, anyway.

_______________________________________________

homenet mailing list

[email-masked]

https://www.ietf.org/mailman/listinfo/homenet

---

From: Ted Lemon <[email-masked]>
Date: Sat, 20 Jul 2019 06:04:10 -0400

We have a design for local resolution in the homenet naming architecture doc. I haven’t reviewed the latest front-end naming doc yet but presumably we can implement that and see what happens. :)

Sent from my iPhone

> On Jul 20, 2019, at 4:46 AM, RayH <[email-masked]> wrote:
>

---

From: RayH <[email-masked]>
Date: Sat, 20 Jul 2019 16:49:57 +0300

On 20 Jul 2019 13:04, Ted Lemon <[email-masked]> wrote:

We have a design for local resolution in the homenet naming architecture doc.

This (expired) draft?

https://tools.ietf.org/html/draft-ietf-homenet-simple-naming-03

Or have I missed something?

I haven’t reviewed the latest front-end naming doc yet but presumably we can implement that and see what happens. :)

Sure.

Sent from my iPhone

Regards,

Sent from my iPhone

homenet mailing list

[email-masked]

---

From: Ted Lemon <[email-masked]>
Date: Sat, 20 Jul 2019 13:07:16 -0400

On Jul 20, 2019, at 9:49 AM, RayH <[email-masked]> wrote:
> This (expired) draft?
> 
> https://tools.ietf.org/html/draft-ietf-homenet-simple-naming-03 <https://tools.ietf.org/html/draft-ietf-homenet-simple-naming-03>
Yes.

We decided to get some implementation experience before proceeding, and it hasn’t popped to the top of the stack yet (except maybe at this hackathon).

---

From: RayH <[email-masked]>
Date: Sun, 21 Jul 2019 00:17:19 +0300

On 20 Jul 2019 20:07, Ted Lemon <[email-masked]> wrote:

This (expired) draft?

Yes.

Thanks. Fair enough.

One question on re-reading this version: why not populate the reserve zone automatically from the data used to update the forward zone?

It's exactly the same set of servers, and it saves lots of additional work by the hosts.

If a host really wants a unique forward/reverse binding for a specific service, it can defend a unique stable gua address (rfc8064) for this purpose.

Regards,

---

From: Ted Lemon <[email-masked]>
Date: Sat, 20 Jul 2019 17:35:13 -0400

> One question on re-reading this version: why not populate the reserve zone automatically from the data used to update the forward zone?

That’s exactly what we’ve figured out in the Service Registration Protocol document. :)

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Tue, 23 Jul 2019 03:57:06 +0000

> I reserved the Coller room for Tuesday morning (08:30 - 10:00). It says it holds up to 16 people. There are bigger rooms available (and additional times, but I figured you meant before the first session since there's an anima meeting Tuesday first session), but I thought this size might be better because I'm not expecting a lot of people? I can also support remote attendance with this size of room, using an iPad. 

I just wanted to remind those who are here that we’ll be meeting in an unstructured way in the morning. I had no requests for Webex. If you do want to remotely participate let me know and I’ll set it up in the morning just before we meet. 
Barbara

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Tue, 23 Jul 2019 12:19:44 +0000

FYI. Coller is on the 3rd floor in the hallway on the “other” side of the elevators. 
Barbara 

> On Jul 22, 2019, at 11:57 PM, STARK, BARBARA H <[email-masked]> wrote:
> 
> *** Security Advisory: This Message Originated Outside of AT&T ***.
> Reference http://cso.att.com/EmailSecurity/IDSP.html for more information.
> 
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_homenet&d=DwIF-g&c=LFYZ-o9_HUMeMTSQicvjIg&r=LoGzhC-8sc8SY8Tq4vrfog&m=E1jjmY5RvhwI_bCJLecGy7oq9qmf0_dJeleKron1s0M&s=lcTtq3B-YeMNwYGDMu_vnwR37gaBSGfd39hTfno5-FQ&e=