Subject: Re: [homenet] [DNSOP] Montreal homenet activities -- front-end-naming

From: Normen Kowalewski <[email-masked]>
Date: Mon, 8 Jul 2019 11:05:00 +0200

Hi Michael, 

apologies for this really very late reply, but FAIW it's IMHO not really a "Synchronization Server", because the flow is really hierachical - from home via the to-be-named-entity, and then to the place tha scales out, like the slaves of that entity. I think it is also not really a “Distribution Server", if the collecting to-be-named-entity is a fully grown-up DNS Auth by itself, in which i can/do also manage zones directly.

When I ran things in a chain like this, it saw the  to-be-named-entity as acting in the capacity of a "DNS intermediary [master]", or "DNS provisioning proxy".

AFAIK already when we starting the early discussions on this (Hi Daniel, Hi Ralf!) for the former expired draft, we had not found a specific terminology for such a use of nn DNS Authorittive Server in a draft/doc anywhere, but i still think it is worth the effort to have a specific term for that. 

BR, 

Normen Kowalewski

> On 11. Jun 2019, at 19:54, Michael Richardson <[email-masked]> wrote:
> 
> 
> (context: The HOMENET WG will not meet in Montreal at IETF105)
> 
> The HOMENET front-end-naming design team will spend some unstructure time
> together.   This relates to
> https://datatracker.ietf.org/doc/draft-ietf-homenet-front-end-naming-delegation/
> 
> The exact time is to be determined as the unstructured schedule has yet to be
> determined.  Tentatively, I want to suggest an hour on Tuesday morning.
> 
> We would love to spend some time with people who design and/or operate public
> anycast DNS systems.  We want to make sure that we match any terminology that
> you use, and to learn about practical limitations that we might be unaware
> of.  This in particular relates to the questions at:
>  https://mailarchive.ietf.org/arch/msg/homenet/VcXftoB30feY9PlsPtvEV65JycM
> 
> --
> Michael Richardson <[email-masked]>, Sandelman Software Works
> -= IPv6 IoT consulting =-
> 
> 
> 
> _______________________________________________
> DNSOP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop

---

From: Michael Richardson <[email-masked]>
Date: Mon, 08 Jul 2019 15:31:04 -0400

Normen Kowalewski <[email-masked]> wrote:
    > apologies for this really very late reply, but FAIW it's IMHO not
    > really a "Synchronization Server", because the flow is really
    > hierachical - from home via the to-be-named-entity, and then to the
    > place tha scales out, like the slaves of that entity. I think it is
    > also not really a “Distribution Server", if the collecting
    > to-be-named-entity is a fully grown-up DNS Auth by itself, in which i
    > can/do also manage zones directly.

I never liked "Synchornization Server", and we removed that term.

We settled on Distribution Master, which is usually the stealth primary, and
transfers zones to the public secondaries.

    > When I ran things in a chain like this, it saw the  to-be-named-entity
    > as acting in the capacity of a "DNS intermediary [master]", or "DNS
    > provisioning proxy".

DNS intermediary Master, conveniently could also be abbreviated to "DM" :-)

    > AFAIK already when we starting the early discussions on this (Hi
    > Daniel, Hi Ralf!) for the former expired draft, we had not found a
    > specific terminology for such a use of nn DNS Authorittive Server in a
    > draft/doc anywhere, but i still think it is worth the effort to have a
    > specific term for that.