Subject: [homenet] homenet notes

From: "STARK, BARBARA H" <[email-masked]>
Date: Tue, 23 Jul 2019 14:09:10 +0000

Here are the notes I took in the unstructured homenet session this morning.
Barbara

Present were Ted Lemon, Michael Richardson, Daniel Migault, Stephen Farrell, Barbara Stark

Notes:
We should try to have multiple little docs rather than big docs that try to have everything.
Focus here is on naming. We should have drafts on
 - terminology (homenet)
 - front-end naming
 - SRP in homenet (assumes dnssd SRP draft)
 - HNCP for external domain
 - service discovery in homenet

At IETF 106, see if we can have joint dnssd + homenet 2 hour session and give homenet 30 minutes to discuss service discovery in homenet.
Before IETF 106, there should be day where Ted, Michael and Daniel hack and talk together. August 28 tentatively set as date.

Picture of flip chart drawing is attached.

---

From: Michael Richardson <[email-masked]>
Date: Mon, 29 Jul 2019 20:08:31 -0400

>   - service discovery in homenet

It seems like "SRP in homenet" and "service discovery in homenet" might 
be the same thing.  I can't recall what the distinction was, but I 
recall that's we'd wind up with five documents.

 > At IETF 106, see if we can have joint dnssd + homenet 2 hour session
 > and give homenet 30 minutes to discuss service discovery in homenet.
 > Before IETF 106, there should be day where Ted, Michael and Daniel
 > hack and talk together. August 28 tentatively set as date.

I also think that maybe we should have a virtual interim in october?

---

From: Ted Lemon <[email-masked]>
Date: Mon, 29 Jul 2019 20:10:24 -0400

On Jul 29, 2019, at 8:08 PM, Michael Richardson <[email-masked]> wrote:
> It seems like "SRP in homenet" and "service discovery in homenet" might be the same thing.  I can't recall what the distinction was, but I recall that's we'd wind up with five documents.

There’s the stateful service and the stateless service—I think that might have been the distinction.   It’s easier to describe the stateless solution, of course.

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Tue, 30 Jul 2019 16:31:59 +0000

> From: Michael Richardson <[email-masked]>
> 
> It seems like "SRP in homenet" and "service discovery in homenet" might be
> the same thing.  I can't recall what the distinction was, but I recall that's we'd
> wind up with five documents.
> 
>  > At IETF 106, see if we can have joint dnssd + homenet 2 hour session  > and
> give homenet 30 minutes to discuss service discovery in homenet.
>  > Before IETF 106, there should be day where Ted, Michael and Daniel  >

I think it's reasonable to consider the possibility of having an October virtual interim. Perhaps a decision could be made during the August virtual interim?
Barbara

---

From: Ted Lemon <[email-masked]>
Date: Wed, 31 Jul 2019 06:22:49 -0400

> I think it's reasonable to consider the possibility of having an October virtual interim. Perhaps a decision could be made during the August virtual interim?

I would be inclined toward virtual hackathons, personally.   I think we’ve made more progress by just getting code running.   Documents spring naturally from that work, not vice versa.