Subject: [homenet] why the period / full stop...

From: <[email-masked]>
Date: Wed, 7 Aug 2019 10:51:19 +0000

Hey homenetters!

Quick question regarding rfc8375 “Special-Use Domain 'home.arpa.'”

Within the text, what is the meaning of suffixing a period (.) in the use of the text “home.arpa” throughout the text ? Does it have any special meaning ?

e.g

      why      ↓
“'home.arpa.' is designated for non-unique use in residential home networks”

It’s not causing any distress, just curios ☺

Regards

Mal

---

From: Andrew Sullivan <[email-masked]>
Date: Wed, 7 Aug 2019 09:13:46 -0400

> “'home.arpa.' is designated for non-unique use in residential home networks”

That's how you write a fully-qualified domain.

Domains of the form "example.com" are not actually fully qualified.
They're relatively qualified, but "to save typing" (actual quote from
RFC 1034) we make that relative qualification to the root zone.

Now, the thing is that the root label is 0 octets long (that's how you
know it's the root), so it can't be typed.  So, you end up with a
separator and no visible label after it when the labels appear in
presentation form (like in running text).

Hope that helps,

A

-- 
Andrew Sullivan
[email-masked]

---

From: <[email-masked]>
Date: Wed, 7 Aug 2019 13:18:39 +0000

:O mind blown

Thanks

-----Original Message-----
From: homenet [mailto:[email-masked]] On Behalf Of Andrew Sullivan
Sent: 07 August 2019 14:14
To: [email-masked]
Subject: Re: [homenet] why the period / full stop...

Hope that helps,

A

-- 
Andrew Sullivan
[email-masked]

_______________________________________________
homenet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/homenet