Subject: [homenet] DoH??

From: Michael Thomas <[email-masked]>
Date: Wed, 18 Sep 2019 15:07:04 -0700

So I'm a little unclear about the specifics of Firefox using DNS over 
HTTP, but wouldn't this affect homenet naming, or any split horizon kind 
of naming?

Mike

---

From: Ted Lemon <[email-masked]>
Date: Wed, 18 Sep 2019 18:12:05 -0400

On Sep 18, 2019, at 6:07 PM, Michael Thomas <[email-masked]> wrote:
> So I'm a little unclear about the specifics of Firefox using DNS over HTTP, but wouldn't this affect homenet naming, or any split horizon kind of naming?

In order for DoH to not break lots of things, it has to be implemented in such a way that special-use names are not resolved using a global resolver, and that VPN-supported names are looked up using the VPN resolver.   It would also be nice if there were a way for the homenet to signal that a public domain belonging to it is resolved locally, so that split-horizon naming on the homenet works correctly.  Similar functionality will be required for corporate networks that do split-horizon naming.

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 18 Sep 2019 23:21:28 +0100

Hiya,

> HTTP, but wouldn't this affect homenet naming, or any split horizon kind

FWIW, I just tested with FF nightly in my home n/w for a
name that is locally resolved within net10 but that also
has a global IPv6 address. It worked fine with FF's TRR
mode 2, though there was maybe a short but visible delay
before FF fell back to the system resolver.

So - doesn't have to be a problem.

Cheers,
S.

> 
> Mike
> 
> _______________________________________________
> homenet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/homenet
>

---

From: Michael Thomas <[email-masked]>
Date: Wed, 18 Sep 2019 15:27:41 -0700

On 9/18/19 3:12 PM, Ted Lemon wrote:
> On Sep 18, 2019, at 6:07 PM, Michael Thomas <[email-masked] 
> <mailto:[email-masked]>> wrote:
>> HTTP, but wouldn't this affect homenet naming, or any split horizon 
>> kind of naming?
>
> In order for DoH to not break lots of things, it has to be implemented 
> in such a way that special-use names are not resolved using a global 
> resolver, and that VPN-supported names are looked up using the VPN 
> resolver.   It would also be nice if there were a way for the homenet 
> to signal that a public domain belonging to it is resolved locally, so 
> that split-horizon naming on the homenet works correctly.  Similar 
> functionality will be required for corporate networks that do 
> split-horizon naming.
>
Yeah, that's pretty much what it seemed to me too. How vetted was this? 
I mean, did it make the rounds in standards-ville, or is this roll your 
own by Mozilla?

I also don't get what the motivation is, and/or problem it's trying to 
solve. Seems pretty scary to have a single point of failure (Cloudflare) 
introduced.

Mike