Subject: [homenet] appropriateness of draft-shytyi-opsawg-vysm-03 to homenet WG?

From: Alexandre Petrescu <[email-masked]>
Date: Tue, 17 Sep 2019 13:06:32 +0200

Hi,

This draft-shytyi-opsawg-vysm-03 describes a YANG model for uCPE. A 
Customer Premises Entity is for enterpise and home networks.

Is this draft appropriate here?

Alex

---

From: Ted Lemon <[email-masked]>
Date: Tue, 17 Sep 2019 08:27:54 -0400

On Sep 17, 2019, at 7:06 AM, Alexandre Petrescu <[email-masked]> wrote:
> This draft-shytyi-opsawg-vysm-03 describes a YANG model for uCPE.  A Customer Premises Entity is for enterpise and home networks.
> 
It’s a bit off-charter.  It’s not necessarily a wrong thing to pursue here, but you’d need to talk us into doing it, and more importantly there’d need to be people here interested in working on it.  It’s likely that most people reading this have no idea what the draft is about, so if you want to try to pursue it here, the first thing I’d suggest you do is tell the WG what problem you are trying to solve.  :)

---

From: Alexandre Petrescu <[email-masked]>
Date: Tue, 17 Sep 2019 15:29:50 +0200

Le 17/09/2019 à 14:27, Ted Lemon a écrit :
> On Sep 17, 2019, at 7:06 AM, Alexandre Petrescu 
> <[email-masked] <mailto:[email-masked]>>
> wrote:
>> 
>> This draft-shytyi-opsawg-vysm-03 describes a YANG model for uCPE.
>> A Customer Premises Entity is for enterpise and home networks.
>> 
> It’s a bit off-charter.  It’s not necessarily a wrong thing to pursue
>  here, but you’d need to talk us into doing it, and more importantly
>  there’d need to be people here interested in working on it.  It’s
> likely that most people reading this have no idea what the draft is
> about, so if you want to try to pursue it here, the first thing I’d
> suggest you do is tell the WG what problem you are trying to solve.
> :)

Hi Ted,

Thanks for the reply.  As I do not author the draft, and my colleague is 
not subscribed to this list, I paste here his reply to your question:

> It is not really clear if the draft is appropriate to the homenet wg.
> One can state that this draft presents a tool/solution (service yang
> model) for orchestator to manage the different uCPE equipment. uCPE
> eqipment is not regular cpe/homenet device.
> 
> uCPE is a host that hosts guest OSs. uCPE is like PC with virtualbox
> where the VMs are running (VMs such as homenet router,cisco router,
> firewall, SD-WAN.)

Alex

---

From: Ted Lemon <[email-masked]>
Date: Tue, 17 Sep 2019 09:34:31 -0400

On Sep 17, 2019, at 9:29 AM, Alexandre Petrescu <[email-masked]> wrote:
> Thanks for the reply.  As I do not author the draft, and my colleague is not subscribed to this list, I paste here his reply to your question:
> 

Thanks.   The question I would ask here is, is it intended that this uCPE integrate into a multi-subnet, multi-homed homenet?

---

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 18 Sep 2019 10:14:19 +0200

Le 17/09/2019 à 15:34, Ted Lemon a écrit :
> On Sep 17, 2019, at 9:29 AM, Alexandre Petrescu 
>> Thanks for the reply.  As I do not author the draft, and my
>> colleague is not subscribed to this list, I paste here his reply to
>> your question:
>> 
>>> It is not really clear if the draft is appropriate to the homenet
>>> wg. One can state that this draft presents a tool/solution
>>> (service yang model) for orchestator to manage the different uCPE
>>> equipment. uCPE eqipment is not regular cpe/homenet device. uCPE
>>> is a host that hosts guest OSs. uCPE is like PC with virtualbox 
>>> where the VMs are running (VMs such as homenet router,cisco
>>> router, firewall, SD-WAN.)
> 
> Thanks.   The question I would ask here is, is it intended that this
>  uCPE integrate into a multi-subnet, multi-homed homenet?

Temporary speaking for my colleague, this is what he has to say to the 
question:

> If we are talking, for example, about several IPv6 prefixes that are
> learned from muliple ISPs I could suggest that uCPE is transparent in
> this case. On the figure below we can see that uCPE connects 2 PHY
> ports via virtual Links to the Virtual Ports of VNF. So it is the
> VNF(vRouter) that is doing the job. There is example where the
> constructor of equipment merges the uCPE NFVIs with router (i find it
> as a very particular case).
> 
> If we are talking about implementation of babel in the uCPE please
> check the figure below. I suppose it is a vRouter that will have this
> functionality (not uCPE NFVIs).
> 
> P.S. There is a management of NFVIs that maybe could be integrated.
> But it is a question if there is an interest to do that.

            +--------------------------------+
            |uCPE                            |
            |                                |
            |                 +--------+     |
            |           |-----|vRouter |-----|----WAN1
LAN1 ------|----|      |     +--------+     |
            |    |      |          |         |
            |    |      |          |         |
LAN2 ------|----|------|          |---------|----WAN2
            |    |                           |
            |    |                           |
LAN3 ------|----|                           |
            |                                |
            |                                |
            +--------------------------------+

---

From: Ted Lemon <[email-masked]>
Date: Wed, 18 Sep 2019 09:58:41 -0400

That diagram isn’t consistent with what Homenet has been trying to build: it appears to be a base assumption of this work that there is a single virtual CPE router, and that’s not a homenet problem.

> On Sep 18, 2019, at 4:14 AM, Alexandre Petrescu <[email-masked]> wrote:
> 
> 
> 
>> On Sep 17, 2019, at 9:29 AM, Alexandre Petrescu <[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>>
>> wrote:
>>>> is a host that hosts guest OSs. uCPE is like PC with virtualbox where the VMs are running (VMs such as homenet router,cisco
> Temporary speaking for my colleague, this is what he has to say to the question:
>