Subject: [homenet] https://tools.ietf.org/id/draft-ietf-mboned-ieee802-mcast-problems-09.txt

From: Dave Taht <[email-masked]>
Date: Tue, 22 Oct 2019 23:56:58 -0700

has anyone here had much chance to review this?

-- 

Dave Täht
CTO, TekLibre, LLC
http://www.teklibre.com
Tel: 1-831-205-9740

---

From: "Ray Hunter (v6ops)" <[email-masked]>
Date: Wed, 23 Oct 2019 10:55:32 +0200

> has anyone here had much chance to review this?
Thanks for the prompt.

 From a pure Homenet perspective, it reinforces that L3 routing is the 
correct solution for segmenting networks where end nodes have different 
characteristics. e.g. battery powered or different underlying LAN 
technology. And maybe we need a firewall in front of those segments to 
prevent inbound scanning traffic overloading the link.

Other than that I'm not sure it says much more than "Multicast is great 
for efficiency, until it isn't".

Section 3.2.4:
 > On a wired network, there is not a huge difference between unicast, 
multicast and broadcast traffic.

I'd dispute this statement as being overly generic. Anyway, it doesn't 
add much to the discussion (about wireless).

The majority of modern wired Ethernets are actually effectively point to 
point networks, with multicast and broadcast being emulated in silicon 
or software.

Although maybe having a less visible impact than on wireless, multicast 
and broadcast can also have some similar operational impact on wired 
networks (waking nodes unnecessarily, switching via a slow (software) 
path in the main processor,  https://tools.ietf.org/html/rfc6583 etc.).

-- 
regards,
RayH
<https://www.postbox-inc.com/?utm_source=email&utm_medium=siglink&utm_campaign=reach>

---

From: [email-masked]
Date: Wed, 23 Oct 2019 11:27:40 +0200

Hi,
  I have a couple of naive questions

* Section 3.1.1 «Since typically there are no ACKs for multicast packets...»

Does anyone remember why WiFi had chosen not to acknowledge 
multicast/broadcast packets?
This choice was certainly made on the basis of assumptions. Which ones?
Are these assumptions still valid?

* Section 3.1.4 «Multicast traffic is delayed in a wireless network if
any of the STAs in that network are power savers.  All STAs associated
to the AP have to be awake at a known time to receive multicast traffic.»

Why? Why does everyone have to be awake at the same time? APs have
buffers, isn't?  So, why not delivering immediately multicast packets to
awaked STAs (which have to acknowledge them), and keep packets in
buffers for sleeping STAs?

I would be surprised if such a naive process have not been studied when
WiFi was designed. Does anyone remember why this was not selected?

* Is there any standard or well-known test to measure the quality of an
AP regarding its ability to manage multicast traffic?

* The paper is about multicast on wireless links, but what's about
PowerLine Adapters?

Best regards,
Christophe

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Wed, 23 Oct 2019 21:33:05 +0000

Ray and Christophe and others,

As the responsible AD for this draft, would you mind forwarding/adding [email-masked]<mailto:[email-masked]> to the recipient list? So that authors can read your valuable comments?

Thank you

-éric

From: homenet <[email-masked]> on behalf of "Ray Hunter (v6ops)" <[email-masked]>
Date: Wednesday, 23 October 2019 at 10:55
To: Dave Taht <[email-masked]>
Cc: HOMENET <[email-masked]>, cerowrt-devel <[email-masked]>
Subject: Re: [homenet] https://tools.ietf.org/id/draft-ietf-mboned-ieee802-mcast-problems-09.txt

Thanks for the prompt.

>From a pure Homenet perspective, it reinforces that L3 routing is the correct solution for segmenting networks where end nodes have different characteristics. e.g. battery powered or different underlying LAN technology. And maybe we need a firewall in front of those segments to prevent inbound scanning traffic overloading the link.

Other than that I'm not sure it says much more than "Multicast is great for efficiency, until it isn't".

Section 3.2.4:
> On a wired network, there is not a huge difference between unicast, multicast and broadcast traffic.

I'd dispute this statement as being overly generic. Anyway, it doesn't add much to the discussion (about wireless).

The majority of modern wired Ethernets are actually effectively point to point networks, with multicast and broadcast being emulated in silicon or software.

Although maybe having a less visible impact than on wireless, multicast and broadcast can also have some similar operational impact on wired networks (waking nodes unnecessarily, switching via a slow (software) path in the main processor,  https://tools.ietf.org/html/rfc6583 etc.).

--
regards,
RayH