Subject: [homenet] auto-passthrough from ISP routers

From: Michael Richardson <[email-masked]>
Date: Tue, 21 Jul 2020 21:52:36 -0400

In the ADD WG, Barbara STARK, BARBARA H <[email-masked]> wrote:
    > [BHS] While my ISP requires me to use the CE router they supply, I’ve
    > never had an issue connecting that to my own router and then running my
    > home network from my router. The CE router from my particular ISP
    > (YMMV) even automatically passes on the public IPv4 address it acquires
    > and a /64 IPv6 prefix to my router (so IPv4 just has the single NAT and
    > IPv6 works great). I have total ability to choose any router I want and
    > configure that router as much as that router vendor’s GUI allows (e.g.,

1) Does your ISP provides router auto-detect that there is another router behind
   it, and turn itself into a modem only?  or did you have configure that?

2) I can imagine how a cable modem/router could become a bridge, and all
   would be well.
   But, I think that AT&T is more in the DSL space with PPPoE.
   Does this work for PPPoE, and if so, do you have to put the PPPoE
   password, into your "own" router?
   The ppp password is among those things that ISPs like to provision automatically.

I'm really hoping that there is some technology out there that I'm ignorant of.
(but, I'm cynically thinking that the technology involves sending Barbara out
in a GPS equipped truck)

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Wed, 22 Jul 2020 15:56:26 +0000

> -----Original Message-----
> From: Michael Richardson <[email-masked]>
>

The ISP router auto-detects the presence of a router on its LAN and uses a capture screen to ask the user if they want the ISP router to go into "IPv4 passthrough" mode. The ISP router does not become a modem-only. It is still a router. It still sets up the WAN connection and does all DHCP to the WAN and gets IP address and prefix delegations from the WAN. For IPv4 passthrough, it keeps a couple of ports of the public IPv4 address for its own management purposes, and delegates (DHCPv4) that public IPv4 address to the internal "passed through to" router (and forwards all inbound traffic to all other ports to the internal router). It has its own IPv6 /64 prefix, and requests a 2nd /64 prefix it then delegates to the internal router. If any other DHCPv6 IA_PD requests come from the LAN, it will request additional /64 prefixes for those -- so this function is independent of passthrough mode which is an IPv4-only function.
 
>    The ppp password is among those things that ISPs like to provision

PPPoE is only legacy (old ADSL). The IPv4 passthrough does work there (because the ISP router is still a router, as described above). IPv6 on legacy is 6rd with a /60 -- so the IPv6 stuff is different. Fiber, VDSL, and Gfast (and some newer ADSL) are IPoE (PTM), and not IP o PPPoE o ATM.

Here is some info (includes instructions to directly configuring IP passthrough):
https://www.att.com/Common/storefront/resources/pdf/att_bridged_mode_vs_ip_passthrough_nov2012_v3.pdf
 
> (but, I'm cynically thinking that the technology involves sending Barbara out

Hah! No. We've been doing IPv4 passthrough for 15+ years.
Barbara

---

From: Michael Richardson <[email-masked]>
Date: Thu, 23 Jul 2020 12:58:53 -0400

> The ISP router auto-detects the presence of a router on its LAN and
    > uses a capture screen to ask the user if they want the ISP router to go
    > into "IPv4 passthrough" mode. The ISP router does not become a

This is very cool.
Is it written up as a specification somewhere?  What is the signal that the
device behind is a router, and not a PC?

Why isn't homenet standardizing this?

    > PPPoE is only legacy (old ADSL). The IPv4 passthrough does work there
    > (because the ISP router is still a router, as described above). IPv6 on
    > legacy is 6rd with a /60 -- so the IPv6 stuff is different. Fiber,
    > VDSL, and Gfast (and some newer ADSL) are IPoE (PTM), and not IP o
    > PPPoE o ATM.

Nobody has told Bell Canada the PPPoE is legacy :-)

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Thu, 23 Jul 2020 19:08:52 +0000

>     >> > never had an issue connecting that to my own router and then
> running
>     >> my
>     >> 1) Does your ISP provides router auto-detect that there is another
> router
>     >> behind

It's sort of written up in https://www.broadband-forum.org/technical/download/TR-124_Issue-5.pdf. Search for LAN.ADDRESS and go to 6. There are related requirements that reference "LAN.ADDRESS.6". Auto detection of routers behind the ISP CE router is imperfect (which is why manual configuration exists), but usually right. I forget what it is the ISP CE router sees that triggers it to think there is a router connecting to it. I'm thinking it could be some DHCPv4 options that routers tend to ask for but regular hosts don't; but I could be mis-remembering. Auto-detection isn't described in TR-124.

> Why isn't homenet standardizing this?

Reason 1: This is an IPv4 thing. Why would homenet or IETF standardize an IPv4 thing since IPv4 is historic?
Reason 2: The functionality is accomplished within the ISP CE router without anything else needing to do anything special. No need to define requirements to accomplish interoperability. So the ISPs who knowingly wanted this functionality defined it in TR-124 because they use TR-124 to help with CE router RFPs. These ISPs perceive no additional benefit from the effort required to create an IETF RFC.

> Nobody has told Bell Canada the PPPoE is legacy :-)

LOL. You were asking about AT&T. For AT&T it's legacy. I realize it's still widely used around the world. Your Network May Vary.

Barbara

---

From: [email-masked]
Date: Fri, 24 Jul 2020 10:47:56 +0200

> On 23 Jul 2020, at 18:58, Michael Richardson <[email-masked]> wrote:
> 
> This is very cool.

Cause it's architecturally "challenged"?

Cheers,
Ole

---

From: Ted Lemon <[email-masked]>
Date: Fri, 24 Jul 2020 06:51:58 -0400

> Cause it's architecturally "challenged"?

The working group or the solution?

---

From: [email-masked]
Date: Fri, 24 Jul 2020 13:04:11 +0200

> The working group or the solution?

Not sure how you could interpret that as pointing to the working group.

The solution obviously.
IPv4 "pass through" implies sharing the IPv4 address among multiple nodes.
Creating all sorts of tricky problems.
Which of the nodes gets an ICMP error message for example.

Cheers,
Ole

---

From: Ted Lemon <[email-masked]>
Date: Fri, 24 Jul 2020 07:08:35 -0400

> Which of the nodes gets an ICMP error message for example.

Thanks for clarifying. It really was ambiguous and I really was confused—sorry!

---

From: Michael Richardson <[email-masked]>
Date: Sun, 26 Jul 2020 16:47:37 -0400

> Creating all sorts of tricky problems.

Yeah, it's a weird situation where it basically is forced/transparent
proxying it's management port, and then letting everything else through.
Definitely a place where moving the management to IPv6 would be easier.

I think that the signaling that is observed to cause the bypass should be written down.
That it nicely does DHCPv6-PD proxying is very nice.

I think that had this description come to the WG five years ago, we would
have thought about it deeply.