Subject: [homenet] homenet naming drafts "terminology"

From: "STARK, BARBARA H" <[email-masked]>
Date: Wed, 5 May 2021 14:17:07 +0000

I'm hoping not to start divisive discussion, but think it's better to discuss inside the WG rather than wait until IETF LC.

Might the authors consider whether a word other than "Master" could be used in the terms Distribution Master, Reverse Distribution Master, Distribution/Distributed Master Option [BTW, I notice that there are several instances of the "Distributed" instead of "Distribution" in the DHC option draft], Reverse Distribution Master Option, OPTION_DIST_MASTER, OPTION_REVERSE_DIST_MASTER?

Perhaps "Primary" could be used? Or something else?

If anyone needs context for my comment, I'm happy to provide it. Otherwise, I'll just leave it at this request for the authors to consider this question.
Thx,
Barbara

---

From: Michael Richardson <[email-masked]>
Date: Wed, 05 May 2021 11:51:16 -0400

STARK, BARBARA H <[email-masked]> wrote:
    > I'm hoping not to start divisive discussion, but think it's better to
    > discuss inside the WG rather than wait until IETF LC.

    > Might the authors consider whether a word other than "Master" could be
    > used in the terms Distribution Master, Reverse Distribution Master,

Yes, the authors discussed this at length, and we actually reached out to
quite a number of people for the terminology.  There were even emails on this
ML, I think.

1) DM is a term used in the DNS operational community.  It's not ubiquitous,
   but it is understood in many of the anycast DNS groups.

2) The term "stealth primary" is also used, but according to how it is used,
   that term would apply to the HNA, not the DM function.

3) We would be happy to go with another term, but we don't want to invent
   another term.  So, if the DNS anycast operator has another term, then
   I'd go with it.

    > Perhaps "Primary" could be used? Or something else?

Nope, because that's confusing in the DNS space.
It's not a primary.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Ted Lemon <[email-masked]>
Date: Wed, 5 May 2021 13:47:50 -0400

>   another term.  So, if the DNS anycast operator has another term, then

Authority database?

RFC 8499 appears to have deprecated the term “master” to some extent, although it’s not perfect. “Master server” just says “see Primary Server.”

The server on the home router really is the primary authoritative server for the zone from a DNS perspective, even if it doesn’t show up in a public NS record.

FWIW I fully support using different terminology.

---

From: Michael Richardson <[email-masked]>
Date: Wed, 05 May 2021 15:09:04 -0400

Ted Lemon <[email-masked]> wrote:
    >> 3) We would be happy to go with another term, but we don't want to
    >> invent another term.  So, if the DNS anycast operator has another
    >> term, then I'd go with it.

    > Authority database?

I thought that you were asking who was an authoritive database of operators.
Then I understood that you are suggesting "authority database" as the term.

Some ascii art, (so pick a sensible mono-spaced font, or use the archive link):

.-----.      .-----.
| S P | ---> | D M |----\-------\------\
`-----'      `-----'    |       |      |
                        V       V      V
                     .-----. .----. .----.
                     | Sec | | Sec| |Sec |
                     `-----' `----' `----'

S.P. = Stealth Primary
Sec  = Secondary
D M  = Distribution M*

Note that the "DM" is usually not listed as an NS, but rather,
two or more "Sec" are what is listed.

So, maybe "Distribution Authority" would make us both happy.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Ole Troan <[email-masked]>
Date: Wed, 5 May 2021 21:10:53 +0200

Is this the same as a hidden primary name server?

Cheers 
Ole

> On 5 May 2021, at 21:09, Michael Richardson <[email-masked]> wrote:
> 
> 
> _______________________________________________
> homenet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/homenet

---

From: Ted Lemon <[email-masked]>
Date: Wed, 5 May 2021 15:36:54 -0400

Or “Distribution Primary?” I think given this chart that “Distribution Authority” is less clear, since the real authority is the stealth primary.

> On May 5, 2021, at 3:09 PM, Michael Richardson <[email-masked]> wrote:
> 
>

---

From: Michael Richardson <[email-masked]>
Date: Wed, 05 May 2021 18:06:17 -0400

> Is this the same as a hidden primary name server?

That's Stealth Primary.
The DM is not a stealth primary, because it's not primary.
It hasn't got the DNSSEC signing keys, for instance.

    >>>> On May 5, 2021, at 11:51 AM, Michael Richardson <[email-masked]>
    >>>> wrote: 3) We would be happy to go with another term, but we don't
    >>>> want to invent another term.  So, if the DNS anycast operator has
    >>>> another term, then I'd go with it.
    >>
    >>> Authority database?
    >>
    >> I thought that you were asking who was an authoritive database of
    >> operators.  Then I understood that you are suggesting "authority
    >> database" as the term.
    >>
    >> .-----.  .-----.  | S P | ---> | D M |----\-------\------\ `-----'
    >> `-----' | | | V V V .-----. .----. .----.  | Sec | | Sec| |Sec |
    >> `-----' `----' `----'
    >>
    >> S.P. = Stealth Primary Sec = Secondary D M = Distribution M*
    >>
    >> Note that the "DM" is usually not listed as an NS, but rather, two or
    >> more "Sec" are what is listed.
    >>
    >> Michael Richardson <[email-masked]> . o O ( IPv6 IøT consulting
    >> ) Sandelman Software Works Inc, Ottawa and Worldwide
    >> _______________________________________________ homenet mailing list
    >> [email-masked] https://www.ietf.org/mailman/listinfo/homenet

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 6 May 2021 07:16:05 +0200

> It hasn't got the DNSSEC signing keys, for instance.

Distribution hub
Distribution leader
Distribution manager
Distribution head
Distribution director
Distribution controller
Distribution governor
Distribution center
Distribution central

Grüße, Carsten

---

From: Daniel Migault <[email-masked]>
Date: Wed, 12 May 2021 12:47:16 -0400

"Distribution Primary" is probably my preferred alternative as the
replacement of Master by Primary makes a smooth transition from what is
currently used. If that is fine with everyone I will update the document
with it as well as the DHCP option draft. If not feel free to provide a
better alternative.

Yours,
Daniel

-- 
Daniel Migault
Ericsson

---

From: Michael Richardson <[email-masked]>
Date: Wed, 12 May 2021 17:11:28 -0400

Daniel Migault <[email-masked]> wrote:
    > currently used. If that is fine with everyone I will update the
    > document with it as well as the DHCP option draft. If not feel free to
    > provide a better alternative.

I'm okay with that, but would list "Distribution Manager" as a nice TLA
preserving of "DM"

---

From: Daniel Migault <[email-masked]>
Date: Wed, 12 May 2021 21:44:58 -0400

Sounds good to me. Anyone objecting DIstribution Manager ? If not I will
consider this terminology.
Yours,
Daniel

-- 
Daniel Migault
Ericsson