Subject: Re: [homenet] Should homenet continue ?

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Wed, 1 Sep 2021 14:08:34 +0000

[Changing the subject header to better reflect the current discussion]

Stephen, I agree with you: let's continue this thread about homenet WG continuation until mid-September.

To be honest, I am wondering whether there is WG momentum as only active IETF drafts authors are replying to this thread. Let's hope that the change of Subject will trigger more vivid reactions.

Regards

-éric	

PS: I am pretty sure that the 'stub network' I-D could find another home
-----Original Message-----
From: homenet <[email-masked]> on behalf of Stephen Farrell <[email-masked]>
Date: Tuesday, 31 August 2021 at 17:41
To: Daniel Migault <[email-masked]>, Michael Richardson <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, Ted Lemon <[email-masked]>
Subject: Re: [homenet] Looking for a Homenet co-chair

    Hiya,

    On 31/08/2021 15:53, Daniel Migault wrote:
    > I also support that homenet work being made in homenet. It is unclear to me
    > why we are looking at an alternate way to proceed.

     From my POV, mostly because, as co-chair, it's very hard
    to be confident that we have sufficient participation to
    usefully claim WG consensus for the (good) work being done
    when we put that forward for e.g. IETF LC.

    As a WG, we're suffering from lack of input and at some
    point (and now being a good point) we should consider whether
    or not the WG is still tractable or not.

    Cheers,
    S.

    PS: As it's still just about vacation season, I figure
    it makes sense to let this discussion go on for another
    week or two, so if someone hasn't yet chimed in, it's
    still a fine time to do that!

    > Yours,
    > Daniel
    > 
    > On Fri, Aug 27, 2021 at 7:05 AM Michael Richardson <[email-masked]> wrote:
    > 
    >>
    >> Michael Richardson <[email-masked]> wrote:
    >>      >> progress the stub networks draft because I've been too busy doing
    >>      >> dnssd work, but that would be an example. I'd really like to
    >> progress
    >>      >> that draft /somewhere/, and it seems a /bit/ off-topic for dnssd. It
    >>      >> could go in v6ops, but it's pretty off-topic for v6ops. Same with
    >>      >> intarea.
    >>
    >>      >> But of course the stub networks document isn't what Homenet set out
    >> to
    >>      >> do.  It's just a building block that might lead there. The original
    >>      >> work of homenet doesn't seem to have caught on in the market, and I
    >>      >> think it's because we didn't have an adoption strategy. Personally I
    >>      >> think stub networks is a good bottom-up beginning to a strategy that
    >>      >> could ultimately produce an adoptable version of what we originally
    >>      >> tried to do. But again, only if people here want to pursue that.
    >>
    >>      > I thought that you *wanted* to go to INTAREA with this document.  I
    >>      > agree that it's an important document.
    >>
    >> If we need to keep HOMENET open to do stub networks, then let's do that.
    >>
    >> _______________________________________________
    >> homenet mailing list
    >> [email-masked]
    >> https://www.ietf.org/mailman/listinfo/homenet
    >>
    > 
    > 
    > 
    > _______________________________________________
    > homenet mailing list
    > [email-masked]
    > https://www.ietf.org/mailman/listinfo/homenet
    >

---

From: Huaimo Chen <[email-masked]>
Date: Wed, 8 Sep 2021 19:32:59 +0000

Hi Ted,

    I read through your draft, which describes an interesting topic. The
followings are my comments.
    1) A few of possible approaches are proposed in the draft.
It would be better to compare these approaches in a section.
    2) One of the reasons for not using HNCP is its implementation
(prototype and problematic) as mentioned in the draft. In the
first approach "Proxy ND" you proposed, the use of Proxy ND for
providing connectivity to stub networks is described in
[I-D.ietf-6lo-backbone-router]. What is the implementation status
of [I-D.ietf-6lo-backbone-router]?
    3) In the abstract, a stub network seems to be a
collection of hosts behind a router. In section 1 "Introduction",
a constrained 802.15.4 network is used as an example of a stub
network. It would be better to have a section containing
a complete definition of a stub network in details as well as others
such as a stub router.

Best Regards,
Huaimo