Subject: Re: [Hrpc] [hrpc] Nomenclature/Definition of Human Rights issues in Protocol Design

From: Niels ten Oever <[email-masked]>
Date: Mon, 06 Apr 2015 23:13:54 +0200

Hi Aaron,

On 03/27/2015 07:10 PM, Aaron Zauner wrote:
<<snip>>

> I think the proper approach is to think of intent (as done in
> security in general). Speaking of malicious intent when a protocol
> is (mis)used in a way that causes human rights issues would be an
> example.
> 

Why would one need the concept of intent when it can already been
shown that a protocol is causing human rights violations?

Intent is very hard to show, and only having a protocol be used the
way it was intended would probably have negative consequences for
permission-less innovation.

Looking forward to discuss.

Best,

Niels

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Tue, 7 Apr 2015 07:55:36 +0000

> On Apr 6, 2015, at 2:13 PM, Niels ten Oever <[email-masked]> wrote:
> 

You seem to start from the assumption that a protocol *causes* human rights violations. It would help me if you could cite a case.

Cause: http://dictionary.reference.com/browse/cause

As we discussed at the IETF, the only one that comes close (that I can quickly think of) is an IP address. It identifies a locality in the routing system and can, under some circumstances, be correlated with a geographic location and/or a subscriber.

I would argue doesn’t *cause* human rights violations, any more than the fact that my geographic address is on my business card. But it might give someone intent on violating someone else’s rights the information they need to do so.

In my mind, the concept that a protocol element or design, or the misuse of a protocol element or design, is *causal* in a human rights violation remains to be shown.

---

From: Niels ten Oever <[email-masked]>
Date: Tue, 07 Apr 2015 13:53:56 +0200

On 04/07/2015 09:55 AM, Fred Baker (fred) wrote:
> You seem to start from the assumption that a protocol *causes*
> human rights violations. It would help me if you could cite a
> case.
> 

I was reacting to Aaron who said that if a protocol caused human
rights issues, one can speak of malicious intent, but if a protocol is
causing human rights issues, one doesn't need to show intent.

But your question remains valid.

I would say that a protocol infringes on a users right to freedom of
expression if it in-transparently negatively impacts the connectivity
of the user.

This could be done either intentionally or unintentionally.

> 
> As we discussed at the IETF, the only one that comes close (that I 
> can quickly think of) is an IP address. It identifies a locality
> in the routing system and can, under some circumstances, be
> correlated with a geographic location and/or a subscriber.
> 
> I would argue doesn’t *cause* human rights violations, any more
> than the fact that my geographic address is on my business card.
> But it might give someone intent on violating someone else’s rights
> the information they need to do so.
> 
> In my mind, the concept that a protocol element or design, or the 
> misuse of a protocol element or design, is *causal* in a human
> rights violation remains to be shown.
> 

Am working on examples, but one (contentious) example that comes to
mind is DRM which is often meant as a 'speed bump' that merely 'keeps
honest people honest', but it is also limiting the non-commercial and
personal use of content and also limiting the access to knowledge and
the access to culture.

EFF argues that EME (standardization of DRM in HTML by W3C) runs
counter to the philosophy that "the Web needs to be a universal
ecosystem that is based on open standards and fully implementable on
equal terms by anyone, anywhere, without permission or negotiation."
EME undermines the Web's compatibility by allowing sites to demand
"specific proprietary third-party software or even special hardware
and particular operating systems." [0]

Best,

Niels

[0]
http://arstechnica.com/business/2013/05/drm-in-html5-is-a-victory-for-the-open-web-not-a-defeat/

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Tue, 7 Apr 2015 17:57:29 +0000

> On Apr 7, 2015, at 4:53 AM, Niels ten Oever <[email-masked]> wrote:
> 

Well, I think EFF is a little over the top. I would expect that someone offering a service or content has the right to say under what circumstances they are willing to do so. A grocery store sells food to anyone that can enter the store and pay for the goods they choose. I have, I think, a right to enter the store, choose food, pay for it, and leave the store; I don’t have the right to leave without paying. If Netflix is the “store” and video service is the “food”, we have an analogous situation. I have the right to purchase content services from Netflix, at a a mutually agreed price. Youtube is also analogous, but with a price point of $0, and as a result no requirement for much of the machinery for exchanging money.

What I would require of an online retailer is that what they require, and the means by which they ensure that requirements are met, be transparent, and that the retailer be the person responsible for enforcement of whatever provisions s/he requires.

Digital products differ from food (in this context) primarily in that food, once consumed, is unavailable, while digital content remains available and usable. If a company spends half a billion dollars creating a bit of content, I think it has a reasonable expectation of recovering the cost of doing so plus profit. If once it releases the first copy that gets distributed for free (“information wants to be free”), that expectation is no longer reasonable - people will choose the unencumbered and free copy to the encumbered copy. If it does not recover its costs and make something extra, it has neither the capital nor the motivation to make the next bit of content. So hammering on the point that “information wants to be free” is a good way to make such information no longer exist. There needs to be a compromise unless the objective is to put the industry out of business.

Where I do get a little antsy is with pricing. If I make a bit of content that can be delivered as a hard copy book or a set of bits delivered to my kindle-or-whatever t a nominal cost, when I purchase the kindle version, I don’t think I should pay the price of a physical copy. The value is comparable. If the cost is comparable, that might justify the price being comparable. But I suspect that the cost (while non-zero - someone bought the bandwidth to deliver it) is significantly less than the creation and distribution of a physical object. Hence, for me, if the price is comparable or higher than the cost of the physical object, I vote with my feet and don’t buy it.

So I actually don’t have a problem with digital watermarking and other methods of proving that someone created the content, and expressing as a condition of the purchase that it is for the use of the person to whom it was sold.

What I do have a problem with is legal remedies like SOPA etc that make the conduit (the ISP) responsible to enforce such things or collect revenue. Your water pipes aren’t responsible for the water that flows through them apart from contamination of the water. Why would your ISP be responsible for what flows through the Intertubes?