Subject: [hrpc] ID on censorship techniques

From: Joseph Lorenzo Hall <[email-masked]>
Date: Wed, 22 Jul 2015 18:17:02 +0200

This still has outstanding edits that I owe to Stephane Bortzmeyer and
Martin Nilsson, so please consider it a work in progress... I also
have a number of other academic authors (Nick Feamster's group from
Princeton) that I haven't plugged in or included text from just yet.

A Survey of Worldwide Censorship Techniques
https://tools.ietf.org/html/draft-hall-censorship-tech-01

If we can get consensus on this kind of descriptive document, we could
replicate it for other components of the definitions you're working on
and apply to other human rights-adversarial goals (traffic analysis,
fingerprinting, etc.)

best, Joe

-- 
Joseph Lorenzo Hall
Chief Technologist
Center for Democracy & Technology
1634 I ST NW STE 1100
Washington DC 20006-4011
(p) 202-407-8825
(f) 202-637-0968
[email-masked]
PGP: https://josephhall.org/gpg-key
fingerprint: 3CA2 8D7B 9F6D DBD3 4B10  1607 5F86 6987 40A9 A871

---

From: Seda <[email-masked]>
Date: Thu, 23 Jul 2015 08:44:26 -0400

Joe, you may want to include in the conversation Saadia Afroz et al. from ICSI/UC Berkeley (if they are not involved already). They had this WIP paper at HotPETs this summer:

Censorship Arms Race: Research vs. Practice
https://petsymposium.org/2015/papers/afroz-censor-eval-hotpets2015.pdf
We argue that the censor models under which circumvention tools are evaluated should be informed by the real world as much as possible. We observe that system designers tend to place undue emphasis on censor capabilities that may become important in the future, but are not often seen in practice today, and put too little focus on actual blocking techniques used by current censors. In particular, we identify four disconnects between practice and re- search:

Research has emphasized forms of steganography irrelevant for today’s arms race.

Real censors employ very simple features; research often wrestles with complex ones.

The practical interplay between censorship and evasion does not depend upon deep properties of background traffic.

Research emphasizes development costs, whereas censors likely emphasize operational costs. 

On Jul 22, 2015, at 12:17 PM, Joseph Lorenzo Hall <[email-masked]> wrote:

> _______________________________________________
> hrpc mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/hrpc

---

From: Joseph Lorenzo Hall <[email-masked]>
Date: Thu, 23 Jul 2015 14:49:13 +0200

Very neat, thanks much for pointing this out!

On Thu, Jul 23, 2015 at 2:44 PM, Seda <[email-masked]> wrote:
> Joe, you may want to include in the conversation Saadia Afroz et al. from
> ICSI/UC Berkeley (if they are not involved already). They had this WIP paper
> at HotPETs this summer:
>
> We argue that the censor models under which circumvention tools are
> evaluated should be informed by the real world as much as possible. We
> observe that system designers tend to place undue emphasis on censor
> capabilities that may become important in the future, but are not often seen
> in practice today, and put too little focus on actual blocking techniques
> used by current censors. In particular, we identify four disconnects between
> practice and re- search:
>