Subject: Re: [hrpc] About draft-tenoever-hrpc-association

From: Niels ten Oever <[email-masked]>
Date: Tue, 6 Feb 2018 22:25:56 +0100

Hi all,

On 11/11/2017 02:26 PM, Stephane Bortzmeyer wrote:
> [About version -02]
> 
>> spam infringes both rights if an op-out [sic] mechanism is not
>> provided
> 
> Why opt-out? Giving the amount of spam sources, this is completely
> unscalable (you cannot unsubscribe faster than marketers subscribe
> you).
> 

Maybe we should drop the whole paragraph about spam. Especially since
there is less and less scientific proof that a filter bubble actually
exists.

>> namely the possibility of centralized policy making on the
>> management and operation of domain names
> 
> Let's be precise: the DNS is not centralized (if it were, you would
> have to talk to ICANN each time you change an IP address).
> 

I don't think the text says that the DNS is centralized, but the current
hierarchical structuring does allow for a centralized venue for policy
making vis a vis the DNS, right?

>> 6.4.2.  ASes
> 
> This section does not talk about network neutrality, which could be a
> good idea.
> 

Let's see if we can come up with a session about routing, economic costs
and maybe refer to net neutrality?

Let's see what we can make of it. Suggestions always welcome.

Best,

Niels

---

From: Vittorio Bertola <[email-masked]>
Date: Thu, 8 Feb 2018 15:03:34 +0100 (CET)

Il 6 febbraio 2018 alle 22.25 Niels ten Oever ha scritto:

Hi all,

"a"? "Centralized policy making on the management and operation of domain
names" is also being done in a number of different and uncorrelated places, either for each of the subtrees in the DNS hierarchy or for those nodes that have certain feature. First of all this happens at the national lawmaking level; also, each TLD defines their policies, and often second level domain administrators define policies too. I'd say that the policy making is as hierarchical as the system itself, or if you prefer centralized at each of the layers of the hierarchy for anything existing in the nodes below, rather than simply "centralized".

Also, "surveillance of the services
running on the domain, domain based censorship [RFC7754], or
impersonation of the domain through DNS cache poisoning" are things that could also happen if the DNS were flat rather than hierarchical.

All in all, I guess that what you were trying to say is that if you could get a domain name without having to register it somewhere, just by publishing the registration independently, no one could censor/influence you by taking the domain down or by attaching conditions to the registration. This looks to me like blockchain hype: it's actually true for a part of the potential threats (but not, as I said, for some others), but, as of today, no one has found yet a workable way to remove that last piece of centralization (actually, even the current toy-scale blockchains are controlled by an elite class of miners because they require so many resources that only relatively few people can afford to run the nodes, so I would not say that they could solve this problem).

Moreover, the reason why the DNS is hierarchical is not because its authors wanted to introduce a central point of control, but exactly the opposite: the authors wanted to distribute control and management of the namespace so to make it less centralized and less controllable (even if, possibly, for practical engineering reasons rather than for political and ethical ones). So it makes sense to point out the remaining risks, but perhaps one should also recognize the positive, liberal features of such a hierarchical model.

Ciao

--

Vittorio Bertola
Head of Policy & Innovation

Cell:

+39 348 7015022

Skype:

[email-masked]

Email:

[email-masked]

Twitter: @openexchange - Facebook: OpenXchange - Web: www.open-xchange.com

Open-Xchange AG, Rollnerstr. 14, 90408 Nuremberg, District Court Nuremberg HRB 24738
Managing Board: Rafael Laguna de la Vera, Carsten Dirks, Michael Knapstein, Stephan Martin
Chairman of the Board: Richard Seibt

European Office:
Open-Xchange GmbH, Olper Huette 5f, D-57462 Olpe, Germany, District Court Siegen, HRB 8718
Managing Director: Frank Hoberg

US Office:
Open-Xchange. Inc., 530 Lytton Avenue, Palo Alto, CA 94301, USA

Confidentiality Warning: This message and any attachments are intended only for the use of the intended recipient(s), are confidential, and may be privileged. If you are not the intended recipient, you are hereby notified that any review, retransmission, conversion to hard copy, copying, circulation or other use of this message and any attachments is strictly prohibited. If you are not the intended recipient, please notify the sender immediately by return e-mail, and delete this message and any attachments from your system.

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Mon, 12 Feb 2018 21:51:46 +0100

On Thu, Feb 08, 2018 at 03:03:34PM +0100,
 Vittorio Bertola <[email-masked]> wrote 
 a message of 223 lines which said:

>    (actually, even the current toy-scale blockchains are controlled
>    by an elite class of miners because they require so many
>    resources that only relatively few people can afford to run the
>    nodes, so I would not say that they could solve this problem).

A real analysis of the blockchains require more than one
paragraph. For instance, the blockchain is not "controlled" by the
miners because everything is public (that's the point) and collusion
between the miners to make false results would be detected (there are
many nodes which are not miners, it is not so demanding).

Also, Bitcoin is not the only blokchain. Bitcoun's proof-of-work
depends on an algorithm that can be implemented in specially-built
ASIC, so it is quite expensive to run a miner. Other blockchains have
different algorithms, often ASIC-resistant.

---

From: Vittorio Bertola <[email-masked]>
Date: Mon, 12 Feb 2018 22:21:03 +0100 (CET)

Il 12 febbraio 2018 alle 21.51 Stephane Bortzmeyer ha scritto:

Vittorio Bertola wrote

paragraph.

Agreed.

For instance, the blockchain is not "controlled" by theminers because everything is public (that's the point)

It is controlled by the miners because if they organize and decide to stop mining, the blockchain freezes and any service built on top of it becomes unavailable to new transactions. Other people having enough resources could pick up the work from there, but then they would become a new potential point of failure and so on. Of course, the more miners you have and the less likely this is to happen, but still this architecture makes a distinction in powers between the class of those who run a full node and the class of those who cannot afford to do so, much like, in the DNS, one could argue that the class of those who run a root server is conceptually more powerful than the others.

and collusionbetween the miners to make false results would be detected

But still, since they are the only ones adding new blocks, if acting together, they would be able to publicly alter/fork/takeover/whatever the blockchain.

(there aremany nodes which are not miners, it is not so demanding).

Yes, that's why one paragraph is not enough :-) But my point was rather than some degree of centralization is inherent in any directory system conceived up to now, including these fancy new ones, so we should not blame poor old DNS too much.

Regards,

--

Vittorio Bertola | Head of Policy & Innovation, Open-Xchange
[email-masked]
Office @ Via Treviso 12, 10144 Torino, Italy

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Tue, 13 Feb 2018 14:54:45 +0100

On Mon, Feb 12, 2018 at 10:21:03PM +0100,
 Vittorio Bertola <[email-masked]> wrote 
 a message of 41 lines which said:

>    the class of those who run a full node

You mean a miner? Full nodes are different (I run a full Bitcoin
node.)

>    But still, since they are the only ones adding new blocks, if acting
>    together, they would be able to publicly alter/fork/takeover/whatever
>    the blockchain.

Yes. My point is not that they cannot, but that it would be detected
(by full nodes).

---

From: Niels ten Oever <[email-masked]>
Date: Tue, 13 Feb 2018 17:57:27 +0100

Hi,

Would this be a better description:

The structuring of DNS as a hierarchical authority structure also brings
about specific characteristic, namely the possibility of centralized
policy making vis a vis the management and operation of Top Level
Domains, which is what (in part) happens at ICANN. The impact of ICANN
processes on human rights will not be discussed here.

Best,

Niels

On 02/08/2018 03:03 PM, Vittorio Bertola wrote:
> "a"? "Centralized policy making on the management and operation of
> domain names" is also being done in a number of different and
> uncorrelated places, either for each of the subtrees in the DNS
> hierarchy or for those nodes that have certain feature. First of all
> this happens at the national lawmaking level; also, each TLD defines
> their policies, and often second level domain administrators define
> policies too. I'd say that the policy making is as hierarchical as the
> system itself, or if you prefer centralized at each of the layers of the
> hierarchy for anything existing in the nodes below, rather than simply
> "centralized".
> 
> Also, "surveillance of the services running on the domain, domain based
> censorship [RFC7754 <https://tools.ietf.org/html/rfc7754>], or
> impersonation of the domain through DNS cache poisoning" are things that
> could also happen if the DNS were flat rather than hierarchical.
> 
> All in all, I guess that what you were trying to say is that if you
> could get a domain name without having to register it somewhere, just by
> publishing the registration independently, no one could censor/influence
> you by taking the domain down or by attaching conditions to the
> registration. This looks to me like blockchain hype: it's actually true
> for a part of the potential threats (but not, as I said, for some
> others), but, as of today, no one has found yet a workable way to remove
> that last piece of centralization (actually, even the current toy-scale
> blockchains are controlled by an elite class of miners because they
> require so many resources that only relatively few people can afford to
> run the nodes, so I would not say that they could solve this problem).
> 
> Moreover, the reason why the DNS is hierarchical is not because its
> authors wanted to introduce a central point of control, but exactly the
> opposite: the authors wanted to distribute control and management of the
> namespace so to make it less centralized and less controllable (even if,
> possibly, for practical engineering reasons rather than for political
> and ethical ones). So it makes sense to point out the remaining risks,
> but perhaps one should also recognize the positive, liberal features of
> such a hierarchical model.
> 
> Ciao
> 
> --
> 
> *Vittorio Bertola*
> Cell:	+39 348 7015022
> Skype:	[email-masked]
> Email:	[email-masked]
> <mailto:[email-masked]>
> 
> 
> Twitter: @openexchange <http://twitter.com/openexchange> - Facebook:
> OpenXchange <https://www.facebook.com/OpenXchange> - Web:
> www.open-xchange.com <http://www.open-xchange.com>
> Confidentiality Warning: This message and any attachments are intended
> only for the use of the intended recipient(s), are confidential, and may
> be privileged. If you are not the intended recipient, you are hereby
> notified that any review, retransmission, conversion to hard copy,
> copying, circulation or other use of this message and any attachments is
> strictly prohibited. If you are not the intended recipient, please
> notify the sender immediately by return e-mail, and delete this message
> and any attachments from your system.
> 
> 
> 
> _______________________________________________
> hrpc mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/hrpc
>