Subject: Re: [hrpc] draft-tenoever-hrpc-association-02

From: Niels ten Oever <[email-masked]>
Date: Tue, 6 Feb 2018 17:20:59 +0100

Hi,

On 11/28/2017 07:16 PM, Andrew Sullivan wrote:
> Hi,
> 
> On Thu, Nov 23, 2017 at 06:09:59PM -0600, Gisela Perez de Acha wrote:
>>
> 
>> 2. I loved Andrew’s definition of “the Internet” because I think it
>> talks about an assembly: an emergent-process-driven thing that is born
>> from the collections of the ASes that happen to be gathered together at
>> any given time. The fact that they tend to interact at any given time,
>> it’s an emergent property that happens because they use the protocols
>> defined at IETF.
> 
> I am not sure that's quite what I said, but I do think it's not quite
> what I meant.  Nevertheless, there's something you're tugging on that
> is in line with my point.
> 
>> 1. The OSCE-ODIHR Guidelines on Freedom of Peaceful Assembly  define
>> assembly as an intentional and temporary presence of a number of
>> individuals in a public place for a common expressive purpose. ( Source
>> https://www.osce.org/odihr/73405?download=true). Is this definition
>> enough? Can “machines” or “nodes within an AS” can be considered as an
>> individual for this purpose?
> 
> The problem this raises is that "the Internet" is an ongoing
> phenomenon, and "assembly" in that definition is not.
> 
> This was the point I was trying to make about "the traffic".  When I
> say, "The traffic is heavy on the 401, and never drops below 60% or
> 70% of road capacity," what I'm saying is that there's this ongoing
> phenomenon of vehicles being in relation to one another, without any
> of the individual vehicles staying the same.
> 
> This is _not_ the definition of assembly you're using: assembly is
> _this group_ of individuals, and they're gathered temporarily.
> 
> So, you might say that the nature of freedom of the Internet arises
> out of a freedom of assembly that is internetworking: any arbitrary
> set of network operators (you don't need ASes for this, I think) can
> network their networks together, and get an internet.  The totality of
> that behaviour together in the world is the emergent thing called
> _the_ Internet.  Any given member or set of members can refuse or fail
> to participate to some extent, which means that the Internet is fuzzy.
> The individual network operators who are internetworking might meet
> the definition of "assembly" you've been using, but the Internet does
> not get that even transitively.
> 
> Does that make sense?

This makes a lot of sense. For me this answers the question 'Is the
Internet an assembly?' Because the Internet not temporary, therefore it
is not an assembly. Now we should seek to answer the question whether
the Internet is an association (but I think the research question will
also look a bit different in the next version).

Thanks a lot!

Niels

> Best regards,
> A

---

From: Niels ten Oever <[email-masked]>
Date: Tue, 6 Feb 2018 17:25:44 +0100

On 12/04/2017 12:47 AM, Jefsey wrote:
> Gaines' one : "we [the users] are the internet".

Do you have a source for that by any chance? I would like to add it to
the glossary as one of the definitions.

Thanks!

Niels

---

From: Fred Baker <[email-masked]>
Date: Tue, 6 Feb 2018 13:09:40 -0800

I won't say that Jeffsey is wrong, but I will say that he has given one of several possible definitions. He's not particularly *right*.

Personally, I would look back to the documents written by the early Internet pioneers and their use of the term. These would include early RFCs, INWG documents, and so on. http://alexmckenzie.weebly.com/inwg-and-the-conception-of-the-internet-an-eyewitness-account.html is an interesting article in context, as is RFC 675, which is the first RFC that I find using the term.

What I find is that the term was used without a formal definition, but in every early context in which I find it, it is the domain in which an Internet Protocol packet might wander. RFC 675 is an early definition of what today we call TCP, and is used between the endpoints of such sessions. The other word that is used in that context is "internetwork", used as an adjective and as a verb ("internetworking").

For clarity, a contrast needs to be drawn with the word "catenet", which was used in the same timeframe to refer to "concatenated networks". An example of this is the Network-to-Network-Interface (NNI) definition from the ITU specifying a data circuit composed of a sequence of Frame Relay DLCs and ATM VCs; one sets up an end to end circuit composed of a random set of those, and whenever the circuit sees to change protocols, there is a defined algorithm for the translation. It's Y.1417, IIRC. One can set up a circuit, and transfer data from end to end using that circuit, without knowing the set of companies or technologies the path traverses, and data can travel end to end without being bumped up to a higher layer such as the Internet Protocol. That was a common view of networking in the 1970s, and even into the 1980s and 1990s in some technologies and SDOs; I heard it most recently in the SGIP context, where some wanted to implement gateways at the edges of every Smart Grid network to translate to the next.

The Internet is not a catenet - it is not a concatenated set of link layer technologies. Rather, each network implements whatever it likes, which might be an IP network, some random overlay, Ethernet here, Token Ring there, and MPLS somewhere else, or whatever else, and presents an IP-to-IP interface at its interconnects to other networks. There is no circuit, and no call setup. Rather, some device somewhere sends a packet, it wanders in whatever way it wanders, and it arrives somewhere else - the two places being specified by the source and destination addresses in the packet. The way the term was used by those that invented it (and failed to formally define it) was a set of networks that operated in some respects as a single larger network, a network of networks, using one addressing system and one internetworking protocol end to end.

To repeat: The Internet is a network of networks interconnected using the Internet Protocol.

Feeding exactly that sentence into Google, I come up with a number of interesting articles. One you could refer to, if you like, is https://www.igi-global.com/dictionary/internet/15369. It lists 93 different definitions, mostly taking the next higher view of the network that I have also often found people using. Definition 89 has it referring to the network that connects computers: "Internet is an electronic network connecting billions of computers globally", while definition 92 has it being the computers that are interconnected by networks: "Network of networks of computers".

I would actually push back pretty hard on the concept that the Internet is fundamentally a set of people, if only because many important points on the Internet are not people. Consider, if you will, the Internet of Things; it is comprised of a set of services of various kinds that communicate in various ways with a variety of sensors and actuators - telemetry devices and things that might be controlled after evaluation of those inputs in the context of some policy. There are people that are ultimately served by it and people that care about its operation, but as far as IOT itself is concerned, there is no human in the loop. That's why it's called the Internet of THINGS, in comparison to the Internet used by PEOPLE. Consider also the number of services in the network that are involved with even the simplest things a human user does - if I'm curious how many people live in Thailand, for example, I turn on tcpdump, open a browser, type "how many people live in Thailand", close tcpdump, and discover that I have captured 7149 messages exchanged with 44 peers in 46 identifiable sessions. I'll send you the file if you're interested. As far as I, the human, was concerned, I asked one question of one party - Google. You don't even want to think about how many entities were involved in the discussion.

If I'm talking about the Internet and what it is, I'd stick to the Internet itself, as opposed to what fits my predisposition...

> On Feb 6, 2018, at 8:25 AM, Niels ten Oever <[email-masked]> wrote:
> 
> 
> _______________________________________________
> hrpc mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/hrpc

---

From: Niels ten Oever <[email-masked]>
Date: Fri, 16 Feb 2018 14:51:27 +0100

Hi Fred,

Thanks for this. I took me a while to chew on this. I actually liked
your example where several definitions of the Internet were possible,
that next to each other, expose the different things one can think of a
network.

The most technical is probably something like:

Internet
: The Network of networks, that consists of Autonomous Systems that are
connected through the Internet Protocol (IP).

Less technical reductionist definitions will probably look like:

: A persistent socio-technical system over which services are delivered

: A techno-social assemblage of devices, users, sensors, networks,
routers, governance, administrators, operators and protocols.

Whereas I initially thought it might be better to push for one
definition I now think we can actually use this vocabulary ambiguity to
bring the different understandings of the Internet to the forefront,
because this might be at the core of many contemporary Internet discussions.

Best,

Niels