Subject: [hrpc] Thoughts on Intersection of Content and Protocols

From: Nalini J Elkins <[email-masked]>
Date: Tue, 18 Sep 2018 18:09:35 +0000 (UTC)

All,

These are some thoughts around content, protocols, the role of government, and human rights.   Bear with me, I believe they all relate to each other.  In particular, I believe they are intersecting now in both "censorship" and regulation.   I will also try not "hand-wave".  Specific protocol fields will be mentioned.  But, I need to set some background and motivations. 

1. We human beings often choose to live in nation-states and have a social contract with a group from within our ranks which we choose to call "government".   We choose to abridge some of our rights and pay them some of our hard-earned money (taxes) in return for some benefits we hope to gain.   Some of these include: acting against criminal activity, doing things for the common good (parks, schools, roads, fair elections) and so on. 

Now, governments may be further broken down: 

a.  Government in a nation-state which by-and-large tries to follow the rule of law.  (Although one wonders at times.) 

b.  Authoritarian governments 

c.  Rogue nations 

d.  Failed states 

(There may be other classifications but I think you get the point.) 

2.  Let us take some content providers on the Internet : Facebook, Twitter, Google (YouTube) etc. 

These are not ethereal pieces of vaporware with no existence in reality.   They are real companies with real checking accounts who pay taxes and are incorporated to do business under the laws of one or more nation-states. 

3.  More and more, governments (by and large, governments which attempt to follow the rule of law) are becoming quite aware that content on the Internet affects real human beings.  And taking action by legislation. 

4.  Content on the Internet can be classified broadly as : problematic and non-problematic. 

We are not concerned here with non-problematic content. 

Problematic content can be further categorized but let's just take one category:

-- Criminal activity 

Let's take some acts which are generally considered criminal by many governments / people over time.   These activities also happen as Internet content. 

Such acts include: 

* Violent offence against people or inciting such (firearms and offensive weapons may fall here) 
* Sexual offences or inciting such 
* Offences against property (Forgery, impersonation and cheating) 
* Other dangerous acts against people (harmful or dangerous drugs may fall here) 
* Offences against the State/offences against the Crown and Government/political offences (this is likely to be most seen as the purview of the authoritarian or failed state, but not exclusively so.) 

5.  There is activity which some may call "censorship" or "blocking" content.

For example, the EU wishes to fine FB, Google, etc. for problematic content.  You may wish to read the article below: 

https://www.bbc.com/news/technology-45495544 

"If authorities flag content that incites and advocates extremism, the content must be removed from the web within an hour, the proposal from the EU's lead civil servant states. Net firms that fail to comply would face fines of up to 4% of their annual global turnover." 

In fact, the social media companies are indeed attempting to act to "block" or censor content. 

Again, from the article: 

"In 2017, Google said it would dedicate more than 10,000 staff to rooting out violent extremist content on YouTube 

YouTube said staff had viewed nearly two million videos for violent extremism from June to December 2017 

YouTube said more than 98% of such material was flagged automatically, with more than 50% of the videos removed having fewer than 10 views 

Industry members have worked together since 2015 to create a database of "digital fingerprints" of previously identified content to better detect extremist material. As of December 2017, it contained more than 40,000 such "hashes" 

in 2017, Facebook claimed that 99% of all Islamic State and al Qaeda-related content was removed before users had flagged it. The social network said that 83% of the remaining content was identified and removed within an hour 

between August 2015 and December 2017, Twitter said that it had suspended more than 1.2 million accounts in its fight to stop the spread of extremist propaganda. It said that 93% were flagged by internal tools, with 74% suspended before their first tweet." 

6. So, why would these companies act to "block content"?   Possibly because they wish to avoid regulation.  As I said before, these companies have a real presence under the regulations of real nation-states.   The Internet content referred to above can lead to real harm to real people.  Government (possibly rightfully) feels that it has an interest in legislation in this area. 

Why would government wish to "block content" or have censorship?  In this case, I would say to protect some people's right to live without being subject to violence.  A human right.

7.  I had discussed before potentially blocking content for plans for 3-d printed guns. Clearly, there is legislation on this in the United States.  It is likely
that other nation-states will follow.  Or possibly put up nation-state firewalls.  Again, to protect the most basic of human rights.

8.  Now, at times, the government itself may be the "criminal".  Clearly, not all governments or government agencies act in the interests of all their people.  Take the case of Myanmar. Apparently, FB had very few people who could read Burmese.  So, posts were not reviewed.   The posts by the military led to wholesale killing of Rohingya muslims.   

https://www.theguardian.com/technology/2018/aug/27/facebook-removes-accounts-myanmar-military-un-report-genocide-rohingya

FB is now censoring such posts in the interests of preserving the human right to live for the Rohingya people.

9.   Let us now discuss the intersection of protocols and content. 

a.  There is a great deal of intersection in the area of criminal activity around financial theft.   You may think of phishing, homographic attacks, fraud, data leakage and so on.  There is a group which is working on this to propose a potential new research group at the IRTF.   I do not wish to steal any of their thunder and will encourage you to sign up for their proposal and email list when they have it. 

b.  Another relatively simple intersection is IP addresses.   Here is one where the FBI used IP addresses to prosecute visitors to a child pornography web site. 

https://gizmodo.com/fbis-disturbing-hacking-powers-challenged-in-court-over-1794885187 

Interpol has also complained about CGN because it hides IP addresses.   They wish to tie IP addresses to the user.  (Now, of course, as we know, an IP address as an identifier is of limited value for many reasons.  But, it is certainly an example of the intersection of protocols and content.) 

https://www.europol.europa.eu/newsroom/news/closing-online-crime-attribution-gap-european-law-enforcement-tackles-carrier-grade-nat-cgn 

Might one expect legislation in this area in the future? 

c.  The end-to-end principle.   Some in the IETF have told me (paraphrasing somewhat) that "Some of us who have been in the IETF for many years find that having smart endpoints and a dumb network is the best architecture.  This is the end-to-end principle."   Others believe that the end-to-end principle leads to an unsustainable trajectory to ever more complex endpoints and network functions. 

The intersection of content and protocols here is that if you have the "endpoint" being the only viewer of the unencrypted data (for example), then no middlebox on the network can remove ads (for example).   Taking out ads would remove a source of revenue for people who control the endpoints. 

Now, I am not in the least against companies having a business model and even being extremely successful at implementing the business model.  The people at "endpoint" companies are smart, work very hard and are successful.  Good for them.

I am merely providing another example of the intersection of protocols and content. 

 Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 18 Sep 2018 21:59:25 +0100

Hiya,

I agree with a number of the points you make but I think your
argument doesn't yet hold together.

Two main reasons:

> problematic and non-problematic.

This is pretty clearly wrong. The same content can be classified as
either depending who you ask. The classification can change over time
even asking the same person. Even "The content" isn't necessarily
that useful - what's "The content" for a web page with a href to
a picture of a kitten and another to some JS code that does modular
exponentiation? (The latter would be classified problematic by some.)
Most web pages are an order of magnitude more complex than my toy
example here btw, involving a whole host of parties.

Some of the same ambiguities apply to other things on which you
base your argument, e.g. 30 years ago the Irish government suffered
a lot from corruption that we (those of us not "in the know") didn't
know about at the time. I hope and suspect that the situation is
better now in that case, but back then it meant that a non-trivial
number of cases that appeared to demonstrate following the rule of
law, weren't that in reality. Similarly, before Snowden, many of us
didn't appreciate the scale of 5eyes activities, yet they were
happening. And governments being very large organisations, they also
tend to be acting in many ways at once - e.g. at the same time as
running BULLRUN, other bits of the US govt were doing fine work
to make crypto better.

> We are not concerned here with non-problematic content.

Yes we are. Any content can be claimed to be problematic with a
bit of inventiveness. Joyce's Ulysses was not actually banned in
Ireland but the censorship then in place was sufficient so that
nobody imported it for sale for many years. That book would now
be considered a major cultural asset by the Irish government.

I'm not trying to just poke holes - if we wanna do some such
analysis properly we need to consider the subtleties that are
really involved.

I think the above shows weak points in your analysis so far.
I'm not sure how fixable those are tbh, but it could be that
those weak points are fixable.

However, (and this is the 2nd main point where I disagree with
your argument), even without those weak points, and even if I
accepted all your earlier points, then I'd still say that there's
a mega-gap between all those made earlier and your IMO unjustified
leap to the e2e argument.

> c.  The end-to-end principle.   Some in the IETF have told me
> (paraphrasing somewhat) that "Some of us who have been in the IETF
> for many years find that having smart endpoints and a dumb network is
> the best architecture.  This is the end-to-end principle."   Others
> believe that the end-to-end principle leads to an unsustainable
> trajectory to ever more complex endpoints and network functions.
> 
> The intersection of content and protocols here is that if you have
> the "endpoint" being the only viewer of the unencrypted data (for
> example), then no middlebox on the network can remove ads (for
> example).   Taking out ads would remove a source of revenue for
> people who control the endpoints.

Seems hypothetical - has there ever been such a MITM attack box
that only existed to remove ads? (There may have been some to
replace ads, but none to just remove them afaik.)

> Now, I am not in the least against companies having a business model
> and even being extremely successful at implementing the business
> model.  The people at "endpoint" companies are smart, work very hard
> and are successful.  Good for them.
> 

I'd suggest we'd be far better off not entangling this discussion
with attempts (previous, current or future) to weaken crypto. There
are many aspects of this that could perhaps usefully be considered
that have nothing to do with e2e confidentiality, and as we know,
that latter topic is highly controversial. (And after all, we just
got done with not breaking TLS in the IETF, we should give the
topic at least a summer off:-) My prediction is that if we cannot
put that issue aside, this discussion will go nowhere.

Cheers,
S.

> 
> Thanks,
> 
> Nalini Elkins CEO and Founder Inside Products, Inc. 
> www.insidethestack.com (831) 659-8360
> 
> _______________________________________________ hrpc mailing list 
> [email-masked] https://www.irtf.org/mailman/listinfo/hrpc
>

---

From: Nalini J Elkins <[email-masked]>
Date: Tue, 18 Sep 2018 21:22:12 +0000 (UTC)

Stephen,
Shockingly enough, I think we might be able to come to some agreement on a number of things.   Has H*** frozen over?
> The same content can be classified as either depending who you ask. 
Yes, absolutely.  I had originally intended to add several more paragraphs on how this would happen.  But, I felt I had rambled on long enough.   Actually, it is likely even more complex than that.   Rashomon comes to mind.
I suspect though, that there are some types of content that we may be able to agree on as being problematic.  Throughout history, people seem to have managed to reach some consensual agreement within each culture on those things.
But, I think a more fruitful path might be to think about what is important for us as a community to know and think about these issues at this particular point in time.  

> And after all, we just got done with not breaking TLS in the IETF, we should give the topic at least a summer off:-)
Despite my objection to your characterization of the effort as "breaking", in the interests of reaching some level of community agreement, I will take the e2e argument as well as anything about crypto as it is highly unlikely that you and I will be able to reach any type of understanding on those issues.
How about this?  Why don't we start with maybe you talking about what you DO agree with or what you think are the most important points for us as a community to deal with around this topic?
Thoughts?
 Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

      From: Stephen Farrell <[email-masked]>
 To: Nalini J Elkins <[email-masked]>; Hrpc <[email-masked]> 
 Sent: Tuesday, September 18, 2018 9:59 PM
 Subject: Re: [hrpc] Thoughts on Intersection of Content and Protocols

Hiya,

Two main reasons:

Cheers,
S.

> [email-masked] https://www.irtf.org/mailman/listinfo/hrpc
[email-masked]
https://www.irtf.org/mailman/listinfo/hrpc

---

From: Vittorio Bertola <[email-masked]>
Date: Wed, 19 Sep 2018 10:15:07 +0200 (CEST)

>     Il 18 settembre 2018 alle 22.59 Stephen Farrell < [email-masked] mailto:[email-masked] > ha scritto:
>      
> 
>     either depending who you ask.
> 
The sum of these two is IMHO the biggest tension that we have now. The Internet was conceived on the idea that layers could be separated, transport should be neutral, and everyone got to access the same things everywhere. Reality is that content that is ok, or even very desirable, for certain people, is problematic for others; and that there are authorities that have to act as "semi-centralized" checkpoints for content monitoring and control (semi-centralized meaning that it's not a single authority for the entire Internet, but it is a single authority for an entire network or an entire country, so, seen from within that subset of the Internet, it is a centralized single point of control).

Though, of course, there also are people (in my perception, disproportionately represented in the IETF) that still think that there should be no point of control whatsoever and the Internet should still follow the ideal model of the last century; and there is an issue with who gets to decide who can act as a content control checkpoint, since you have at least three possible cases:
- content control that the user wants (e.g., parental control mechanisms, ad removal, or security filters)
- content control that the user does not want, but is mandated and made legitimate by applicable real-world sovereignty features (e.g. governmental site blocking)
- content control that the user does not want and is not mandated or even allowed by law, but still is being done by third parties for commercial reasons (e.g. violations of net neutrality, traffic analysis and monetization etc.)

So, the technical challenge I see is to preserve the good things about the original model as far as possible, while also supporting architectural features that provide differentiated access to content and multiple layers of "semi-centralized" content control authorities, giving the user some control on who acts as content control authority, but not enough of it to make it possible to bypass sovereignty.

Regards,

--

Vittorio Bertola | Head of Policy & Innovation, Open-Xchange
[email-masked] mailto:[email-masked] 
Office @ Via Treviso 12, 10144 Torino, Italy

---

From: Amelia Andersdotter <[email-masked]>
Date: Wed, 19 Sep 2018 13:14:45 +0200

On 2018-09-19 10:15, Vittorio Bertola wrote:
>
>> Il 18 settembre 2018 alle 22.59 Stephen Farrell <
>> [email-masked] <mailto:[email-masked]>> ha
>> scritto:
>>  
>>
> The sum of these two is IMHO the biggest tension that we have now. The
> Internet was conceived on the idea that layers could be separated,
> transport should be neutral, and everyone got to access the same
> things everywhere. Reality is that content that is ok, or even very
> desirable, for certain people, is problematic for others; and that
> there are authorities that have to act as "semi-centralized"
> checkpoints for content monitoring and control (semi-centralized
> meaning that it's not a single authority for the entire Internet, but
> it is a single authority for an entire network or an entire country,
> so, seen from within that subset of the Internet, it is a centralized
> single point of control).
>
> Though, of course, there also are people (in my perception,
> disproportionately represented in the IETF) that still think that
> there should be no point of control whatsoever and the Internet should
> still follow the ideal model of the last century; and there is an
> issue with who gets to decide who can act as a content control
> checkpoint, since you have at least three possible cases:
> - content control that the user wants (e.g., parental control
> mechanisms, ad removal, or security filters)
> - content control that the user does not want, but is mandated and
> made legitimate by applicable real-world sovereignty features (e.g.
> governmental site blocking)
> - content control that the user does not want and is not mandated or
> even allowed by law, but still is being done by third parties for
> commercial reasons (e.g. violations of net neutrality, traffic
> analysis and monetization etc.)
>
> So, the technical challenge I see is to preserve the good things about
> the original model as far as possible, while also supporting
> architectural features that provide differentiated access to content
> and multiple layers of "semi-centralized" content control authorities,
> giving the user some control on who acts as content control authority,
> but not enough of it to make it possible to bypass sovereignty.
>
I thought Andrew made a good point earlier in this regard: are measures
requesting control aimed at changing the protocols or the architecture
for protocols as deviced within IETF? Or are they in fact measures for
control to be applied somewhere else?

I revert to my W3C example (EME in HTML5) from when Andrew first brought
it up. It looks to me clearly destined for some other form of
standardisation than that which occurs at the IETF.

best,

A

> [email-masked] <mailto:[email-masked]> 

-- 
Amelia Andersdotter
Technical Consultant, Digital Programme

ARTICLE19
www.article19.org

PGP: 3D5D B6CA B852 B988 055A 6A6F FEF1 C294 B4E8 0B55

---

From: Vittorio Bertola <[email-masked]>
Date: Wed, 19 Sep 2018 14:32:25 +0200 (CEST)

> Il 19 settembre 2018 alle 13.14 Amelia Andersdotter <[email-masked]> ha scritto:
>

Well, for example (the one I am familiar with) the already mentioned DNS-over-HTTPS protocol does just that - it is a technical measure designed to make it impossible for governments and ISPs to exert control via DNS-based policies on the content that is made accessible to their citizens/users, and if you have that discussion with the authors, they will proudly say that this is intended. So it is definitely not policy-neutral; the protocol could have encompassed ways for appropriate parties to supply DNS filtering policies, or at least recommendations to find ways to do so, but it does not.

Regards,
-- 

Vittorio Bertola | Head of Policy & Innovation, Open-Xchange
[email-masked]
Office @ Via Treviso 12, 10144 Torino, Italy

---

From: Nalini J Elkins <[email-masked]>
Date: Wed, 19 Sep 2018 14:59:32 +0000 (UTC)

>Well, for example (the one I am familiar with) the already mentioned DNS-over-HTTPS protocol does just that - it is a technical measure >designed to make it impossible for governments and ISPs to exert control via DNS-based policies on the content that is made accessible to >their citizens/users, and if you have that discussion with the authors, they will proudly say that this is intended. So it is definitely not policy->neutral; the protocol could have encompassed ways for appropriate parties to supply DNS filtering policies, or at least recommendations to >find ways to do so, but it does not.
I might also add that at times when I have been part of a proposed protocol change discussion, it is stated to me by others as a show-stopper that the proposed feature *could* be used by a coercive government to repress its people.  The reverse, that is, that a feature might be used by a benign government to protect its people, is apparently not to be discussed.
I also recall Mallory's statement about the group (whether she meant HRPC or the IETF is not clear) 
"It seems to me that if more and more measures are passed by governments to regulate content, while efforts in protocol and standards development try to push more and more anti-censorship and resilience of content like this group, then at some point that divergence is going to precipitate efforts to influence design and development at these lower layers."
So, what exactly are these "protocol efforts to push anti-censorship"?   
Should any of these discussions be at the IETF?
Nalini

---

From: [email-masked]
Date: Wed, 19 Sep 2018 20:33:11 -0400

I'll suggest that something needed in your breakdown is the ability of
end-users to filter content as they see fit and how that can be
facilitated.

Protocols which for example enable tagging of content and thus
facilitate endpoint filtering are very different from external actors
(govt, companies) filtering.

And how do we determine which, end point or external, is superior.

This is implied by your "end-to-end principle" section but begs more
explicit analysis.

-- 
        -Barry Shein

Software Tool & Die    | [email-masked]             | http://www.TheWorld.com
Purveyors to the Trade | Voice: +1 617-STD-WRLD       | 800-THE-WRLD
The World: Since 1989  | A Public Information Utility | *oo*

---

From: Nalini J Elkins <[email-masked]>
Date: Thu, 20 Sep 2018 10:46:52 +0000 (UTC)

Barry,
>I'll suggest that something needed in your breakdown is the ability of>end-users to filter content as they see fit and how that can be>facilitated.
>Protocols which for example enable tagging of content and thus>facilitate endpoint filtering are very different from external actors>(govt, companies) filtering.
>This is implied by your "end-to-end principle" section but begs more>explicit analysis.

I think this is an interesting area for analysis. But, let me presenta somewhat broader picture.  I propose the following:
1.  Some history of content classifications
2.  Who will do it?
3.  How will it be done?
4.  A meta-question: where should this discussion take place?

First, let me say that, at least in my opinion, WE MUST TRY TO PRESERVE THE FREEDOMOF SPEECH FOR POLITICAL DISSIDENTS.  We need to balance their needs with the need of others for safety.  This is as much selfish as anything. I am kind of a loud mouth myself (as you may have gathered) and I wish to retain the right to freely speak my political opinions, as much as possible.
So, let's analyze this problem a bit.  Let me start by apologizing for how long thispost is.  It is a complex problem with many facets.

Section 1.  Some history of content classification
The problem of content classification has come up before.  We may look to the movie industry. People wish to know before they take their children to see a particular movieif it has objectional content of some type.
Here is the Wikipedia entry:
https://en.wikipedia.org/wiki/Motion_picture_content_rating_system
Quoting from that entry:
"A motion picture content rating system is designated to classify films with regard to suitability for audiences in terms of issues such as sex, violence, substance abuse, profanity, impudence or other types of mature content. A particular issued rating can be called a certification, classification, certificate or rating. Ratings typically carry age recommendations in an advisory or restrictive capacity, and are often given in lieu of censorship. In some jurisdictions the legal obligation of administering the rating may be imposed on movie theaters." Books, in my knowledge (which may be lacking) for instance, are generally not rated, exceptin the most egregious cases.  One is rather horrified, in fact, to think of books asbeing rated.  Except to protect children from explicit sexual or violent content.  But,I am speaking as a parent from a particular cultural background.  YMMV. Just my opinion, but I would like to see only the most offensive cases of Internet contentas having some type of rating.  Maybe .0001 percent of all content on the Internet, something like that.  But, we do not know yet have any specifics.  We have no real data to supportany statements.
There are, of course, cultural and personal variations on how content is regarded. Currently,movie ratings are done by nation-states.  More on this in the "Who will do this" section.
For example, one might conceive of a taxonomy such as:
A. Criminal content
* Violent offence against people or inciting such (firearms and offensive weapons may fall here) * Sexual offences or inciting such * Offences against property (Forgery, impersonation and cheating) * Other dangerous acts against people (harmful or dangerous drugs, fake pharmaceutical sites) 

B. "Fake content", hate speech, or content aimed at spreading terrorism 
I understand this will be controversial but I think it is an important category to discuss.This is what apparently caused the killings of the Rohingya muslims.
https://www.theguardian.com/technology/2018/aug/27/facebook-removes-accounts-myanmar-military-un-report-genocide-rohingya
It may in the future have more impact.  One might easily imagine a fake video with Mr. Trump declaring war on [North Korea / China / Canada].  This is likely to cause disruption.
I understand that Facebook, as well as a number of academic institutions, are already working in thespace of trying to detect fake content.

C.  Content which is intentionally addictive
Governments often feel compelled to step in with regulation for things which cause addiction to their populace. In the past, it was narcotics.  From the Wikipedia entry on the First Opium War:
https://en.wikipedia.org/wiki/First_Opium_War
"In the 17th and 18th centuries, the demand for Chinese goods (particularly silk, porcelain, and tea) in Europe created a trade imbalance between Qing Imperial China and Great Britain. European silver flowed into China through the Canton System, which confined incoming foreign trade to the southern port city of Canton. To counter this imbalance, the British East India Company began to auction opium grown in Indiato independent foreign traders in exchange for silver, and in doing so strengthened its trading influence in Asia. This opium was transported to the Chinese coast, where local middlemen made massive profits selling the drug inside China. The influx of narcotics reversed the Chinese trade surplus, drained the economy of silver, and increased the numbers of opium addicts inside the country, outcomes that worried Chinese officials."
The Chinese government took action.  You may be familiar with what happened.
Some feel that some content on the Internet, particularly on mobile phones, particularly on some platforms,is intentionally formulated to be addictive.  Some call this the "Dopamine economy".
One might expect to see regulation in this area.

D.  Content about a specific person subject to the "Right to be forgotten".  As I understand, it is extremelydifficult to actually comply to this regulation.  You may wish to read an interesting book on thistopic "So You've Been Publicly Shamed" by Jon Ronson.
https://en.wikipedia.org/wiki/So_You%27ve_Been_Publicly_Shamed

E.  This is not an exhaustive taxonomy.  I wonder if we need a group of people to collaborate on developing a taxonomy and have an open discussion in some forum.  I do not know where that forum should be.Should it be at the IETF?  Should it be in another SDO?  Should it be in a new group sponsored byISOC?
I think it is likely premature to discuss that before we have more of a feel of the boundaries of this problem.
I do believe, though, that there are implications for protocols.  As in, if a classification system isdeveloped, then IETF protocols should respect that classification.  How this will play out, I do not know.

Section 2.  Who will do this?
A.  For the movie industry, it varies.  Again from the Wikipedia entry:
"In countries such as Australia and Singapore, an official government body decides on ratings; in other countries, such as the United States, it is done by industry committees with little if any official government status. In most countries, however, films that are considered morally offensive have been censored, restricted, or banned. Even if the film rating system has no legal consequences, and a film has not explicitly been restricted or banned, there are usually laws forbidding certain films, or forbiddingminors to view them."
Where the analogy between movie content and Internet breaks down is in the level of impact. (No analogyis perfect.)  The impact of Internet content appears to have a much greater level of potential harmthan most movies.  People can actually get killed by unfortunate Internet content.

B. As I said before in another (overly lengthy post) today, there are de-facto efforts by content providers: Facebook, Twitter, Google (YouTube) to self-censor.
https://www.bbc.com/news/technology-45495544
To quote from that article:
"In 2017, Google said it would dedicate more than 10,000 staff to rooting out violent extremist contenton YouTube 
YouTube said staff had viewed nearly two million videos for violent extremism from June to December 2017 
YouTube said more than 98% of such material was flagged automatically, with more than 50% of the videos removed having fewer than 10 views 
Industry members have worked together since 2015 to create a database of "digital fingerprints" of previously identified content to better detect extremist material. As of December 2017, it contained more than 40,000 such "hashes" 
in 2017, Facebook claimed that 99% of all Islamic State and al Qaeda-related content was removed before users had flagged it. The social network said that 83% of the remaining content was identified and removed within an hour 
between August 2015 and December 2017, Twitter said that it had suspended more than 1.2 million accounts in its fight to stop the spread of extremist propaganda. It said that 93% were flagged by internal tools, with 74% suspended before their first tweet." 

C. The UK government has also been working in this area.  They want to help the smaller social media platformsand content providers.
https://www.gov.uk/government/news/new-technology-revealed-to-help-fight-terrorist-content-online
To quote from the article:
"The Home Office has today announced the development of new technology to automatically detect terrorist content on any online platforms."
This technology can be used by social media platforms who are NOT FB, Twitter, and YouTube.

D.  One option we have is to simply rely on governments and content providers to police content accordingto the needs they see fit.  This has the merit of simplicity.  None of us really have to do anythingbut sit back and watch.  This is somewhat compelling as I suspect we all prefer to do actual protocoldesign. 
But, the problem is likely to come when there is a conflict with a protocol specification by the IETFand a government regulation.  It is also likely to move governments to reach into lower and lower levelsof the protocol stack to regulate.  It may be a good idea to work together with regulators / governmentto think over these issues.

Section 3: How will it be done?
This is an area where protocol design is most directly affected.
There are at least four types of content: (I am sure you can think of more)
- standalone web sites- content on some platform (social media, YouTube, SnapChat, etc)- email- forums for discussion
I suspect that the content filtering we are talking of is for the first two.

A. Today, some filtering of content (parental controls) for standalone web sites is done by DNS proxies (as I understand from talking to one ISP).  I suspect that this may come into conflict with DNS over HTTPS.
B. Filtering of content on platforms is done by self-censorship.  Is this OK?
C. Some have suggested a tag for web sites.  If done, this should be respected by IETF protocols.  Thereis a question of who should do this?  Should it be directives by some SDO to search engines?
D. To quote from one of Vittorio's posts:
"[We] have at least three possible cases: 
- content control that the user wants (e.g., parental control mechanisms, ad removal, or security filters) - content control that the user does not want, but is mandated and made legitimate by applicable real-world  sovereignty features (e.g. governmental site blocking) - content control that the user does not want and is not mandated or even allowed by law, but still is being  done by third parties for commercial reasons (e.g. violations of net neutrality, traffic analysis and monetization etc.) 
Clearly, there is a potential tension between these.

Section 4: The Meta Issue: Where should this discussion take place?
I, for one, think that this is probably one of the most important issues facing us today.  As you might deduce from my extremely lengthy (sorry!) posts.
I am quite happy to move this discussion to the [email-masked] email list. Or even to stop talking aboutthis altogether and approach another SDO (ETSI, ITU) to see if they are interested in this topic.
I believe that this issue has protocol implications and would like to see this discussion take placeat the IETF (or ISOC) somewhere.  But, I pose the question to the community to decide.
  Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

---

From: Nalini J Elkins <[email-masked]>
Date: Thu, 20 Sep 2018 10:46:52 +0000 (UTC)

Barry,

Nalini Elkins
CEO and Founder
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

---

From: [email-masked]
Date: Thu, 20 Sep 2018 14:40:28 -0400

For the purpose of this list I tend towards mechanism rather than
policy.

That is, how protocols might be used, abused, or even invented to help
others implement policy both good and bad.

But it is true that one needs some vision of the goals to effect that,
so broader context is appropriate.

In my ideal world tagging of content would be done by independent
organizations funded largely by those with an interest, such as the
large social media organizations.

This should encourage commercial efforts to provide end-users ways to
implement this tagging according to their own desires such as we've
seen with "Net Nannies".

Following the film analogy this is basically how the US' Motion
Picture Association of America (MPAA) works.

The MPAA was formed in 1922 and established a system of film ratings
in 1968.

Its importance arose largely after films gained sound and thus greater
popularity which produced a hue and outcry regarding film content

In reaction to congressional threats to regulate film content the film
industry formed the so-called Hays Code headed by former
postmaster-general Will H Hays and major studios agreed to abide by
that code. The code was largely abandoned piecemeal in the 1950s and
on but other self-regulation was continually being adopted (e.g.,
standards on racism and sexism, romanticization of tobacco smoking.)

Films were rarely outright banned only "tagged" with a rating which
was publicly displayed in advertisements and theater entrances.

Many theater owners refused to show films with certain ratings
probably both because they didn't want their theater identified with
such films -- thus grew "art houses", theaters which specialized in
such films -- and their income potential was often not very good.

I remember, and perhaps this is still true, the Roman Catholic Church
publishing lists of films which their adherents should not see. A
friend's mother would pull it out and carefully check it before
letting any of her children go to a film and sometimes we had to
change our plans.

The point is that by and large this approach seems to have worked for
films though there's a contingent who would dispute that.

What has significantly changed is we seem to have lately broadened
what might be deemed offensive and in need of some sort of controls.

Typical sources of offensiveness in films, TV, etc were:

1. Sexually explicit
2. Amoral such as romanticizing crime
3. Extreme depictions of violence or gore
4. Offensive language

There were others.

Today we seem to have, or at least have fine-tuned:

1. Cultural and gender stereotyping and/or offensiveness
2. Promotion or depiction of unpopular political or
   religious ideas
3. Fake news by some standard
4. Attempts to influence elections by some standard
5. Smoking tobacco (not just ads but mere depiction)
6. Bullying, which tends to require an individual target
7. Harrassment
8. Commercial fraud
9. Unwanted exposure to sexually explicit or violent content

Of course commercial fraud has always been a concern but with spam and
phishing etc there has been a marked attempt to be more pro-active.

The point is this is a huge, broad, and culturally-relative set of
concerns trying to regulate something as vast as the billions on the
internet with few central points of control.

I believe that any attempt to provide mechanism has to take into
account this vastness.

Which is why I see mechanisms such as tagging content as potentially
much more productive than trying to create taxonomies of content which
some believe needs control.

-- 
        -Barry Shein

---

From: Nalini J Elkins <[email-masked]>
Date: Thu, 20 Sep 2018 20:16:39 +0000 (UTC)

Barry,
>some believe needs control.
 I think we will get stuck on taxonomy but let's follow your train of thought andsee where we get to.   I am just thinking out loud here.
Let's just take web sites.   We can think about content on platforms later.
So, we need the following:
1.  First, some group to do the classification.  We call this: Classifying_Group.   They use a methodology for assigning a rating to the     web site.   
     Call this: Content_classification.
     Values: 1= no problem to 5= really horrible.
     How they come by the rating (or the methodology) is TBD.
2.  Then we need some means of associating the classification with the content
     What might we do?

     a.  We could have an IPv6 Destination Option which had a field:
     Content_classification
     Values: 1= no problem to 5= really horrible.
     How does that field get populated?   Maybe there is an initial setting when you do the DNS lookup.  Let's say each DNS server knows     about the rating of the web site.

     b.  We could have a browser plug in.   Maybe each browser knows about the rating of the web site.

     c.  Now, this is all quite crude.  I am sure you can think of a hundred ways to break / spoof these methods.  As I say, I am just          thinking out loud.  I am pretty sure that if we put our collective heads together, then we could come up with some way          to "tag" a web site. 
3.  So, I think the really hard problem here is what methodology / taxonomy will the classifying_group use to rate web sites?   That is, what     is the criteria whereby one web site is a "1" and another is a "5"?
Thoughts?

Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 20 Sep 2018 21:35:16 +0100

Hiya,

Sorry to keep picking holes but...

On 20/09/18 21:16, Nalini J Elkins wrote:
> 1.  First, some group to do the classification.  We call this:
> Classifying_Group.   They use a methodology for assigning a rating to
> the     web site.

Web sites are not static things. They change all the time, esp
the related advertising content. And even the "primary" content
for some web sites with lots of user-generated content changes
all the time (e.g. discussion boards). (*)

So I don't think any scheme for classification based on ideas
of static content is that useful here, if what we're after are
ideas as to how or if we might change protocols to address the
real issues with centralisation etc. If what someone is after
is a way to regulate operators of services based on some non
technical view of what they do, then I'm also unsure that that
needs to affect protocols that are broadly used.

In passing I'd also note that labelling systems (e.g. in multi
level security) have always been horrendously expensive and, if
not then often brittle, so I'd be surprised if such a generic
labelling scheme for protocols would fly. But there may be some
proposals like that in the literature if someone wants to root
them out.

S.

(*) The same is true of many forms of what I guess is being
called "content" in this thread - which is why I didn't reply
to your earlier email - I'm not sure myself how to classify
protocol payload in a way that's at all useful for this
discussion and even if we did I'm not sure that calling it
"content" is useful. I am thinking a bit about it though.

---

From: Tony Rutkowski <[email-masked]>
Date: Thu, 20 Sep 2018 16:40:21 -0400

Hi Nalini,

In many respects, Bob Kahn (yes, that Bob Kahn) has provided the DOI
platform for this kind of content tagging. See www.doi.org. Bob's platform
is additionally attractive because you can use multiple rating tables for
the same object.  It also probably the most ubiquitous of the tagging
platforms because of its use for IPR assertions.

Like all these schemes, however, the challenge is getting users to use them.

On Thu, Sep 20, 2018, 4:16 PM Nalini J Elkins <
[email-masked]> wrote:

> I think we will get stuck on taxonomy but let's follow your train of
> thought and
> see where we get to.   I am just thinking out loud here.
>
> Classifying_Group.   They use a methodology for assigning a rating to the
>      web site.
>
>      How they come by the rating (or the methodology) is TBD..
>
>      How does that field get populated?   Maybe there is an initial
> setting when you do the DNS lookup.  Let's say each DNS server knows
>      about the rating of the web site.
>
>
>      c.  Now, this is all quite crude.  I am sure you can think of a
> hundred ways to break / spoof these methods.  As I say, I am just
>           thinking out loud.  I am pretty sure that if we put our
> collective heads together, then we could come up with some way
>           to "tag" a web site.
>
> 3.  So, I think the really hard problem here is what methodology /
> taxonomy will the classifying_group use to rate web sites?   That is, what
>      is the criteria whereby one web site is a "1" and another is a "5"?
>
> Thoughts?
>
>
> Thanks,
>
> Nalini Elkins
> CEO and Founder
> Inside Products, Inc.
> www.insidethestack.com
> (831) 659-8360
>
>

---

From: Nalini J Elkins <[email-masked]>
Date: Thu, 20 Sep 2018 20:53:44 +0000 (UTC)

Stephen,
>all the time (e.g. discussion boards). (*)
Yes, that could all be true but somehow search engines manageto keep up pretty well with changing content on web sites.
But, I am interested to see what Barry thinks.  I was expandingon his idea of tagging web sites.  I am wondering if what I saidis what he was thinking of.   

Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

---

From: Tony Rutkowski <[email-masked]>
Date: Thu, 20 Sep 2018 17:14:15 -0400

Bob Kahn would dispute your assertion.

---

From: Ted Lemon <[email-masked]>
Date: Thu, 20 Sep 2018 17:55:24 -0400

On Sep 20, 2018, at 4:53 PM, Nalini J Elkins <[email-masked]> wrote:
> Yes, that could all be true but somehow search engines manage
> to keep up pretty well with changing content on web sites.

That's a different problem.   You aren't dealing with a creative adversary in this case: the interests of the site owner and of the search engine are aligned.

---

From: Mark Perkins <[email-masked]>
Date: Thu, 20 Sep 2018 22:01:14 +0000 (UTC)

Not sure that this is true - while search engines tend to be pretty homogenous in their interests (selling users &/or their data to advertisers & avoiding litigation or prohibition), the same is definitely not true for websites & their creators.
Mark P.

    On Friday, September 21, 2018, 8:55:41 AM GMT+11, Ted Lemon <[email-masked]> wrote:  

That's a different problem.   You aren't dealing with a creative adversary in this case: the interests of the site owner and of the search engine are aligned.
_______________________________________________
hrpc mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/hrpc

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 21 Sep 2018 01:00:40 +0100

> Bob Kahn would dispute your assertion.

I'm fairly sure I made more than one assertion but welcome
substantive discussion/disputation of any of 'em.

S

---

From: [email-masked]
Date: Thu, 20 Sep 2018 21:37:28 -0400

Let me try to gather a few responses here...I'm not big on voluminous
quoting unless necessary to show precisely what someone said and not
risk unfair paraphrasing, my idea is we all have access to the
original notes.

1. Tagging websites:

Although websites would likely be subject to tagging I don't believe
that's the only or even primary granularity for tagging. Specific
content down to any level, an image for example or article, might be
tagged.

2. IPv6 models:

I really don't think tagging should be done at such a low level and it
would be problematic due to issues like CGN and other dynamic
addressing schemes.

And it's too limiting to have to squeeze what's needed into a routing
packet.

3. Cost of tagging:

Compared to what?

The cost of tagging vs blocking should be about the same.

In either case a decision is being made on content and that's where,
one assumes, most of the cost lies.

4. Tagging in general:

My thought would be this would occur at a level such as HTTP which
might include a new header, much like Cookies etc are sent.

So for example a header indicating the source of the tag, the nature
of the tag (e.g., sexually explicit) in broad terms, date, and perhaps
a URL if one wants more specifics on the tag and source.

This could be provided by the content provider such as tagging what
they know is sexually explicit material. I think many would do this
even if just to avoid liability. It might even have marketing value
helping those who are looking for such material to find it.

And/or by a third party which the browser or similar could query if
desired in which case it wouldn't necessarily be embedded in the HTTP
conversation, just a returned response.

But standardizing the format of the response (e.g., much like the
cookie format is standardized, or DNS responses) would be useful.

One could imagine a proxy which embeds tags not provided by the
content provider by querying one or more third party services and/or
local decision-making. Use might be wholly voluntary or, for example,
imposed by an employer.

A lot of spam filtering works like this to varying extents.

Spamassassin, for example, is pretty good at rating emails based on
surface features such as "all image no text", "selling
pharmaceuticals", "loan offer", "invisible embedded text" (e.g., white
on white or black on black etc, always suspicious*), and assigns a
point system which is added up and one can choose a threshold.

It will also assign negative score ratings for some features which is
a good thing and lowers the spamminess score.

And an end-user can add advice into a local database like I only read
languages A, B, C so increase the score if not one of those, or don't
ever mark anything from this source as spammy.

It can also use third-party sources querying address blacklist
maintainers for example.

I would argue that a lot of what is needed, at an architectural level,
is already in place in the spam fighting world, with the addition of
applying the methodology more generally to any content and involving
content providers such as social media sites.

* Why suspicious? Because invisible text is often used to thwart
text-rating algorithms (e.g., Bayesian), and even very simple schemes,
such as "Cheap Viagra" versus "Ch<invisible>eap V<inv>ia<inv>gra".

-- 
        -Barry Shein

---

From: [email-masked]
Date: Thu, 20 Sep 2018 22:08:54 -0400

Although not identical a closely related issue is copyright protection.

This has become a particularly active area since the EU adopted its
digital copyright rules negotiating position (i.e., still in early
stages) on 2018-09-12:

  http://www.europarl.europa.eu/news/en/press-room/20180906IPR12103/parliament-adopts-its-position-on-digital-copyright-rules

In that case my thought was to study how the music industry has
evolved copyright protection over the past 100+ years in the US and
elsewhere.

In brief (US) they rely on designated third-party agencies (such as
BMI, ASCAP, Harry J Fox) to provide licensing and collect royalties
and distribute those back to copyright owners. And statutory fees set
by the US congress. Private agreements are also possible, and common,
of course.

The music industry has developed a sophisticated ecosystem and rather
than rely first on threats of criminal prosecution (which is possible
in extreme cases) instead tries to convert as much of the problem as
possible into civil claims (you used my work, you owe me money!)

This is in stark contrast to the EU directive which approaches the
problem via draconian fines etc. and seems to create none of that
infrastructure. One doubts any of those fines, which could be in the
billions of euros, will go to the content creators and owners.

As an internetworking example I could imagine creating licensing
agents with various types of licenses for sale depending on intended
use and embedding those into (https etc) SSL certificates.

Something analogous could be done for content in general.

For example identification and certification by third-party vetting
organizations which could be embedded into SSL certificates indicating
that a site adheres to certain content standards.

That sort of thing is very defensible legally (at least in the US) if
the third-party is identified by a trademark (think: Good Housekeeping
Seal of Approval, Underwriters Laboratory.)

The similarities to managing content in general is potentially useful.

THE POINT:

This is a big, big, and complex problem.

It might take "organic" thinking which embraces the nature of global
networking and creates and evolves infrastructure to respond usefully.

It's not going to be solved by simple analysis even if that's useful
to thinking about it.

A problem of this magnitude also requires synthesis of an
implementation ecosystem which can be much more difficult.

And each aspect of it SHOULDN'T evolve its own unique solution.

-- 
        -Barry Shein

---

From: Nalini J Elkins <[email-masked]>
Date: Fri, 21 Sep 2018 07:35:36 +0000 (UTC)

On Sep 20, 2018, at 4:53 PM, Nalini J Elkins <[email-masked]> wrote:
>Yes, that could all be true but somehow search engines manage> to keep up pretty well with changing content on web sites.

>That's a different problem.   You aren't dealing with a creative adversary in this case: the interests of the site owner and of the search engine >are aligned.

Well, maybe.  But, if the content were to change completely, then the site would likely lose its customer base.  What I mean is that if the site started doing shape shifting to "creatively" try to defeat our categorization algorithm, then there are limits to what they could do before the site became a completely different thing.
That is, if a site which originally was for pornography now started showing cat videos, or a site which had plans for 3-d printed guns instead had plans for 3-d printed lawn mowers, or a site which was originally for ISIS recruitment started recruiting for the girl scouts (OK, I will stop now!), then I submit the site would indeed evade our categorization algorithm, but they would also lose their intended customer base.

Nalini

---

From: Nalini J Elkins <[email-masked]>
Date: Fri, 21 Sep 2018 08:31:06 +0000 (UTC)

Barry,
Very good writeups.   Let me think over the issues you have raised for a couple of days.
Some things I think already:
- likely we need to form a core group that is interested in this issue- we need the search engines / platforms engaged- we don't want multiple solutions
But, after that, I need to think about what you are saying.  I will sit in the park and ponder. Thank you for taking the time and effort to engage so seriously.

Nalini Elkins
CEO and Founder
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

      From: "[email-masked]" <[email-masked]>
 To: Nalini J Elkins <[email-masked]> 
Cc: Hrpc <[email-masked]>; "[email-masked]" <[email-masked]>
 Sent: Friday, September 21, 2018 3:09 AM
 Subject: Re: [hrpc] Thoughts on Intersection of Content and Protocols

THE POINT:

-- 
        -Barry Shein

---

From: Vittorio Bertola <[email-masked]>
Date: Fri, 21 Sep 2018 11:06:10 +0200 (CEST)

> Il 21 settembre 2018 alle 10.31 Nalini J Elkins <[email-masked]> ha scritto:
> 
>     Barry,
> 
>     - likely we need to form a core group that is interested in this issue
>     - we need the search engines / platforms engaged
>     - we don't want multiple solutions
> 
I think that you need to create a standard for attaching and transmitting tags that allows tagging different types of objects (ranging from a specific image to an entire AS including intermediate steps like a social media post, a page, a website, a hostname, an entity) under multiple tagging systems managed by different entities (including ways for these entities to sign these tags and for users to pick one entity, connect to its/a server, download the information and verify the signatures), and then you need to write all the software that is necessary to create and transmit these tags and to inject them into the servers for any of the protocols that should use such tagging information to apply filtering/marking policies to the payload they deal with.

It doesn't look like a big job :-D

No, seriously: it's a huge job but it's also a huge and important issue, so why not: once you have a standard way, for people who want to do so, to use the "Internet Content Tagging Protocol" to connect to the authority they like and get updated listings of "undesirable" content, then it will actually be possible to add "ICTP support" to server software, e.g. DNS servers could have an option to bring up an ICTP client with some parameters, download filtering lists and apply them to the query results; same for the UGC-based platforms and social networks that are now required to filter out stuff by law in Europe.

At this point time this is already happening in bits and pieces, and every community has its own standard protocol(s), which may be public, such as RPZ for the DNS, or proprietary, as it will happen for the UGC filters. Should we rather have a single global protocol?

Ciao

--

Vittorio Bertola
Head of Policy & Innovation

Cell: 	+39 348 7015022
Skype: 	[email-masked]
Email: 	[email-masked] mailto:[email-masked]

Twitter: @openexchange http://twitter.com/openexchange - Facebook: OpenXchange https://www.facebook.com/OpenXchange - Web: www.open-xchange.com http://www.open-xchange.com
Open-Xchange AG, Rollnerstr. 14, 90408 Nuremberg, District Court Nuremberg HRB 24738
Managing Board: Rafael Laguna de la Vera, Carsten Dirks, Michael Knapstein, Stephan Martin
Chairman of the Board: Richard Seibt

European Office:
Open-Xchange GmbH, Olper Huette 5f, D-57462 Olpe, Germany, District Court Siegen, HRB 8718
Managing Director: Frank Hoberg

US Office:
Open-Xchange. Inc., 530 Lytton Avenue, Palo Alto, CA 94301, USA

Confidentiality Warning: This message and any attachments are intended only for the use of the intended recipient(s), are confidential, and may be privileged. If you are not the intended recipient, you are hereby notified that any review, retransmission, conversion to hard copy, copying, circulation or other use of this message and any attachments is strictly prohibited. If you are not the intended recipient, please notify the sender immediately by return e-mail, and delete this message and any attachments from your system.

---

From: Nalini J Elkins <[email-masked]>
Date: Fri, 21 Sep 2018 09:28:40 +0000 (UTC)

Vittorio,
> No, seriously: it's a huge job but it's also a huge and important issue, so why not: once you have a standard way, for people who want to do > so, to use the "Internet Content Tagging Protocol"
I REALLY like your idea and love the name!  Indeed, a huge and important issue.  Thank you so much for your thoughts.  

You know, the search engines HAVE quite a bit of data already.   I wonder if that can be leveraged.

In any case, I have to say that the way this discussion has gone and the wonderful ideas that have come out really show how very special the IETF is in terms of the level of intellect and dialogue.   (And, Stephen, PLEASE poke holes.  We need you to find all the flaws you can.)
I wonder if it is time to ask for a different email list for this topic?  I wonder if where this may be headed is a potential WG.
Thoughts?  I think we can use some of the words that Vittorio and Barry have used as the start for a potential charter.
Of course, now we need a cute acronym for this group...
Thanks,Nalini

---

From: Tony Rutkowski <[email-masked]>
Date: Fri, 21 Sep 2018 06:56:57 -0400

Hi Barry,

It is worth noting this activity is associated with human right

>     CESCR15 the right of everyone...to take part in cultural life...to
>     enjoy the benefits of scientific progress and its applications...the
>     protection of the moral and material interests resulting from any
>     scientific, literary or artistic production of which he is the
>     author...the development and the diffusion of science and culture 

It is also the basis for implementing global treaty instruments in both
UNESCO and WIPO.

It is also worth noting that Bob Kahn's DOI content tagging platform
largely exists for providing IPR related information, and has been
significantly supported by and in use among multiple copyright
communities over the past 20 years.  It also is secure and successfully
scaled.  Even RFC's now have DOIs for this purpose.  See RFC7669.  

For those who enjoy the history, this is not by chance.  Bob - both in
DARPA and CNRI - played a leading role in the instantiation of DNS. 
Patrice Lyons, his wife, is a copyright attorney who once worked at
UNESCO.  In the mid-1990s, CNRI created the DOI platform to facilitate
tagging of all digital objects to allow discovery of IPR related
information and management of the material.  Bob also played perhaps the
most central role in facilitating the existence of the IETF.

--tony

---

From: [email-masked]
Date: Fri, 21 Sep 2018 13:35:36 -0400

> Of course, now we need a cute acronym for this group...

Tag Adornment Group (TAG)?

-- 
        -Barry Shein

---

From: Nalini J Elkins <[email-masked]>
Date: Sat, 22 Sep 2018 10:38:27 +0000 (UTC)

> Tag Adornment Group (TAG)?

Very interesting!

How about Tagging Content (TaCo)?

I will now start looking about for someone (I suppose in IESG) to assist in creating new non-WG email list.

If anyone capable of authorizing new email list is listening & has interest, please contact me.  Otherwise, I will be reaching out 
to people myself.

If people would prefer to keep this discussion on HRPC email list, that is fine also.   Please indicate your thoughts.

I think the next things to do are:

1.   Set up a meeting time / description for bar bof in Bangkok.   Probably on that Friday as I believe that was the intent of the extra day.

2.   Create a Use Cases draft

3.   Combine thoughts on possible charter

Please let me know if anyone has comments.

Thanks,
Nalini

---

From: Nalini J Elkins <[email-masked]>
Date: Sat, 22 Sep 2018 10:38:27 +0000 (UTC)

Very interesting!

Thanks,
Nalini

---

From: Nalini J Elkins <[email-masked]>
Date: Sat, 22 Sep 2018 10:38:27 +0000 (UTC)

Very interesting!

Thanks,
Nalini

---

From: [email-masked]
Date: Sun, 23 Sep 2018 17:10:08 -0400

Tony,

I'm looking at DOI.ORG and it's interesting, there's a lot there.

If nothing else it would seem to provide a well thought out framework
for identifier creation. No sense reinventing wheels.

There's still a lot left to think about such as an infrastructre for
tagging content and utilizing those tags plus rights management
implied in that activity.

It may be there but I'm wondering if organizations such as Library of
Congress have bought into DOI, perhaps as an adjunct to their MARC
system (by "such as" I'm thinking int'l library systems, I see some of
the other endorsements.)

I'll keep studying it, thanks.

-- 
        -Barry Shein