Subject: [http-state] I-D Action:draft-ietf-httpstate-cookie-04.txt

From: [email-masked]
Date: Tue, 23 Feb 2010 08:15:04 -0800 (PST)

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the HTTP State Management Mechanism Working Group of the IETF.

	Title           : HTTP State Management Mechanism
	Author(s)       : A. Barth
	Filename        : draft-ietf-httpstate-cookie-04.txt
	Pages           : 33
	Date            : 2010-02-23

This document defines the HTTP Cookie and Set-Cookie headers.  These
headers can be used by HTTP servers to store state on HTTP user
agents, letting the servers maintain a stateful session over the
mostly stateless HTTP protocol.  The cookie protocol has many
historical infelicities and should be avoided for new applications of
HTTP.

NOTE: If you have suggestions for improving the draft, please send

email to [email-masked].  Suggestions with test cases are

especially appreciated.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-httpstate-cookie-04.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Blake Frantz <[email-masked]>
Date: Tue, 23 Feb 2010 10:44:36 -0600

7.6 second paragraph

s/with/will/ in "the Path attribute does not provide any integrity protection because the user agent with accept an arbitrary"

B

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, February 23, 2010 8:15 AM
To: [email-masked]
Cc: [email-masked]
Subject: [http-state] I-D Action:draft-ietf-httpstate-cookie-04.txt

This document defines the HTTP Cookie and Set-Cookie headers.  These headers can be used by HTTP servers to store state on HTTP user agents, letting the servers maintain a stateful session over the mostly stateless HTTP protocol.  The cookie protocol has many historical infelicities and should be avoided for new applications of HTTP.

especially appreciated.

Below is the data which will enable a MIME compliant mail reader implementation to automatically retrieve the ASCII version of the Internet-Draft.

---

From: "Anne van Kesteren" <[email-masked]>
Date: Tue, 23 Feb 2010 18:10:02 +0100

On Tue, 23 Feb 2010 17:15:04 +0100, <[email-masked]> wrote:
> The cookie protocol has many

What exactly does this mean? There's no suitable replacement for cookies  
available currently so giving this advice seems a bit premature, but maybe  
I misunderstand what it says.

-- 
Anne van Kesteren
http://annevankesteren.nl/

---

From: Blake Frantz <[email-masked]>
Date: Tue, 23 Feb 2010 11:15:52 -0600

Similarly, the top of section '7.1 General Recommendations' states:

"The cookie protocol is NOT RECOMMENDED for new applications".

This statement may require the same clarification as the one noted by Anne.

Blake

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Anne van Kesteren
Sent: Tuesday, February 23, 2010 9:10 AM
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [http-state] I-D Action:draft-ietf-httpstate-cookie-04.txt

-- 
Anne van Kesteren
http://annevankesteren.nl/
_______________________________________________
http-state mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/http-state

---

From: Julian Reschke <[email-masked]>
Date: Tue, 23 Feb 2010 18:14:56 +0100

On 23.02.2010 18:10, Anne van Kesteren wrote:
> available currently so giving this advice seems a bit premature, but
> maybe I misunderstand what it says.

It also says in 7.1:

"The cookie protocol is NOT RECOMMENDED for new applications."

BR, Julian

---

From: Adam Barth <[email-masked]>
Date: Tue, 23 Feb 2010 18:46:30 -0800

Fixed.  Thanks!

Adam