Subject: P7: IANA registry for schemes (issue 141)

From: Julian Reschke <[email-masked]>
Date: Sun, 07 Nov 2010 14:21:24 +0100

Hi,

we introduced this in -12 (see 
<http://tools.ietf.org/wg/httpbis/trac/ticket/141>), however there's 
work left to do.

At least:

(1) Add "Considerations for new authentication schemes", and

(2) Something that registers the existing schemes.

For "Basic" and "Digest" I have prepared 
draft-ietf-httpbis-authscheme-registrations 
(<http://trac.tools.ietf.org/wg/httpbis/trac/export/1078/draft-ietf-httpbis-authscheme-registrations/latest/draft-ietf-httpbis-authscheme-registrations.html>). 
This hasn't been submitted yet, because it depends on the -12 drafts, 
and the submission window for -00 had already closed.

We can do this starting tomorrow; are we OK with this becoming -00, and 
add more details and potentially more schemes later on?

Best regards, Julian

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 9 Nov 2010 12:25:47 +1100

On 08/11/2010, at 12:21 AM, Julian Reschke wrote:

> Hi,
> 
> we introduced this in -12 (see <http://tools.ietf.org/wg/httpbis/trac/ticket/141>), however there's work left to do.
> 
> At least:
> 

http://trac.tools.ietf.org/wg/httpbis/trac/ticket/257

> For "Basic" and "Digest" I have prepared draft-ietf-httpbis-authscheme-registrations (<http://trac.tools.ietf.org/wg/httpbis/trac/export/1078/draft-ietf-httpbis-authscheme-registrations/latest/draft-ietf-httpbis-authscheme-registrations.html>). This hasn't been submitted yet, because it depends on the -12 drafts, and the submission window for -00 had already closed.
> 
> We can do this starting tomorrow; are we OK with this becoming -00, and add more details and potentially more schemes later on?

Seems reasonable.

--
Mark Nottingham   http://www.mnot.net/