Subject: Re: connection limits, was: [apps-discuss] APPSDIR review of draft-ietf-httpbis-p1-messaging-24

From: [email-masked]
Date: Sun, 3 Nov 2013 07:20:24 -0800

A huge number of connections might be problematic for a 2.0 intermediary/proxy talking to an HTTP 1.1 server.

Not sure that should be dealt with in the spec.

Peter

On Oct 30, 2013, at 1:50 AM, Julian Reschke <[email-masked]> wrote:

> On 2013-10-30 09:31, S Moonesamy wrote:
>> Hi Julian,
>> At 09:03 29-10-2013, Julian Reschke wrote:
>>> I have trouble parsing this comment. Do you see an issue here?
>> 
>> I read the text again (Section 6.4).  It is difficult to say what is
>> deemed abusive.  You could get around that with, for example:
>> 
>>   A client SHOULD limit the number of simultaneous open connections
>>   that it maintains to a given server as each connection consumes
>>   server resources.
>> 
>> Please note that I used some text from the third paragraph of that section.
> 
> Well, there are more reasons for limiting the connection; that's why we have a separate paragraph about it. Just moving one of them up here doesn't look like an improvement to me.
> 
> Best regards, Julian
>

---

From: Martin Thomson <[email-masked]>
Date: Sun, 3 Nov 2013 09:01:44 -0800

> A huge number of connections might be problematic for a 2.0 intermediary/proxy talking to an HTTP 1.1 server.

Yes, that's a problem, but I don't think there is any need to include
text in a spec.