Subject: Header Structure Draft 17 -- Any diff from 16?

From: Ian Clelland <[email-masked]>
Date: Mon, 16 Mar 2020 12:05:59 -0400

I just got the announcement for SH draft 17, and went to check out the
differences since 16, and noticed that the diff link isn't working, and the
text[2] has no changelog from draft 16. (C.1 is "Since
draft-ietf-httpbis-header-structure-15")

I'm going to check the commit logs to see if there were substantive
changes, but this looks like an error somewhere.

[1] Diff link from the email is
https://www.ietf.org/rfcdiff?url2=draft-ietf-httpbis-header-structure-17,
which brings up an error.
[2] Checked text version at
https://tools.ietf.org/html/draft-ietf-httpbis-header-structure-17.

---

From: Julian Reschke <[email-masked]>
Date: Mon, 16 Mar 2020 18:57:44 +0100

On 16.03.2020 17:05, Ian Clelland wrote:
> differences since 16, and noticed that the diff link isn't working, and
> the text[2] has no changelog from draft 16. (C.1 is "Since
> https://www.ietf.org/rfcdiff?url2=draft-ietf-httpbis-header-structure-17, which
> brings up an error.

Try

<https://tools.ietf.org/rfcdiff?url2=draft-ietf-httpbis-header-structure-17.txt>

Best regards, Julian

---

From: Ian Clelland <[email-masked]>
Date: Mon, 16 Mar 2020 14:43:26 -0400

Thanks -- that works.

Any idea why the (apparently) auto-generated announcement email would have
a URL that doesn't work?

Also, should there have been a changelog from draft 16?

On Mon, Mar 16, 2020 at 1:57 PM Julian Reschke <[email-masked]>
wrote:

> which
> <
> https://tools.ietf.org/rfcdiff?url2=draft-ietf-httpbis-header-structure-17.txt
> >
>
> Best regards, Julian
>
>

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 17 Mar 2020 09:29:45 +1100

Hey,

Not sure why the e-mail links don't work, but -17 just incorporated some feedback from Martin regarding extensibility in dictionaries, along with a few editorial improvements.

Yes, it should have had a change note, sorry for that.

Cheers,

> On 17 Mar 2020, at 3:05 am, Ian Clelland <[email-masked]> wrote:
> 
> I just got the announcement for SH draft 17, and went to check out the differences since 16, and noticed that the diff link isn't working, and the text[2] has no changelog from draft 16. (C.1 is "Since draft-ietf-httpbis-header-structure-15")
> 
> I'm going to check the commit logs to see if there were substantive changes, but this looks like an error somewhere.
> 
> [1] Diff link from the email is https://www.ietf.org/rfcdiff?url2=draft-ietf-httpbis-header-structure-17, which brings up an error. 
> [2] Checked text version at https://tools.ietf.org/html/draft-ietf-httpbis-header-structure-17.
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: Julian Reschke <[email-masked]>
Date: Mon, 16 Mar 2020 23:32:09 +0100

On 16.03.2020 19:43, Ian Clelland wrote:
> Thanks -- that works.
>
> Any idea why the (apparently) auto-generated announcement email would
> have a URL that doesn't work?

That's a question for the tools team (I think).

> Also, should there have been a changelog from draft 16?

Probably. Mark?