Subject: Re: Working Group Last Call: HTTP Client Hints

From: Mark Nottingham <[email-masked]>
Date: Mon, 2 Mar 2020 13:57:15 +1100

Yes, I think that makes sense.

The reason for adding this was to make sure that CH authors understood that they'd see better cache efficiency if they did this, but it's not ready yet.

> On 29 Feb 2020, at 7:23 am, Jeffrey Yasskin <[email-masked]> wrote:
> 
> On Thu, Feb 27, 2020 at 2:28 AM Yoav Weiss <[email-masked]> wrote:
> The PR is now merged and addresses most of the comments.
> 
> 
> Appendix A.  Interaction with Variants Response Header Field
> 
>     Client Hints may be combined with Variants response header field
>     [VARIANTS] to enable fine-grained control of the cache key for
>     improved cache efficiency.  Features that define Client Hints will
>     need to specify the related variants algorithms as described in
>     Section 6 of [VARIANTS].
> 
> Unless we're planning to finish VARIANTS really soon, I'd drop this
> appendix.
> 
> mnot - thoughts? 
>  
> Friendly ping! :) 
> 
> I might have been involved in asking for this section... Basically, if this document is ready to go to RFC before Variants, we don't want to artificially block it behind Variants, which this Appendix would do. To fix that, this text ought to move to https://tools.ietf.org/html/draft-ietf-httpbis-variants-06#appendix-A.
> 
> If Variants had gone first, this text would be in the right place, for the same reason.
> 
> That is, I agree with Julian.
> 
> Does that make sense?
> 
> Jeffrey

--
Mark Nottingham   https://www.mnot.net/

---

From: Yoav Weiss <[email-masked]>
Date: Mon, 2 Mar 2020 10:17:03 +0100

Thanks! PR at https://github.com/httpwg/http-extensions/pull/1082

On Mon, Mar 2, 2020 at 3:57 AM Mark Nottingham <[email-masked]> wrote:

> The reason for adding this was to make sure that CH authors understood
> that they'd see better cache efficiency if they did this, but it's not
> ready yet.
>
>
>
> > I might have been involved in asking for this section... Basically, if
> this document is ready to go to RFC before Variants, we don't want to
> artificially block it behind Variants, which this Appendix would do. To fix
> that, this text ought to move to
> https://tools.ietf.org/html/draft-ietf-httpbis-variants-06#appendix-A.
> >

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 5 Mar 2020 10:40:34 +1100

Based on the feedback, it looks like this is ready to go. 

Authors, please submit an updated draft based upon the (largely editorial) feedback, and we'll send it on to the IESG.

Thanks!

> On 18 Feb 2020, at 3:09 pm, Mark Nottingham <[email-masked]> wrote:
> 
> Hello Working Group Participants,
> 
> The authors of the Client Hints draft believe this is ready for last call, and there are no open issues. 
> 
> So, this email starts a working group last call ending on Wednesday, 4 March. Please review the document and reply to the list with your comments (or file an issue), and state whether you think this document is ready for publication.
> 
> The current version of the document can be found at:
>  https://tools.ietf.org/html/draft-ietf-httpbis-client-hints-08
> 
> Cheers,
> 
> Mark and Tommy

---

From: Yoav Weiss <[email-masked]>
Date: Wed, 11 Mar 2020 09:25:08 +0100

The latest draft is now at
https://tools.ietf.org/html/draft-ietf-httpbis-client-hints-11

Thanks! :)

On Thu, Mar 5, 2020 at 12:40 AM Mark Nottingham <[email-masked]> wrote:

> Authors, please submit an updated draft based upon the (largely editorial)
> feedback, and we'll send it on to the IESG.
>
> Thanks!
>
>
> > So, this email starts a working group last call ending on Wednesday, 4
> March. Please review the document and reply to the list with your comments
> (or file an issue), and state whether you think this document is ready for
> publication.
> >