Subject: I-D Action: draft-ietf-httpbis-http2bis-01.txt

From: [email-masked]
Date: Mon, 22 Feb 2021 14:56:42 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the HTTP WG of the IETF.

        Title           : Hypertext Transfer Protocol Version 2 (HTTP/2)
        Authors         : Martin Thomson
                          Cory Benfield
	Filename        : draft-ietf-httpbis-http2bis-01.txt
	Pages           : 91
	Date            : 2021-02-22

Abstract:
   This specification describes an optimized expression of the semantics
   of the Hypertext Transfer Protocol (HTTP), referred to as HTTP
   version 2 (HTTP/2).  HTTP/2 enables a more efficient use of network
   resources and a reduced perception of latency by introducing header
   field compression and allowing multiple concurrent exchanges on the
   same connection.  It also introduces unsolicited push of
   representations from servers to clients.

   This specification is an alternative to, but does not obsolete, the
   HTTP/1.1 message syntax.  HTTP's existing semantics remain unchanged.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-httpbis-http2bis/

There is also an HTML version available at:
https://www.ietf.org/archive/id/draft-ietf-httpbis-http2bis-01.html

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-httpbis-http2bis-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Martin Thomson" <[email-masked]>
Date: Tue, 23 Feb 2021 11:23:38 +1100

> 	Filename        : draft-ietf-httpbis-http2bis-01.txt

I just pushed a snapshot of what we have done in the past little while.  This includes updated terminology and a few minor improvements.

There are two larger pieces drafted that we will want to confirm next, both "removals":
* priority: https://github.com/httpwg/http2-spec/pull/795
* upgrade: https://github.com/httpwg/http2-spec/pull/820
If you have opinions about these proposed changes, your feedback would be most welcome.

Then there are a bunch of issues to work through, but not that many overall: https://github.com/httpwg/http2-spec/issues

I don't think that this submission otherwise requires action on the part of anyone in particular.  Of course, if you feel inspired, spending effort on fixing one of the outstanding issues might be more helpful than reviewing at this stage.