Subject: Re: New Version Notification for draft-cdn-control-header-00.txt

From: Dmitri Tikhonov <[email-masked]>
Date: Thu, 4 Feb 2021 09:12:47 -0500

On Thu, Jan 28, 2021 at 07:44:18PM +1100, Mark Nottingham wrote:
> > On 27 Jan 2021, at 6:03 am, Piotr Sikora <[email-masked]> wrote:
> > 
> > CDN-Cache-Control (as written today) is limited to "max-age",
> > "must-revalidate", "no-store", "no-cache", and "private", so it
> > primarily fixes incompatibilities between "s-maxage" and "no-store" /
> > "no-cache". I don't believe it allows for expressing richer policy
> > than Cache-Control.
> 
> CDN-Cache-Control, just like Cache-Control, is extensible -- see <https://httpwg.org/http-core/draft-ietf-httpbis-cache-latest.html#cache.control.extensions>.
> 

This (extensibility of CDN-Cache-Control) is not stated in the draft:

  https://tools.ietf.org/html/draft-cdn-control-header-00

  - Dmitri.

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 5 Feb 2021 10:55:28 +1100

Ah - it's implied because these headers share directives with Cache-Control, but we should make that more explicit. Thanks!

> On 5 Feb 2021, at 1:12 am, Dmitri Tikhonov <[email-masked]> wrote:
> 

--
Mark Nottingham   https://www.mnot.net/