Subject: FYI: default branches for httpwg repos

From: Mark Nottingham <[email-masked]>
Date: Sun, 14 Feb 2021 10:42:32 +1100

Hi everyone,

We're in the process of changing the default branch from 'master' to 'main' for our repos; most of the repos are already done, because they're not actively used by multiple people, and so the risk of making the change was correspondingly low.

Now that we're comfortable with the process, we think the risk of a problem is slight and well-understood, and so are going to switch over the following repos:

* httpwg/http-extensions
* httpwg/structured-field-tests

Github will automatically rewrite URLs, PRs, etc. to handle this; the only impact is that anyone with a clone of one of these repos will need to run:

git branch -m master main
git fetch origin
git branch -u origin/main main

You'll also see a notice with these instructions the first time you visit the repo on the Web after this change is made.

This will leave httpwg/http-core as the only httpwg repo with a 'master' branch. Given that core is about to ship, we thought it prudent to wait until the end of that process before making this change.

We expect to make this change in the next 48 hours, and will send out an e-mail when the process is completed, so that anyone with a local clone can run the commands above. Please get in touch with me or Tommy if you have any problems.

Cheers,

--
Mark Nottingham   https://www.mnot.net/

---

From: Lucas Pardue <[email-masked]>
Date: Sat, 13 Feb 2021 23:50:39 +0000

Thanks for the heads up, I support this change.

On Sat, 13 Feb 2021, 23:47 Mark Nottingham, <[email-masked]> wrote:

> Hi everyone,
>
> We're in the process of changing the default branch from 'master' to
> 'main' for our repos; most of the repos are already done, because they're
> not actively used by multiple people, and so the risk of making the change
> was correspondingly low.
>
> Now that we're comfortable with the process, we think the risk of a
> problem is slight and well-understood, and so are going to switch over the
> following repos:
>
> * httpwg/http-extensions
> Github will automatically rewrite URLs, PRs, etc. to handle this; the only
> impact is that anyone with a clone of one of these repos will need to run:
>
> You'll also see a notice with these instructions the first time you visit
> the repo on the Web after this change is made.
>
> This will leave httpwg/http-core as the only httpwg repo with a 'master'
> branch. Given that core is about to ship, we thought it prudent to wait
> until the end of that process before making this change.
>
> We expect to make this change in the next 48 hours, and will send out an
> e-mail when the process is completed, so that anyone with a local clone can
> run the commands above. Please get in touch with me or Tommy if you have
> any problems.
>
> Cheers,
>
> --

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 15 Feb 2021 17:31:30 +1100

This is now done - if you have a local copy of http-extensions or structured-header-tests, please run:

Cheers,

> On 14 Feb 2021, at 10:42 am, Mark Nottingham <[email-masked]> wrote:
> 
> Hi everyone,
>

---

From: "Martin Thomson" <[email-masked]>
Date: Tue, 16 Feb 2021 09:36:57 +1100

One extra step can help various tools identify the main branch correctly:

git symbolic-ref refs/remotes/origin/HEAD refs/remotes/origin/main