Subject: #1639: One last tweak to proxy-status

From: Mark Nottingham <[email-masked]>
Date: Tue, 14 Sep 2021 09:53:10 +1000

<https://github.com/httpwg/http-extensions/issues/1639>

In going over the draft during IESG processing, I noticed that there was some editorial misalignment between how we talk about parameters; this issue has a PR that attempts to correct that.

I'm bringing it up to the WG because there is one non-editorial change involved: the text for `next-protocol` says 'This [parameter] is only applicable when that connection was actually established.'

Upon reflection, that doesn't make sense -- both because it isn't aligned with how the other parameters work, and because there are situations where it's useful to record what the next protocol that was used to fetch a stored response was.

See <https://github.com/httpwg/http-extensions/pull/1640> for the suggested changes.

I don't think this will be controversial, but wanted to bring it up to make sure it got proper review. If you see any issues, please bring them up (here or there).

Cheers,

--
Mark Nottingham   https://www.mnot.net/

---

From: Amos Jeffries <[email-masked]>
Date: Wed, 15 Sep 2021 13:01:05 +1200

> See <https://github.com/httpwg/http-extensions/pull/1640> for the suggested changes.

+1. LGTM

Amos