Subject: Distributed Origins and Alt-Svc

From: Mike Bishop <[email-masked]>
Date: Thu, 7 Oct 2021 16:17:24 +0000

A problem I've been turning over in my head is dealing with "distributed origins," content libraries which are logically a single origin but are too large to actually be managed by a single host.  There are several obvious examples on the Internet at large.  An extension to Alt-Svc seems like a potential avenue to address it, but other properties of Alt-Svc would require other modifications to work smoothly.

This draft explores the problem and looks at one possible solution set.  I'm not totally happy with that solution, because it has too many moving parts, but I still see it as a useful starting point.  I'd be interested to have feedback from folks, and ideas for other ways to address the scenario.

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: Monday, October 4, 2021 12:00 PM
To: Mike Bishop <[email-masked]>
Subject: New Version Notification for draft-bishop-httpbis-distributed-origin-00.txt

A new version of I-D, draft-bishop-httpbis-distributed-origin-00.txt
has been successfully submitted by Mike Bishop and posted to the IETF repository.

Name:		draft-bishop-httpbis-distributed-origin
Revision:	00
Title:		Distributed HTTP Origins: Solution Space Exploration
Document date:	2021-10-04
Group:		Individual Submission
Pages:		9
URL:            https://www.ietf.org/archive/id/draft-bishop-httpbis-distributed-origin-00.txt
Status:         https://datatracker.ietf.org/doc/draft-bishop-httpbis-distributed-origin/
Html:           https://www.ietf.org/archive/id/draft-bishop-httpbis-distributed-origin-00.html
Htmlized:       https://datatracker.ietf.org/doc/html/draft-bishop-httpbis-distributed-origin

Abstract:
   Certain content libraries are logically a single origin, but too
   large to be practically served by a single origin server.  This
   document discusses existing solutions and explores possible
   directions for future protocol development.

The IETF Secretariat

---

From: Ben Schwartz <[email-masked]>
Date: Wed, 13 Oct 2021 11:43:00 -0400

It seems to me that HTTPS records and Cross-SNI Resumption should fully
minimize the performance penalties mentioned at the end of Section 2.1.
Without those concerns, is there enough motivation here to justify the
complexity?

On Thu, Oct 7, 2021 at 12:22 PM Mike Bishop <[email-masked]> wrote:

> A problem I've been turning over in my head is dealing with "distributed
> origins," content libraries which are logically a single origin but are too
> large to actually be managed by a single host.  There are several obvious
> examples on the Internet at large.  An extension to Alt-Svc seems like a
> potential avenue to address it, but other properties of Alt-Svc would
> require other modifications to work smoothly.
>
> This draft explores the problem and looks at one possible solution set.
> I'm not totally happy with that solution, because it has too many moving
> parts, but I still see it as a useful starting point.  I'd be interested to
> have feedback from folks, and ideas for other ways to address the scenario.
>
> Subject: New Version Notification for
> draft-bishop-httpbis-distributed-origin-00.txt
>
>
> URL:
> https://www.ietf.org/archive/id/draft-bishop-httpbis-distributed-origin-00.txt
> Status:
> https://datatracker.ietf.org/doc/draft-bishop-httpbis-distributed-origin/
> Html:
> https://www.ietf.org/archive/id/draft-bishop-httpbis-distributed-origin-00.html
> Htmlized:
> https://datatracker.ietf.org/doc/html/draft-bishop-httpbis-distributed-origin
>
>
> Abstract: