Subject: Call for Adoption: Binary Representation of HTTP Messages

From: Mark Nottingham <[email-masked]>
Date: Tue, 9 Nov 2021 22:17:03 +1100

Hello everyone,

This draft was discussed in our last interim, and there seemed to be interest in adoption. Additionally, the newly formed OHAI working group has a dependency on it:
  <https://datatracker.ietf.org/doc/draft-thomson-http-binary-message/>

So, this kicks off a one-week call for adoption for this draft. Please respond saying whether you support adoption of this draft as a work item.

Cheers,

--
Mark Nottingham   https://www.mnot.net/

---

From: "Martin Thomson" <[email-masked]>
Date: Tue, 09 Nov 2021 22:48:52 +1100

I am supportive of doing the work. :)

On Tue, Nov 9, 2021, at 22:17, Mark Nottingham wrote:
> Hello everyone,
>
> This draft was discussed in our last interim, and there seemed to be 
> interest in adoption. Additionally, the newly formed OHAI working group 
> has a dependency on it:
> So, this kicks off a one-week call for adoption for this draft. Please 
> respond saying whether you support adoption of this draft as a work 
> item.
>
> Cheers,
>
> --

---

From: Julian Reschke <[email-masked]>
Date: Tue, 9 Nov 2021 12:53:23 +0100

> So, this kicks off a one-week call for adoption for this draft. Please respond saying whether you support adoption of this draft as a work item.

+1 - I support adoption.

Best regards, Julian

---

From: Tommy Pauly <[email-masked]>
Date: Tue, 09 Nov 2021 03:56:03 -0800

As an individual (not as chair), I support adoption! I implemented this recently, as well, so I had to read it carefully. =)

Best,
Tommy

> On Nov 9, 2021, at 3:17 AM, Mark Nottingham <[email-masked]> wrote:
> 
> Hello everyone,
>

---

From: Willy Tarreau <[email-masked]>
Date: Tue, 9 Nov 2021 14:51:25 +0100

On Tue, Nov 09, 2021 at 10:17:03PM +1100, Mark Nottingham wrote:
> Hello everyone,
> 
> This draft was discussed in our last interim, and there seemed to be interest
> in adoption. Additionally, the newly formed OHAI working group has a
> dependency on it:
> respond saying whether you support adoption of this draft as a work item.

For having worked on related concepts on this in the past, I think it
makes a lot of sense to try to standardize a way to reliably serialize
a message.

Thus +1 for adoption!
Willy

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 9 Nov 2021 13:59:47 +0000

I support adoption.

I am curious what relationship (if any) there is to the binary structured
fields I-D [1].

Cheers,
Lucas

[1]
https://datatracker.ietf.org/doc/draft-nottingham-binary-structured-headers/

On Tue, Nov 9, 2021 at 1:55 PM Willy Tarreau <[email-masked]> wrote:

> interest

---

From: "Martin Thomson" <[email-masked]>
Date: Wed, 10 Nov 2021 02:28:53 +1100

On Wed, Nov 10, 2021, at 00:59, Lucas Pardue wrote:
> I am curious what relationship (if any) there is to the binary 
> structured fields I-D [1].

Today: none.

In the future: a new format that fuses the two could be really nice.  Binary SF has advantages for parsing efficiency, for simplicity, for compactness, and predictability that fit very neatly with this.  But I would say that we need to be confident with each independently before marrying them.

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 10 Nov 2021 02:30:43 +1100

No real relationship (at least yet).

> On 10 Nov 2021, at 12:59 am, Lucas Pardue <[email-masked]> wrote:
> 
> I support adoption.
> 
> I am curious what relationship (if any) there is to the binary structured fields I-D [1].
> 
> Cheers,
> Lucas
> 
> [1] https://datatracker.ietf.org/doc/draft-nottingham-binary-structured-headers/
>

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 9 Nov 2021 16:06:33 +0000

Thank you for the clarifications. That sounds fine and doesn't affect my
support for binary HTTP adoption

---

From: David Schinazi <[email-masked]>
Date: Wed, 10 Nov 2021 06:05:19 -0800

I support adoption.

David

On Tue, Nov 9, 2021 at 3:20 AM Mark Nottingham <[email-masked]> wrote:

> interest in adoption. Additionally, the newly formed OHAI working group has
> a dependency on it:

---

From: Roberto Polli <[email-masked]>
Date: Wed, 10 Nov 2021 17:25:55 +0100

I support adoption.

Thanks to the editors,
R.

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 17 Nov 2021 17:30:32 +1100

Let's consider this document adopted. Martin, please create a PR for the -00 draft.

Cheers,

> On 9 Nov 2021, at 10:17 pm, Mark Nottingham <[email-masked]> wrote:
> 
> Hello everyone,
>