Subject: RE: [Hubmib] FW: Ethernet switch forwarding table MIB? (fwd)

From: "Harrington, David" <[email-masked]>
Date: Thu, 7 Feb 2002 17:09:19 -0500

Hi,

The phrasing of your question is a bit ambiguous - a standard mib for what? 

There is no standard mib to my knowledge designed to solve the 911 location
issue directly.

identifying the room a switch is in? The system MIB contains an object
(sysLocation) where an operator can specify the device location.

the backtracking of MAC addresses? I don't think there is a standard mib for
this directly, but there are some mibs with data that could be used to
backtrack MAC addresses. PTOPO (RFC2922) contains physical topology
connections. 

I hope this helps,
dbh

> -----Original Message-----
> From: Wijnen, Bert (Bert) [mailto:[email-masked]]
> Sent: Saturday, February 02, 2002 6:53 AM
> To: Hubmib Mailing List
> Subject: [Hubmib] FW: Ethernet switch forwarding table MIB? (fwd)
> 
> 
> HUBMIBbers...
> 
> Any input or answer on this question?
> 
> Bert
> --- original email -------
> 
> Date: Fri, 01 Feb 2002 10:33:05 -0500
> From: "Henning G. Schulzrinne" <[email-masked]>
> Organization: Dept. of Computer Science, Columbia University
> To: [email-masked]
> Subject: Ethernet switch forwarding table MIB?
> 
> I normally don't get close to MIBs, but here's a problem that I found
> surprisingly difficult to solve in a vendor-independent way:
> 
> For emergency calls, some countries mandate that you can figure out
> which room a call originates from, if the emergency call 
> originates from
> within a large enterprise or campus, so that emergency help can be
> provided more expeditiously. For example, in the US (and, I believe,
> Canada), it's the law that large PBXs must provide this 
> information to a
> semi-national database.
> 
> One approach to solving this for IP-over-802 devices is to backtrack a
> MAC address to the switch and switch port, using switch forwarding
> tables. This applies to VoIP, naturally, but it's only a 
> matter of time
> before the first 911/112-over-IM "call
> 
> " happens.
> 
> However, while most managed Ethernet switches have such tables (and we
> apparently locally have tools to use them, primarily to track down
> systems that have been compromised and are spewing attack packets),
> there doesn't seem to be a standard MIB for that. I may well 
> have missed
> this in my quick browsing of the RFC MIB list, but that's 
> what our local
> network admin claimed.
> 
> Is there a standard way of solving the same problem? If not, should
> there be?
> 
> Henning
> - -- 
> Henning Schulzrinne   http://www.cs.columbia.edu/~hgs
> 
> _______________________________________________
> Hubmib mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/hubmib
>

---

From: Henning Schulzrinne <[email-masked]>
Date: Sat, 09 Feb 2002 13:13:47 -0500

> "Harrington, David" wrote:
> 
> Hi,
> 

Basically, what I'm looking for is something that says "MAC address X
was seen on port Y of this switch".

> 
> the backtracking of MAC addresses? I don't think there is a standard
> mib for this directly, but there are some mibs with data that could be
> used to backtrack MAC addresses. PTOPO (RFC2922) contains physical
> topology connections.

Is this something implemented by Ethernet LANs?

---

From: Henning Schulzrinne <[email-masked]>
Date: Sat, 09 Feb 2002 13:13:47 -0500